• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
keytotime

How to make a 7-Zip Switchless Installer

288 posts in this topic

hurray i finally made my first 7zip installer file...adobe acrobat pro with updates slipstreamed. man it was a struggle....hey keytotime just another suggestion u need to add to this excellent guide....this is with regards to the installation done via msi files....heres wht i did with the config.txt ....

;!@Install@!UTF-8!

RunProgram="StartX.exe /WAIT \"msiexec /i AcroPro.msi TRANSFORMS=AcroPro.mst /qn\""

;!@InstallEnd@!

yes i made a mst file and installed and it workled flawlessly...i had earlier tried without the transform file...it just extracted it...and then nothing....i then checked the office 2003 file that i had made and checked where i was going wrong and realised that i hadn't mentioned the mst file along with msi.

now i am off to conquer nero 7...wish me luck. :D:hello::thumbup

0

Share this post


Link to post
Share on other sites

OK, this is probably a stupid question, but is there any way to get your config.txt file back if you deleted it after doing the copy command? I've tried running the installer and looking in the temp directory and only the files from the .7z archive are there, and extracting the installer gives me the same thing.

0

Share this post


Link to post
Share on other sites
OK, this is probably a stupid question, but is there any way to get your config.txt file back if you deleted it after doing the copy command? I've tried running the installer and looking in the temp directory and only the files from the .7z archive are there, and extracting the installer gives me the same thing.

AFAIK, you can't. The files other than the .7z files (7zS.sfx, config.txt) are included in the executable, and not part of the archive that is extracted. That's why when you extract the archive, you only get the contents of the 7-zip file.

0

Share this post


Link to post
Share on other sites
OK, this is probably a stupid question, but is there any way to get your config.txt file back if you deleted it after doing the copy command? I've tried running the installer and looking in the temp directory and only the files from the .7z archive are there, and extracting the installer gives me the same thing.

You could try this in Command Prompt.

Find /I "RunProgram=" "path\to\file.exe"
0

Share this post


Link to post
Share on other sites

Is there a way to create an 7Z installer for winamp.msi (created by moderator alan). Becuase his installer accepts only full path of the INI file during unattended installation.

ex:

winamp.msi INI="%CDROM%\software\applications\Winamp\winamp.ini" /qb-!

Has anyone succeeded in creating an 7z installer with paths being provided using system variables?

0

Share this post


Link to post
Share on other sites

You could try this in Command Prompt.

Find /I "RunProgram=" "path\to\file.exe"

Shaggy, you get a Scooby snack! That works like a charm and gives me just what I want. Thanks.

0

Share this post


Link to post
Share on other sites
You could try this in Command Prompt.
Find /I "RunProgram=" "path\to\file.exe"

Shaggy, you get a Scooby snack! That works like a charm and gives me just what I want. Thanks.

Haha....

Thanks Shaggy! Another thing learned today! :yes:

0

Share this post


Link to post
Share on other sites

You could try this in Command Prompt.

Find /I "RunProgram=" "path\to\file.exe"

Shaggy, you get a Scooby snack! That works like a charm and gives me just what I want. Thanks.

Haha....

Thanks Shaggy! Another thing learned today! :yes:

Like to help if I can.

Edited by shaggy
0

Share this post


Link to post
Share on other sites

I'm creating a switchless installeer for Poweer DVD, and it works, for the most part... The issue I'm running into is that in the config.txt script

;!@Install@!UTF-8!
RunProgram="program.exe –switch"
;!@InstallEnd@!

Theer's a set of "'s, I need to use anotheer set as the code I need it

;!@Install@!UTF-8!
RunProgram="setup.exe –s -f2"%systeemdrive%\pdvd.log""
;!@InstallEnd@!

It spits an error back at me...

How do I teell it to ignoree the inner "'s..?

0

Share this post


Link to post
Share on other sites

Could it be this?

;!@Install@!UTF-8!

RunProgram="setup.exe –s -f2"%systeemdrive%\pdvd.log""

;!@InstallEnd@!

Should be systemdrive, not systeemdrive.

Edited by Zxian
0

Share this post


Link to post
Share on other sites

The keyboard I was using sometimes makes an e appear twice... Sorry... That's not the reason...

0

Share this post


Link to post
Share on other sites

bah... I know why... I was just too tired to realize it.

To enter quotes in commands like that you need to use \".

So...

;!@Install@!UTF-8!
RunProgram="setup.exe –s -f2\"%systeemdrive%\pdvd.log\""
;!@InstallEnd@!

Also... should there be a space between the -f2 switch and the log destination? like the following:

;!@Install@!UTF-8!
RunProgram="setup.exe –s -f2 \"%systeemdrive%\pdvd.log\""
;!@InstallEnd@!

0

Share this post


Link to post
Share on other sites

Update the guide, changed the .msi info, now the pictures all screwed up. :realmad::realmad::realmad:

Edited by keytotime
0

Share this post


Link to post
Share on other sites
Update the guide, changed the .msi info, now the pictures all screwed up. :realmad::realmad::realmad:

it looks good, thanks again for the guide :)

0

Share this post


Link to post
Share on other sites

Hello and thank you for the great tutorial

I have some Q please

1:- Now and after I do the MSI and finsih it If I add this to Nlite .. will it going to be installed automaticlly while windows installing ..

2:- If I need to install another program .. that its not MSI... how can I know the switch for it

Again and again

Thank you

Edited by farisnt
0

Share this post


Link to post
Share on other sites

1.) I don't use nlite, but if you make it silent and nlite can run it, it will install silently

2.)Search

0

Share this post


Link to post
Share on other sites

i'd like to thank keytotime for the great guide , works perfect :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.