Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  

Install Cant Find Icfgnt.dll

Recommended Posts


It is not a bad burn, I install from a second harddrive ;)

I always start with a clean version of XP(SP2) and I know for a fact that my harddisk is in top shape. I will try ChipCraze23 advise

But you are correct that a lot of strange problem can be explained by faulty media.

Share this post

Link to post
Share on other sites


Yes you got me right, use the HDDINST.SIF as your Unattend.txt file to allow you to use the installation on a CD later....

Share this post

Link to post
Share on other sites

I have the same problem. All the solutions proposed in this thread have not worked for me....

Share this post

Link to post
Share on other sites


Okay, I have an idea to workaround this problem :whistle: (that recurred again to me.... :realmad: )...

--> During GUI Setup, (which is the GUI mode of setup), looks for the source of Windows XP files in this registry key during setup....


The data is in a REG_MULTI_SZ value called "Installation Sources"....


There are also other values in there which are (REG_SZ) in the registry....

They are:

-- SourcePath (REG_SZ)

-- ServicePackSourcePath (REG_SZ)

-- When booting from the CD, these values are set to the path of the CD...


---> When we use WINNT.EXE / WINNT32.EXE , some files are copied from %CDROM%\I386 to a temporary folder called C:\$WIN_NT$.~LS on the hard drive....

Then all of the values in the keys listed above are set to point to that folder (C:\$WIN_NT$.~LS) and in the REG_MULTI_SZ value (mentioned above), both sources are listed...


So here is my idea....

--> If somehow a script executes at "DetachedProgram" from WINNT.SIF (T-39), which looks for the source of the files (I posted the source of such a script at the thread linked in this reply) and then sets all these keys to the source directly...

(Thus effectively spoofing the SETUP program into acting like this is a CDInstall), but that will also mean that the copying files part will be completely useless waste of time...

But if it works, then we might have solved the ICGFNT.DLL problem....


Another possible method.... :


I noticed that NOT all files from I386 are properly copied to C:\$WIN_NT$.~LS, what if we manually XCOPY all files from I386 in DOS to C:\$WIN_NT$.~LS BEFORE running in DOS (WINNT.EXE)

--> And if we ResHack SETUP.EXE (the autorun component) (still figuring out which resource) to launch a batch file (instead of WINNT32.EXE), that launches XCOPY and copies the files to C:\$WIN_NT$.~LS , then launches WINNT32.EXE with WINNT.SIF support... then maybe this can be fixed....


Please, someone try to experiment with this... This could be the end of all of these ICGFNT.DLL threads....

Share this post

Link to post
Share on other sites


Just to add my experience today. I also made a slipstreamed install CD with nLite.

First, the setup gave error that it couldn't copy file inetcpl.cpl. Next, in grpahical portion I got another error that icfgnt.dll can't be found (or registered?). Anyway, after that netwrok didn't work at all and I couldn't install it.

So, I suspected a faulty CD because the VMWare tests had been succesfull. I burned it again on another CD-RW and behold, the new installation went just fine and everything worked ok :)

Just one possible solution to the problem...

Share this post

Link to post
Share on other sites
Guest Tervel

I'm trying to install from a USB hard drive and am having the same problem. So far I have tried to manually extract the files from the cab and then place them where they should go based on the Path listed in the cab file. That Still didn't work but in a worst way - I was unable to boot up into windows after the setup completed AND I still got the stupid cannot find ICFGNT.DLL file!!! I tried to remove the msmsgs=no and msnexplorer lines from [Components] in my unattend.txt - this time I was not even able to complete the setup - I started getting file cannot be found still in the blue screen area for ATAPY.SYS and DISK.SYS. There were more but I just quit at that point of time...

This is very frustrating.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.