• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
iwod

Xpize 3.0 Released

48 posts in this topic

@iwod, install xpize on your host machine and export winrar.exe to your winrar's silent installation ;)

thanks, never thought of it this way.

0

Share this post


Link to post
Share on other sites

hallo again

is there any news regarding the installation problem ???

ok the second one

i took a screenshot from a password wizard so - does someone know where the ressource for this key picture is - it is not royalized - so i would like to change manual or give the offer to include in next version *gg*

thanks

yergling

p.s. how can i attach files to the post - like in the german forum ?????????

here is the link to the german forum picture

http://board.windows-unattended.de/forum/i...pe=post&id=2505

0

Share this post


Link to post
Share on other sites

hallo again

for the german users here is a working auto-it script

if you do not try to get the message in silent mode, but click throu the complete setup uotoit works great

AutoItSetOption("MouseCoordMode", 0)
AutoItSetOption("TrayIconHide", 1)
BlockInput(1)
run("XPIZE_3.0.exe")
winwait("Installer Language")
controlclick("Installer Language", "OK", "Button1")
winwait("XPize v3.0 Installation", "Willkommen")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Lizenzabkommen")
controlclick("XPize v3.0 Installation", "Ich &akzeptiere das Lizenzabkommen.", "Button4")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Read Me")
controlclick("XPize v3.0 Installation", "Next >", "Button2")
winwait("XPize v3.0 Installation", "Installation Type")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Komponenten auswählen")
mouseClick("left", 200, 158, 1, 0)
controlclick("XPize v3.0 Installation", "&Installieren", "Button2")
winwait("XPize v3.0 Installation", "Die Installation ist vollständig")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Windows jetzt neu starten?")
mouseClick("left", 190, 207, 1, 0)
controlclick("XPize v3.0 Installation", "&Fertig stellen", "Button2")
BlockInput(0)

so you have to modify if you want to install english or other version

this script installs default, but without creating restore point and without restart

have fun

yergling

0

Share this post


Link to post
Share on other sites

after i installed it, rebooted my computer, and my winlogon.exe is broken. It says it cant find a SHREF call in msigna.dll. Only option is OK, so I click it, it then says it can't load winlogon.exe. contact system admin. I had to reinstall windows

I'm hesitant to install it again. Anyone else run into this?

0

Share this post


Link to post
Share on other sites

I had the same problem by installing SP2, when it occurs, just place that file back from the cd.

0

Share this post


Link to post
Share on other sites
I had the same problem by installing SP2, when it occurs, just place that file back from the cd.

unfortunately I could not get to a point where that was possible. It's a laptop, so the hard drive isn't exactly easily accessible to hook up to another machine to force the file over that way, and I can't run recovery console because I don't own a floppy drive.

0

Share this post


Link to post
Share on other sites

You can run the recovery console with the setup disc.

0

Share this post


Link to post
Share on other sites

i tried running recovery console, it just kept telling me to insert the floppy disk and hit enter

0

Share this post


Link to post
Share on other sites

@rendrag:

Your problem is strange because XPize does not replace your original logon, instead it places the new one in C:\Windows\XPize (hidden by default) and applies a new registry value to make it the default one. Anyway, I will try to figure out what the cause can be.

XPero

0

Share this post


Link to post
Share on other sites

I to have a problem with the winrar patch and I have tried a dozen different ways will some one provide me the patched winrar??

PLEASE PLEASE...

0

Share this post


Link to post
Share on other sites

The new Xpize breaks .cmd and .bat. I've tried a few and none work.

0

Share this post


Link to post
Share on other sites

@keytotime:

Send me those .cmd and .bat, I will see what happens in my system. And please, specify your system (XP, 2003, MCE and what Service Pack you have).

0

Share this post


Link to post
Share on other sites

Xp Sp2 with ryan's pack, one of them is ryan's cab updater. Anything that has a cd or looks at a different directory than the default one has problems.

0

Share this post


Link to post
Share on other sites

@keytotime:

Although this is very strange, try this: look into C:\WINDOWS\XPize\Backup and replace

patched wscript.exe and cscript.exe with the original ones. If you installed Windows using the i386 patching feature, look into your Windows CD and Ryan's Pack for those original files. You can use Replacer

@Daeron Tinúviel:

Run the installer again and select skins-->WinRAR 3.xx only. This should work.

0

Share this post


Link to post
Share on other sites

Whoa! amazingly nice toy!! :w00t:

maybe something for the next release: replacement of the IE animated icons?

EDIT (after PM): I mean the throbber..

Edited by Glowy
0

Share this post


Link to post
Share on other sites
Bug report: XPize modifies user32.dll, which in some unknown way, causes applications using some of its APIs to crash. Example: Futuremark 3DMark03. This bug was found on Windows XP SP1.

XPize does not touch user32.dll. At least I haven't found that file in C:\WINDOWS\XPize\Backup, so it hasn't been modified.

0

Share this post


Link to post
Share on other sites

that's right

user32.dll is not modified by xpize

so i had 2 little problems in the last weeks using xpize

i hope they are not generated because i used xpize - maybe someone knows

1. if i click my network places with the right mouse button and select "properties" a message appears that i can not place a shortcut here

2. if i click on an other system my computer with the right mouse button and select "manage" a message appears that the default management console can not be found - management is completely impossible - on the same system internet properties and search is also impossible

i reinstalled one of them and used also xpize 3.0 and the error does not occure again - may it be that there is an update problem from xpize 2.5 to 3.0 ???

thanks

yergling

0

Share this post


Link to post
Share on other sites

Hi Xpero

I said;

I was just wondering if anyone else is having problems with XPize3.0

installing silently after using nlite, I get 2 popup windows, one about

systemrestore not being written to and one about uxtheme not compatable

with system........

Nuhi said;

You removed SysRestore and patched Uxtheme...that's normal.

Contact XPize installer author and tell him to add silent switch for these warnings.

I said;

yes I do remove systemrestore, and use nLites uxtheme

Xpero said;

here's how I do it........

I then said;

I think I'll just leave in sysrestore and use your uxtheme.......... should solve

the problem, right??

NO.

And now I finally got around to making a new ISO and left in systemrestore and did not

use nLites uxtheme, and still I get those 2 popups.......

thought you should know Xpero.....also don't forget the problem with command promt.....

had to uninstall it for window to work.......

thanks BD

0

Share this post


Link to post
Share on other sites

@bonedaddy:

OK. It seems that all the effort put in the "i386 patching feature" has been a waste of time for some, because you dont use it. Having this into account, I think I'm going to put end to all this. I'm currently learning NSIS and thought about a final solution to that unattended problem. I'm not going to give details about my idea (dont want to create expectations). Let's see what happens. Untill now, install XPize normally, believe me, it is not a big problem (irony).

XPero

0

Share this post


Link to post
Share on other sites

Hi Xpero

Don't get the wrong idea, I use it for me, and it's just not the complete program if

you patch..... But the big deal is I use WAIT post installer and for some that use

my ISO's they don't want all programs offered, their loss. Me for my use I don't care

if I click twice and it's not silent, but if I state ISO is silent then I have to leave off

XPize 3.0...........I hope this makes since to you.........

BD

0

Share this post


Link to post
Share on other sites

hallo xpero

the feature of patching i386 is great, but at the moment there are so many post sp2 fixes that kill xpize from svcpack.inf on so i just use the normal installer

hope that its not so difficult to fix all this - the pack is simply great

yergling

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.