Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Xpize 3.0 Released

- - - - -

  • This topic is locked This topic is locked
47 replies to this topic

#26
iwod

iwod

    Member

  • Member
  • PipPip
  • 265 posts
  • Joined 26-March 04

@iwod, install xpize on your host machine and export winrar.exe to your winrar's silent installation ;)

<{POST_SNAPBACK}>


thanks, never thought of it this way.


How to remove advertisement from MSFN

#27
yergling

yergling

    Newbie

  • Member
  • 37 posts
  • Joined 03-December 04
hallo again

is there any news regarding the installation problem ???

ok the second one

i took a screenshot from a password wizard so - does someone know where the ressource for this key picture is - it is not royalized - so i would like to change manual or give the offer to include in next version *gg*

thanks
yergling


p.s. how can i attach files to the post - like in the german forum ?????????

here is the link to the german forum picture

http://board.windows...pe=post&id=2505

#28
scankurban

scankurban

    F_s_M

  • Member
  • PipPip
  • 240 posts
  • Joined 29-August 03
Thank you for your work
Posted Image

#29
yergling

yergling

    Newbie

  • Member
  • 37 posts
  • Joined 03-December 04
hallo again

for the german users here is a working auto-it script

if you do not try to get the message in silent mode, but click throu the complete setup uotoit works great

AutoItSetOption("MouseCoordMode", 0)
AutoItSetOption("TrayIconHide", 1)
BlockInput(1)
run("XPIZE_3.0.exe")
winwait("Installer Language")
controlclick("Installer Language", "OK", "Button1")
winwait("XPize v3.0 Installation", "Willkommen")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Lizenzabkommen")
controlclick("XPize v3.0 Installation", "Ich &akzeptiere das Lizenzabkommen.", "Button4")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Read Me")
controlclick("XPize v3.0 Installation", "Next >", "Button2")
winwait("XPize v3.0 Installation", "Installation Type")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Komponenten auswählen")
mouseClick("left", 200, 158, 1, 0)
controlclick("XPize v3.0 Installation", "&Installieren", "Button2")
winwait("XPize v3.0 Installation", "Die Installation ist vollständig")
controlclick("XPize v3.0 Installation", "&Weiter >", "Button2")
winwait("XPize v3.0 Installation", "Windows jetzt neu starten?")
mouseClick("left", 190, 207, 1, 0)
controlclick("XPize v3.0 Installation", "&Fertig stellen", "Button2")
BlockInput(0)

so you have to modify if you want to install english or other version

this script installs default, but without creating restore point and without restart

have fun

yergling

#30
rendrag

rendrag

    grrrrrr

  • Member
  • PipPipPipPip
  • 687 posts
  • Joined 28-October 04
  • OS:Windows 7 x64
  • Country: Country Flag
after i installed it, rebooted my computer, and my winlogon.exe is broken. It says it cant find a SHREF call in msigna.dll. Only option is OK, so I click it, it then says it can't load winlogon.exe. contact system admin. I had to reinstall windows

I'm hesitant to install it again. Anyone else run into this?

ASUS M4A78T-E | AMD Phenom II X4 905e 2.5GHz | 4x 2GB A-Data DDR3 1600 RAM | Saphire Radeon HD 7950 | 256GB Crucial M4 SSD | 1TB Western Digital Black | 256GB Seagate Barracuda | Samsung DVD Burner SH-S222L | 22" Samsung 226BW LCD | Creative Gigaworks S700 5.1 speakers


#31
Nanaki

Nanaki

    Leg-humper

  • Member
  • PipPipPipPip
  • 511 posts
  • Joined 17-January 05
I had the same problem by installing SP2, when it occurs, just place that file back from the cd.
CDswitch - Making CD/DVD-switching fun. / VMcleaner - Cleaning your virtual memory by killing unnecessary tasks
WinampUser - Silently install multiuser functionality for Winamp / OfficeExec - Installing Office at T-12/cmdlines.txt
Dropper - Changing file properties by drag-'n-dropping (not for unattended use)

#32
rendrag

rendrag

    grrrrrr

  • Member
  • PipPipPipPip
  • 687 posts
  • Joined 28-October 04
  • OS:Windows 7 x64
  • Country: Country Flag

I had the same problem by installing SP2, when it occurs, just place that file back from the cd.

<{POST_SNAPBACK}>


unfortunately I could not get to a point where that was possible. It's a laptop, so the hard drive isn't exactly easily accessible to hook up to another machine to force the file over that way, and I can't run recovery console because I don't own a floppy drive.

ASUS M4A78T-E | AMD Phenom II X4 905e 2.5GHz | 4x 2GB A-Data DDR3 1600 RAM | Saphire Radeon HD 7950 | 256GB Crucial M4 SSD | 1TB Western Digital Black | 256GB Seagate Barracuda | Samsung DVD Burner SH-S222L | 22" Samsung 226BW LCD | Creative Gigaworks S700 5.1 speakers


#33
Nanaki

Nanaki

    Leg-humper

  • Member
  • PipPipPipPip
  • 511 posts
  • Joined 17-January 05
You can run the recovery console with the setup disc.
CDswitch - Making CD/DVD-switching fun. / VMcleaner - Cleaning your virtual memory by killing unnecessary tasks
WinampUser - Silently install multiuser functionality for Winamp / OfficeExec - Installing Office at T-12/cmdlines.txt
Dropper - Changing file properties by drag-'n-dropping (not for unattended use)

#34
rendrag

rendrag

    grrrrrr

  • Member
  • PipPipPipPip
  • 687 posts
  • Joined 28-October 04
  • OS:Windows 7 x64
  • Country: Country Flag
i tried running recovery console, it just kept telling me to insert the floppy disk and hit enter

ASUS M4A78T-E | AMD Phenom II X4 905e 2.5GHz | 4x 2GB A-Data DDR3 1600 RAM | Saphire Radeon HD 7950 | 256GB Crucial M4 SSD | 1TB Western Digital Black | 256GB Seagate Barracuda | Samsung DVD Burner SH-S222L | 22" Samsung 226BW LCD | Creative Gigaworks S700 5.1 speakers


#35
XPero

XPero

    Father of XPize / Vize

  • Developer
  • 1,912 posts
  • Joined 08-August 04
@rendrag:

Your problem is strange because XPize does not replace your original logon, instead it places the new one in C:\Windows\XPize (hidden by default) and applies a new registry value to make it the default one. Anyway, I will try to figure out what the cause can be.

XPero

#36
Kelsenellenelvian

Kelsenellenelvian

    WPI Guru

  • Developer
  • 8,823 posts
  • Joined 18-September 03
  • OS:Windows 7 x64
  • Country: Country Flag
I to have a problem with the winrar patch and I have tried a dozen different ways will some one provide me the patched winrar??

PLEASE PLEASE...

#37
keytotime

keytotime

    Advanced Member

  • Member
  • PipPipPip
  • 400 posts
  • Joined 05-October 04
The new Xpize breaks .cmd and .bat. I've tried a few and none work.

#38
XPero

XPero

    Father of XPize / Vize

  • Developer
  • 1,912 posts
  • Joined 08-August 04
@keytotime:

Send me those .cmd and .bat, I will see what happens in my system. And please, specify your system (XP, 2003, MCE and what Service Pack you have).

#39
keytotime

keytotime

    Advanced Member

  • Member
  • PipPipPip
  • 400 posts
  • Joined 05-October 04
Xp Sp2 with ryan's pack, one of them is ryan's cab updater. Anything that has a cd or looks at a different directory than the default one has problems.

#40
Daeron Tinúviel

Daeron Tinúviel

    Newbie

  • Banned
  • 25 posts
  • Joined 17-February 04
i already had xpize installed now i want to patch winrar how i do it?

#41
XPero

XPero

    Father of XPize / Vize

  • Developer
  • 1,912 posts
  • Joined 08-August 04
@keytotime:
Although this is very strange, try this: look into C:\WINDOWS\XPize\Backup and replace
patched wscript.exe and cscript.exe with the original ones. If you installed Windows using the i386 patching feature, look into your Windows CD and Ryan's Pack for those original files. You can use Replacer

@Daeron Tinúviel:

Run the installer again and select skins-->WinRAR 3.xx only. This should work.

#42
Glowy

Glowy

    The voices made me do it!

  • Member
  • PipPipPip
  • 315 posts
  • Joined 25-March 04
Whoa! amazingly nice toy!! :w00t:

maybe something for the next release: replacement of the IE animated icons?

EDIT (after PM): I mean the throbber..

Edited by Glowy, 25 March 2005 - 05:04 PM.

Why geeks like computers: unzip, strip, touch, finger, grep, mount, fsck, more, yes,fsck,fsck,fsck,umount, sleep.

#43
XPero

XPero

    Father of XPize / Vize

  • Developer
  • 1,912 posts
  • Joined 08-August 04

Bug report: XPize modifies user32.dll, which in some unknown way, causes applications using some of its APIs to crash. Example: Futuremark 3DMark03. This bug was found on Windows XP SP1.

<{POST_SNAPBACK}>

XPize does not touch user32.dll. At least I haven't found that file in C:\WINDOWS\XPize\Backup, so it hasn't been modified.

#44
yergling

yergling

    Newbie

  • Member
  • 37 posts
  • Joined 03-December 04
that's right

user32.dll is not modified by xpize

so i had 2 little problems in the last weeks using xpize

i hope they are not generated because i used xpize - maybe someone knows

1. if i click my network places with the right mouse button and select "properties" a message appears that i can not place a shortcut here

2. if i click on an other system my computer with the right mouse button and select "manage" a message appears that the default management console can not be found - management is completely impossible - on the same system internet properties and search is also impossible

i reinstalled one of them and used also xpize 3.0 and the error does not occure again - may it be that there is an update problem from xpize 2.5 to 3.0 ???

thanks
yergling

#45
bonedaddy

bonedaddy

    Bonafide Member

  • Member
  • PipPipPip
  • 454 posts
  • Joined 20-October 03
Hi Xpero

I said;
I was just wondering if anyone else is having problems with XPize3.0
installing silently after using nlite, I get 2 popup windows, one about
systemrestore not being written to and one about uxtheme not compatable
with system........


Nuhi said;
You removed SysRestore and patched Uxtheme...that's normal.
Contact XPize installer author and tell him to add silent switch for these warnings.


I said;
yes I do remove systemrestore, and use nLites uxtheme


Xpero said;
here's how I do it........


I then said;
I think I'll just leave in sysrestore and use your uxtheme.......... should solve
the problem, right??


NO.
And now I finally got around to making a new ISO and left in systemrestore and did not
use nLites uxtheme, and still I get those 2 popups.......

thought you should know Xpero.....also don't forget the problem with command promt.....
had to uninstall it for window to work.......


thanks BD
Using WPI the best Post installer
Using W.A.I.T v23 the 2nd Best Post Installer

#46
XPero

XPero

    Father of XPize / Vize

  • Developer
  • 1,912 posts
  • Joined 08-August 04
@bonedaddy:

OK. It seems that all the effort put in the "i386 patching feature" has been a waste of time for some, because you dont use it. Having this into account, I think I'm going to put end to all this. I'm currently learning NSIS and thought about a final solution to that unattended problem. I'm not going to give details about my idea (dont want to create expectations). Let's see what happens. Untill now, install XPize normally, believe me, it is not a big problem (irony).

XPero

#47
bonedaddy

bonedaddy

    Bonafide Member

  • Member
  • PipPipPip
  • 454 posts
  • Joined 20-October 03
Hi Xpero

Don't get the wrong idea, I use it for me, and it's just not the complete program if

you patch..... But the big deal is I use WAIT post installer and for some that use

my ISO's they don't want all programs offered, their loss. Me for my use I don't care

if I click twice and it's not silent, but if I state ISO is silent then I have to leave off

XPize 3.0...........I hope this makes since to you.........

BD
Using WPI the best Post installer
Using W.A.I.T v23 the 2nd Best Post Installer

#48
yergling

yergling

    Newbie

  • Member
  • 37 posts
  • Joined 03-December 04
hallo xpero

the feature of patching i386 is great, but at the moment there are so many post sp2 fixes that kill xpize from svcpack.inf on so i just use the normal installer

hope that its not so difficult to fix all this - the pack is simply great

yergling




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users