• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
LaptoniC

Silence of the foxes

235 posts in this topic

After few tries, all I get is 'app.7z' file and it is not the installer, jast 7z archive. I think that SOF should make an exe file for silent install, but it doesn't. How to make it work?

Millan

0

Share this post


Link to post
Share on other sites

Forecastfox doesn't install properly. It gives an error stating; "An error occured starting the Disk I/O Component." when it starts up. If I uninstall this extension, then firefox doesn't give this error. When I try to reinstall forecastfox, it never works properly after that... :(

I had the same problem. But I worked through it but doing a test install from the web. Grab these two folders:

"extensions" - this one includes a folder named "{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}"

"forecastfox" - this includes a bunch of files and folders.

And put them in the SOF "profile" folder.

No rebuild your SOF package.

Thanks alot. :thumbup

I'll give it a try tonight.

0

Share this post


Link to post
Share on other sites
To edit the FF instaler directly:

1) Download Firefox

2) Open config.ini, change Run Mode=Normal to Run Mode=Silent

3) Delete adt.xpi, talkback.xpi

4) To add your extentions and themes open browser.xpi in winrar, browse to bin\extensions, copy all your themes and extention's to the folder.

5) To add plugin's in browser.xpi, browse to \bin\plugins and copy all the plugin's to that folder. Note some plugin's also have files in bin\components.

6) To add your bookmarks's and prefs.js, open up your language.xpi (ex: en-US.xpi) and browse to i\bin\defaults\profile and then copy in your bookmark and pref's.

7) Then just make a 7-zip installer.

this is the best method for me :thumbup first time i manually edit the installer, it works like a charm...thnx keytotime! :thumbup

0

Share this post


Link to post
Share on other sites
To edit the FF instaler directly:

1) Download Firefox

2) Open config.ini, change Run Mode=Normal to Run Mode=Silent

3) Delete adt.xpi, talkback.xpi

4) To add your extentions and themes open browser.xpi in winrar, browse to bin\extensions, copy all your themes and extention's to the folder.

5) To add plugin's in browser.xpi, browse to \bin\plugins and copy all the plugin's to that folder. Note some plugin's also have files in bin\components.

6) To add your bookmarks's and prefs.js, open up your language.xpi (ex: en-US.xpi) and browse to i\bin\defaults\profile and then copy in your bookmark and pref's.

7) Then just make a 7-zip installer.

Hrm. Doesn't seem to work with 1.5. I did exactly as described above, only added a few extensions to browser.xpi -> bin/extensions. They are supposed to go right there, not in bin/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd} right ??

It installs just fine, but none of the extensions are installed.

Another question - how to prevent it from dropping a shortcut on the desktop ?

D.

Edited by Halfwalker
0

Share this post


Link to post
Share on other sites

@ halfwalker.. it works well with my FF 1.5... when u open ur FF the first time, the extension installer will popup & after it installs firefox will open... but of course u shud restart firefox for the extension/ themes to work..

the extensions shud be inside bin/extensions/

i recommend using bookmark backup extension to backup ur FF settings... it can backup prefs.js.. then what i did is to put it & replace the original prefs.js in the FF installer... even ur previous extension settings will be restored :thumbup

Edited by slimzky
0

Share this post


Link to post
Share on other sites

Hrm - no workee. I wonder - this VM had 1.07 installed. I uninstalled that, then installed the new modified 1.5. The extension installer never pops up, and going to Tools->Extensions shows an empty list.

My browser.xpi looks like this :

6233469812500Extensions.png

I'll try a new VM with a clean install of this 1.5.

D.

0

Share this post


Link to post
Share on other sites

Nope - didn't work. Extensions panel is still empty. On first start of FF it just does the usual import of IE settings, that's it.

D.

0

Share this post


Link to post
Share on other sites
Hrm - no workee. I wonder - this VM had 1.07 installed. I uninstalled that, then installed the new modified 1.5. The extension installer never pops up, and going to Tools->Extensions shows an empty list.

My browser.xpi looks like this :

6233469812500Extensions.png

I'll try a new VM with a clean install of this 1.5.

D.

i used 7zip... try it..

Edited by slimzky
0

Share this post


Link to post
Share on other sites

7zip doesn't really have anything to do with it. (I use it too btw). FF seems to install just fine, but it doesn't install any of the extensions I added into the bin/extensions directory of browser.xpi.

Did anyone make any other changes to the config.ini file ?

D.

0

Share this post


Link to post
Share on other sites

hi

i'm experiencing problems with my firefox 1.07

the 7za.exe seems to lock on browser.xpi

the rest of the operations looks good coz once 7za.exe terminated, i have a silentfirefoxe.exe

for about 6 hours, 7za.exe can't be compressing browser.xpi

any ideas please?

excuse my english BTW

0

Share this post


Link to post
Share on other sites

Can`t Read sfx 7zSD.sfx - Error.

Compressing UninstallFirefox.zip

System error:

Not enough storage is available to complete this operation. I dont know why it says not enough storage - I have about 90 GB free.

-edit-

Resolved.

It was my problem. I disabled paging file.....stupid me :lol:

Edited by malinduta
0

Share this post


Link to post
Share on other sites
hi

i'm experiencing problems with my firefox 1.07

the 7za.exe seems to lock on browser.xpi

the rest of the operations looks good coz once 7za.exe terminated, i have a silentfirefoxe.exe

for about 6 hours, 7za.exe can't be compressing browser.xpi

any ideas please?

excuse my english BTW

I had almost the same problem........my paging file (virtual memoty) was disabled. Enable it and should work.

0

Share this post


Link to post
Share on other sites
"Silence of the birds?" :)

Late reply but....

Come on, the only possible slogan would have to be:

'The Delicate Sound Of Thunderbird'

Pink Floyd connotations for those that aren't fans :)

0

Share this post


Link to post
Share on other sites

ehm, what you mean for: "Choose your original Firefox setup package"..

you mean after i install firefox but then i will have the folder Mozilla\Firefox so, what kind of exe you mean? arrrrrghhhh

0

Share this post


Link to post
Share on other sites
ehm, what you mean for: "Choose your original Firefox setup package"..

you mean after i install firefox but then i will have the folder Mozilla\Firefox so, what kind of exe you mean? arrrrrghhhh

1. Start up SOF

2. Hit New Project

3. Navigate to the Installer for firefox (Firefox Setup 1.5.exe)

4. press unpack

5. press next

6. add files to your project press pack when done and enjoy..

0

Share this post


Link to post
Share on other sites

This program is working great for me except for one, teensy tiny, minor issue:

Is there a way to set the install to not overwrite the existing profile?

I want to be able to deploy this as a uniform package throughout my company, but I can't seem to make heads nor tails of the overwrite feature. My users would have my head on a platter if all of their bookmarks disappeared every time I installed Firefox on their system.

Any help in this matter would be really appreciated. I thank my lucky stars for noscript and adblock and creating a package that my users could install on their own easily would...well you would make me cry.

Thanks for the wonderful prog!

- John

0

Share this post


Link to post
Share on other sites

Unfortunately, Silence of the Foxes 1.0 is but of little benefit to me.

I did several attempts, editing the ini file and such... however, the probs remain.

First to say, I'm using a localized version of both Windows XP (up to date) and Firefox 1.5.0.1.

For testing purposes I did a fresh new install of Firefox, customizing it meticulously the way I want it to be.

I included the following components (no themes yet):

Plugins

  • Macromedia Authorware Web Player 2004
  • Macromedia Flash 8.0 r24
  • Macromedia Shockwave Player 10.1.1.016

Extensions (partly localized)

  • Adblock Plus 0.5.11.3
  • CustomizeGoogle[de] 0.45
  • FlagFox II[de] 2.3.4
  • Nuke Anything Enhanced 0.53
  • Pearl Crescent Page Saver[de] 1.0
  • Plain Text Links[de] 0.2
  • PrefButtons[de] 0.3.4
  • User Agent Switcher[de] 0.6.8

Customization

  • bookmarks.html
  • hostperm.1
  • localstore.rdf
  • prefs.js
  • search.rdf
  • userChrome.css
  • userContent.css

Red items do pose problems: Both Shockwave Player and my extensions are missing when using my SoF generated setup.

The files userChrome.css and userContent.css are not treated correctly since they reside in a subfolder (this doesn't seem to be supported in SoF yet).

I tried adding them manually

ProfileFiles=bookmarks.html, […] ,chrome\userChrome.css,chrome\userContent.css

That way they're included, but put in the profile folder, not a subfolder chrome.

Another point I'd like to mention:

When installing the customized Firefox installer the exact profile's path is restored, for instance

%AppData%\Mozilla\Firefox\Profiles\o6ivw2mr.default

and the original profile.ini, respectively.

However, doing an unattended Firefox installation, I usually copy this profile.ini in $OEM$\$Docs\Default User\Application Data\Mozilla\Firefox:

[General]
StartWithLastProfile=0

[Profile0]
Name=Sysprofile
IsRelative=0
Path=C:\Programs\Net\Firefox\profile
Default=1

Therefore, one system wide profile is written within %ProgramFiles%\Net\Firefox\profile (YMMV).

A program option for this would be quite convenient.

Last, not least, I never ever use the default path for Firefox (or Thunderbird), instead I choose %ProgramFiles%\Net\Firefox.

An option to modify the application path would be handy, too.

Edited by Mikka
0

Share this post


Link to post
Share on other sites
I tried adding them manually

ProfileFiles=bookmarks.html, […] ,chrome\userChrome.css,chrome\userContent.css

That way they're included, but put in the profile folder, not a subfolder chrome.

Your method wont work.SOF copies what it sees in ini file to project directory.It doesnt create folders.If you want to copy those files just enter chrome.Then at RemoveFiles section remove the files you dont want.

Another point I'd like to mention:

When installing the customized Firefox installer the exact profile's path is restored, for instance

%AppData%\Mozilla\Firefox\Profiles\o6ivw2mr.default

and the original profile.ini, respectively....

You should copy edit your files so that it wont have any reference to profile directory you have before.That is why including chrome directory is bad idea.When extensions and themes installed their path is written to chrome AFAIR.

Last, not least, I never ever use the default path for Firefox (or Thunderbird), instead I choose %ProgramFiles%\Net\Firefox.

An option to modify the application path would be handy, too.

This option is already present.You can change where to install by modifying the ini of original installer.Open config.ini file and change the Path variable.

0

Share this post


Link to post
Share on other sites

I'm having the same problem as hostein did. The compression of Browser.XPI takes so long I have to cancel the process. (My page file is set to system managed). I don't have 6 hours of patience as hostein did, but 30+ mins should be well more than enough. It only takes it a minute or so to get to browser.xpi and then just stays there. It shouldn't be taking that much longer than anything else.

I've read the rest of this thread and my extensions, themes, prefs.js are all in the right places. The only thing I've otherwise customized is to set it to a silent install.

Input?

0

Share this post


Link to post
Share on other sites

Hey guys,

Just a quick tip for beginners. I've been using SoF for a while without any problems but suddenly found that my bookmarks etc. were not being included in the install.

After much ado, I discovered the reason for this was that I'd inadvertently deleted the Profiles directory out of my FireFox project directory. SoF has a small bug whereby it doesn't create the Profiles directory only copies the relevant files into it.

So, if you don't have the Profiles directory (as given in the SoF.zip download) then you won't have your profile settings saved! (incidentally, SoF does create the Main directory so alls well there!).

0

Share this post


Link to post
Share on other sites

Haven't experienced this but very interesting.

Cheers

MC.

0

Share this post


Link to post
Share on other sites

SoF don't work on Windows 2000 SP4.

I tried in two different machines at work.

After unpack the setup in the log windows I see "Everything is Ok"

But an Application Error is raised pressing the Next button.

Any Idea?

0

Share this post


Link to post
Share on other sites

I am sorry, my English is very bad… I will speak French but if you cannot understand it it is not serious.

J'aurais souhaitais, si tu peux LaptoniC, un tutorial sur ton logiciel : The silence of the foxes, et si possible, et oui je suis ennuyeux :no: , en français. D'après ton flag tu es Marocain n'est-ce pas ? Merci d'avance LaptoniC. :hello:

Tu peux venir faire un tour chez nous si tu le désires ! :Win-web.be Ca parle de Unattended aussi ! :yes:

Aralde Trent.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.