• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
maximus-decim

Maximus-Decim Native USB Drivers

804 posts in this topic

maximus-decim, do you plan to update the original 2.2 installer with this new INF? it would be great and easier to deploy if an updated installer is available.
Is there an all-in version 2.3 on the horizon by any chance?
0

Share this post


Link to post
Share on other sites
Is there an all-in version 2.3 on the horizon by any chance?

of course, ;)

but the best way to make it is to publish here links to infs and drivers missed in 2.2 - it's so hard to browse web everyday for the newones :wacko:

Also we have one limitation - USBSTOR.INF is about 50KB in size now - 64K max :}

0

Share this post


Link to post
Share on other sites
Is there an all-in version 2.3 on the horizon by any chance?

of course, ;)

but the best way to make it is to publish here links to infs and drivers missed in 2.2 - it's so hard to browse web everyday for the newones :wacko:

Also we have one limitation - USBSTOR.INF is about 50KB in size now - 64K max :}

There are lots of "DeviceDesc"s on the "Strings" section. You can combine most of them.

0

Share this post


Link to post
Share on other sites
There are lots of "DeviceDesc"s on the "Strings" section. You can combine most of them.

agreed :D

0

Share this post


Link to post
Share on other sites

Woav!

Tanx. Will try it first thing tommorrow!

btw. Just wondering who did the slovenian version?*

I did! :hello:

Here are the files included:

slovenian files

---------------

qfecheck.exe, 4.10.0.1998

systray.exe, 4.10.0.2224

user.exe, 4.10.0.2227

hotplug.dll, 4.10.0.2224

QFECHECK.HLP

english files

-------------

advpack.dll, 4.72.3110.0

user32.dll, 4.10.0.2227

1394BUS.SYS, 4.10.0.2226

NTMAP.SYS, 4.10.0.2227

OHCI1394.SYS, 4.10.0.2228

SBP2PORT.SYS, 4.10.0.2227

USBAUTH.SYS, 4.90.3000.1

USBNTMAP.SYS, 4.90.3000

USBSTOR.SYS, 4.90.3000.1

language neutral

----------------

USBU2A.SYS, 1.4.2.0

VXD, PDR files

-----------

NTMAPHLP.PDR

USBMPHLP.PDR

DISKTSD.VXD

IOS.VXD

BTW, have you installed the package???

Servus.

Had some problems with WIn98 since we only had the first edition installed. And such things moves very slowly in school. So I finally got around to do a fresh WIn98SE SLO install. Will tell u the results on friday. Wish us luck!!

And tanx again for SLO edition. Which town are U from?

0

Share this post


Link to post
Share on other sites

I'm also interesting in whether there will be a new version anytime soon, as I'm prepping the Windows 98 Power Pack compilation yet again, and I want to get all the latest, stable apps integrated into it.

0

Share this post


Link to post
Share on other sites

I've noticed that in 2.21 are the following lines for Mitsumi:

%VID_03EE&PID_0000.DD%=USBSTOR_CBI, USB\VID_03EE&PID_0000

%VID_03EE&PID_6901.DD%=USBSTOR_CBI, USB\VID_03EE&PID_6901

;%VID_03EE&PID_6902.DD%=USBSTOR_CBI, USB\VID_03EE&PID_6902

As I already reported here, the driver does not work with Mitsumi Floopy drive with VID_03EE&PID_6901 so I suppose it should be commented out too.

Strange thing is that with Windows ME it works perfectly without any driver, and wit Windows 98 SE without nusb and with Mitsumi supplied driver too. I have no idea what is wrong with nusb driver.

Petr

0

Share this post


Link to post
Share on other sites

Great Problem here.

I am happy with the Maximum-Decim Native USB driver for a period of time. However, when I decide to add one more external USB disk (I already have an identical one), the system just cannot recognize the new disk. Only if I eject the existing drive, the new drive probe up.

Are there any methods that can make them co-exist?

thanks

0

Share this post


Link to post
Share on other sites

You can add Maxtor PL series to the list of drives that work with NUSB, I tried to get my Sandisk Cruzer to work too, but no joy there, have to use Sandisk drivers

0

Share this post


Link to post
Share on other sites

I work above the following version of the NUSB (2.3?). New devices will be added many. The file usbstor.inf will be divided into some files (usbstor1.inf, usbstor2.inf, etc) that it was possible to add easily the new device independently. But I very much do not have time, therefore the new version will be not fast. :(

0

Share this post


Link to post
Share on other sites

@Petr

Recently, a friend just bought IBM usb fdd which was made by Teac and hoping

it really IBM.

However, Win XP (no driver needed) & 98SE (using the supplied drivers)

recognized it as Mitsumi usb fdd.

Attached is usb-fdd.zip (MTMFDVSD.INF + MTMUSBFD.INF) of IBM usb fdd which

might interest u, especially MTMFDVSD.INF refers to "Port Driver".

Those 2 files might be identical to ur Mitsumi usb fdd or pls pm for complete

supplied drivers.

HTH.

usb_fdd.zip

0

Share this post


Link to post
Share on other sites

hello, this universal driver should work in a win98SE spanish version?

If don't, there are any possibility to modify it for work? Is difficult? if necessary, I can spend some time trying to port it to spanish version....

0

Share this post


Link to post
Share on other sites
hello, this universal driver should work in a win98SE spanish version?

If don't, there are any possibility to modify it for work? Is difficult? if necessary, I can spend some time trying to port it to spanish version....

Hi, the English version should work but many system messages would change from Spanish to English. There are some files that should be modified for spanish version.

Hardware.hlp - available in Q242975 update

Hotplug.dll 4.10.2224 - available in Q242975 update

Systray.exe 4.10.2224 - available in Q242975 update

QFECheck.exe - available in Q242975 update

QFECheck.hlp - available in Q242975 update

Ios.vxd 4.10.2225 - you have to ask Microsoft for Spanish version of Q239696 hotfix

User.exe 4.10.2231 - you have to ask Microsoft for Spanish version of Q291362 hotfix

!readme.txt - has to be translated by you

_nusb.inf and maybe other infs - has to be translated by you if you need

Q242975 update can be downloaded here:

http://download.microsoft.com/download/win.../242975SPA8.EXE

For building the installation package you will need the iexpress utility, it is part of the IEAK - can be downloaded here: http://download.microsoft.com/download/ie6...XP/ES/ieak6.exe

Iexpress utility uses SED (Self Extraction Directive) files that describe how the package should be build. It can build new SED files or it can use already prepared file. I have prepared an example of such file for Spanish nusb here: http://www.winpack.org/nsp_petr/nusb221es.sed - it expects all files in nusb221es folder.

If you want just to build the package with no interactive options, you can use the following command line:

iexpress /N nusb221es.sed

You may also want to translate the "FriendlyName" in the .SED file.

I tried to localize Ios.vxd and user.exe by myself and build the package here:

http://www.winpack.org/nsp_petr/nusb221es.exe

It was not tested at all (I have no Spanish Windows 98 SE here) so please be careful and backup first!. It may not install or crash your system, I don't know!

If you will need more information about INF files and other related things, you can check te following website: http://www.winpack.org/petr/INF_web/ - the original disappeared so I just mirrored it from web archive.

Petr

Edited by Petr
0

Share this post


Link to post
Share on other sites

I'm having an issue with these drivers... Whever I plug in a USB flash device, it shows up in device manager, but no drive letter gets assigned to the Disk Drive component... This also happens with the vendor's drivers. Does anyone have a fix for this?

Thanks,

mtp

0

Share this post


Link to post
Share on other sites
I'm having an issue with these drivers... Whever I plug in a USB flash device, it shows up in device manager, but no drive letter gets assigned to the Disk Drive component... This also happens with the vendor's drivers. Does anyone have a fix for this?

Thanks,

mtp

It's too general question. What "USB Flash device"? What is the VID and PID? Is the VID and PID of your flash device listed in USBSTOR.INF? What "vedndor's drivers" do you use?

Before installing nUSB all other USB storage drivers should be removed (in Safe Mode) including their INF files from %windir%\INF folder and all USB flash devices should be removed from the system. The best way is to install nUSB on fresly installed Windows 98 SE.

Then you will install the nUSB driver and then you can plug in your USB flash device. There is no warranty that all devices will really work.

Petr

0

Share this post


Link to post
Share on other sites

Mr The Plague

have U "lastdrive=..." string in your config.sys file?

have U "net use ..." command in any startup file (f.e. autoexec.bat or any logon script with drive mapping)?

is your PC used as a workstation in Novell Netware network?

0

Share this post


Link to post
Share on other sites
It's too general question. What "USB Flash device"? What is the VID and PID? Is the VID and PID of your flash device listed in USBSTOR.INF? What "vedndor's drivers" do you use?

Before installing nUSB all other USB storage drivers should be removed (in Safe Mode) including their INF files from %windir%\INF folder and all USB flash devices should be removed from the system. The best way is to install nUSB on fresly installed Windows 98 SE.

Then you will install the nUSB driver and then you can plug in your USB flash device. There is no warranty that all devices will really work.

Well, the drivers provided by the vendor for the respective devices. - concord Eye-Q 4363Z camera, Lexar Jumpdrive, and Jumpdrive Secure. The camera gets recognized as a GenericBulkOnly, and the jumpdrives get recognized as their names. They just don't get a drive letter assigned by Windows.

I cannot install this on a fresh 98se box; it's for my girlfriend and she'd freak if I had to reformat.

have U "lastdrive=..." string in your config.sys file?

have U "net use ..." command in any startup file (f.e. autoexec.bat or any logon script with drive mapping)?

is your PC used as a workstation in Novell Netware network?

None of the above.

0

Share this post


Link to post
Share on other sites
I tried to localize Ios.vxd and user.exe by myself and build the package here:

http://www.winpack.org/nsp_petr/nusb221es.exe

It was not tested at all (I have no Spanish Windows 98 SE here) so please be careful and backup first!. It may not install or crash your system, I don't know!

Petr

Thank you very much!!!!!!

at the moment, it seems to work well, if it don't give problems in the PC that I installed it, soon I will install it in the rest.

0

Share this post


Link to post
Share on other sites

All of a sudden I've got ghost usb hdd drives, didn't show up right away, was a couple of days later. Does anyone know how to get rid of them? Doesn't affect performace, just annoying :blink:

0

Share this post


Link to post
Share on other sites

I hope i installed the latest version the file is nusb22es.exe. Anyways, after i installed nusb, it did NOT work with one of my USB flash disks. The disk is a Sony MicroVault USB 2.0 256 MB. Is it because Win98SE WON'T support USB 2.0, or what? Nusb worked with a Sandisk Cruzer Mini, but it ONLY works after i restart my computer. What gives? I thought USB is Plug'n' Play.

Edited by seskanda
0

Share this post


Link to post
Share on other sites

I'm having an issue with these drivers... Whever I plug in a USB flash device, it shows up in device manager, but no drive letter gets assigned to the Disk Drive component... This also happens with the vendor's drivers. Does anyone have a fix for this?

Thanks,

mtp

hard disk usb ? perhaps in NTFS format no ? if that windows 9x/me can't read ntfs drive directly ...

Edited by sonic
0

Share this post


Link to post
Share on other sites
I hope i installed the latest version the file is nusb22es.exe.

Do you mean nusb221es.exe ? As far as I know, no file associated with this project is called nusb22es.exe .

The latest English version is nusb22e.exe.

There's also an additional update of the USBSTOR.INF file to download as a .zip package and install afterwards, called nusb221e_upd.zip.

Petr has put together a version for Windows 98 SE Spanish, after someone here requested one, called nusb221es.exe. Is this the version you installed? If you did, then hopefully you intended to install this Spanish version (because your OS is a Spanish version, I would presume).

From what I understand, USB has often been problematic for several well-known hardware manufacturers. An updated Windows 98 SE should be able to handle USB 2.0, providing you have the correct drivers from your motherboard manufacturer (in addition to these 'native' USB drivers for USB devices). So, if you know what make and model your motherboard is and you haven't already done this, go to the manufacturer's website and download the latest USB driver. I guess you would have to re-install these nUSB drivers after updating your motherboard's USB drivers.

It's well worth taking a look at the USBMan website for help (although some parts of it may be a little bit out of date), particularly if you have a VIA chipset/motherboard.

Hope this helps. Maybe someone more experienced with matters USB will chip in and help you out some more if needed.

0

Share this post


Link to post
Share on other sites

Oops, your right, it is nusb22e.exe. Where can i download the update to USBSTOR.INF? My motherboard is an Intel 440ZX, i think, once i'm certain i'll check out Intel's site and look for those USB update drivers. After i install the motherboard USB drivers, can i UN-install Nusb, or will it be fine to just RE-install it instead? Also, about having to Restart after inserting the Sandisk Flash drive, USBman.com says it should be PnP, what's the deal? Is there something internally wrong with my PC, because i have to reboot the system everytime i use the Sandisk Flash disk?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.