Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
Guillaume_fr

cmd.exe starting directory

Recommended Posts

Hello,

When I launch cmd.exe on my XP SP2 (via Start | Run), the current directory is my Home Directory; I get this :

Microsoft Windows XP [version 5.1.2600]

© Copyright 1985-2001 Microsoft Corp.

D:\Documents and Settings\Guillaume>

How can I set up Windows to open cmd.exe in another directory (C:\ or anything else) ?

Thanx,

Guillaume.

Share this post


Link to post
Share on other sites

oioldman    0

@baywatch - That URL is bad.

@Guillaume_fr - Also, it is done via the SET HOMEPATH option.

if you open the command box and type SET then hit return.

What is your homepth, and change as needed.

Share this post


Link to post
Share on other sites

I have

HOMEDRIVE=d:

HOMEPATH=\Documents and Settings\Guillaume

If I make

> set HOMEDRIVE="C:"

> set HOMEPATH="\"

The next time I'll launch cmd.exe my HOMEDRIVE and HOMEPATH will be "d:" and "\Documents ..."

So, how can I make my changes persistants ?

And won't there have any other effects ?

Share this post


Link to post
Share on other sites
maxXPsoft    27

Heres what I use to make the path in the Dir it executes on.

This gives you right click on all Files/Folders and DOS HERE appears. Click it and opens the cmd prompt with path in dir of containing. That Microsoft one is useless to me.

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\cmd]
@="DOS HERE"

[HKEY_CLASSES_ROOT\*\shell\cmd\command]
@="cmd.exe \\\"%1\\\""

[HKEY_CLASSES_ROOT\Directory\shell\cmd]
@="DOS HERE"

[HKEY_CLASSES_ROOT\Directory\shell\cmd\command]
@="cmd.exe /k \"cd %L\\\""

[HKEY_CLASSES_ROOT\Directory\shell\cmd]
@="DOS HERE"

[HKEY_CLASSES_ROOT\Directory\shell\cmd\command]
@="cmd.exe /k \"cd %L\\\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\shell\cmd]
@="DOS HERE"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Directory\shell\cmd\command]
@="cmd.exe /k \"cd %L\\\""

Share this post


Link to post
Share on other sites
maxXPsoft    27

BTW if you right click on a file on the desktop it will give you what you had. Anywhere else its the actual path

E:\_beta.microsoft.com>

C:\UnattendXP>

Share this post


Link to post
Share on other sites
maxXPsoft    27

Hmm I tried cmdinit.bat but no joy to do that. I'm not sure then a way to get it there. You could use that above and just click the C: drive and click Dos Here. I get

C:\>

Share this post


Link to post
Share on other sites
spiritpyre    0

this probably doesn't help but using /K parameter you can set the directory when you call cmd

cmd.exe /k cd "C:\"

opens cmd pointed to C:\

although if you always want cmd to point to C:\ and you use a shortcut to call cmd

you could just put that in the shortcut? just an idea

Share this post


Link to post
Share on other sites
rubyquyen    0
Hello,

When I launch cmd.exe on my XP SP2 (via Start | Run), the current directory is my Home Directory; I get this :

             Microsoft Windows XP [version 5.1.2600]

             © Copyright 1985-2001 Microsoft Corp.

            

             D:\Documents and Settings\Guillaume>

How can I set up Windows to open cmd.exe in another directory (C:\ or anything else) ?

[HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor]
"AutoRun"="C: && cd \\"

Voilà :)

Share this post


Link to post
Share on other sites
Zxian    0
[HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor]
"AutoRun"="C: && cd \\"

Voilà :)

That should read:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Command Processor]
"AutoRun"="C: && cd \"

Note the single backslash. Otherwise you get an error (surprise...:P). Thanks for this though! Very nice!

Cheers!

Share this post


Link to post
Share on other sites
rubyquyen    0
Note the single backslash. Otherwise you get an error (surprise...:P). Thanks for this though! Very nice!

Yes, single backslash if you enter the value directly into the registry. Mine is extracted from a .reg file, so double backslash are required.

Share this post


Link to post
Share on other sites
Yzöwl    30

What about this?

REG ADD "HKLM\SOFTWARE\Microsoft\Command Processor" /v AutoRun /d "%%SystemDrive%%" /f

or in reg format

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor]
"AutoRun"="%SystemDrive%"

Share this post


Link to post
Share on other sites
rubyquyen    0
What about this?
REG ADD "HKLM\SOFTWARE\Microsoft\Command Processor" /v AutoRun /d "%%SystemDrive%%" /f

or in reg format

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor]
"AutoRun"="%SystemDrive%"

That sounds good, except that if you want C:\mydir as default, but your system is on D:, that won't work :)

Share this post


Link to post
Share on other sites
Yzöwl    30
That sounds good, except that if you want C:\mydir as default, but your system is on D:, that won't work :)
None of the examples given to date used C:\mydir. In fact if you want C:\mydir, your example(s) will not work either.

The original questioner also only asked

I'd like to be on C:\ when opening cmd.exe
Since most users C: drive is also the %SystemDrive%, I gave that as an alternative, because in that scenario you don't need the && cd etc..

If you would like to explain the probability of someone installing their system on D: and running the cmd shell, very likely located at D:\WINDOWS\system32 or D:\WINNT\system32 to access root at C:, which will very likely belong to another OS! (How many people create a 'data' drive as C: and then install the OS to D:)

In your case, (as given in your quote above), all you should need would be

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor]
"AutoRun"="cd /d c:\\mydir"

or in a case where you have spaces in your chosen path. (The additional quotes may not be necessary if you have command extensions enabled)

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor]
"AutoRun"="cd /d \"c:\\my dir\""

By the way, if anyone is testing these without having first backed up the key, to return to the default setting use this

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Command Processor]
"AutoRun"=""

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×