MDGx

98SE2ME = Killer Replacements: ME -> 98 SE

1,084 posts in this topic

98SE2ME

Updated12-14-2011

By popular demand... :blink:

98SE2ME is the automated installer designed to perform all Killer Replacements ME -> 98 SE "transplant" operations completely unattended, a.k.a. "hands-free". :thumbup

Download + install 98SE2ME [English, 4.3 MB].

Use this link ONLY IF link above does not work.

98SE2ME September 2007 French [2.65 MB].

98SE2ME September 2007 Italian [2.56 MB].

MUST read READ1ST.TXT CAREFULLY BEFORE installing ANY 98SE2ME options.

98SE2ME HTML Help Guide + Manual [152 KB, old, not updated].

Killer Replacements: ME -> 98 SE do-it-yourself guide.

98SE2ME info, downloads + screen shots.

98SE, 98SESP2 + 98SE2ME boot logos [1.05 MB].

Changes + Updates

See UPDATES.TXT.

IMPORTANT

REQUIRED:

  • Windows 98 Second Edition (SE) MUST be ALREADY installed.
  • ALL Windows Millennium Edition (ME) setup *.CAB files [CABs] MUST be anywhere on your local disk(s)/partition(s) into the SAME directory/folder or a Windows ME Gold/Final/RTM/MSDN setup CD-ROM (any Edition: Full, Update) MUST be inside 1st CD/DVD drive (if more than 1).

Everything here is for English language ONLY.

This is an Open Source project.

This is NOT a Microsoft product.

By replacing Microsoft files you may VOID the EULA, warranty and/or support (if any).

You do all this at your OWN risk.

Nobody is liable NOR responsible for ANYTHING due to the use of these files.

ALWAYS BACKUP FIRST!

100% UNofficial + UNsupported compilation of Microsoft files.

All ©, ® + retain the property of their respective owners and are used here solely in non-trademark descriptive sense.

MUST use and distribute ONLY for educational and profit-free purposes.

Please post here all BUGs, FIXes, tips, comments etc, so I can improve 98SE2ME accordingly. This is the only way we can all benefit.

Special thank you to all contributors.

E-mail

Enjoy.

0

Share this post


Link to post
Share on other sites

MDGx:

Awesome work!

You, Gape & Tihy have truely breathed new life into Win 98se! My 'test bed' PC & laptop not only look better, but are both much more stable. Your 98SE2ME was a painless install. I had already installed Tihiys' Revolution Pack on the 'test bed' before, so I had to re-install it. No problems... at all. I call it a 'test bed' 'cause once it's running all fine & dandy, I try to break it by installing software I know alters system files and such (unless your into beta testing, don't try this at home, kids). I'll pass on what info I can if there are conflicts and we'll get this good enough for anybody to use.

0

Share this post


Link to post
Share on other sites

MDGx,

Great stuff and thanks!

I just wanted to report a problem I had.

I had just finished setting up my new system and had installed 98SE2ME from 5-14, the bugless edition!

Coming here to browse around as usual, I noticed today's update. Not knowing exactly what to do, I uninstalled 98SE2ME from your shortcut and reinstalled the new one.

It ran fine and rebooted, but nothing appeared at startup and none of the changes were made. I rebooted again and noticed that your line in autoexec.bat "IF EXIST..." was placed at the end of the "Set qtjava..." line instead of on its own line.

I cut and pasted it in sysedit to its own line, rebooted, and then I got the "7 hundred some odd files copied with 0 errors" at bootup.

Upon checking autoexec.bat, the "IF EXIST..." line had been removed properly as well.

Now, when running System File Checker, the changes of files occured as advertised in the readme.

So, I had repaired the operation myself but just wanted you to know what had happened. Some folks will think the update installed and might not even notice nothing had installed and might wonder about the "IF EXIST..." line sitting there at bootup at the end of another line's command.

0

Share this post


Link to post
Share on other sites
MDGx,

Great stuff and thanks!

I just wanted to report a problem I had.

I had just finished setting up my new system and had installed 98SE2ME from 5-14, the bugless edition!

Coming here to browse around as usual, I noticed today's update.  Not knowing exactly what to do, I uninstalled 98SE2ME from your shortcut and reinstalled the new one.

It ran fine and rebooted, but nothing appeared at startup and none of the changes were made.  I rebooted again and noticed that your line in autoexec.bat "IF EXIST..." was placed at the end of the "Set qtjava..." line instead of on its own line.

I cut and pasted it in sysedit to its own line, rebooted, and then I got the "7 hundred some odd files copied with 0 errors" at bootup. 

Upon checking autoexec.bat, the "IF EXIST..." line had been removed properly as well.

Now, when running System File Checker, the changes of files occured as advertised in the readme.

So, I had repaired the operation myself but just wanted you to know what had happened.  Some folks will think the update installed and might not even notice nothing had installed and might wonder about the "IF EXIST..." line sitting there at bootup at the end of another line's command.

-Eck, why do you uninstall first? I always install on top, just in case the uninstall isn't quite "clean" enough... any chance that's your problem? Because this update worked perfectly for me, 710 files copied (note the TEN), and it DID update the files he mentioned...

>;]

0

Share this post


Link to post
Share on other sites

-MDGx: uh oh....

? I was curious if 98se2me updated the std windows screen savers (in particular, Blank Screen.scr, which I use and seems to maybe cause long-term bogging and potential instability, especially w/ the memory-leaky WinMX), so I went searching... and oops, Start/Search/Files would not find Blank Screen.scr, or BLANKS~1.SCR (both did show up on manual searching) ? And, System File Checker (& extracter) couldn't find it either, neither for win98se nor winME (options/cabs)... ??? -Any ideas? Any chance 98se2me messed up the searches or 8.3 filename searches?

*update: oh yeah, I do now recall, 98se2me does kill "~" searches (8.3), thru Start button... just like Properties no longer shows the 8.3 filename, either... but what about sfc? are the screen savers maybe grouped into something that won't be found by sfc?

**update2: I can't just use the monitor power saving, because of instability of power saving in my Matsonic 9327e+(usb) icky mobo... lol... -any suggestions for more reliable blank screen savers (which don't kick the cpu into 100% mode) ?

0

Share this post


Link to post
Share on other sites

Hello,

for the french users, or the users of the french versions of Windows, i made a translation of the program dated from 2005-05-15, you can find it on my website : http://www.webmatze.tk

0

Share this post


Link to post
Share on other sites

PsycoUnc,

I didn't uninstall the fixes, just the program. That just empties the 98SE2ME files in the folder, but the Windows system files aren't touched. This way when I install the new 98SE2ME, there's no chance of older files being used since they're gone.

To revert Windows files back you gotta run that batch file from a dos-mode command prompt before uninstalling 98SE2ME.

It was weird the way it put the IF EXIST line at the end of the last line in my autoexec.bat instead of on its own line.

When I finally got it running by cutting and pasting it to the right place on its own line, the only files system file checker reported as changed (I've got it set to report changed and deleated files in the options) were the latest additions. But all the other changes from before aren't touched. (Well, I supposed the same versions are copied over themselves.)

0

Share this post


Link to post
Share on other sites

I just needed to reinstall it again after the 2.0.1 service pack, and since its the same version of 98SE2ME I didn't uninstall anything first.

Same problem. I had to cut and paste the batch line in autoexec from the end of the last line to its own line.

As before, then it worked.

Something weird about my autoexec.bat?

SET PATH=%PATH%;C:\PROGRA~1\WIN98RK;C:\PROGRA~1\ATITEC~1\ATICON~1;C:\PROGRA~1\COMMON~1\ULEADS~1\MPEG;C:\PROGRA~1\COMMON~1\ULEADS~1\DVD

Set tvdumpflags=10

SET CLASSPATH="C:\Program Files\Java\jre1.5.0_02\lib\ext\QTJava.zip"

SET QTJAVA="C:\Program Files\Java\jre1.5.0_02\lib\ext\QTJava.zip"

The tvdumpflags is something ZoneAlarm puts there.

And, yeah, I just noticed there's a new java (1.5.0.03). Downloaded. Now I need to freakin uninstall Quicktime and Java, and delete the remaining file containing that QTjava thing (the Java folder, the rest is left empty), and reinstall both otherwise Quicktime wont find Java properly. (Britannica uses it.)

0

Share this post


Link to post
Share on other sites

Eck + PsycoUnc:

The autoexec.bat error is now fixed.

Although I have no idea why this happened, I have not thouched that code for over 2 months now. ;(

The weird error was:

the appended autoexec.bat line to run 98MEDOS.BAT was *added* at the end of the last line [on the same line] instead of being added *as* last line [as separate line]. [?!]

WebMatze:

Merci beaucoup pour votre traduction. B)

If you want to update the French translation, the only difference from the 5-15-2005 version is this code at the end of E0!X.BAT:

ECHO.>>C:\AUTOEXEC.BAT
ECHO IF EXIST C:\9!M\98MEDOS.BAT C:\9!M\98MEDOS.BAT>>C:\AUTOEXEC.BAT
ECHO.>>C:\AUTOEXEC.BAT

This corrects the error above.

Thanks.

? I was curious if 98se2me updated the std windows screen savers (in particular, Blank Screen.scr, which I use and seems to maybe cause long-term bogging and potential instability, especially w/ the memory-leaky WinMX), so I went searching... and oops, Start/Search/Files would not find Blank Screen.scr, or BLANKS~1.SCR (both did show up on manual searching) ?  And, System File Checker (& extracter) couldn't find it either, neither for win98se nor winME (options/cabs)... ???  -Any ideas?  Any chance 98se2me messed up the searches or 8.3 filename searches?

*update: oh yeah, I do now recall, 98se2me does kill "~" searches (8.3), thru Start button... just like Properties no longer shows the 8.3 filename, either...  but what about sfc?  are the screen savers maybe grouped into something that won't be found by sfc?

**update2:  I can't just use the monitor power saving, because of instability of power saving in my Matsonic 9327e+(usb) icky mobo... lol... -any suggestions for more reliable blank screen savers (which don't kick the cpu into 100% mode) ?

98se2me doesn't have any screen savers, as far as I know they are all identical with the ones from 98se.

The 8.3 ["~"] long file name adapted to short file name convention [NameNumericTail DWORD value] exists [only if previously modified manually by a REG file or by a tweaking tool like TweakUI, X-Setup etc] in the registry as:

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
"NameNumericTail"=dword:00000001

and is probably changed by 98SE2ME option 3 [not the other options], because option 3 installs shell32.dll from WinME, which has to be registered into the registry for proper operation:

%windir%\SYSTEM\REGSVR32.EXE /I /S %windir%\SYSTEM\SHELL32.DLL

%windir%\SYSTEM\REGSVR32.EXE /S %windir%\SYSTEM\SHELL32.DLL

and when that happens, it probably resets the reg 8.3 value.

I can't fix that, because some people decided not to change that option, and others decided to change it. So it's up to the respective user how they want that option handled on their systems.

You can change it back by using TweakUI 1.33 [free from MS]:

http://download.microsoft.com/download/win...-US/Tweakui.exe

or see this guide for more details + a warning:

http://www.mdgx.com/newtip9.htm#NUMTAIL

Hope this helps.

0

Share this post


Link to post
Share on other sites

Hello,

I will update the french version on my website as soon as possible, but there still is a bug, when the computer reboots after the extraction of the cab, the system boots in native DOS and starts to do a backup, the cloning is made without problem but then it hangs and nothing appends, there already was that problem in the version of 2005-05-15, the only solution i found to avoid this problem was to delete some lines in the 98medos.bat file:

ECHO Y | IF EXIST C:\9S2M\PINBALL\NUL DEL C:\9S2M\PINBALL\*.*>NUL

IF EXIST C:\9S2M\PINBALL\NUL RD C:\9S2M\PINBALL>NUL

ECHO Y | IF EXIST C:\9S2M\COMMAND\NUL DEL C:\9S2M\COMMAND\*.*>NUL

IF EXIST C:\9S2M\COMMAND\NUL RD C:\9S2M\COMMAND>NUL

ECHO Y | IF EXIST C:\9S2M\FONTS\NUL DEL C:\9S2M\FONTS\*.*>NUL

IF EXIST C:\9S2M\FONTS\NUL RD C:\9S2M\FONTS>NUL

ECHO Y | IF EXIST C:\9S2M\HELP\NUL DEL C:\9S2M\HELP\*.*>NUL

IF EXIST C:\9S2M\HELP\NUL RD C:\9S2M\HELP>NUL

ECHO Y | IF EXIST C:\9S2M\MSAPPS\GRPHFLT\NUL DEL C:\9S2M\MSAPPS\GRPHFLT\*.*>NUL

IF EXIST C:\9S2M\MSAPPS\GRPHFLT\NUL RD C:\9S2M\MSAPPS\GRPHFLT>NUL

ECHO Y | IF EXIST C:\9S2M\MSAPPS\NUL DEL C:\9S2M\MSAPPS\*.*>NUL

IF EXIST C:\9S2M\MSAPPS\NUL RD C:\9S2M\MSAPPS>NUL

ECHO Y | IF EXIST C:\9S2M\SYSBCKUP\NUL DEL C:\9S2M\SYSBCKUP\*.*>NUL

IF EXIST C:\9S2M\SYSBCKUP\NUL RD C:\9S2M\SYSBCKUP>NUL

ECHO Y | IF EXIST C:\9S2M\MEDIA\NUL DEL C:\9S2M\MEDIA\*.*>NUL

IF EXIST C:\9S2M\MEDIA\NUL RD C:\9S2M\MEDIA>NUL

ECHO Y | IF EXIST C:\9S2M\SYSTEM\SHELLEXT\NUL DEL C:\9S2M\SYSTEM\SHELLEXT\*.*>NUL

IF EXIST C:\9S2M\SYSTEM\SHELLEXT\NUL RD C:\9S2M\SYSTEM\SHELLEXT>NUL

ECHO Y | IF EXIST C:\9S2M\SYSTEM\VMM32\NUL DEL C:\9S2M\SYSTEM\VMM32\*.*>NUL

IF EXIST C:\9S2M\SYSTEM\VMM32\NUL RD C:\9S2M\SYSTEM\VMM32>NUL

ECHO Y | IF EXIST C:\9S2M\SYSTEM\IOSUBSYS\NUL DEL C:\9S2M\SYSTEM\IOSUBSYS\*.*>NUL

IF EXIST C:\9S2M\SYSTEM\IOSUBSYS\NUL RD C:\9S2M\SYSTEM\IOSUBSYS>NUL

ECHO Y | IF EXIST C:\9S2M\SYSTEM\NUL DEL C:\9S2M\SYSTEM\*.*>NUL

IF EXIST C:\9S2M\SYSTEM\NUL RD C:\9S2M\SYSTEM>NUL

ECHO Y | IF EXIST C:\9S2M\SYSTEM32\DRIVERS\NUL DEL C:\9S2M\SYSTEM32\DRIVERS\*.*>NUL

IF EXIST C:\9S2M\SYSTEM32\DRIVERS\NUL RD C:\9S2M\SYSTEM32\DRIVERS>NUL

ECHO Y | IF EXIST C:\9S2M\SYSTEM32\NUL DEL C:\9S2M\SYSTEM32\*.*>NUL

IF EXIST C:\9S2M\SYSTEM32\NUL RD C:\9S2M\SYSTEM32>NUL

ECHO Y | IF EXIST C:\9S2M\NUL DEL C:\9S2M\*.*>NUL

IF EXIST C:\9S2M\NUL RD C:\9S2M>NUL

MDGx can you correct the problem?

Bye

0

Share this post


Link to post
Share on other sites

I found a second bug:

the pinball exe is'nt copied in the windows/pinball folder

bye

0

Share this post


Link to post
Share on other sites
Hello,

I will update the french version on my website as soon as possible, but there still is a bug, when the computer reboots after the extraction of the cab, the system boots in native DOS and starts to do a backup, the cloning is made without problem but then it hangs and nothing appends, there already was that problem in the version of 2005-05-15, the only solution i found to avoid this problem was to delete some lines in the 98medos.bat file.

MDGx can you correct the problem?

I have replaced the DOS commands DEL + RD with WININIT.INI code [dirnul=C:\9S2M]. Hope this fixes the error you had.

I didn't notice any errors on my PC, but since you are using 98SE French, there may be differences in directory/files names, and the DOS code was deleting only English directories + files.

So all those lines that were giving you grief in 98MEDOS.BAT, are now replaced by these:

IF EXIST %winbootdir%\WININIT.* C:\9!M\ATTRIB.COM/B +A -H -R -S %winbootdir%\WININIT.*>NUL
IF EXIST %winbootdir%\WININIT.INI GOTO WIX
ECHO [Rename]>>%winbootdir%\WININIT.INI
:WIX
ECHO DIRNUL=C:\9S2M>>%winbootdir%\WININIT.INI
ECHO.>>%winbootdir%\WININIT.INI

Please d/l the revised 5-17-2005 98SE2ME edition:

http://www.mdgx.com/4

I could not reproduce this bug on my PC:

PINBALL.EXE not copied to %windir%\PINBALL . :(

Maybe the French WinME CD CABs have different structure or CABs reside in different dir name?

On English WinME CD pinball.exe is inside WIN_17.CAB and CABs dir name is WIN9X .

Or maybe pinball.exe exists under a different name in the WinME CD CABs?

If u can get more details, please let me know.

Hope this helps.

0

Share this post


Link to post
Share on other sites

Ok, this time it works perfectly, your fix in the latest version is ok and the system doesn't hang anymore on reboot.

For pinball.exe the file is located in the cab number 16 in the french version so i corrected the batch to extract the right cab.

I will upload the corrected version today on my site.

thanks a lot for your help

0

Share this post


Link to post
Share on other sites

MDGx,

Thanks for the fast fix.

I'll download it just in case, but they'll probably be even newer versions of 98SE2ME before I destroy Windows again somehow.

Heh, heh. If that's the only change for now, I'll await the newer releases before installing it over itself again. (Hopefully on THIS system.)

It's all running great at the moment.

0

Share this post


Link to post
Share on other sites

Can you just install this one over the one from a few days ago? Is there anything different to do for an upgrade?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.