Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

98SE2ME = Killer Replacements: ME -> 98 SE

* * * * - 5 votes

  • Please log in to reply
1083 replies to this topic

#1
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

98SE2ME
Updated12-14-2011

By popular demand... :blink:
98SE2ME is the automated installer designed to perform all Killer Replacements ME -> 98 SE "transplant" operations completely unattended, a.k.a. "hands-free". :thumbup

Download + install 98SE2ME [English, 4.3 MB].
Use this link ONLY IF link above does not work.
98SE2ME September 2007 French [2.65 MB].
98SE2ME September 2007 Italian [2.56 MB].
MUST read READ1ST.TXT CAREFULLY BEFORE installing ANY 98SE2ME options.
98SE2ME HTML Help Guide + Manual [152 KB, old, not updated].
Killer Replacements: ME -> 98 SE do-it-yourself guide.
98SE2ME info, downloads + screen shots.
98SE, 98SESP2 + 98SE2ME boot logos [1.05 MB].

Changes + Updates

See UPDATES.TXT.

IMPORTANT

REQUIRED:
  • Windows 98 Second Edition (SE) MUST be ALREADY installed.
  • ALL Windows Millennium Edition (ME) setup *.CAB files [CABs] MUST be anywhere on your local disk(s)/partition(s) into the SAME directory/folder or a Windows ME Gold/Final/RTM/MSDN setup CD-ROM (any Edition: Full, Update) MUST be inside 1st CD/DVD drive (if more than 1).
Everything here is for English language ONLY.

This is an Open Source project.
This is NOT a Microsoft product.
By replacing Microsoft files you may VOID the EULA, warranty and/or support (if any).
You do all this at your OWN risk.
Nobody is liable NOR responsible for ANYTHING due to the use of these files.
ALWAYS BACKUP FIRST!

100% UNofficial + UNsupported compilation of Microsoft files.
All ©, ® + ™ retain the property of their respective owners and are used here solely in non-trademark descriptive sense.
MUST use and distribute ONLY for educational and profit-free purposes.

Please post here all BUGs, FIXes, tips, comments etc, so I can improve 98SE2ME accordingly. This is the only way we can all benefit.

Special thank you to all contributors.

E-mail

Enjoy.



How to remove advertisement from MSFN

#2
nitebat

nitebat

    Newbie

  • Member
  • 47 posts
MDGx:

Awesome work!

You, Gape & Tihy have truely breathed new life into Win 98se! My 'test bed' PC & laptop not only look better, but are both much more stable. Your 98SE2ME was a painless install. I had already installed Tihiys' Revolution Pack on the 'test bed' before, so I had to re-install it. No problems... at all. I call it a 'test bed' 'cause once it's running all fine & dandy, I try to break it by installing software I know alters system files and such (unless your into beta testing, don't try this at home, kids). I'll pass on what info I can if there are conflicts and we'll get this good enough for anybody to use.

#3
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
MDGx,

Great stuff and thanks!

I just wanted to report a problem I had.

I had just finished setting up my new system and had installed 98SE2ME from 5-14, the bugless edition!

Coming here to browse around as usual, I noticed today's update. Not knowing exactly what to do, I uninstalled 98SE2ME from your shortcut and reinstalled the new one.

It ran fine and rebooted, but nothing appeared at startup and none of the changes were made. I rebooted again and noticed that your line in autoexec.bat "IF EXIST..." was placed at the end of the "Set qtjava..." line instead of on its own line.

I cut and pasted it in sysedit to its own line, rebooted, and then I got the "7 hundred some odd files copied with 0 errors" at bootup.

Upon checking autoexec.bat, the "IF EXIST..." line had been removed properly as well.

Now, when running System File Checker, the changes of files occured as advertised in the readme.

So, I had repaired the operation myself but just wanted you to know what had happened. Some folks will think the update installed and might not even notice nothing had installed and might wonder about the "IF EXIST..." line sitting there at bootup at the end of another line's command.
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#4
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts

MDGx,

Great stuff and thanks!

I just wanted to report a problem I had.

I had just finished setting up my new system and had installed 98SE2ME from 5-14, the bugless edition!

Coming here to browse around as usual, I noticed today's update.  Not knowing exactly what to do, I uninstalled 98SE2ME from your shortcut and reinstalled the new one.

It ran fine and rebooted, but nothing appeared at startup and none of the changes were made.  I rebooted again and noticed that your line in autoexec.bat "IF EXIST..." was placed at the end of the "Set qtjava..." line instead of on its own line.

I cut and pasted it in sysedit to its own line, rebooted, and then I got the "7 hundred some odd files copied with 0 errors" at bootup. 

Upon checking autoexec.bat, the "IF EXIST..." line had been removed properly as well.

Now, when running System File Checker, the changes of files occured as advertised in the readme.

So, I had repaired the operation myself but just wanted you to know what had happened.  Some folks will think the update installed and might not even notice nothing had installed and might wonder about the "IF EXIST..." line sitting there at bootup at the end of another line's command.

<{POST_SNAPBACK}>



-Eck, why do you uninstall first? I always install on top, just in case the uninstall isn't quite "clean" enough... any chance that's your problem? Because this update worked perfectly for me, 710 files copied (note the TEN), and it DID update the files he mentioned...
>;]

#5
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
-MDGx: uh oh....

? I was curious if 98se2me updated the std windows screen savers (in particular, Blank Screen.scr, which I use and seems to maybe cause long-term bogging and potential instability, especially w/ the memory-leaky WinMX), so I went searching... and oops, Start/Search/Files would not find Blank Screen.scr, or BLANKS~1.SCR (both did show up on manual searching) ? And, System File Checker (& extracter) couldn't find it either, neither for win98se nor winME (options/cabs)... ??? -Any ideas? Any chance 98se2me messed up the searches or 8.3 filename searches?

*update: oh yeah, I do now recall, 98se2me does kill "~" searches (8.3), thru Start button... just like Properties no longer shows the 8.3 filename, either... but what about sfc? are the screen savers maybe grouped into something that won't be found by sfc?

**update2: I can't just use the monitor power saving, because of instability of power saving in my Matsonic 9327e+(usb) icky mobo... lol... -any suggestions for more reliable blank screen savers (which don't kick the cpu into 100% mode) ?

#6
WebMatze

WebMatze

    Junior

  • Member
  • Pip
  • 54 posts
Hello,

for the french users, or the users of the french versions of Windows, i made a translation of the program dated from 2005-05-15, you can find it on my website : http://www.webmatze.tk

#7
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
PsycoUnc,

I didn't uninstall the fixes, just the program. That just empties the 98SE2ME files in the folder, but the Windows system files aren't touched. This way when I install the new 98SE2ME, there's no chance of older files being used since they're gone.

To revert Windows files back you gotta run that batch file from a dos-mode command prompt before uninstalling 98SE2ME.

It was weird the way it put the IF EXIST line at the end of the last line in my autoexec.bat instead of on its own line.

When I finally got it running by cutting and pasting it to the right place on its own line, the only files system file checker reported as changed (I've got it set to report changed and deleated files in the options) were the latest additions. But all the other changes from before aren't touched. (Well, I supposed the same versions are copied over themselves.)
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#8
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
I just needed to reinstall it again after the 2.0.1 service pack, and since its the same version of 98SE2ME I didn't uninstall anything first.

Same problem. I had to cut and paste the batch line in autoexec from the end of the last line to its own line.

As before, then it worked.

Something weird about my autoexec.bat?


SET PATH=%PATH%;C:\PROGRA~1\WIN98RK;C:\PROGRA~1\ATITEC~1\ATICON~1;C:\PROGRA~1\COMMON~1\ULEADS~1\MPEG;C:\PROGRA~1\COMMON~1\ULEADS~1\DVD
Set tvdumpflags=10

SET CLASSPATH="C:\Program Files\Java\jre1.5.0_02\lib\ext\QTJava.zip"
SET QTJAVA="C:\Program Files\Java\jre1.5.0_02\lib\ext\QTJava.zip"


The tvdumpflags is something ZoneAlarm puts there.

And, yeah, I just noticed there's a new java (1.5.0.03). Downloaded. Now I need to freakin uninstall Quicktime and Java, and delete the remaining file containing that QTjava thing (the Java folder, the rest is left empty), and reinstall both otherwise Quicktime wont find Java properly. (Britannica uses it.)
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#9
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag
Eck + PsycoUnc:
The autoexec.bat error is now fixed.
Although I have no idea why this happened, I have not thouched that code for over 2 months now. ;(
The weird error was:
the appended autoexec.bat line to run 98MEDOS.BAT was *added* at the end of the last line [on the same line] instead of being added *as* last line [as separate line]. [?!]

WebMatze:
Merci beaucoup pour votre traduction. B)
If you want to update the French translation, the only difference from the 5-15-2005 version is this code at the end of E0!X.BAT:
ECHO.>>C:\AUTOEXEC.BAT
ECHO IF EXIST C:\9!M\98MEDOS.BAT C:\9!M\98MEDOS.BAT>>C:\AUTOEXEC.BAT
ECHO.>>C:\AUTOEXEC.BAT
This corrects the error above.
Thanks.

? I was curious if 98se2me updated the std windows screen savers (in particular, Blank Screen.scr, which I use and seems to maybe cause long-term bogging and potential instability, especially w/ the memory-leaky WinMX), so I went searching... and oops, Start/Search/Files would not find Blank Screen.scr, or BLANKS~1.SCR (both did show up on manual searching) ?  And, System File Checker (& extracter) couldn't find it either, neither for win98se nor winME (options/cabs)... ???  -Any ideas?  Any chance 98se2me messed up the searches or 8.3 filename searches?

*update: oh yeah, I do now recall, 98se2me does kill "~" searches (8.3), thru Start button... just like Properties no longer shows the 8.3 filename, either...  but what about sfc?  are the screen savers maybe grouped into something that won't be found by sfc?

**update2:  I can't just use the monitor power saving, because of instability of power saving in my Matsonic 9327e+(usb) icky mobo... lol... -any suggestions for more reliable blank screen savers (which don't kick the cpu into 100% mode) ?

98se2me doesn't have any screen savers, as far as I know they are all identical with the ones from 98se.

The 8.3 ["~"] long file name adapted to short file name convention [NameNumericTail DWORD value] exists [only if previously modified manually by a REG file or by a tweaking tool like TweakUI, X-Setup etc] in the registry as:
[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\FileSystem]
"NameNumericTail"=dword:00000001
and is probably changed by 98SE2ME option 3 [not the other options], because option 3 installs shell32.dll from WinME, which has to be registered into the registry for proper operation:

%windir%\SYSTEM\REGSVR32.EXE /I /S %windir%\SYSTEM\SHELL32.DLL
%windir%\SYSTEM\REGSVR32.EXE /S %windir%\SYSTEM\SHELL32.DLL

and when that happens, it probably resets the reg 8.3 value.
I can't fix that, because some people decided not to change that option, and others decided to change it. So it's up to the respective user how they want that option handled on their systems.
You can change it back by using TweakUI 1.33 [free from MS]:
http://download.micr...-US/Tweakui.exe
or see this guide for more details + a warning:
http://www.mdgx.com/...ip9.htm#NUMTAIL
Hope this helps.

#10
WebMatze

WebMatze

    Junior

  • Member
  • Pip
  • 54 posts
Hello,

I will update the french version on my website as soon as possible, but there still is a bug, when the computer reboots after the extraction of the cab, the system boots in native DOS and starts to do a backup, the cloning is made without problem but then it hangs and nothing appends, there already was that problem in the version of 2005-05-15, the only solution i found to avoid this problem was to delete some lines in the 98medos.bat file:

ECHO Y | IF EXIST C:\9S2M\PINBALL\NUL DEL C:\9S2M\PINBALL\*.*>NUL
IF EXIST C:\9S2M\PINBALL\NUL RD C:\9S2M\PINBALL>NUL
ECHO Y | IF EXIST C:\9S2M\COMMAND\NUL DEL C:\9S2M\COMMAND\*.*>NUL
IF EXIST C:\9S2M\COMMAND\NUL RD C:\9S2M\COMMAND>NUL
ECHO Y | IF EXIST C:\9S2M\FONTS\NUL DEL C:\9S2M\FONTS\*.*>NUL
IF EXIST C:\9S2M\FONTS\NUL RD C:\9S2M\FONTS>NUL
ECHO Y | IF EXIST C:\9S2M\HELP\NUL DEL C:\9S2M\HELP\*.*>NUL
IF EXIST C:\9S2M\HELP\NUL RD C:\9S2M\HELP>NUL
ECHO Y | IF EXIST C:\9S2M\MSAPPS\GRPHFLT\NUL DEL C:\9S2M\MSAPPS\GRPHFLT\*.*>NUL
IF EXIST C:\9S2M\MSAPPS\GRPHFLT\NUL RD C:\9S2M\MSAPPS\GRPHFLT>NUL
ECHO Y | IF EXIST C:\9S2M\MSAPPS\NUL DEL C:\9S2M\MSAPPS\*.*>NUL
IF EXIST C:\9S2M\MSAPPS\NUL RD C:\9S2M\MSAPPS>NUL
ECHO Y | IF EXIST C:\9S2M\SYSBCKUP\NUL DEL C:\9S2M\SYSBCKUP\*.*>NUL
IF EXIST C:\9S2M\SYSBCKUP\NUL RD C:\9S2M\SYSBCKUP>NUL
ECHO Y | IF EXIST C:\9S2M\MEDIA\NUL DEL C:\9S2M\MEDIA\*.*>NUL
IF EXIST C:\9S2M\MEDIA\NUL RD C:\9S2M\MEDIA>NUL
ECHO Y | IF EXIST C:\9S2M\SYSTEM\SHELLEXT\NUL DEL C:\9S2M\SYSTEM\SHELLEXT\*.*>NUL
IF EXIST C:\9S2M\SYSTEM\SHELLEXT\NUL RD C:\9S2M\SYSTEM\SHELLEXT>NUL
ECHO Y | IF EXIST C:\9S2M\SYSTEM\VMM32\NUL DEL C:\9S2M\SYSTEM\VMM32\*.*>NUL
IF EXIST C:\9S2M\SYSTEM\VMM32\NUL RD C:\9S2M\SYSTEM\VMM32>NUL
ECHO Y | IF EXIST C:\9S2M\SYSTEM\IOSUBSYS\NUL DEL C:\9S2M\SYSTEM\IOSUBSYS\*.*>NUL
IF EXIST C:\9S2M\SYSTEM\IOSUBSYS\NUL RD C:\9S2M\SYSTEM\IOSUBSYS>NUL
ECHO Y | IF EXIST C:\9S2M\SYSTEM\NUL DEL C:\9S2M\SYSTEM\*.*>NUL
IF EXIST C:\9S2M\SYSTEM\NUL RD C:\9S2M\SYSTEM>NUL
ECHO Y | IF EXIST C:\9S2M\SYSTEM32\DRIVERS\NUL DEL C:\9S2M\SYSTEM32\DRIVERS\*.*>NUL
IF EXIST C:\9S2M\SYSTEM32\DRIVERS\NUL RD C:\9S2M\SYSTEM32\DRIVERS>NUL
ECHO Y | IF EXIST C:\9S2M\SYSTEM32\NUL DEL C:\9S2M\SYSTEM32\*.*>NUL
IF EXIST C:\9S2M\SYSTEM32\NUL RD C:\9S2M\SYSTEM32>NUL
ECHO Y | IF EXIST C:\9S2M\NUL DEL C:\9S2M\*.*>NUL
IF EXIST C:\9S2M\NUL RD C:\9S2M>NUL


MDGx can you correct the problem?

Bye

#11
WebMatze

WebMatze

    Junior

  • Member
  • Pip
  • 54 posts
I found a second bug:
the pinball exe is'nt copied in the windows/pinball folder

bye

#12
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

Hello,

I will update the french version on my website as soon as possible, but there still is a bug, when the computer reboots after the extraction of the cab, the system boots in native DOS and starts to do a backup, the cloning is made without problem but then it hangs and nothing appends, there already was that problem in the version of 2005-05-15, the only solution i found to avoid this problem was to delete some lines in the 98medos.bat file.

MDGx can you correct the problem?

I have replaced the DOS commands DEL + RD with WININIT.INI code [dirnul=C:\9S2M]. Hope this fixes the error you had.
I didn't notice any errors on my PC, but since you are using 98SE French, there may be differences in directory/files names, and the DOS code was deleting only English directories + files.
So all those lines that were giving you grief in 98MEDOS.BAT, are now replaced by these:
IF EXIST %winbootdir%\WININIT.* C:\9!M\ATTRIB.COM/B +A -H -R -S %winbootdir%\WININIT.*>NUL
IF EXIST %winbootdir%\WININIT.INI GOTO WIX
ECHO [Rename]>>%winbootdir%\WININIT.INI
:WIX
ECHO DIRNUL=C:\9S2M>>%winbootdir%\WININIT.INI
ECHO.>>%winbootdir%\WININIT.INI
Please d/l the revised 5-17-2005 98SE2ME edition:
http://www.mdgx.com/4

I could not reproduce this bug on my PC:
PINBALL.EXE not copied to %windir%\PINBALL . :(
Maybe the French WinME CD CABs have different structure or CABs reside in different dir name?
On English WinME CD pinball.exe is inside WIN_17.CAB and CABs dir name is WIN9X .
Or maybe pinball.exe exists under a different name in the WinME CD CABs?
If u can get more details, please let me know.

Hope this helps.

#13
WebMatze

WebMatze

    Junior

  • Member
  • Pip
  • 54 posts
Ok, this time it works perfectly, your fix in the latest version is ok and the system doesn't hang anymore on reboot.
For pinball.exe the file is located in the cab number 16 in the french version so i corrected the batch to extract the right cab.
I will upload the corrected version today on my site.
thanks a lot for your help

#14
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
MDGx,

Thanks for the fast fix.

I'll download it just in case, but they'll probably be even newer versions of 98SE2ME before I destroy Windows again somehow.

Heh, heh. If that's the only change for now, I'll await the newer releases before installing it over itself again. (Hopefully on THIS system.)

It's all running great at the moment.
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#15
wizy

wizy

    Newbie

  • Member
  • 39 posts
Can you just install this one over the one from a few days ago? Is there anything different to do for an upgrade?

#16
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
wizy,

All uninstalling the 98SE2ME does is empty the program's directory. This does not undo any of the enhancments made to Windows. So, in my view, this is a good thing to do before installing a newer version (of almost anything, not just this).

Note that between the time you have uninstalled 98SE2ME and reinstalled the newer version, you will not be able to restore the backup Windows folder of original Windows files. So, for that brief time (what, a minute?) you will not be able to restore your system to the way it was before you ran 98SE2ME.pif the first time. Ehh? I'll live dangerously for a minute.

Once the new one is installed fresh like this, you can be sure that none of the older version's files will be used since you uninstalled them. Now, an install over the top will usually be fine as well, but this just ensures that no older things can conflict with the latest release.

MDGx,

Already, new changes? Okay, it only takes a few minutes. Heh, heh. One of the advantages of using my Voodoo 5 5500 was not having to install a new Catalyst driver every month. But, then again, new drivers that fix stuff and make things go better is a good thing. Just, a tiny bit annoying.

But, don't take that seriously. I love it. Thanks.
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#17
wizy

wizy

    Newbie

  • Member
  • 39 posts
Thanks for the respnse. Thats what I figured, just didnt want to do it and be wrong...

#18
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
All Right!

New version installed, no problems.

I do want to mention something. Each time I reinstall, I've got to go to the Space Cadet Pinball's right click Properties menu and put "C:\WINDOWS\PINBALL" in the "Start in" box. This is to fix the bug in the Windows Me version of Pinball that it won't play the music background when clicking "Music" in the drop down options menu.

I don't think it's necessary to take the trouble to figure out how to fix this when it installs as part of 98SE2ME since it's so easy to fix by the user. However, perhaps the readme can make mention of the fix. Some folks new to Windows Pinball might be wondering why they can't get the music to play. (The sound effects always work fine, but the backgroung music is cool!)

I think you mention this somewhere in your website, and Microsoft has a KB article explaining the fix, but perhaps a short comment on how to fix it would be helpful to folks just reading the 98SE2ME readme.

Ya know, the improved version of the game in Maxi's Full Tilt! Pinball (also on the Pinball Madness cd) includes a seperate track that plays whenever you reach a goal. No reason to bring it up other than it sounds cool to be rewarded with more music when reaching a goal.

If anyone reading this has that stand alone version, the other tables game music is fixed by lowering the audio hardware acceleration to basic in your Sound and Audio or Multimedia Properties applet in Windows Control Panel.

It is midi music, so it also helps to have something other than Microsoft midi installed. A lot of modern cards leave this out. Anything Creative and you're all set. Otherwise, Yamaha SYXG-50 or WinGroove will do it. WinGroove is easier to get these days. Just pay the guy, will ya? I can't stand people using cracks when that guy worked out a complete midi driver that even runs on XP (with the beta version). And, even on 9x, use the Beta. It's really the final, with a bunch of fixes.
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#19
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
MDGx,

I just saw your reply in the Service Pack forum to my problems with the USB Cable Modem drivers.

The only way for me to test that again would be to either muck around with my current, working great on ethernet, system, or to switch motherboards in my older (currently KT7A) box back to the Asus SPAX-M SiS5598 board (made for HP Pavilion 4430 and 4440) and reinstall all the stuff to duplicate what happened to it that time.

Uhh, nobody else has had any problems with USB Modem drivers?

It's really not that I don't want to help! But I'm just starting to install some games and have some fun with my new A7V333. Just don't want to tinker right now.

I'm sorry that I posted in the other area, too. I just didn't know which program might have caused the problem. I do know that Windows wouldn't let me install the driver, and that it did install properly previously when I hadn't run these updates.

And that Windows Me driver signing check bit me when I tried installing the unsigned Creative 383 Audigy 2 drivers on my SB0224 SBLive 5.1. It greyed out the Advanced button where you'd check "Warn" instead of "Prevent" unsigned drivers. The official cd with unsigned 252's installed fine and let me click the Advanced button and select "Warn." However, unlike on Windows Me, it doesn't seem to remember it for future installs. (I had to click "Advanced" and do that for another driver later.) It's all okay though. I'm satisfied with the official drivers and software. Whenever I try and see what the hoopla over alternate drivers for the Creative stuff is (like at Driver Heaven) I usually find that what the manufacturer offers winds up to be the least buggy way to go. Sounds fine, too.

I've been reading your website for years and find it amazing! Nearly everything anyone would ever want to know about running and optimizing any kind of Windows is on that website! (Johnny Carson couldn't argue that.)
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#20
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

Can you just install this one over the one from a few days ago?  Is there anything different to do for an upgrade?

I believe your question is answered in the readme, please read the "EXTREMELY IMPORTANT" + "FAQ" chapters:
http://www.mdgx.com/9s2m/READ1ST.TXT

Hope this helps.

#21
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

All Right!

New version installed, no problems.

I do want to mention something.  Each time I reinstall, I've got to go to the Space Cadet Pinball's right click Properties menu and put "C:\WINDOWS\PINBALL" in the "Start in" box.  This is to fix the bug in the Windows Me version of Pinball that it won't play the music background when clicking "Music" in the drop down options menu.

I don't think it's necessary to take the trouble to figure out how to fix this when it installs as part of 98SE2ME since it's so easy to fix by the user.  However, perhaps the readme can make mention of the fix.  Some folks new to Windows Pinball might be wondering why they can't get the music to play.  (The sound effects always work fine, but the backgroung music is cool!)

I think you mention this somewhere in your website, and Microsoft has a KB article explaining the fix, but perhaps a short comment on how to fix it would be helpful to folks just reading the 98SE2ME readme.

Your wish is my command... ;)
I fixed 2G.INF which creates the game shortcuts.
You don't need to add the folder name to the "Start in:" box anymore. :)
Please d/l the revised 5-19-2005 98SE2ME edition.

#22
charly

charly

    member

  • Member
  • Pip
  • 78 posts
[quote name='MDGx' date='May 16 2005, 06:39 AM']
<span style='font-size:10pt;line-height:100%'>98SE2ME · UPDATED · 5-19-2005</span>
By popular demand... :blink:
98SE2ME is the automated installer which performs all Killer Replacements 98 SE -> ME "transplant" operations completely unattended, a.k.a. "hands-free". :thumbup
Download 98SE2ME.EXE [2 MB, English].
MUST read READ1ST.TXT *carefully* BEFORE running 98SE2ME.PIF !

NEWS + CHANGES:
5-19-2005
* Replaced WinME system file [%windir%\SYSTEM]: SYSTRAY.EXE 4.90.3001 with newer SYSTRAY.EXE 4.90.3002 from Q298058 Hotfix into options 1 + 2.
* Replaced WinME system file [%windir%\SYSTEM]: SYSDM.CPL 4.90.3000 with newer SYSDM.CPL 4.90.3001 from Q272620 Hotfix into options 1 + 2.
* Replaced WinME system file [%windir%\SYSTEM32\DRIVERS]: USBHUB.SYS 4.90.3000 with newer USBHUB.SYS 4.90.3002 from Q278289 Hotfix into options 1 + 2.
* Fixed PINBALL.EXE Game shortcut "Start in:" folder error in [color="navy"]2G.INF
. [thank you Eck]

][/url].

MDGx,

Installed 5-19a and sysdm.cpl went to WINDOWS/SYSTEM32/drivers and old version in WINDOWS/SYSTEM was still there--SYSTRAY.EXE was not installed at all
but USBHUB.SYS did install? Also only 709 files installed not the 710 ?

THANKS again for all the work and help.

#23
rainyd

rainyd

    Advanced Member

  • Member
  • PipPipPip
  • 407 posts
  • OS:98SE
  • Country: Country Flag
MDGx, can I install your SP on my Polish Win98 SE? Any risk involved? If the only problem is to have the OS mixing two languages, I don't mind. Thanks in advance.

#24
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
Wow, that was fast! It must have been easier to change the inf than I thought.

Well, I downloaded and will store it on a cdr but will await the next update before running it again. I already have installed the update that has all the other additions mentioned. No need to double fix pinball!
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#25
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts

MDGx,

Installed 5-19a and sysdm.cpl went to WINDOWS/SYSTEM32/drivers and old version in WINDOWS/SYSTEM was still there--SYSTRAY.EXE was not installed at all
but USBHUB.SYS did install? Also only 709 files installed not the 710 ?

THANKS again for all the work and help.

<{POST_SNAPBACK}>


-confirmed: windows/system/systray.exe is still 3001, not 3002. Option #1 didn't update it, tho usbhub is updated... the only 3002 version of systray.exe on my HD is in \9!M... (707 files copied)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN