Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

98SE2ME = Killer Replacements: ME -> 98 SE

* * * * - 5 votes

  • Please log in to reply
1083 replies to this topic

#26
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

MDGx, can I install your SP on my Polish Win98 SE? Any risk involved? If the only problem is to have the OS mixing two languages, I don't mind. Thanks in advance.

Please download INNOFILE.ZIP:
http://www.mdgx.com/9s2m/INNOFILE.ZIP
and then read INNOFILE.TXT.

Hope this helps.


How to remove advertisement from MSFN

#27
crashnburn

crashnburn

    Newbie

  • Member
  • 20 posts
  • Joined 02-April 05
double high 5's :thumbup :thumbup on all this work....... no problems at all upgrading as long as the original 98SE unit is 'tight'....... i have two on my desk......... one a 300mhz gateway and a 1.4ghz to its right....... i run the 1.4 for 3 days before i upgrade the other one...... i seem to have lost my blue screen syndrome.....lol........
one question-------- :whistle: i see that the msdos.sys file is totally changed from the original 98se........... can it be put back in............ to what advantage/disadvantage.......?????? :w00t:
p.s........... coincidental or a bug????? i dunno.......... but i just discovered that my regional clock settings were wiped out when i saw that my antivirus was running 2x per scheduled run and when i double checked the scan program there was no a.m. or p.m. finally went into the control panel regional settings and all's well............

still the dbbl hi 5................

#28
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05
-MDGx, I have need of your infinite wisdom yet again: when trying to export the registry in real-mode dos (from ebd, using regedit), I get "unable to open registry (1,016)..." ? -I was only trying to test the registry editor for my new modified EBD, on a good-working system, in case of a need to edit the registry in real-dos mode emergency... MS has an article, but of course all they say to resolve it is "do it in protected-mode"... that's not helpful, as usual... do ya know of any real-mode dos registry editors that actually work with real-sized registries?

#29
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

double high 5's on all this work....... no problems at all upgrading as long as the original 98SE unit is 'tight'....... i have two on my desk......... one a 300mhz gateway and a 1.4ghz to its right....... i run the 1.4 for 3 days before i upgrade the other one...... i seem to have lost my blue screen syndrome.....lol........

one question-------- i see that the msdos.sys file is totally changed from the original 98se........... can it be put back in............ to what advantage/disadvantage.......??????

p.s...........  coincidental or a bug????? i dunno.......... but i just discovered that my regional clock settings were wiped out when i saw that my antivirus was running 2x per scheduled run and when i double checked the scan program there was no a.m. or p.m.  finally went into the control panel regional settings and all's well............

still the dbbl hi 5................

1. Many thanks for your kind appreciation. Glad it works. ;)

2. Do you mean your msdos.sys file is changed after installing 98SE2ME?
Because it doesn't touch it at all.
Complete MSDOS.SYS guide:
http://www.mdgx.com/msdos.htm

3. Never heard of such bug, but I'll try to find out if it is related to 98se2me, and will get back to you.
IMHO I don't think your regional clock error is related to 98se2me.
Weird, maybe there is a chance this is related to the antivirus tool you're using?
Also, have u installed Gape's SP before installing 98se2me?
If u have, most all system errors that plague "out of the box" 98SE OS should have been fixed.

Hope this helps.

#30
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

-MDGx, I have need of your infinite wisdom yet again:  when trying to export the registry in real-mode dos (from ebd, using regedit), I get "unable to open registry (1,016)..." ?  -I was only trying to test the registry editor for my new modified EBD, on a good-working system, in case of a need to edit the registry in real-dos mode emergency... MS has an article, but of course all they say to resolve it is "do it in protected-mode"... that's not helpful, as usual... do ya know of any real-mode dos registry editors that actually work with real-sized registries?

I need more details, please:
- were u using the regedit.exe from WinME [modded by Tihiy] that is installed by 98se2me? If not, which regedit.exe were u using? The 1 from 98SE setup CD? Or maybe the fixed 98SE regedit.exe from this archive:
http://www.users.dir...ble/reg/reg.zip
documented here:
http://www.users.dir...e/regsmall.html
- were u using a batch file to backup your registry? If u were, can u post its contents here?
- what is the size [in Bytes] of your SYSTEM.DAT + USER.DAT files found in %windir% ?

#31
tentonine

tentonine

    Newbie

  • Member
  • 40 posts
  • Joined 12-January 05

-MDGx, I have need of your infinite wisdom yet again:  when trying to export the registry in real-mode dos (from ebd, using regedit), I get "unable to open registry (1,016)..." ?  -I was only trying to test the registry editor for my new modified EBD, on a good-working system, in case of a need to edit the registry in real-dos mode emergency... MS has an article, but of course all they say to resolve it is "do it in protected-mode"... that's not helpful, as usual... do ya know of any real-mode dos registry editors that actually work with real-sized registries?

<{POST_SNAPBACK}>


This happens when booting from a boot disk. You have to use the /L and /R switches to tell regedit where the *.dat files are.
You need to use the full path with drive letter. Same with the /E switch.

#32
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

-MDGx, I have need of your infinite wisdom yet again:  when trying to export the registry in real-mode dos (from ebd, using regedit), I get "unable to open registry (1,016)..." ?  -I was only trying to test the registry editor for my new modified EBD, on a good-working system, in case of a need to edit the registry in real-dos mode emergency... MS has an article, but of course all they say to resolve it is "do it in protected-mode"... that's not helpful, as usual... do ya know of any real-mode dos registry editors that actually work with real-sized registries?

This happens when booting from a boot disk. You have to use the /L and /R switches to tell regedit where the *.dat files are.
You need to use the full path with drive letter. Same with the /E switch.

Good point. I didn't know that. :(
I never had to recreate/restore the registry from a boot disc, because I always have another working copy of Windows on C as backup.

#33
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05
-I did try the /l /r switches, with full path, along with of course being in the same dir as the .dat's (/windows), and of course did the attrib -r -s -h *.dat to make sure they were available...

-it's the same w/all versions of regedit.exe, 98se/ME/updated/"fixed"...

-combined size of user.dat + system.dat is 7mb... (old-install test system, lotsa installs/uninstalls... but I do clean/optimize it regularly)

-and nope, no batch file to back it up, just standard/auto...

-it's no big deal, was just curious... I also keep many generational copies of reg, prob won't ever need it, but was thinking of all poss. emergencies, it'd be nice to be able to edit the reg from real-mode if windows won't boot... but I also keep "safe" copies of windows on C, so prob won't ever need this, but just in case...

#34
crashnburn

crashnburn

    Newbie

  • Member
  • 20 posts
  • Joined 02-April 05
all is well............ :wacko: glad i found the correction quicker than the cause....... possibly the 98se updates may have put a few issues in default state..... but my order of updating is whenever there is a 98se update i always follow thru with a re-install of option 3 and 1 of the 98seMe............ no clue as to why my pooters went on a 12 hour cycle, but if it occurs again i will take notes............. lol............

#35
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05
--re: regedit w/EBD:

-DOH! :blushing: it's working fine, it was a typo when specifying the /L /R paths (my "C" and "D" drive letters swap, when booting from EBD... bios stuff)... I was so used to typing "c:\windows...", shoulda been "D:\windows...". SO sorry to waste your time here... :blushing:

#36
crashnburn

crashnburn

    Newbie

  • Member
  • 20 posts
  • Joined 02-April 05
:thumbup all is well.............. but i do have one question/request...... i also use a freeware aka TclockEx in my clock tray....... and i have noticed since all the mods that it tends to resize itself......... is there anything on your site or mod that i can 'fix' the sizing on that icon area.......????
thank you again......

#37
maninabox

maninabox

    Newbie

  • Member
  • 25 posts
  • Joined 17-May 05
MDGx, after service pack from Gape i would try to translate your pack. You use inno setup for compile the pack, right? There is a guide file as the file .sed for the sp. Which file (inf, batch) i must/can translate? For dll and exe i pick the file from my windows me italian cd.

Thanks :)

#38
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

all is well.............. but i do have one question/request...... i also use a freeware aka TclockEx in my clock tray....... and i have noticed since all the mods that it  tends to resize itself......... is there anything on your site or mod that i can 'fix' the sizing on that icon area.......????
thank you again......

I've been using TclockEx in the past, but I gave it up cuz I've hexed my explorer.exe, shell32.dll, comdlg32.dll, user.exe etc in Resource Hacker, so I have no need for it anymore. ;)
But I just tried it again, and this is what happens:
u need to modify both date/day/year and hour/min/sec display to always show with leading zeroes [u can change separators to whatever u want]:
MM-dd-yy ff
HH:mm:ss tt
If u have something like:
M-d-yy ff
H:m:s tt
then it will always resize when the time/date changes e.g. from 9 [1 digit] to 10 [2 digits] to fit the extra digit.

Hope this helps.

#39
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

MDGx, after service pack from Gape i would try to translate your pack. You use inno setup for compile the pack, right? There is a guide file as the file .sed for the sp. Which file (inf, batch) i must/can translate? For dll and exe i pick the file from my windows me italian cd.

Thanks

Thanks a lot for taking the time to do this.
All files you need for compiling Inno Setup are in this small zip [10 KB]:
http://www.mdgx.com/9s2m/INNOFILE.ZIP
Please read INNOFILE.TXT for details.

Please ask me if you need anything else.
Hope this helps.

Buona fortuna.

#40
crashnburn

crashnburn

    Newbie

  • Member
  • 20 posts
  • Joined 02-April 05
:thumbup already on to that.......... thanks for the reply but if you could lead me to the registry or ini area that i could reconfigure that particular tray area as it also encloses the task scheduler so i can 'play' with it............ BTW 4+ days and no blue screen since the 98seMe upgrades................. BOTH machines.........

#41
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

already on to that.......... thanks for the reply but if you could lead me to the registry or ini area that i could reconfigure that particular tray area as it also encloses the task scheduler so i can 'play' with it............

This is where TClockEx writes into the registry:
REGEDIT4

; all users reg key:
[HKEY_USERS\.Default\Software\TClockEx\Settings]
"ClockFormatString"="MM-dd-yy ff"
"TooltipFormatString"="dddddddddd MMMM dd yyyy"

; current user reg key:
[HKEY_CURRENT_USER\Software\TClockEx\Settings]
"ClockFormatString"="MM-dd-yy ff"
"TooltipFormatString"="dddddddddd MMMM dd yyyy"
These are the values I use.
U need to change them if u like a different display.

Nonetheless, I still recommend to make these changes from the UI:
right-click on the tray TClockEx display -> TClockEx Properties -> Clock Format tab -> make your changes -> OK.
This is the bugs list + how to use case sensitive date strings:
http://www.rcis.co.z...lockex/bugs.htm
FAQ:
http://www.rcis.co.z...clockex/faq.htm

Note that TClockEx works also with Windows 2000/XP/2003/Longhorn.

Hope this helps.

#42
JEGjr

JEGjr
  • Member
  • 6 posts
  • Joined 25-May 05
I've been looking all over the internet for something like the: 98SE2ME.EXE

I bought a mass storage device in Hong Kong w/ no driver (didn't need one for XP). But I've been trying to find a driver so I can use it on my old laptop w/ 98SE. Found this site finally, and installed the 98SE2ME.EXE My computer finally recognized a driver. When I click on the Device Manager the note states: "This device is working properly", and that it accepted this driver. I also now show the little "safe to remove" icon in the lower right toolbar. BUT, I cannot access the device. I never get an icon in My Computer that allows me access it. I have tried other avenues and have turned up empty as well. Any suggestions? Please. Thanks.

#43
krick

krick

    Member

  • Member
  • PipPip
  • 116 posts
  • Joined 25-October 04

I bought a mass storage device in Hong Kong w/ no driver (didn't need one for XP).  But I've been trying to find a driver so I can use it on my old laptop w/ 98SE.  Found this site finally, and installed the 98SE2ME.EXE  My computer finally recognized a driver.  When I click on the Device Manager the note states: "This device is working properly", and that it accepted this driver.  I also now show the little "safe to remove" icon in the lower right toolbar.  BUT, I cannot access the device.  I never get an icon in My Computer that allows me access it.  I have tried other avenues and have turned up empty as well.  Any suggestions?  Please.  Thanks.

<{POST_SNAPBACK}>


Have you tried installing this...

Maximus Decim Native USB Pack ver.2.2
http://www.msfn.org/...showtopic=43605

Also, is the mass storage drive formatted? In order to see it, I believe that it needs to be formatted somehow if it isn't already formatted correctly from the factory.

It's kind of like hooking up an unformatted hard drive to your computer. Until you format it, it doesn't show up with a drive letter in My Computer.

#44
JEGjr

JEGjr
  • Member
  • 6 posts
  • Joined 25-May 05

is the mass storage drive formatted?


Thanks for the reply Krick. Does it have to be reformatted for Win98SE? I don't know. It works fine in XP. I think you may be right though, I mean the computer is doing everything right now - it finally accepted a driver and is showing signs of life. But still no drive letter in My Computer (which I do get in XP).

#45
JEGjr

JEGjr
  • Member
  • 6 posts
  • Joined 25-May 05
BTW - Yes, I did try "Maximus Decim Native USB Pack ver.2.2", that didn't work. If I can't get this thing to work, I have plan B. You see, I'm going on vacation and need to be able to transfer all of my pics from the flash cards to something larger, and all I have is this old laptop. Well, I found another alternative that will work. I'm posting it here in case any one else is interested. A guy has reworked a Microsoft driver so that you can connect your Ipod to Windows98 (I have SE, and it worked for me), and use it as a mass storage device (I have the 40GB Ipod, and it worked for me. He hadn't tested that one yet). You cannot install I-tunes, but you will get the Ipod drive letter in My Computer that will enable you to use it for storage. Here's the LINK.

#46
reguerra

reguerra
  • Member
  • 5 posts
  • Joined 21-April 05
Hello, 98SE2ME is really fantastic. Thanks.
But I have 2 litlle problems with it, the first (more important) is that after 98SE2ME installation I can't use RasPPPOE (software to connect to adsl using dial-up standard window). It doesn't recognize the "pseudo modem driver" installed. Desinstalling or reinstalling doesn't helps.
Second (not very important) is that the links to "my documents", "my networks places", "my computer", etc. in windows explorer doesn't works at all (option 3 installed).
Thanks in advance and congratulations for your work :)

#47
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

I've been looking all over the internet for something like the: 98SE2ME.EXE

I bought a mass storage device in Hong Kong w/ no driver (didn't need one for XP).  But I've been trying to find a driver so I can use it on my old laptop w/ 98SE.  Found this site finally, and installed the 98SE2ME.EXE  My computer finally recognized a driver.  When I click on the Device Manager the note states: "This device is working properly", and that it accepted this driver.  I also now show the little "safe to remove" icon in the lower right toolbar.  BUT, I cannot access the device.  I never get an icon in My Computer that allows me access it.  I have tried other avenues and have turned up empty as well.  Any suggestions?  Please.  Thanks.

All I can think of right now:
1. install 98SE SP 2.0.1:
http://exuberant.ms11.net/98sesp.html
2. Install 98SE2ME:
http://www.mdgx.com/4
3. Install Native USB 2.0 Drivers:
http://www.msfn.org/...showtopic=43605
4. Make sure you have no USB:
http://www.mdgx.com/98-5.htm#FWUE
or power/ACPI/APM errors/conflicts:
http://www.mdgx.com/newtip15.htm#MYP
5. Install manufacturer drivers for your USB device, starting with drivers made of WinME (if u find any, and if they'll allow u to install them on 98SE), otherwise install 98SE specific drivers.
In certain cases even 2000/XP specific drivers may work [INF files can be modified to accept 98SE/ME], it's all a "try-and-error" game.

USB stuff [see the USB related links]:
http://www.mdgx.com/drv.htm#DRV

Hope this helps.

#48
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

Hello, 98SE2ME is really fantastic. Thanks.
But I have 2 litlle problems with it, the first (more important) is that after 98SE2ME installation I can't use RasPPPOE (software to connect to adsl using dial-up standard window). It doesn't recognize the "pseudo modem driver" installed. Desinstalling or reinstalling doesn't helps.
Second (not very important) is that the links to "my documents", "my networks places", "my computer", etc. in windows explorer doesn't works at all (option 3 installed).
Thanks in advance and congratulations for your work

Thanks a lot for your kind appreciation. ;)

About your RASPPPOE problem, try this:
After installing 98SE2ME, replace these files from %windir%\SYSTEM :

NDSWAN16.DLL
NDSWAN32.DLL
NETAPI.DLL
NETAPI32.DLL
NETDI.DLL
NETOS.DLL
RASAPI16.DLL
RASAPI32.DLL
RNAUI.DLL

with their older Win98 SE couterparts [which probably were on your computer before u installed 98SE2ME] from the 98 SE setup CD CABs.
Or if u backed up your OS in C:\W98SEOLD [by running 98SE2ME options 1 or 2], restore these files from there.
This zip has a text file called CABL98SE.TXT with the exact location of these files:
http://www.mdgx.com/files/EXTCAB.ZIP
More info on extracting files from CABs:
http://www.mdgx.com/last4.htm#EXTRACT
To replace some of these files u need to hold down Shift + F5 at the same time during BIOS boot POST (Power On Self Test) sequence to boot into native/true MS-DOS [or boot from a 98SE boot floppy to native MS-DOS], and then move them to %windir%\SYSTEM [usually C:\WINDOWS\SYSTEM].
Replace these files in small groups, for example start with:

NDSWAN16.DLL
NDSWAN32.DLL

if that doesn't work, then replace:

RASAPI16.DLL
RASAPI32.DLL

if that doesn't work, then replace:

RNAUI.DLL

and only after that:

NETAPI.DLL
NETAPI32.DLL
NETDI.DLL
NETOS.DLL

Reboot normal back into Windows.
See if that fixes your DSL modem problem, and then please post here your findings.
If that is the case, and those files are the "culprit", please let me know so I can remove them from 98SE2ME.
Thanks.

About links to "my documents", "my networks places", "my computer" not working after installing option 3:
I need more details:
what language is your OS?
If it is any language other than English, it doesn't work properly.
98SE2ME is designed specifically for English editions only.
Please see the "FAQ" chapter in READ1ST.TXT:
http://www.mdgx.com/9s2m/READ1ST.TXT
for more details.
Also, if u installed Tihiy's Revolutions Pack, that makes massive changes to the interface, and if that is the case, u need to ask Tihiy, the author:
http://www.msfn.org/...showtopic=39333

Hope this helps.

#49
Tihiy

Tihiy

    the creator

  • Member
  • PipPipPipPipPipPipPip
  • 1,932 posts
  • Joined 19-November 04
  • OS:Windows 7 x64
  • Country: Country Flag

Donator

USER.EXE without proper USER32.DLL will cause LOCKUP! :no:
Have you deleted USER32.DLL also? :P

#50
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

USER.EXE without proper USER32.DLL will cause LOCKUP!
Have you deleted USER32.DLL also?

Yeah, I've removed both, posted the update, experimented again, then my mouse [+ Intellipoint 4.12 installed] started to move erratically [with USER.EXE + USER32.DLL 4.10.2231 for 98SE], and in the end I thought...
this [USER.EXE + USER32.DLL 4.90.3001] is one of the best features of all ME replacements, so I put them back in. ;)
So my little "experiment" is over now. :blink:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users