Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

98SE2ME = Killer Replacements: ME -> 98 SE

* * * * - 5 votes

  • Please log in to reply
1083 replies to this topic

#51
chankya

chankya

    Member

  • Member
  • PipPip
  • 142 posts
  • Joined 13-November 04
Dear MDGx

Great Success in this proj. what about silent update for advance user like /q /n in 98setoMe in dos/windows mode.

and kindly post here a full proof proj. just like the one u posted on 15/05/05 with info that it's most tested one so someone can rely better that the beta version i think u like the idea so that u can name it as beta ver for tester.

what about adding xp component i am still waiting for that. 98MEXP Edition.


by4now.

WWW.MDGX.COM

Best Site for All Microsoft Operating System All Latest Updates Patches is There even LINUX tutorials and u dont like GAMES

Best ever Explorer Firefox

MSFN ENJOY !!!

THANKS to all LOVEING people for there sweet suggestions to improve this mission.
" Imagination is more important than knowledge" - Albert Einstein


How to remove advertisement from MSFN

#52
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

Great Success in this proj. what about silent update for advance user like /q /n in 98setoMe in dos/windows mode.

and kindly post here a full proof proj. just like the one u posted on 15/05/05 with info that it's most tested one so someone can rely better that the beta version i think u like the idea so that u can name it as beta ver for tester.

what about adding xp component i am still waiting for that. 98MEXP Edition.

Sorry, but I'm afraid this is not currently possible, because the 98SE2ME installer as it is today, is made up of 2 parts:
1. the part that installs in C:\9!M = does not make any changes to your 98SE OS.
This part is compiled with Inno Setup installer:
http://www.jrsoftware.org/isinfo.php
2. the part that installs the WinME system files = does make changes to your 98SE OS.
This part is made up of a bunch of batch, INF + REG files, all of which run from within 98SE2ME.PIF.
Because of this structure, it is not possible to run unattended with /C /Q /T:<path> etc switches, which are specific only to installer executables compiled with MS iexpress/cab sdk and similar tools.
Maybe in the future, and/if/when I have time, I'll redesign the entire installer from scratch using Iexpress or similar tools. And if/when I'll do this, I'll post it all here. ;)

About "fool proof" 98SE2ME:
obviously that is very hard to achieve, because 98SE2ME replaces too many files from the WinME CD [~ 710 as of current release], not to create any bugs, errors, minor annoyances, incompatibilities etc.
So unfortunately there is always a "trade-off" and error margin we need to account for.
But, I can tell you that most major bugs have been squashed as far as I'm aware.
Please read the "KNOWN BUGS + FIXES" chapter in READ1ST.TXT for details:
READ1ST.TXT

About 98SE2XP:
I'm now experimenting with 2003 SP1, so I think these 2 should be treated as 1 from the point of view of creating install scripts.
As soon as I'm sure all these system files work ok, I'll post some scripts here + at my site, and will let everybody know.
Untill then, you can cut + paste my scripts from:
http://www.mdgx.com/98-5.htm#KRM9S
if u wish to install XP SP2 components [not available separately as installers] on your computer.
Similarly, u can d/l 2003 SP1 [330 MB :(]:
http://www.mdgx.com/ws3toy.htm#SP1
and then modify the XP SP2 scripts at URL above to extract + copy these files from 2003 SP1 to:

- %windir% :

HH.EXE

- %windir%\SYSTEM :

HHCTRL.OCX
HHSETUP.DLL
ITIRCL.DLL
ITSS.DLL
MSHTML.TLB
MSHTMLED.DLL
MSHTMLER.DLL
RICHED20.DLL
USP10.DLL

- %windir%\FONTS :

ARIAL.TTF
ARIALBD.TTF
ARIALBI.TTF
ARIALI.TTF
COUR.TTF
COURBD.TTF
COURBI.TTF
COURI.TTF
GEORGIA.TTF
GEORGIAB.TTF
GEORGIAI.TTF
GEORGIAZ.TTF
MICROSS.TTF
TAHOMA.TTF
TAHOMABD.TTF
TIMES.TTF
TIMESBD.TTF
TIMESBI.TTF
TIMESI.TTF
VERDANA.TTF
VERDANAB.TTF
VERDANAI.TTF
VERDANAZ.TTF

HTML Help files above can also be installed separately:
http://www.mdgx.com/web.htm#HHU
or as part of Gape's SP 2.0.1:
http://exuberant.ms11.net/98sesp.html

Also, if you're wondering what actual files I'm going to include inside 98SE2XP/98SE22K3 installers, I need to tell you that I'm not going to add any files from XP SP2 or 2003 SP1, but only the scripts which will allow you to download these service packs, a dos console command line tool which will extract the files to a temp folder, a couple of DOS detection tools to make sure they can't be installed on anything else except 98SE [see the 98SE2ME free DOS tools I'm using], and that's it.

Note that all these files are from the English releases, and are meant *only* for the English release.
I'm not familiar with any other language releases, so I don't know which files work or which don't.

Hope this helps.

#53
chankya

chankya

    Member

  • Member
  • PipPip
  • 142 posts
  • Joined 13-November 04
Dear MDGx

Thanks for u'r well explained answer.

As u mentioned in http://www.mdgx.com/98-5.htm#KRM9S



FIRST install the "WINDOWS 98 SECOND EDITION (SE) ESSENTIAL FREE UPGRADES + FIXES" AND the Unofficial Windows 98 SE Service Pack (SP) 2.0.1 [15.5 MB, English, free], and ONLY AFTER that replace Win98 SE system files with the ones from WinME listed below!

Is unofficial SP2.0.1 dosenot contain all updated so we still require
"WINDOWS 98 SECOND EDITION (SE) ESSENTIAL FREE UPGRADES + FIXES"
before killer replacement.

i have found these updates if u like i can send it's around 50 files 58MB

273991_A3D4C8D71DDD5905F41EF36B5BB3E07C73C1EAE6[1].EXE
323172_98_8C18CC16D21737816C36ABE51EB16E21A190BEB5[1].EXE
323255_W98_edcf77d7d30b955b4b251552ee51748[1].EXE
329115_W98_E99E3479AB8198E03FE5A107BDBBC962BC6C333E[1].EXE
811630_W98_CF47941DB1D6B7747FE9FB7EEA966E0198E88326[1].EXE
823559USA8.EXE
823559USA8_0e714506b380e4be11ff07b31da9da9[1].EXE
DirectX9-KB819696-x86-ENU.exe
DirectX9-KB819696-x86-ENU_977f8cc86c1e151a0168d1296210913[1].exe
JS56MEN.EXE
JS56_15B3577990DA7650A1E79DCAA51851CD0E041639[1].EXE
MPSetup.exe
Q320920.EXE
Q330994.EXE
Q824145.EXE
Q832894_a56d1a98d775e1031c72934a0baa9d7[1].exe
WindowsMedia71-KB817787-x86-ENU_d7d598b87d35de7e883e07a6b786c8f[1].exe
273991USAM.EXE
msjavwu_8073687b82d41db93f4c2a04af2b34d[1].exe
q313829.exe
q313829_5EEDD33FA704078BE5873EFA6E8C3D62B82C2EFF[1].exe
q316059.exe
q329414_mdacall_x86.exe
q329414_mdacall_x86_6455F9E15D1FD876A354AC196BCE848B4EA39180[1].exe
259728_1F6BE1EC0FCD72AB4A8D0FBB4E6A82918E888392[1].EXE
q824145_76dd839870a655458701c0b937b91d6[1].exe
q824150.exe
q827667.exe
scr56en.exe
vbrun60sp5.exe
wm320920_64.exe
wm320920_71_24C932549D7BCFAB6954D52590DB7C146A42E8BB[1].exe
256015_A570D63F5E6B4F80CC852D2C802AC7D14B32614F[1].EXE
245729US8_4D1A7A9CD3703E514D051595BB16A3BC69A0ABE8[1].EXE
238453US8_CFED25E588C85FDF548557F04A09892055011D7C[1].EXE
WindowsMedia9-KB819639-x86-ENU_bfd620da8e1529c3e4ffadfb93f33fa[1].exe
190656_98UP.EXE
216641up.exe
220460_98up.exe
240075UP.EXE
241134usa8.exe
242975USA8.EXE
243450USA8.EXE
256015USA8.EXE
263044USA8.EXE
4756US8.EXE
811630USA8.EXE
dun14-98.exe
310695usam.exe
wucsp.exe
y2k.exe
273991USA8.EXE
98ZAK.EXE
q330994_257f5a9aeead109bc4c764ae1b5b00f[1].exe

is it sufficient before installing sp2.0.1 and 98se2me.

thanks and bye

MSFN ENJOY!!!
" Imagination is more important than knowledge" - Albert Einstein

#54
reguerra

reguerra
  • Member
  • 5 posts
  • Joined 21-April 05
About your RASPPPOE problem, try this:
After installing 98SE2ME, replace these files from %windir%\SYSTEM :
Replace these files in small groups, for example start with:

NDSWAN16.DLL
NDSWAN32.DLL

if that doesn't work, then replace:

RASAPI16.DLL
RASAPI32.DLL

if that doesn't work, then replace:

RNAUI.DLL

and only after that:

NETAPI.DLL
NETAPI32.DLL
NETDI.DLL
NETOS.DLL

Reboot normal back into Windows.
See if that fixes your DSL modem problem, and then please post here your findings.
If that is the case, and those files are the "culprit", please let me know so I can remove them from 98SE2ME.

About links to "my documents", "my networks places", "my computer" not working after installing option 3: I need more details:
what language is your OS?


[/quote]

Hello MDGx,
thank you very much for your reply.

I replaced the files you said, under pure DOS, but the problem continues.
I'm sending a few screen captures for you.
My OS is Win98SE English version + SP2.0 + 98SE2ME
Tihiy package NOT installed.

Thank you.

Attached File  raspppoe1.jpg   24.61KB   60 downloads
Attached File  raspppoe2.jpg   12.63KB   49 downloads
Attached File  raspppoe3.jpg   52.73KB   115 downloads

#55
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag
reguerra:
I have received this feedback from a concerned 98SE2ME user who tested his ADSL modem in a similar environment, with 98SE2ME option 1 or 2 installed [they both install exactly the same ME files], and his conclusion is...
[quote]Some time ago someone reported trouble with 98SE2ME on a computer with a USB ADSL modem.
Today [5-29-2005]I installed 98SE2ME (without option 3) on a Pentium II system with a USB ADSL modem.

At first, no internet connection could be established, though the ADSL modem itself reported it had connected successfully. But after re-installing TCP/IP and Client for Microsoft Networks, connection worked fine.

It was often necessary to reset the IP adresses etc... with winipcfg.exe to get a connection, but this is not related to 98SE2ME because it already was necessary in pure 98SE on this system.[/quote]
98SE2ME option 3 files have nothing to do with the internet/network connection, because installs only UI + Shell controls [quoted from READ1ST.TXT]:
Option 3 installs these newer WinME system files [Windows User Interface (UI) Controls]:
=> %windir% (usually C:\WINDOWS):
- Windows Explorer = EXPLORER.EXE build 5.50.4134.100
=> %windir%\SYSTEM (usually C:\WINDOWS\SYSTEM):
- Common Dialog 32-bit Control = COMDLG32.DLL build 5.50.4134.100
- Active IMM Server = DIMM.DLL build 5.00.3000.1
- OLE DOCument Properties = DOCPROP.DLL build 5.00.2136.1
- OLE DOCument Properties 2 = DOCPROP2.DLL build 5.00.2136.1
- Fonts Folder Control = FONTEXT.DLL build 4.90.3000
- My DOCuments Folder Control = MYDOCS.DLL build 5.50.4134.100
- Map Network Drives/Network Places Wizard = NETPLWIZ.DLL build 5.00.2136.1
- Effects Control = PLUSTAB.DLL build 5.00.2136.1
- Shell 32-bit Control = SHELL32.DLL build 5.50.4134.100
- Image Preview Control = SHIMGVW.DLL build 5.50.4134.100
- Shell Scrap Object Handler = SHSCRAP.DLL build 5.00.2136.1
- Web View Control = WEBVW.DLL build 5.50.4134.100
- Customize Folder Wizard = IESHWIZ.EXE build 5.50.4134.100
Exception:
NETPLWIZ.DLL = only maps remote drives/UNC addresses as local drive letters.

Please try to reset/reconfigure/reinstall/repair TCP/IP protocols + Client for MS Networks, and see if it works. These may help:
Winsock/TCP/IP (DUN/RAS) + Layered Service Provider (LSP) 32-bit repair tools (freeware):
http://www.careyholz...om/netfixes.htm
- WinsockXPFix for Windows 9x/2000/ME/XP:
http://www.iup.edu/h...net/winfix.shtm
Direct download [1.34 MB]:
http://www.iup.edu/h...insockXPFix.exe
- SockFix for Windows 9x/ME:
http://www.lavasoftusa.com/
Direct download [33 KB]:
http://digital-solut...ft/whndnfix.zip
- Winsock2 Fix for Windows 98/ME:
http://www.bu.edu/pc...insock2fix.html
Direct download [60 KB]:
http://www.bu.edu/pc...ccess/w2fix.exe
- LSP-Fix for Windows 9x/NT4/2000/ME/XP/2003:
http://www.cexx.org/lspfix.htm
Direct download [179 KB]:
http://www.cexx.org/lspfix.zip

Unfortunately I can't test your environment because I don't have a DSL modem.

Hope this helps.

#56
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05
-reguerra: let us know if and how that ADSL/network prob gets resolved, I have a friend who could REALLY benefit from 98se2me...
>;]

#57
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

I have a friend who could REALLY benefit from 98se2me...

You don't need to wait for reguerra to do this.
You [or your friend] can always install 98SE2ME on your friend's computer, because it backs up the entire OS into C:\W98SEOLD , where the original OS can be always restored from, just in case.
Just allow 98SE2ME to create a new backup when u run option 1 or option 2 [those are the only options that need full backup].

Hope this helps.

#58
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05

I have a friend who could REALLY benefit from 98se2me...

You don't need to wait for reguerra to do this.
You [or your friend] can always install 98SE2ME on your friend's computer, because it backs up the entire OS into C:\W98SEOLD , where the original OS can be always restored from, just in case.
Just allow 98SE2ME to create a new backup when u run option 1 or option 2 [those are the only options that need full backup].

Hope this helps.

<{POST_SNAPBACK}>

-true; I just thought, if Reguerra is already working this out, why duplicate the effort? Just wait and see what he comes up with, take it from there... But if he takes too long, I will give it a shot, too...

#59
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

-true; I just thought, if Reguerra is already working this out, why duplicate the effort?  Just wait and see what he comes up with, take it from there... But if he takes too long, I will give it a shot, too...

roger that B)

#60
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05
-uh oh, looks like broken link for 98se2me download, MDGx.....

-I'll try it on another puter, to make sure, but both browsers here failed...

#61
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

-uh oh, looks like broken link for 98se2me download, MDGx.....

-I'll try it on another puter, to make sure, but both browsers here failed...

Sorry for your trouble.
I just tried it and works ok.
My web provider might have had problems at the time when u tried.
Please try again at a later time.
98SE2ME [2 MB]:
http://www.mdgx.com/4

Hope this helps.

#62
KeBwOb

KeBwOb
  • Member
  • 2 posts
  • Joined 06-June 05
Hi, a quick question for MDGx :thumbup if I may...

I have just done a comparison between your current list of ME files known to work with 98SE with the list you had on your site from about a year ago, and was surprised to see some omissions:

C:\Windows :
GRPCONV.EXE
HIMEM.SYS
IFSHLP.SYS

C:\Windows\System :
DESK.CPL
POWERCFG.CPL
DOCPROP.DLL
DSKMAINT.DLL
FONTEXT.DLL
MFC42.DLL
MSAB32.DLL
MSASN1.DLL
MSNSSPC.DLL
MSVCIRT.DLL
SNMPAPI.DLL
REGSVR32.EXE
FIOLOG.VXD
MSSP.VXD

C:\Windows\System32\Drivers :
JPEGIM32.FLT

C:\Program Files\Common Files\Microsoft Shared\Grphflt :
JPEGIM32.FLT

C:\Program Files\Common Files\System\Ole Db :
MSDATL2.DLL

Not many, but I guess some problems were found with these and they were left out of the updated list?

Thanks,
PJ

Edited by KeBwOb, 06 June 2005 - 01:35 PM.


#63
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

Hi, a quick question for MDGx  :thumbup if I may...

I have just done a comparison between your current list of ME files known to work with 98SE with the list you had on your site from about a year ago, and was surprised to see some omissions:

C:\Windows :
GRPCONV.EXE
HIMEM.SYS
IFSHLP.SYS

C:\Windows\System :
DESK.CPL
POWERCFG.CPL
DOCPROP.DLL
DSKMAINT.DLL
FONTEXT.DLL
MFC42.DLL
MSAB32.DLL
MSASN1.DLL
MSNSSPC.DLL
MSVCIRT.DLL
SNMPAPI.DLL
REGSVR32.EXE
FIOLOG.VXD
MSSP.VXD

C:\Windows\System32\Drivers :
JPEGIM32.FLT

C:\Program Files\Common Files\Microsoft Shared\Grphflt :
JPEGIM32.FLT

C:\Program Files\Common Files\System\Ole Db :
MSDATL2.DLL

Not many, but I guess some problems were found with these and they were left out of the updated list?

Thanks,
PJ

Hi PJ,

I believe most of these files + explanations why I removed them are listed in READ1ST.TXT:
READ1ST.TXT
under the "NEWS + CHANGES" chapter [it's a long read thou :(].
READ1ST.TXT also installs into the C:\9!M folder as part of 98SE2ME.EXE [2 MB]:
http://www.mdgx.com/4

The only files that are not listed in READ1ST.TXT are:
GRPCONV.EXE = In 98SE2ME I'm using the one from MS IE 6.0 SP1, it's the same build but newer date stamp. If u install 98SE2ME, you'll find it into the C:\9!M folder.
HIMEM.SYS + IFSHLP.SYS = these are identical with the ones from 98SE setup CD.
JPEGIM32.FLT = much newer build [from MS Office 2003] is installed by MS Paint Add-on Import + Export Graphic Filters Plugins Pack:
http://www.mdgx.com/add.htm#PNT

Hope this helps.

#64
KeBwOb

KeBwOb
  • Member
  • 2 posts
  • Joined 06-June 05

I believe most of these files + explanations why I removed them are listed in READ1ST.TXT....

<{POST_SNAPBACK}>


Doh! So thats what its for :blushing: !
Once I get out of work, I can read it (no websense blocking)
Thx!

#65
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
  • Joined 17-February 05
MDGx,

Hi. I set up my old SiS5598 board and found that my D-Link DCM202 Cable Modem has a problem with the USB drivers with the 98SE2ME installed.

With no driver installed previously, Windows will not find a driver for it when directed to the folder with the USB driver.

With the driver previously installed and working, the driver will show that it could not be started after 98SE2ME is installed. When updating the driver, it finds the files (one of which it asks for and I direct it to the folder with the files). When it asks if I should let it keep the newer (Me) versions I tell it to keep the newer versions, it asks to reboot, and it reboots to an unstarted driver same as before. If I tell it to replace the files with the older (98SE) ones, the same startup with an unstarted driver. No difference, except when I did that and it didn't work I removed the device and reinstalled 98SE2ME so I would have all the newer files back (just in case).

I'm writing now because I removed the 98SE2ME (not the program, the actual 98SE Windows files restored with the restor.bat), plugged in the USB modem again and it works perfectly. I guess that's because all the files in the Windows directory are now as they were before installing 98SE2ME.

Why doesn't the driver work with the Me files? You can see what they are, and take a look at the inf as well, by downloading it from the support area for the DCM-202 Cable Modem on the d-link.com website. It's the USB driver. The one posted is the same one as on the cd, but I used the downloaded one this time. I didn't want to wonder whether it was a problem with getting the driver files to transfer from the cd-rom drive. I extracted them all to a folder and at least that's one potential bug I know is not the problem.

If you look at the inf and the files, do you think you can figure out why the newer OS files that Me has somehow don't let the driver work?
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#66
krick

krick

    Member

  • Member
  • PipPip
  • 116 posts
  • Joined 25-October 04
MGDx,

What procedure do you use in 98SE2ME to backup/restore windows?

Is is a batch file? If so, what does it look like?

I want to do some hardware benchmarking on a windows 98SE system and I want to have an easy way to go back to a "clean slate" after installing and benchmarking each hardware device.

#67
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
  • Joined 17-February 05
I think the Microsoft Police have kidnapped MDGx. They want to keep him locked away for two reasons. First, to stop him from making 9x so bug free and updated. The WMP10 installation batch file was the last straw. Second, they need him around to tell them how to get one guy to fix bugs in a day, when it's been taking a mult-billion dollar company months or years to patch up some stuff.

Free MDGx!
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#68
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

MDGx,

Hi.  I set up my old SiS5598 board and found that my D-Link DCM202 Cable Modem has a problem with the USB drivers with the 98SE2ME installed.

With no driver installed previously, Windows will not find a driver for it when directed to the folder with the USB driver.

With the driver previously installed and working, the driver will show that it could not be started after 98SE2ME is installed.  When updating the driver, it finds the files (one of which it asks for and I direct it to the folder with the files).  When it asks if I should let it keep the newer (Me) versions I tell it to keep the newer versions, it asks to reboot, and it reboots to an unstarted driver same as before.  If I tell it to replace the files with the older (98SE) ones, the same startup with an unstarted driver.  No difference, except when I did that and it didn't work I removed the device and reinstalled 98SE2ME so I would have all the newer files back (just in case).

I'm writing now because I removed the 98SE2ME (not the program, the actual 98SE Windows files restored with the restor.bat), plugged in the USB modem again and it works perfectly.  I guess that's because all the files in the Windows directory are now as they were before installing 98SE2ME.

Why doesn't the driver work with the Me files?  You can see what they are, and take a look at the inf as well, by downloading it from the support area for the DCM-202 Cable Modem on the d-link.com website.  It's the USB driver.  The one posted is the same one as on the cd, but I used the downloaded one this time.  I didn't want to wonder whether it was a problem with getting the driver files to transfer from the cd-rom drive.  I extracted them all to a folder and at least that's one potential bug I know is not the problem.

If you look at the inf and the files, do you think you can figure out why the newer OS files that Me has somehow don't let the driver work?

Hi,

Sorry about the delay, been a lil busy lately.

Please try to replace these files [they all go into %windir%\SYSTEM] from native MS-DOS outside Windows:

SETUP4.DLL
SETUPAPI.DLL
SETUPX.DLL

If that doesn't work, replace these:

CFGMGR32.DLL
CFGWIZ.DLL
FINSTALL.DLL

If that doesn't work, replace these:

MSNET32.DLL
MSPP32.DLL
MSTCP.DLL

If that doesn't work, replace these:

NETAPI.DLL
NETAPI32.DLL
NETDI.DLL
NETOS.DLL

If that doesn't work, replace these:

NDSWAN16.DLL
NDSWAN32.DLL
RASAPI16.DLL
RASAPI32.DLL
RNAUI.DLL

Please let me know of results, and if it works, which exact files fixed your problem.

Hope this helps.

Edited by MDGx, 09 June 2005 - 04:58 PM.


#69
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

MGDx,

What procedure do you use in 98SE2ME to backup/restore windows?

Is is a batch file?  If so, what does it look like?

I want to do some hardware benchmarking on a windows 98SE system and I want to have an easy way to go back to a "clean slate" after installing and benchmarking each hardware device.

The 98SE2ME backup/restore procedure is explained in READ1ST.TXT [78 KB]:
READ1ST.TXT
which is also part of 98SE2ME [2 MB]:
http://www.mdgx.com/4
Please see these chapters for complete details:
EXTREMELY IMPORTANT
FAQ
98SE2ME.PIF COMPLETE GUIDE

Backup is only automatic:
must be run from within 98SE2ME.BAT options 1 + 2 [u have the choice not to back up].
Restore is only manual:
must be run by user from 98RESTOR.BAT.
This is the entire system backup/restore function.
Options 3 + 6 have separate backup/restore functions [only replaced fiels are backed up]:
restore must be run from Control Panel -> Add/Remove programs.

Hope this helps.

#70
jack99

jack99

    Banned

  • Banned
  • Pip
  • 75 posts
  • Joined 18-April 05
:o yes i heard mdgx was recruited by apple to built the 9xmesp2.x
Flash and animated signatures and avatars are not permitted.

#71
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
  • Joined 17-February 05
So, I boot into Command Prompt Only or an unfetterred Ms-Dos Mode and copy the files from the system backup made by 98SE2ME to the System folder, right? And when dos asks to overwrite the existing newer files (if Dos even mentions or knows they're newer), I say okay or Y (whatever it asks for)?

I'm just so used to the GUI!

The thing's running fine with what was left after undoing 98SE2ME. I almost hate to mess with it. Of course I'll let you know as soon as I do so you can not replace whichever files are needed for the use of at least this USB modem's drivers.

I noticed first hand that some things are left updated when restoring 98SE's original files. Interesting. I hadn't read the readme for several versions of 98SE2ME but was still surprised to see the new MSCONFIG still here, as I had never ran the restore before. I don't understand why the new version is better for 98SE. If we're still using autoexec.bat and config.sys then why is it better to have an MSCONFIG that will prompt just once that it noticed the Path line there in the autoexec so it will move it to the registry. Then it won't notice any other change after the initial check. And it leaves out access to those files there. The old version lets folks edit them within itself instead of in the original files or Sysedit (though I never did. I never liked looking at stuff like "user edit" and "restore" there). But, really, it seems that the new one is made for WinMe where the config files aren't used and the environmental variables really are in the registry. As far as I can tell, whatever is in my autoexec and config files are the commands that are active, and not what the new MSCONFIG has entered in the registry as environmental variables.

I don't know. It's late and tomorrow is another day. Perhaps I'll mess with it then.

Geez, that old Riptide soundcard/modem sure plays my mp3's nice with my headphones. I wish the megabucks Audigy 2 ZS and M-Audio Revolution 7.1 sounded this good! I do need to use the EQ in WMP (no bass or treble with the Riptide), but once it's the way I like it it's all so much more of a balanced sound than any of those advanced soundcards. Of course, with this weak 366MHz AMD K6-2 processor that's all I can do at one time. The KT7A with 1.2GHz was, of course, somewhat better but the music still skipped when browsing. No internet browsing while listening to music or this machine slows to a crawl. It didn't do that with a dial-up connection, but broadband doesn't agree with it. The music will skip and browsing is impossible. But, just playing WMP is great (gotta turn off the visualizations, possibly because of the always connected internet. They don't move. They did when I used just the Riptide's modem and dial-up). The speaker out is powered, so it's like a built-in headphone amp too! The card and drivers are definately not up to snuff for the modern age with multi-speakers and the bandwidth demands of broadband internet. But it plays music cleaner than any modern card I've used (and I've used way too many of them -love music and soundcards). And it plays dos games in Windows and Dos-Mode (and doesn't need emm386 loaded like the SBLive does, though most of the time I use an exit to dos pif that uses that but also have one for stuff like Ultima where I can leave it out and it works). The dosgames that will run in Windows run with my autoexec and config files clean of anything except my path statement and that ZoneAlarm thing. Bass, highs, mid, it's all there! How come modern cards don't sound this good?
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#72
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
  • Joined 17-February 05
Okay, since I'm just playin' with this box I'm going to see if I can find out what causes the problem.

First I'll disable the cable modem device in Device Manager and turn off ZoneAlarm from running at startup and reinstall the 98SE Service Pack to be sure most is the same as before. I also now have McAfee VirusScan 7.03 added to the equation. I'll use the control panel to stop it from running at startup and hopefully that's enough. I have no idea how it's going to react to the OS system file changes though. I need to use the 7.03 version on this old box because the new one I subscribe to slows this old box to a crawl so it's useless. The older, better designed way of VirusScan doesn't do that. I do turn off all logging so that alogserv thing doesn't run.

Then I'll install 98SE2ME.

When the modem can't be reenabled, I'll start replacing files in the order you instructed. I assume that when one set doesn't solve it, you want me to put back the files from 98SE2ME that I had replaced with the backed up older ones and then proceed to replace the next set of files with the older ones. Otherwise I'll be stuck with the older files when the new Me ones are fine! So I'll need to backup the said Me files before I overwrite them with the original 98SE ones.

Ya know, every so often I'm getting a system crash and when I reboot the HP 3970 Scanner doesn't reset itself at the Windows splash and Windows then installs an Unknown Driver for it. To fix, I need to remove the Unknown Driver, unplug the scanner's USB from the computer, shut down, unplug the scanner's power, replug it and the USB connector and upon reboot the scanner driver is back but I need to reboot one more time for the scanner to properly reset itself at the Windows splash again. The scanner is brand new. I have installed it on my main box with XP (the A7V880), but hadn't had it installed for long before I unhooked that machine and started playing with this old thing. So I really don't know whether the scanner is a lemon, my 350Watt power supply on this box can't handle the thing, the known problematic SiS 7001 USB Controller on this board is losing things, the new updated files have a problem with this scanner, you name it. Or, my power strip has every outlet being used. Perhaps the thing gets overloaded and turns off the scanner's outlet. To find out I'd need to at least use my super duper computer for a while to see if everything stays normal. I would suspect the power strip but that may be fine, since Windows is detecting a device there, where if there was no power then this scanner is not detected even if pluged in. Okay, so I decided it's not that. I highly suspect the SiS7001 USB Controller as the culprit. Plus, the fact that the board has only USB 1.0 ports, not 1.1. Hmmm, perhaps 1.0 just wasn't completely stable, eh?

Okay, I'm a gonna get to work now. If I fubar Windows completely with this I'm just going to give up. I'm already missing my speedy box! Hopefully I'll figure out the needed files for you so you can patch up 98SE2ME so it lets drivers like this modem's run properly. Don't know what's gonna happen though!

I'll post back whatever occurs to let you know.
Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#73
Eck

Eck

    Senior Member

  • Member
  • PipPipPipPip
  • 669 posts
  • Joined 17-February 05
Ha! (Thank you Chris Matthews for the Ha!) OMG it F'n works!

Okay. The only files that needed to be replaced by the older 98SE backed up files were the set with NETAPI, NETAPI32, NETDI, and NETOS dll's. The sets before that didn't work so I returned the Me files to the System folder.

So, whatever those 98SE versions do is not done properly on 98SE by the Me updated versions.

I did have to update the driver. For each set I updated the driver and at the end of the update it would say I needed to reboot. Then I would boot up to the same unstarted situation. However, the last time with this set of files, it did not ask to reboot. But I needed to so the driver would work. I was pleased to see the modem lights return. The exact message in the Device Manager properties tab for the unworking DCM-202 USB Modem was: "The NDIS.VXD, NTKERN.VXD device loader(s) for this device could not load the device driver. (Code 2) To fix this, click Update Driver to update the device driver."

What does this mean for 98SE2ME? Would not updating these files in 98SE2ME adversly effect anything else? I'm sure if the Me files effected my USB Cable Modem driver this way then other folks would run into the problem as well.

Now, if I could figure out why sometimes when clicking "Add" to add files to a multi-session cdr with Nero 6 Express turns the display off and I need to either ctrl-alt-delete 2x to reboot, or if that doesn't work then reset the tower. And although previously this had made Windows turn my scanner into an Unknown Device, the last time it did not lose a thing. And then Nero worked properly. I was adding the folders BKUP (with the 98SE versions of the dll files) and BKUPME (with the 98SE2ME versions). I wanted to make sure I had them on a cd just in case. (Although that wouldn't have helped in Command Prompt Only Mode, I would have been able to use my Ms-Dos Game Mode shortcut with the cd driver on it if Windows had some problem. I don't know, I thought it best to be prepared.)

Well, it was fun to discover that my HP Recovery Disc worked on my generic Asus SPAX-M motherboard with an HP bios that reads for a Pavilion 4440. My discs came with my first computer, a Pavilion 4430. Apparently the software for both models is the same. The 4440 simply came with a 333MHz K6-2 and 64MB SDRAM whereas my 4430 came with a 300MHz K6-2 and 32MB SDRAM. I'm using a 366 with 256MB Crucial SDRAM now, and a Jaton Video 118 G-Force2 MX400 32MB PCI. I also have a Lite-on DVD-ROM, CDRW Combo drive. PowerDVD 3.0 is the latest that will play DVD's semi-okay. Heh, it struggles to get the video to match up with the lips synch and never really gets it. This MB just can't cope. Everest puts the memory latency at over 700ms! Far worse than anything else on its chart.

I do uninstall nearly everything on the HP disc, but it was fun to see some of the old stuff. And I have a 98SE updates (the $20 thing) cd so that's how I make it 98SE. The HP disc comes with 98Gold. I now have my original computer and 2 Asus SPAX-M boards and also 2 366MHz AMD processors. I mean, the stuff was so cheap (except for the new memory) that I couldn't resist.

Now, I do have a question regarding the HD size. I noticed that the Bios reports my Western Digital 80GB HD as 65,535MB. However, using the updated FDISK Windows does detect the entire drive. To try to negate possible file corruption I only partitioned the whole thing the first time just to see what would happen. I now only have 64,400MB partitioned as a single Fat32 formatted partition. I leave the rest unpartitioned. I'm using the last Bios HP provided for these boards, the Puma 2 1.04 Bios of January 1999. I have a feeling, since it is a Pheonix Bios, it is using that Phoenix workaround instead of Int13. So that's why until the 98SE Service Pack was installed I was getting extremly sluggish file copying whether within the folders on the HD or from CD to HD. It would copy some files, then wait for the HD to catch up, then copy some more. I was like when I used to use GoBack. The system would wait until the HD stopped working before continuing. After the Service Pack and probably the HD over 32GB Microsoft Patch for Pheonix Bios's it probably has, this problem went away.

The question is, did I need to restrict the partition size? Or since Windows and even format at the end recognized the whole thing, is it safe to use the whole drive? The Bios reports the lower number but Windows will see the whole thing if I partition for it. Or did I do right by just setting the partition to a size within the Bios reported number?

And, of course, thanks so much for helping me to get the modem driver working. And I think this helps since you now know that that set of dll files stopped it from working.

Edited by Eck, 10 June 2005 - 06:34 PM.

Epox EP8KRAIPRO AthlonXP3200+ NVidia GeForce 6600GT AGP Audigy 2 ZS Crucial 2x1024MB 3200 RAM

#74
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
  • Joined 03-April 05
! NERO is CRAP! (I say as I'm burning a CD w/Nero rite now... :blushing: )
-Nero's had NASTY lockup bugs thru "Add Files" function for quite some time... I still use Nero 5.5..., thought the lockup bugs would be fixed in your newer Nero, but apparently not! Earlier 2nite, it locked up again when I tried to resize the "Add" window (forgot for a moment that it often locks when ya do that; arg!), and had to re-do a LOOOOONG list of files for a homemade win98se reinstall CD (also forgot to Save every now & then, just in case! arg again!)...
-A good FREE replacement is CDBurnerXP Pro (not just for winXP; good for all OS's); it has -plenty- of options, including burning to DVD...
>;]

#75
jack99

jack99

    Banned

  • Banned
  • Pip
  • 75 posts
  • Joined 18-April 05
:thumbup ived burn hundreds of cd using nero with no lockups and i like it now other cd burning programs the lite one work great as well.
Flash and animated signatures and avatars are not permitted.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users