• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
MDGx

98 FE + 98 SE + ME updates + patches + (hot)fixes

1,295 posts in this topic

@soporific: What version of msieftp.dll did you have?

the_guy

Can you do this step for me please? There is nothing wrong with the .sed file.

the_guy

0

Share this post


Link to post
Share on other sites
@soporific: What version of msieftp.dll did you have?

the_guy

Can you do this step for me please? There is nothing wrong with the .sed file.

the_guy

sorry i missed your message...

msieftp.png

Edited by soporific
0

Share this post


Link to post
Share on other sites

That's the problem, it's looking for version 5.50.4807.2300, which I believe now is only installed on Windows 2000.

When I redo the patch, I'll use browselc.dll for versioning, unless there is a way I can use only the highest allowable version for my SED file?

the_guy

0

Share this post


Link to post
Share on other sites
That's the problem, it's looking for version 5.50.4807.2300, which I believe now is only installed on Windows 2000.

When I redo the patch, I'll use browselc.dll for versioning, unless there is a way I can use only the highest allowable version for my SED file?

the_guy

Version 5.50.4807.2300 of MSIEFTP.DLL file CAN be installed under Win9x/ME/NT4 if you install IE 5.5 SP2 and install the Internet Explorer Browsing Enhancement feature. Look in the IE_EXTRA.CAB file of IE 5.5 SP2. Version 5.50.4807.2300 of the MSIEFTP.DLL file was left out of the IE_EXTRA.CAB file for IE 6.x for Win98/ME/NT4 but included in the IE 6.x setup files for Win2000.

soporific, install IE 5.5 SP2 and do a custom install. You need to install the Internet Explorer Browsing Enhancement feature of IE 5.5 SP2 which has version 5.50.4807.2300 of the MSIEFTP.DLL file.

If you do not want to install IE 5.5 SP2 (because if you already have IE 6.x installed) get the IE_EXTRA.CAB file of IE 5.5 SP2 here. Extract the MSIEFTP.DLL file from the IE_EXTRA.CAB file onto the \Windows\System\ folder and ovewrite the existing version.

Edited by erpdude8
0

Share this post


Link to post
Share on other sites
That's the problem, it's looking for version 5.50.4807.2300, which I believe now is only installed on Windows 2000.

Would there be any reason why I get the same message for the Unofficial Cumulative Update for Internet Explorer 6 sp1 (kb925454) AFTER it has been installed ??? (ie i install it, then try to run the hotfix again) -- the message is the same as in the screen-shot I posted a few posts above. Trying to run the OFFICIAL Cumulative Update for Internet Explorer 6 sp1 (kb916281) produces the same message box. This is problematic for anyone wanting to be in harmony with Windows Update. Due to the message box, the official cumulative update for IE6 sp1 (kb916281) cannot be installed and so no matter how many times you go thru the WU process, you cannot get rid of the warning that your PC needs kb916281. This didn't used to be the case.

0

Share this post


Link to post
Share on other sites
I just found the best site for support for all things Windows!! -- http://aumha.org/win4/index.htm ---MDGx i'm pretty sure you don't have this site in your list of Win98 sites
I have links to various pages located on the aumha.org server at these pages:

http://www.mdgx.com/98-3.htm

http://www.mdgx.com/98-4.htm

http://www.mdgx.com/98-5.htm

http://www.mdgx.com/bug.htm

http://www.mdgx.com/html.htm

http://www.mdgx.com/modem.htm

http://www.mdgx.com/reg.htm

http://www.mdgx.com/web.htm

http://www.mdgx.com/wme.htm

http://www.mdgx.com/xp2.htm

http://www.mdgx.com/newtip98.htm

I know about this excellent web site since 1998.

HTH

0

Share this post


Link to post
Share on other sites
PROBLEMCHYLD, please be more specific on what you are talking about
Hosts.exe It does not replace nor backup the original so it means it does not copy at all
Updated HOSTS installers, please check them out:

http://www.mdgx.com/html.htm

I've tested them both on my 98 SE + XP SP2 system, they work ok.

HTH

When i install on Win2000 it just hangs at cmd.exe screen

0

Share this post


Link to post
Share on other sites
PROBLEMCHYLD, please be more specific on what you are talking about
Hosts.exe It does not replace nor backup the original so it means it does not copy at all
Updated HOSTS installers, please check them out:

http://www.mdgx.com/html.htm

I've tested them both on my 98 SE + XP SP2 system, they work ok.

HTH

When i install on Win2000 it just hangs at cmd.exe screen
See this post for updated files:

http://www.msfn.org/board/index.php?s=&amp...st&p=622813

HTH

0

Share this post


Link to post
Share on other sites

MDGx

You state in your message:-

DX 9.0c here:

http://www.mdgx.com/dx.htm#DX9

February 2007 DX 9.0c installs ONLY on Windows XP/2003/Vista!

December 2006 DX 9.0c installs on 98/98 SP1/98 SE/ME:

I had no trouble installing February DX 9.0c on Windows 98SE.

Edited by pjmelect
0

Share this post


Link to post
Share on other sites

PROBLEMCHYLD:

PROBLEMCHYLD, please be more specific on what you are talking about
Hosts.exe It does not replace nor backup the original so it means it does not copy at all
Updated HOSTS installers, please check them out:

http://www.mdgx.com/html.htm

I've tested them both on my 98 SE + XP SP2 system, they work ok.

HTH

When i install on Win2000 it just hangs at cmd.exe screen
Update #2 [released much later tonite]:

I've modified [again, 2nd time] the installers [built using MakeSFX.exe (free GPL): http://www.disoriented.com/FreeExtractor/] to detect the OS from within the BATch instead of the INF, and should work ok now, no matter which Win32 OS you have [9x or NTx].

Please try these files again at your convenience:

http://www.mdgx.com/files/HOSTS0.EXE

http://www.mdgx.com/files/HOSTS127.EXE

Tested with 98 SE + XP SP2.

HTH

0

Share this post


Link to post
Share on other sites
MDGx

You state in your message:-

DX 9.0c here:

http://www.mdgx.com/dx.htm#DX9

February 2007 DX 9.0c installs ONLY on Windows XP/2003/Vista!

December 2006 DX 9.0c installs on 98/98 SP1/98 SE/ME:

I had no trouble installing February DX 9.0c on Windows 98SE.

Of course you haven't.

But you only installed the D3DX9_xx.DLL [xx = 2 digit numbers from 24 up to 31] files, which do not install if you don't have DX 9.0c pre-installed.

Have you noticed that your Windows OS did not reboot after install completed? That's because DX core APIs did not install at all.

So you only installed the useless MDX (Managed DirectX) files, which do not have any function, unless you use MDX to build + distribute DX applications/games.

The actual DX 9.0c core APIs for Windows 98/98 SE/ME do not install, because they are not included in the Feb 2007 release:

http://www.microsoft.com/downloads/details...cd-464ef59da050

They should be in the BDA.CAB + DIRECTX.CAB files, which are missing from Feb 2007 release.

Dec 2006 is the last DX release that includes and installs DX core APIs on Windows 98/98 SE/ME OSes:

http://www.microsoft.com/downloads/details...78-033D9E6C626B

Managed DirectX [MDX] info @ MSDN:

http://msdn.microsoft.com/theshow/episode....37/manifest.xml

MDX requires NFR 1.1 or newer already installed:

http://www.mdgx.com/add.htm#NFR

FYI:

Try this:

install DX CPL tools:

http://www.mdgx.com/dx.htm#SDK

and then open Control Panel -> DirectX -> click the Managed tab. Do you see anything inside the "DirectX for Managed Code" box? Don't worry if you don't, you don't need MDX. ;)

HTH

0

Share this post


Link to post
Share on other sites

Off-topic:

MDGx, please note that the direct link to DirectX Eradicator (DXE) v2.0 on your page linked above is no longer working - it leads to a 404 (page not found). Apparently, the home page is also gone. :(

Edited by Drugwash
0

Share this post


Link to post
Share on other sites

Where can I find ADVPACK.DLL 4.72.3612.1700 in original italian language, without resource hacking?

THX.

PS: It's strictly necessary in NUSB 2.4 or can I put a recent version as 6.0.2800.1106?

Edited by Max_04
0

Share this post


Link to post
Share on other sites
Where can I find ADVPACK.DLL 4.72.3612.1700 in original italian language, without resource hacking?

THX.

PS: It's strictly necessary in NUSB 2.4 or can I put a recent version as 6.0.2800.1106?

Found, thx... :huh:

0

Share this post


Link to post
Share on other sites

@ MDGx:

Last Encryption Updates for Win98/ME in italian

http://www.divshare.com/download/113750-362

In Crypt 98 all files are in italian except 128SC.DLL, ENHSIG.DLL, MSASN1.DLL, RSAENH.DLL..

In Crypt ME all files are in italian except 128SC.DLL, ADVPACK.DLL 5.0.2013.1301 (where?), CRYPTUI.DLL, MSCAT32.DLL, MSSIP32.DLL, SOFTPUB.DLL, WINTRUST.DLL (5.131.2133.2), XENROLL.DLL (5.131.3659.0).

Edited by Max_04
0

Share this post


Link to post
Share on other sites
@ MDGx:

Last Encryption Updates for Win98/ME in italian

http://www.divshare.com/download/113750-362

In Crypt 98 all files are in italian except 128SC.DLL, ENHSIG.DLL, MSASN1.DLL, RSAENH.DLL..

In Crypt ME all files are in italian except 128SC.DLL, ADVPACK.DLL 5.0.2013.1301 (where?), CRYPTUI.DLL, MSCAT32.DLL, MSSIP32.DLL, SOFTPUB.DLL, WINTRUST.DLL (5.131.2133.2), XENROLL.DLL (5.131.3659.0).

Posted here:

http://www.mdgx.com/ietoy.htm#HEP

* Unofficial Windows ME CRYPT32.DLL 5.131.2133.6, CRYPTDLG.DLL 5.00.1558.6072, CRYPTUI.DLL 5.131.2133.2, ENHSIG.DLL 5.00.1877.8, MSASN1.DLL 5.00.2195.6905, MSCAT32.DLL 5.131.2133.2, MSSIP32.DLL 5.131.2133.2, RSAENH.DLL 5.00.2133.2, SCHANNEL.DLL 5.131.2133.2, SOFTPUB.DLL 5.131.2133.2, WINTRUST.DLL 5.131.2133.2 + XENROLL.DLL 5.131.3659.0 128-bit SSL Encryption Security Vulnerability Fixes:

http://www.microsoft.com/technet/security/...n/ms04-011.mspx

Direct download [724 KB, Italian]:

http://www.mdgx.com/files/ITCRPTME.EXE

* Unofficial Windows 95/98 CRYPT32.DLL 5.131.1880.14, CRYPTDLG.DLL 5.0.1558.6072, CRYPTUI.DLL 5.131.1878.14, ENHSIG.DLL 5.0.1877.8, MSASN1.DLL 5.0.2195.6905, MSCAT32.DLL 5.131.1880.14, MSSIP32.DLL 5.131.1878.13, RSAENH.DLL 5.0.1877.8, SCHANNEL.DLL 5.00.1880.14, SOFTPUB.DLL 5.131.1880.14, WINTRUST.DLL 5.131.1880.14 + XENROLL.DLL 5.131.3659.0 128-bit SSL Encryption Security Vulnerability Fixes:

http://www.microsoft.com/technet/security/...n/ms04-011.mspx

Direct download [670 KB, Italian]:

http://www.mdgx.com/files/ITCRPT9X.EXE

Requires MS IE 5.xx or newer already installed:

http://www.mdgx.com/toy.htm#IEX

HTH

0

Share this post


Link to post
Share on other sites

Max_04:

Update below linked here:

http://www.mdgx.com/web.htm#9SU

* Microsoft Windows 98/98 SE System Date Error TIMEDATE.CPL (4.10.2006 for Win98/98 SP1 + 4.10.2225 for Win98 SE) Fix:

http://support.microsoft.com/?id=237493

Direct download [153 KB, Italian]:

http://www.mdgx.com/files/IT237493.EXE

Updates below linked here:

http://www.mdgx.com/web.htm#SP1

* Microsoft Windows 98 SP1 Year 2000 (Y2K) Update #1:

http://www.microsoft.com/windows98/downloa...ecommended/y2k/

Direct download [1.23 MB, Italian]:

http://www.mdgx.com/files/ITY2K_1.EXE

* Microsoft Windows 98 SP1 Year 2000 (Y2K) Update #2:

http://www.microsoft.com/windows98/downloa...commended/y2k2/

Direct download [636 KB, Italian]:

http://www.mdgx.com/files/ITY2K_2.EXE

0

Share this post


Link to post
Share on other sites

@ MDGx:

1) Last Italian Stable SHELLME by anonymous author:

http://uploaded.to/?id=232vf8 (installer .exe)

2) Unofficial Windows 98/98 SE KRNL386.EXE 4.10.1999 Fix ITA:

http://uploaded.to/?id=z9vyfs (installer .exe)

3) Unofficial Windows ME KRNL386.EXE 4.10.1999 Fix ITA:

http://uploaded.to/?id=8emwrv (installer .exe)

4) Unofficial Internet Explorer 5.5 SP2/6.0/6.0 SP1 for Windows 98/98 SP1/98 SE/ME Vector Markup Language (VML) VGX.DLL Security Vulnerability Fix ITA

Italian changelog:

Corrected all folders names in english to italian.

http://uploaded.to/?id=7v30id (archive rar to compile in .exe)

@MDGx 2:

Are you sure that Microsoft Windows 98 SP1 Year 2000 (Y2K) Updates are only for win 98 sp1 and not also for win 98 se?

Edited by Max_04
0

Share this post


Link to post
Share on other sites
@ MDGx:

1) Last Italian Stable SHELLME by anonymous author:

http://uploaded.to/?id=232vf8 (installer .exe)

2) Unofficial Windows 98/98 SE KRNL386.EXE 4.10.1999 Fix ITA:

http://uploaded.to/?id=z9vyfs (installer .exe)

3) Unofficial Windows ME KRNL386.EXE 4.10.1999 Fix ITA:

http://uploaded.to/?id=8emwrv (installer .exe)

4) Unofficial Internet Explorer 5.5 SP2/6.0/6.0 SP1 for Windows 98/98 SP1/98 SE/ME Vector Markup Language (VML) VGX.DLL Security Vulnerability Fix ITA

Italian changelog:

Corrected all folders names in english to italian.

http://uploaded.to/?id=7v30id (archive rar to compile in .exe)

@MDGx 2:

Are you sure that Microsoft Windows 98 SP1 Year 2000 (Y2K) Updates are only for win 98 sp1 and not also for win 98 se?

I'll upload the files you posted soon.

I'm sure, Win98 SE already contains those Y2K updates.

BTW:

I've looked inside SHELLME.EXE ITA you made:

You need to translate this INF text string into Italian:

Remove Unofficial Explorer Lockups SHELL32.DLL Fix

HTH

0

Share this post


Link to post
Share on other sites
Are you sure that Microsoft Windows 98 SP1 Year 2000 (Y2K) Updates are only for win 98 sp1 and not also for win 98 se?

I, too, am ABSOLUTELY 100% sure beyond ANY reasonable doubt that the Win98 Y2K updates are for Win98 FE only and NOT for Win98 SE. Look at the version number of the files included in the two Win98 year 2000 patches, Max_04. They are less than 4.10.2222 and thus, Win98 SE already has ALL Y2K fixes.

0

Share this post


Link to post
Share on other sites

MDGx, see if you have time to create these new unofficial security fixes:

MS07-008 (HHTCRL.OCX) < include in revised Unofficial HTML Help 1.4 [HHUPD.EXE] update

MS07-016 (IE6 SP1 KB928090) - the IE7 edition of KB928090 replaces IE7 KB928089 patch

MS07-013 (RICHED20.DLL - use the Office XP edition) < include in revised RICHED9X.EXE and RICHEDNT.EXE patches

I'll be creating unofficial MS07-012 MFC patch ONLY for WinNT4 since it only updates MFC40U.DLL and MFC42U.DLL files.

Edited by erpdude8
0

Share this post


Link to post
Share on other sites

I hope you're aware of the issues mentioned in post #36 and #39 of this thread, regarding riched20.dll newer than 5.30.x (sorry, direct link to specific post doesn't seem to work :( ).

0

Share this post


Link to post
Share on other sites

@All: I am working on the unofficial MDAC updates for Windows 95/98/ME and will also include compatibility for XP SP1 with the MDAC 2.7 SP1 and 2.8 RTM updates only.

I've also noticed that the XP and 2003 versions of MS07-012 also include mfc42.dll and msvcp60.dll. I might make an update for 9x/ME in the coming days for that bug. Also, it includes a unicode version of atl.dll, so maybe if you want to incorporate that into your fix erpdude?

the_guy

EDIT: the version of mfc42.dll and msvcp60.dll are old versions, so I won't be making an update for those files.

Edited by the_guy
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.