Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

98 FE + 98 SE + ME updates + patches + (hot)fixes

* * * * * 1 votes

  • Please log in to reply
1294 replies to this topic

#76
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
-MDGx: re: your vb6sp6 update link page: typo in version # of MSVCP60.DLL:
6.00.9782.0 should be 6.00.8972.0 (as shown in both "version places" in the newest file in vb6sp6)...


How to remove advertisement from MSFN

#77
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
-MDGx: re: vb6sp6:
Several of these new files don't already exist at all on my system, so does that mean we need to regsvr em? (just to be safe, I WAS gonna register em all, but it'd be nice to know if it's necessary or not, and if so, do ya need to include that step on your links page? I'll hold off 'til u say yea or nay...)

:edit: -? and a couple of these files have exactly the same version #'s in all places, yet different dates and slightly (1k) different sizes... ?

-thx again,
your humble and unworthy follower PsycoUnc >;]

Edited by PsycoUnc, 22 July 2005 - 02:40 AM.


#78
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts

Several of these new files don't already exist at all on my system, so does that mean we need to regsvr em?


To my (limited) knowledge, most of MS runtimes are self registering. They register themselves as soon as they are called upon by an app. For those who don't self register, you'll usually get a specific error message aying the app cannot find such or such file. So far I have noticed that problem with one single MS runtime file : MSSTDFM.DLL.

Here are a few handy context menu entries that I am using to register/unregister COM components :

REGEDIT4

[HKEY_CLASSES_ROOT\dllfile\shell\Register]

[HKEY_CLASSES_ROOT\dllfile\shell\Register\command]
@ = "regsvr32.exe \"%L\""

[HKEY_CLASSES_ROOT\dllfile\shell\UnRegister]

[HKEY_CLASSES_ROOT\dllfile\shell\UnRegister\command]
@ = "regsvr32.exe /u \"%L\""

REGEDIT4

[HKEY_CLASSES_ROOT\ocxfile\shell\Register]

[HKEY_CLASSES_ROOT\ocxfile\shell\Register\command]
@ = "regsvr32.exe \"%L\""

[HKEY_CLASSES_ROOT\ocxfile\shell\UnRegister]

[HKEY_CLASSES_ROOT\ocxfile\shell\UnRegister\command]
@ = "regsvr32.exe /u \"%L\""

REGEDIT4

[HKEY_CLASSES_ROOT\.ax]
@ = "axfile"

[HKEY_CLASSES_ROOT\axfile]
@ = "DirectShow Filter"

[HKEY_CLASSES_ROOT\axfile\DefaultIcon]
@ = "C:\\Windows\\System\\Ax.ico"

[HKEY_CLASSES_ROOT\axfile\shell\Register]

[HKEY_CLASSES_ROOT\axfile\shell\Register\command]
@ = "regsvr32.exe \"%L\""

[HKEY_CLASSES_ROOT\axfile\shell\UnRegister]

[HKEY_CLASSES_ROOT\axfile\shell\UnRegister\command]
@ = "regsvr32.exe /u \"%L\""
An icon for Ax Files I have made. To be put in the System dir (or elsewhere but then the above registry file must be adapted to its location).
Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#79
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
-MDGx: ...siiiigh... -after running your unofficial oleup and the vb6sp6 stuff, my scripting was screwed! -couldn't get any scripts to run from a file (pcpitstop autofixes, downloaded to HD), or on a website (winupdate, pcpitstop tests)... tried reinstalling wscript5.6, vbrun60sp5, xml, etc. and nothing worked (also tried reducing *all* security (enabling everything, everywhere), logging-off/on windows, etc)... also tried replacing the vb6sp6 files back to originals (which I backed up), unregistering/registering, etc... no luck...

-the thing that finally worked, was manually copying all vbrun60sp5 dll's to win\system folder, overwriting... now scripting works again... ???

? any ideas?

(I'll further test, if this disgusted feeling wears off, one step at a time, but I've already spent the last 3 hrs stuck on this...)

(ps: I manually registered the 6 vb6sp6 files which weren't already existing in \system... then unregistered & removed em during troubleshooting... no effect)

Edited by PsycoUnc, 22 July 2005 - 05:34 PM.


#80
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
---EDIT! DOH! -I spoke too soon (below)! -it IS your OLEUP.EXE, screwin the scripts! Everything was fine, after doing the vb6sp6 files again, then I ran your OLEUP.EXE (since it installs newer builds than vb6sp6), and BOOM! there go the script errors again! -Probably had nothing to do with those 2 exe's (see below) inside vb6sp6, after all...
------------------------

[[[-re: above post: -never mind, I figured it out:

-while unzipping vb6sp6, I ran across 2 .exe's which looked promising: vcredist.exe and vbrun60.exe... I took a peek inside each, they weren't big, looked harmless, like just more auto-update stuff, similar files to what we were updating anyway, so I executed em... -looks like they weren't harmless after all....]]]

[ps: any news about 98se2xp?]

Edited by PsycoUnc, 23 July 2005 - 01:50 AM.


#81
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
(-while we're already on a bug-hunt, the 98se2me winoldap-at-reboot bug came back, as soon as ya changed your code back, a little while ago, but ONLY if option #3 isn't already installed... )

#82
randiroo76073

randiroo76073

    Member

  • Member
  • PipPip
  • 264 posts
PsycoUnc, I just got all of those files dld[dial-up] was gonnna install today, will save vb6 till last and watch this post. Thnx for headsup on possible prob.

#83
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
-turns out the vb6sp6 files were no prob, it's the Unofficial OLEUP.EXE file which MDGx offers to use after vb6sp6...
-I tried the OLEUP.EXE on another install of w98se, without the vb6sp6 files, and the scripting (activeX, too) was shot, just the same... u can go ahead w/vb6sp6 files (16 of em, unzipped from all those cabs inside), but let me know if u have any probs w/his OLEUP.EXE update... (try going to winupdate, after his OLEUP.EXE update, see if it still works... or any site with activeX, like PcPitstop.com...)
>;]

(ps: ouch, dialup downloading that 60mb+ vb6sp6 file! And we only need 5mb (16 files) out of it... (1.5 mb zipped)... lol... -hey, if you'd like to save a lot of time, avoid all the unzipping and comparing version numbers, I can email ya the 1.5mb zipped 16 files... shouldn't be any license probs, it's freely available... PM me... :thumbup )

Edited by PsycoUnc, 23 July 2005 - 06:35 AM.


#84
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts
Problems confirmed here with Oleaut update. Some of my BHOs (Net Transport and Flash Saving Plugin) weren't working anymore properly from IE. Downgrading Oleaut solved the problem.
Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#85
charles__

charles__

    Junior

  • Member
  • Pip
  • 87 posts
Same here even lost my firewall,antivirus,windows update,shockwave and other programs.

#86
PsycoUnc

PsycoUnc

    Member

  • Member
  • PipPip
  • 236 posts
-at least it's easy to fix: just unzip a vbrun60sp5.exe (from Micro$hit; google it) (7-zip will unzip it, and 7-zip is free), shutdown to ms-dos, and copy *.dll from it to \windows\system, overwriting all... (ya have to do it manually, for some reason it won't install right automatically)...
>;]
(edit: I suppose ya could also use vbrun60sp6.exe, newer, just saw it's available at M$, but I haven't tried it yet; I unzipped the sp6 version, and it fixed the prob...)

Edited by PsycoUnc, 23 July 2005 - 09:16 AM.


#87
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • OS:98SE
  • Country: Country Flag

Problems confirmed here with Oleaut update. Some of my BHOs (Net Transport and Flash Saving Plugin) weren't working anymore properly from IE. Downgrading Oleaut solved the problem.

<{POST_SNAPBACK}>


So what version is OK and what not? Windows 2000 SP4 version (4522 - included in SE SP 2.01) is OK and Windows 2000 post SP4 KB886765 hotfix (4526) not? Od do you use IE6SP1 version (4518)?

Is there any easy way how to reproduce the wrong behavior?

For example links to your plugins?

Petr

#88
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts
Hi Petr,

That's the plugins :

http://www.browserto...ugin/index.html

http://www.321downlo.....Net Transport

I have an older version of the Flash plugin than the one on the above page.

My setup is WinME IE5.5 SP2 + latest security updates.

What version is OK ? I do not know as I have downgraded to 4275. For me 4275 is OK. I am not too sure about the highest version number of the Oleaut I had installed without having problems. I think it was 4522. I'll be upgrading to those again.

As well I had other problems with 4526, similar to those PsychoUnc has, with ActiveXs but I thought at first it was because I changed my default security settings in IE. Msdxm would not want to load to play video streams in IE for example.

And then I did downgrade the files from DOS and all problems were gone.

PS : Have you installed 4526 yourself ?

Edited by eidenk, 23 July 2005 - 11:27 AM.

Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#89
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts

(edit: I suppose ya could also use vbrun60sp6.exe, newer, just saw it's available at M$, but I haven't tried it yet; I unzipped the sp6 version, and it fixed the prob...)

I think VB6SP5, VB5SP6, VC6SP5 and VC6SP6 all contain the same version of the oleaut runtimes : 2.40.4275

(ya have to do it manually, for some reason it won't install right automatically)...


Because of the file version that is inferior to the ones already on the machine. The installer checks this and doesn't downgrade the files.
Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#90
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts
There are GUI tools that allow to downgrade locked files from Windows for those who don't like DOS or write by hand a wininit.ini file.

http://noeld.com/dl....h=copylock.zip
http://www.jkh.no/jk...Installfile.zip
Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#91
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag
Hi Guys,

No need to panic... ;)
I was testing [same as you were] the new OLE 2.40.4526 files, and found out that VBScript + DX Media 6.0 TransAnim functions stopped working in MS IE 6.0 SP1. :(
But on the other hand, all OLE core functions I've tested worked ok so far.
So I have updated OLEUP.EXE [446 KB]:
http://www.mdgx.com/files/OLEUP.EXE
Posted here:
http://www.msfn.org/...showtopic=46581
and here:
http://www.mdgx.com/add.htm#OLE
to include older OLEAUT32.DLL 2.40.4522 from Win2000 SP4, which fixed all problems.
_________________________________

PsycoUnc:
To test to see which DLL / OCX files in %windir%\system need to be registered with regsvr32.exe , u can create a DOS batch file and call it RS.BAT [example]:
@echo off
%windir%\system\regsvr32 %windir%\system\%1
exit
and then run something like this [u need to type only the full name + extension of the file u want to regsvr]:

RS OLEAUT32.DLL

To manually test if a DLL or OCX accepts DLLRegisterServer or DLLInstall functions, just run [example using a DLL that does not contain these functions]:

%windir%\system\regsvr32 %windir%\system\asycfilt.dll

and then:

%windir%\system\regsvr32 /i %windir%\system\asycfilt.dll

As u can see, asycfilt.dll does not accept DLLRegisterServer nor DLLInstall functions, therefore does not need to be registered using regsvr32.

More info:
http://www.mdgx.com/newtip13.htm#REGAX

Hope this helps.

Edited by MDGx, 29 July 2005 - 10:52 PM.


#92
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • OS:98SE
  • Country: Country Flag

PS : Have you installed 4526 yourself ?


I just tried to use Net Transport from http://www.axitech.h...Setup_multi.exe with IE 6.0 SP1 and latest updates and SE SP 2.0.1 and I see no difference in behavior with 4522 and 4526 OLE automation files - if I click downloadable link, Net Transport pops up and starts downloading the file. Where should be the problem?

Flash saving I'm evaluating now - but I'm receiveing error message that FLASHBUTTON.DLL/210 line 7 generated library is not registered error. I have to check what dies it mean.

I did simple comparison of internal structure of 4522 and 4526 files - asycfilt.dll, olepro32.dll, stdole2.tlb seems to be almost exactly the same, oleaut32.dll has one small difference - one import was added:
Imp Addr Hint Import Name from ADVAPI32.dll - Not Bound
-------- ---- ---------------------------------------------------------------
00002004 12F RegOpenKeyExW

but this should be no problem.

It would be interesting to see if the same problems are on Windows 2000 too.

Petr

#93
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • OS:98SE
  • Country: Country Flag

I was testing [same as you were] the new OLE 2.40.4526 files, and found out that VBScript + DX Media 6.0 TransAnim functions stopped working in MS IE 6.0 SP1. :(


Hi MDGx, could you give me some steps how to verify this non-functionality on my system too?

Petr

#94
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • OS:98SE
  • Country: Country Flag
BTW, MS in Q321915 recommends OLE version 4515 in some cases

http://download.micr...us/mcrepair.exe


Petr

#95
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts

Flash saving I'm evaluating now - but I'm receiveing error message that FLASHBUTTON.DLL/210 line 7 generated library is not registered error. I have to check what dies it mean.

Same error as I had.

if I click downloadable link, Net Transport pops up and starts downloading the file. Where should be the problem?


It was simply not poping up anymore to start the download. You have maybe installed a different version of Net Transport (I use 1.87 which is the last freeware version) or it might be due the fact that IE5.5 and 6 files are vastly different.

I have now installed the new downgraded upgrade and have no problems with any of the above. I just have to check that msdxm wants to display streaming video.

I was testing [same as you were]the new OLE 2.40.4526 files, and found out that VBScript + DX Media 6.0 TransAnim functions stopped working in MS IE 6.0 SP1.

Hi MDGx, could you give me some steps how to verify this non-functionality on my system too?


You've asked before me.
Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#96
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • OS:98SE
  • Country: Country Flag
I have tried OLE 4526 on my test system (W98 FE + IE5.01SP3) and it stopped displaying the Flash content - there is probably really something rotten in this hotfix.
http://support.micro...om/?kbid=886765
It claims to repair a memory leak only but it seems there are much more changes.

Petr

Edited by Petr, 23 July 2005 - 01:42 PM.


#97
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

Hi MDGx, could you give me some steps how to verify this non-functionality on my system too?

Petr

I saved a couple of DirectX Transform demos on my HD, I can send them in email if u wish.
But MSDN has a nice one here:
http://msdn.microsof...ransformwizard/
Another nice 1 here [not by MS]:
http://www.erwin-020...d.com/awal.html
Make sure u use MS IE 5.5 SP2 or 6.0 SP1 to view those web pages + demos.

Al 9x/ME OSes require DX Media 6 APIs already installed for this to work:
http://www.mdgx.com/dx.htm#DXM
Older versions of some of these files are installed by MS IE 5.5/5.5 SP1/5.5 SP2/6.0/6.0 SP1. Newest versions are installed only by DXM9X.EXE [9x/ME] + DXMNT.EXE [NT4/2000/XP/2003].
DXM9X contains files from WinME setup CD [also installed by 98SE2ME] + DXM 6 [not available anymore].
DXMNT contains newest files from XP SP2.
2003 SP1 also installs DXMNT files.

If using OLEAUT32.DLL 2.40.4526 [from 2000 SP4 UR1] these demos do not work.
But they work ok with OLEAUT32.DLL 2.40.4522 [from 2000 SP4] and other older versions I have tried.

Hope this helps.

#98
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts

Another nice 1 here [not by MS]:
http://www.erwin-020...d.com/awal.html

Not so nice as the page apparently dropped a Trojan that has been intecepted by Antivir. After which IE crashed in kernel32.dll.

PS : I can't reproduce that.

Edited by eidenk, 23 July 2005 - 02:10 PM.

Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#99
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

I did simple comparison of internal structure of 4522 and 4526 files - asycfilt.dll, olepro32.dll, stdole2.tlb seems to be almost exactly the same, oleaut32.dll has one small difference - one import was added:
Imp Addr Hint Import Name from ADVAPI32.dll - Not Bound
-------- ---- ---------------------------------------------------------------
00002004  12F RegOpenKeyExW

but this should be no problem.

It would be interesting to see if the same problems are on Windows 2000 too.

Petr

Same here, haven't seen any errors with offline apps.
The only time I noticed errors was while running VBScripts + DX Transforms from within MS IE 6.0 SP1.
DX Transform code is accessed thru VBScript code implemented in a web page.

I have looked at OLEAUT32.DLL 2.40.4526 in Dependency Walker:
http://www.dependencywalker.com/
and didn't notice anything "special" compared to OLEAUT32.DLL 2.40.4522 .

Edited by MDGx, 23 July 2005 - 02:04 PM.


#100
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • OS:none specified
  • Country: Country Flag

Another nice 1 here [not by MS]:
http://www.erwin-020...d.com/awal.html

Not so nice as the page apparently dropped a Trojan that has been intecepted by Antivir. After which IE crashed in kernel32.dll.

Regarding the fact that this web page is on Tripod servers, it is well known they use JavaScript/VBScript, ActiveX, IFRAME tags and other BHO-inducing spyware targeted to MS IE users, to "push" their ads/etc.
I don't have that problem, because I'm using:
1. A huge HOSTS file which disables [among other 117,000 adware/spyware servers] Tripod servers.
U can get it here:
http://www.mdgx.com/modem.htm#HOS
2. Firefox 1.0.6:
http://www.mdgx.com/toy.htm#MOZ
which does not use ActiveX, BHOs or VBScript.

Hope this helps.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN