Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
Marthax

Registry entry problem

5 posts in this topic

Hi there!

I'm getting an error when I try to compile this code in Xplode:

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
     "DAEMON Tools-1033"=-
           "DiskeeperSystray"=-
           "NeroFilterCheck"=-
           "NVMixerTray"=-
           "NvMEdiaCenter"=-
           "nwiz"=-
           "NvCplDaemon"=-
           "CTHelper"=-
           "iTunesHelper"=-
           "QuickTime Task"=-
           "NvMcTray"=-
           "NvCpl"=-

     [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx]
 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx]

     [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\NewStartPanel]
     "{20D04FE0-3AEA-1069-A2D8-08002B30309D}"=dword:00000000
     "{450D8FBA-AD25-11D0-98A8-0800361B1103}"=dword:00000000
     "{208D2C60-3AEA-1069-A2D7-08002B30309D}"=dword:00000000

     [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
           "NoRecentDocsMenu"=dword:00000001
 "NoSMBalloonTip"=dword:00000000

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
 "StartMenuLogoff"=dword:00000000

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
 "StartMenuLogoff"=dword:00000000

 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
 "LogonType"=dword:00000001

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
 "NoStartMenuMFUprogramsList"=dword:00000001
 "NoDriveTypeAutoRun"=dword:000000FF

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
 "StartMenuInit"=dword:00000002
 "Start_ShowMyPics"=dword:00000001
 "Start_ShowMyMusic"=dword:00000001
 "Start_ShowMyDocs"=dword:00000001

 [HKEY_CURRENT_USER\Control Panel\Accessibility\StickyKeys]
 "Flags"="506"

 [-HKCR\Directory\shellex\ContextMenuHandlers\WinRAR]
 [HKCR\Directory\shellex\ContextMenuHandlers\WinRAR]

 [-HKCR\*\shellex\ContextMenuHandlers\WinRAR]
 [HKCR\*\shellex\ContextMenuHandlers\WinRAR]

 [-HKCR\Folder\shellex\ContextMenuHandlers\WinRAR]
 [HKCR\Folder\shellex\ContextMenuHandlers\WinRAR]


 SET KEY=HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx
 REG ADD %KEY%\002 /V 1 /D "\"%SHORTPF%\Media Player Classic\mplayerc.exe\" /regvid" /f

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
 "Hidden"=dword:00000001

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
 "ShellState"=hex& #58;24,00,00,00,37,88,00,00,00,00,00,00,00,00,00,00,00,00,00,00,\01,00,00,00,0d,00,00,00,00,00,00,00,01,00,00,00


 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
 "NtfsDisable8dot3NameCreation"=dword:00000001
 "NtfsDisableLastAccessUpdate"=dword:00000001
 "Win95TruncatedExtensions"=dword:00000001
 "Win31FileSystem"=dword:00000000

 [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
 "NoCDBurning"=dword:00000001

 [-HKEY_CLASSES_ROOT\.zip\CompressedFolder]
 [-HKEY_CLASSES_ROOT\CLSID\{E88DCCE0-B7B3-11d1-A9F0-00AA0060FA31}]
 [-HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CompressedFolder]

 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\NetCache]
 "Enabled"=dword:00000000
 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\NetCache]
 "SyncAtLogon"=dword:00000000
 "SyncAtLogoff"=dword:00000000
 "NoReminders"=dword:00000001

 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\stisvc]
 "Start"=dword:00000004
 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
 "NoSaveSettings"=dword:00000000
 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
 "NoNetCrawling"=dword:00000001
 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer]
 "NoRemoteRecursiveEvents"=dword:00000001

 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\IntelliForms]
 "AskUser"=dword:00000000

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
 "PrivDiscUiShown"=dword:00000001

 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
 "Search Page"="http://www.google.com"
 "Search Bar"="http://www.google.com/ie"
 [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchURL]
 @="http://www.google.com/search?q=%s"
 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Search]
 "SearchAssistant"="http://www.google.com/ie"

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Url History]
 "DaysToKeep"=dword:00000002

 [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
 "EnableQuickReboot"="1"

 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters]
 "EnablePrefetcher"=dword:00000003

 [-HKEY_CLASSES_ROOT\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}]
 [-HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shellex\PropertyHandler]
 [-HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32]

 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\ServiceProvider]
 "DnsPriority"=dword:00000001
 "HostsPriority"=dword:00000001
 "LocalPriority"=dword:00000001
 "NetbtPriority"=dword:00000001

 [HKEY_CURRENT_USER\Software\Ahead\Nero - Burning Rom\Recorder]
 "ShowSingleRecorderSpeed"=dword:00000001

 [HKEY_CURRENT_USER\Control Panel\Sound]
 "beep"="no"

 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer]
 "EnableAutoTray"=dword:00000000

 [-HKEY_CLASSES_ROOT\.bfc\ShellNew]
 [-HKEY_CLASSES_ROOT\.rtf\ShellNew]
 [-HKEY_CLASSES_ROOT\.bmp\ShellNew]
 [-HKEY_CLASSES_ROOT\.wav\ShellNew]
 [-HKEY_CLASSES_ROOT\.zip\CompressedFolder\ShellNew]

I know that Xplode reads registry entries just as a *.reg file does which means that if xplode has problems reading this, then so will a *.reg file. The problem is, I can't seem to find what the problem is. Can anyone help me out?

Thanks in advance!

Marthax

0

Share this post


Link to post
Share on other sites

what's the error?

0

Share this post


Link to post
Share on other sites

oh, I must have forgot to type that down. My bad. It says only says "offending tag <registry>".

"bad entity reference in text section".

0

Share this post


Link to post
Share on other sites

Check that there aren't any ampersand's (&) in the code. They are used differently in XML, and if there are, you'll need to replace them with & .

0

Share this post


Link to post
Share on other sites

That was the problem. I replaced an & with & and it works now. Thanks Wraith :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.