marek722

slipstream Office 2003 SP1 & rebuild CD

107 posts in this topic

This is just bizarre...I've done exactly everything as per the guide (several times) and I still don't get even an option to cache the installer files. The check box in the last window of the installation page doesn't exist, just as if I had performed an administrative install (which I haven't).

I've used tCP's batch file to perform the post-cabbing clean up. When all is said and done, the final directory for CD1 is 399MB and the install works as normal (installs without errors) except for that annoying little non-existant check box.

0

Share this post


Link to post
Share on other sites

Zxian do you have enough HDD space on virtual pc ?

I ran my tests on virtual pc initially and there was no cache folder

and no option to enable/delete cache as well. As I had setup minimum

required space to run test on virtual pc.

I installed on "real" system and everything went ok

with msocahce folder created with properly cached files/cabinets.

(Using enhanced setup.exe with enforcecahe=true command passed)

Here are my final sizes for all to reference using sp2.

There is no need for a separate guide for sp2, just follow the initial guide and

it works sp2 as well.

frontpage=189 MB (198,405,064 bytes) 94 files,14 folders

office11=400 MB (420,474,476 bytes) 151 files,19 folders

(this has additional remove hidden data tool, office sounds, outlook personal folder backup

extras included for each extra theres 1 extra folder and 3 files, + the original msi's

which comes to 13 extra files and 3 extra folders)

onenote=67.8 MB (71,124,549 bytes) 53 files,12 folders

project=119 MB (125,037,522 bytes) 107 files,18 folders

visio=219 MB (230,668,792 bytes) 126 files,14 folders.

0

Share this post


Link to post
Share on other sites

Yup... the VM has plenty of free space on the hard drive (3.5GB should be enough.. right? ;))

I'll give it a shot on a real computer tonight though. We'll see if that works. *crosses fingers*

0

Share this post


Link to post
Share on other sites
post #18, FaceMouth:

"Also, I am not able to make an admin install point with this version, and I think I will have to manually install my key, not sure if it is going to work in the mst file."

Strange, tested it and worked fine with 5in1sp1 (no other hotfixes). Looked like the original. Seems that more testing is needed and a new version including a framework for the main routines to make all easier ...

I just realized you left this post or I would have replied earlier.

My version is not the full package 5 disk. It's just a single trial disk I bought through school. The 5 disk set is the only one you are able to make an admin install point with (I know there is another thread relating to how to change the install options).

Anyway, I haven't really been playing with this much lately. I think I might work on my unattend disk more this week. School has been busy, but next week looks like a light work load.

I do have the 5 disk set, I really don't need all these programs though, and the academic version was more of a challenge. There are other things I want to work on also, so I am just going to add some of the programs from 5 disk set and move on to other stuff.

I know this was a long winded babbling poet, I got up at 5 after sleeping only 3 hours. Insomnia sucks lol

thanks again for a great guide

I think this guide would be a great sticky as well !!

Edited by FaceMouth
0

Share this post


Link to post
Share on other sites

Great guide, thought I was gonna manage SP2 on my first go, but no.

Shortly (about a minute) after running sort2cabs.js it errors

md5sum: SETUP.EXE: no such file or directory

the file is there, any suggestions? I'm running a fresh install of winXP sp2 if that makes any difference

Thanks in advance,

Suicidal_Orange

0

Share this post


Link to post
Share on other sites

Hi all,

First, thanks a lot to marek722 for is wonderful process and also TCP for is "delete batch" :thumbup

I have followed carefully the instructions to build both "SP2 slipstreamed CDs" and "SP2 slipstreamed AIO CD" of my French Office 2003. Everything went fine during the process (no error from msiexec or from the .js script) and after the "delete batch" I get some SP2 CDs or an AIO CD which looks quite OK.

However when I try to install the five programs I get the following:

Office: NOK (Quickly, before asking for any serial number, I get a popup with "Error 2715. An internal error has occured (IPMAIN11.AW_1036)". Then the installation process is cancelled.

Project/Visio: NOK (Idem, with "Error 2715. An internal error has occured (F346 msdapml.dll.E8D71C4B_62C9_4D1B_A02F_C916CAE50331)". Then the installation process is cancelled.

Frontpage/Onenote: OK (Installation is OK, and programs seems to run OK).

Looks very strange, isn't it? :}

I have repeated marek722 process twice, being very carefully not to forget anything, but I get always this results, whatever on single or AIO built CDs.

Any idea why I get those weird errors on 3 out of 5 office 2003 components...? Could it be something linked to the fact I am doing it with a French Office 2003 + French SP2? Anything which could be language specific?

Thanks in advance,

Stellar7.

0

Share this post


Link to post
Share on other sites

ON CAHCED INSTALL and Administrative Install Points

---------------------------------------------------

Microsoft has 2 differnt strategies for patching Office 2003.

1) Optomized for high-availability LAN

2) Optomized for low-availability LAN, slow-links, mobile, etc.

Option 1 and Option 2 are mutually exclusive. You must use one or the other.

http://www.microsoft.com/technet/itsolutio...ade_5.mspx#EEAA

Option 2 assumes you don't have a lot of bandwidth available and/or that you may be without LAN connectivity from time to time. It compensates for this with LIS (Local Install Sources). LIS keeps a copy of the media on your Local system. The patching stratergy here is based on the same assumption, no connectivity. This istall method favors patches and hotfixes. These are small and install individually. This is the right choice for mobile users or users with slow links.

Option 1 assumes you have a reasonably fast network available all the time. In this situation the network sources are updated en mass. The large scale changes can be easily pushed to the client without as much worry over validation and traffic interruption. THAT is why you can make an administrative install point and install SP1 or SP2 to it.

Once again, Option 1 and Option 2 are mutually exclusive. Therefore if you create an Administrative install point and slipstream it, you have chosen Option 1 and cannot benefit from LIS (Cached install)

On another note: Only Volume License copies of Office can be used for an Administrative install point. You can't buy it in the store and do these procedures.

Now what's my motivation in all this? I'm hoping somebody out there will prove me wrong and show me how to slipstream an SP2 install then repackage it to a compressed CD image that is capable of utilizing the LSI model. Like the rest of you, I want the best of both worlds.

0

Share this post


Link to post
Share on other sites

Nice guide. I'm sure i would give it a try to replace my chained instal i have now.

But i still have some questions:

is it also possible to integrate mui Packs in the installation sources?

Or must i keep these installed with chained install?

And how should I slipstream updates for the MUI packs?

On the moment i have problems with the installation log. If i use the runonceEx command

HKLM,"%RunOnceEx%\install20",1,,"%11%\msiexec.exe /i %CDROM%\Apps\InstallOffice2003\pro11.msi TRANSFORMS="""%CDROM%\Apps\InstallOffice2003\Custom_Setup_1.MST""" /qr /lpiwae """%logdir%\Office Setup(*).log""" "

0

Share this post


Link to post
Share on other sites

Hello world :)

... just realized, that the thread-tracker is purged when no activity is seen - not good!

So here are some good news: finally I found a solution to use the update web pages from microsoft after slipstreaming (better say I managed to convice Office Update to accept my slipstreamed OFF2003SP1 and not to identify it as a administrative version). Looks like approaching the aim :thumbup and going to build a slipstreamed Office 2003 that will act like the original release version. What's still broken are version numbers in the slipstreamed .msi - actually working on this.

Next steps will be: extend the scripts for easier use, include new changes, test a bit, rewrite the guide and give the code to you for more tests. Stay tuned and patient - this project consumes a lot more time than I can afford.

@paulvanleemput:

Can't test MUI version, but maybe it will work when the integration of other patches after the service packs will work. But this will be interesting after service pack slipstreaming is functional.

@polysulfide:

This project may proof that you are wrong. For instance LIS is already working after slipstreaming SP1. Don't know if I will succeed but I'm trying :yes:

@Stellar7:

hmm, looks like missing files. Maybe the new scripts will fix this, otherwise more investigations are nessessary.

@suicidal_orange:

still not tested SP2 cause all seems useless to me, if windows update/office update won't work.

@FaceMouth:

slipstreaming should not change admin install routines in the .msi, in other words if it worked before it should work after too. But I did not read the whole install routines.

next news should include success on updating a slipstreamed SP1 via windows update B)

0

Share this post


Link to post
Share on other sites

I must be doing something wrong... will anyone lend me a hand? I'm using SP2, but I figured as other people have had success there must be some way of getting it to work.

I've tried both methods; 1 CD at a time and all 5 in one directory and both have had quirks.

1 CD at a time results in successful completion of sort2cabs.js and when I go to install the program it usually works. But under some configurations (such as installing Frontpage before Office) I'll get an error saying a CAB file was not found, and when I point it to that file it refuses to have it. Also, on a successful installation ticking the box to delete installation files does nothing (i.e. it doesn't remove the cabs in MSOCache).

5 in 1 is strange because at the end when it tries to calculate the MD5 sums of the cabinets it fails to find one and stops with an object error.

I might try SP1 to see if it makes a difference, but I think I'll wait for this project to ferment a bit futher first :)

EDIT: With a bit more toying around I've finally managed to make the beef stew method work. The same error occured as last time (just after cab creation is completed) but I decided to comment out the cab compression bit and run the script again, where it continued on as if the error didn't exist.

Cache options don't appear much like Zxian was describing, but I used the enhanced setup thingy with enforcecache=true and that allowed me to cache them.

Anyway thanks for the script marek722 :thumbup

Edited by AndrewNi
0

Share this post


Link to post
Share on other sites

I've just finished working with this slipsteaming method.

The results were great: I did it with SP2, it worked great. I did it also for MUI with SP2 and also wotked great.

The size of Office has shrinked by 2 MB; the size of MUI has become bigger by 7 MB.

I used the method 1 CD at a time.

NB: the file "finish_slipstream.bat" worked fine with Office but failed with MUI (it deleted all the contents), so I did it manually.

Great tool Marek722. :thumbup Waiting for new updates from you.

0

Share this post


Link to post
Share on other sites

Great News:

I created AIO CD (Office Pro, Frontpage, Visio, Project and MUI Arabic). Note that Office Pro contains (Access, Frontpage, Excel, Word, Powerpoint, InfoPath, Onenote, Outlook, Publisher) with SP2 for all of them.

The CD size 640MB and down to 596MB if using CDIMAGE (-o) option to optimize duplicate files B)

- 1st I compared the contents of the Office 2003 Pro CD with both the contents of Visio 2003 and Project 2003 and MUI Arabic CD. I found many common files including cabs on all these CDs.

- I moved the contents of them to their corresponding common folder with a unique change: renaming the "setup.exe" and its corresponding ".ini" file in \Files\Setup folder. For Example setupvis.exe and setupvis.ini for Visio instead of setup.exe and setup.ini (just not to conflict each setup of them)

- I downloaded the latest "setup.exe" from microsoft website and replaced each "setup???.exe" file by the new downloaded file.

- I had to leave one copy of the original "setup.exe" as it's used during this guide

- I've got an oringinal AIO CD without any SP or hotfix for it with a total size of 649 MB.

- I followed the guide of Marek722 to end up with the above result.

- I made the same test after including my "*.mst" files and end up also with a positive result.

- I checked for the updates on the microsoft website for all the installed applications: I just found these 2 hotfixes not installed:

* Update for Outlook 2003 Junk Email Filter (KB907492)

* Update for Office 2003 (KB907417)

and this is obviously true as these 2 hotfixes were not included in the SP2 release.

I'm planning to integrate them using the same method.

I can assure you that this guide works properly with SP2 instead of SP1.

Great work Marek722

Edited by wachkar
0

Share this post


Link to post
Share on other sites

Hmmm... whenever I try to do this I get an error after a while that says:

md5sum: ZE561406.CAB No such file or directory

Error: [object Error]

Any ideas what may cause this?

I am using a SP1 disk to begin with... and I slipstreamed the SP2 files to it.

Could this error be because I am starting with SP1 instead of a disk that has no SP?

This looks very interesting... but I am having no luck so far. :wacko:

Edit: Well... It looks like that error is normal. :) I went ahead and finished the tutorial and everything seems to be working fine! :D

Thanks a lot!! This is awsome! It is a pretty confusing tutorial... but it does work. One thing missing from the tutorial is to make sure you copy the setup.exe file to the SORT directory. ;)

Edited by Siginet
0

Share this post


Link to post
Share on other sites

I tried this with the danish version of office 2003 with SP2.

It works well, until I have to run the sort2cabs.js file, and it tells me to update the MSI files with the new tables. The problem is, that there is no new files to import, the sort directory contains no subfolders.

Any ideas?

btw. looking forward to an updated guide that doesn't require ORCA.

0

Share this post


Link to post
Share on other sites

marek722 thanks a lot!! That's work!

Edited by ykaramati2
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.