Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

XPlode Title problem

- - - - -

  • Please log in to reply
2 replies to this topic

#1
hohner

hohner

    Junior

  • Member
  • Pip
  • 88 posts
Hi all,

I never thought I'd be asking for help with something which should be so simple :blushing: but here's my problem.

I run XPlode which calls xplode.xml, this inturn loads the include-StdConfig.xml and Include-Items.xml
In the 'include-StdConfig.xml' I have changed the display.title tag as follows
<display.title>Software Installation</display.title>
 	 <display.complete>completed</display.complete>

But, when XPlode is launched, the title remains XPlode Installation

Here's a log, which to my understanding says it uses the title of 'Software Installation' :blink:
>>> Log session start at: 2005/07/29 02:42:36
XPlode4
   XMLParser::LoadFile(H:\XPCD\$OEM$\xplode\XPlode.xml)
      XMLParser::LoadFile(H:\XPCD\$OEM$\xplode\include-StdConfig.xml)
      Import context: 'XPlode4(0).config(0)', from 'H:\XPCD\$OEM$\xplode\include-StdConfig.xml' succeeded.
      XMLParser::LoadFile(H:\XPCD\$OEM$\xplode\include-Items.xml)
      Import context: 'XPlode4(0)', from 'H:\XPCD\$OEM$\xplode\include-Items.xml' succeeded.
   Reading environment variables from XML
      #DISPLAY.TITLE# = 'Software Installation'
      #DISPLAY.COMPLETE# = 'completed'
      #ACCTMGMT.ADDUSER# = 'Adding user: #1#'
      #ACCTMGMT.DELUSER# = 'Deleting user: #1#'
      #ACCTMGMT.ADDGROUP# = 'Adding group: #1#'
      #ACCTMGMT.DELGROUP# = 'Deleting group: #1#'
      #EXECUTE.STRING# = 'Executing: #1#'
      #MISC.SFCOS-DISABLE# = 'Disabling Windows File Protection'
      #MISC.SFCOS-ENABLE# = 'Enabling Windows File Protection'
      #MISC.NETSTART# = 'Starting #1#'
      #MISC.NETSTOP# = 'Stopping #1#'
      #MISC.SLEEP# = 'Sleeping for #1# seconds'
      #REGISTRY.READ# = 'Reading from registry'
      #REGISTRY.WRITE# = 'Writing to registry'
      #FILEIO.COPY# = 'Copying: #1# to #2# (#3# of #4#, #5# of #6#)'
      #FILEIO.MOVE# = 'Moving: #1# to #2# (#3# of #4#, #5# of #6#)'
      #FILEIO.DELETE# = 'Deleting: #1# from #2# (#4#)'
      #FILEIO.RENAME# = 'Renaming: #1# to #2#'
      #FILEIO.SHORTCUT# = 'Creating shortcut to #1#'
      #FILEIO.RMDIR# = 'Deleting: #1# from #2# (#4\)'
      #FILEIO.MKDIR# = 'Creating directory: #1#'
   Reading tokens from XML
      AccessToken::SetupTokens(Fred)
         Username: Fred
         Domain: HAL
         Password: *****
   Active environment variables
      #ACCTMGMT.ADDGROUP# = 'Adding group: #1#'
      #ACCTMGMT.ADDUSER# = 'Adding user: #1#'
      #ACCTMGMT.DELGROUP# = 'Deleting group: #1#'
      #ACCTMGMT.DELUSER# = 'Deleting user: #1#'
      #ALLUSERSPROFILE# = 'C:\Documents and Settings\All Users'
      #APPDATA# = 'C:\Documents and Settings\Fred\Application Data'
      #CLIENTNAME# = 'Console'
      #COLLECTIONID# = 'COL8143'
      #COMMONPROGRAMFILES# = 'C:\Program Files\Common Files'
      #COMPUTERNAME# = 'HAL'
      #COMSPEC# = '%SystemRoot%\system32\cmd.exe'
      #DISPLAY.COMPLETE# = 'completed'
      #DISPLAY.TITLE# = 'Software Installation'
      #EXECUTE.STRING# = 'Executing: #1#'
      #FILEIO.COPY# = 'Copying: #1# to #2# (#3# of #4#, #5# of #6#)'
      #FILEIO.DELETE# = 'Deleting: #1# from #2# (#4#)'
      #FILEIO.MKDIR# = 'Creating directory: #1#'
      #FILEIO.MOVE# = 'Moving: #1# to #2# (#3# of #4#, #5# of #6#)'
      #FILEIO.RENAME# = 'Renaming: #1# to #2#'
      #FILEIO.RMDIR# = 'Deleting: #1# from #2# (#4\)'
      #FILEIO.SHORTCUT# = 'Creating shortcut to #1#'
      #FP_NO_HOST_CHECK# = 'NO'
      #HMSERVER# = 'https://wwss1pro.cce.hp.com/wuss/servlet/WUSSServlet'
      #HOMEDRIVE# = 'C:'
      #HOMEPATH# = '\Documents and Settings\Fred'
      #ITEMID# = 'dj-22741-15'
      #LANG# = '3081'
      #LOGONSERVER# = '\\HAL'
      #MISC.NETSTART# = 'Starting #1#'
      #MISC.NETSTOP# = 'Stopping #1#'
      #MISC.SFCOS-DISABLE# = 'Disabling Windows File Protection'
      #MISC.SFCOS-ENABLE# = 'Enabling Windows File Protection'
      #MISC.SLEEP# = 'Sleeping for #1# seconds'
      #NUMBER_OF_PROCESSORS# = '1'
      #OS# = 'Windows_NT'
      #OSVER# = 'winXPP'
      #PATH# = '%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem'
      #PATHEXT# = '.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH'
      #PROCESSOR_ARCHITECTURE# = 'x86'
      #PROCESSOR_IDENTIFIER# = 'x86 Family 15 Model 15 Stepping 0, AuthenticAMD'
      #PROCESSOR_LEVEL# = '15'
      #PROCESSOR_REVISION# = '0f00'
      #PROGRAMFILES# = 'C:\Program Files'
      #PROMPT# = '$P$G'
      #REGISTRY.READ# = 'Reading from registry'
      #REGISTRY.WRITE# = 'Writing to registry'
      #SESSIONID# = '1118693261565htx605664cc60:10477504aed:-4402'
      #SESSIONNAME# = 'Console'
      #SOURCEDRIVE# = 'E:'
      #SOURCEPATH# = 'E:\I386'
      #SWUTVER# = '1.0.3.1'
      #SYSTEMDRIVE# = 'C:'
      #SYSTEMROOT# = 'C:\WINDOWS'
      #TEMP# = '%USERPROFILE%\Local Settings\Temp'
      #TIMEOUT# = '0'
      #TMP# = '%USERPROFILE%\Local Settings\Temp'
      #TOOLPATH# = '/C:\Program%20Files\Hewlett-Packard\HP%20Software%20Update\install.htm'
      #UPDATEDIR# = 'C:\DOCUME~1\Fred\LOCALS~1\Temp\rad40359.tmp'
      #USERDOMAIN# = 'HAL'
      #USERNAME# = 'Fred'
      #USERPROFILE# = 'C:\Documents and Settings\Fred'
      #VERSION# = '4.3.50719.1395'
      #WINDIR# = '%SystemRoot%'
      #XPLODE# = 'H:\XPCD\$OEM$\xplode'
      #XPLODE.BASE# = 'H:\XPCD\$OEM$\xplode'
      #__COMPAT_LAYER# = 'EnableNXShowUI '
   Loading XPlode plugins
      Loading display plugin: 'H:\XPCD\$OEM$\xplode\XPlodeSelectInstall.x4d'
         Plugin load successful: 'H:\XPCD\$OEM$\xplode\XPlodeSelectInstall.x4d'
      Loading effects plugins
         Plugin load successful: 'H:\XPCD\$OEM$\xplode\XPlodeRegistry.x4e'
         Plugin load successful: 'H:\XPCD\$OEM$\xplode\XPlodeMisc.x4e'
         Plugin load successful: 'H:\XPCD\$OEM$\xplode\XPlodeFileOps.x4e'
         Plugin load successful: 'H:\XPCD\$OEM$\xplode\XPlodeExecute.x4e'
         Plugin load successful: 'H:\XPCD\$OEM$\xplode\XPlodeAcctMgmt.x4e'
   Registering XPlode commands
      Registering commands in 'H:\XPCD\$OEM$\xplode\XPlodeRegistry.x4e'
         Command registered: <registry ... />
      Registering commands in 'H:\XPCD\$OEM$\xplode\XPlodeMisc.x4e'
         Command registered: <sfcos-enable ... />
         Command registered: <sfcos-disable ... />
         Command registered: <netstart ... />
         Command registered: <netstop ... />
         Command registered: <hidewindow ... />
         Command registered: <showwindow ... />
         Command registered: <sleep ... />
      Registering commands in 'H:\XPCD\$OEM$\xplode\XPlodeFileOps.x4e'
         Command registered: <fileio-copy ... />
         Command registered: <fileio-move ... />
         Command registered: <fileio-delete ... />
         Command registered: <fileio-rename ... />
         Command registered: <fileio-rmdir ... />
         Command registered: <fileio-mkdir ... />
         Command registered: <fileio-shortcut ... />
      Registering commands in 'H:\XPCD\$OEM$\xplode\XPlodeExecute.x4e'
         Command registered: <execute ... />
      Registering commands in 'H:\XPCD\$OEM$\xplode\XPlodeAcctMgmt.x4e'
         Command registered: <adduser ... />
         Command registered: <addgroup ... />
         Command registered: <deluser ... />
         Command registered: <delgroup ... />
   Executing tag: 'XPlode4(0).pre-execute(0).adduser(0)'
      Install log: Running: 'NET USER Fred   /ADD' (hidden)
      Install log: Running: 'NET LOCALGROUP "Administrators" Fred /ADD' (hidden)
   Spawning display plugin
      Install log: Closing dialog
   Executing tag: 'XPlode4(0).post-execute(0).showwindow(0)'
      Error during execution: Window not found..
>>> Log session end at: 2005/07/29 02:42:38

This has me really confused, and again... I appreciate all help I receive.


How to remove advertisement from MSFN

#2
hohner

hohner

    Junior

  • Member
  • Pip
  • 88 posts
So quickly I discovered the answer, I should have checked this first before my initial post. :}

In the Selection directory there is a file called Title.html, I changed the title here using a html editor and it was reflected during test run to what I was trying to achieve in the above post.

So now I have a new question... if the <Display.Title> tag does not affect this title, then which title exactly does it affect?

Edit:
Errr...

I beleive the answer was there all along :blushing:
<!-- strings for the original display plugin -->
 	 <display.title>Software Installation</display.title>
 	 <display.complete>completed</display.complete>
Obviously these tags are only used with the original display plugin

Edited by hohner, 28 July 2005 - 11:37 AM.


#3
Wraith

Wraith

    Dr. Nick

  • Member
  • PipPipPipPipPipPip
  • 1,256 posts
Nice to see someone taking the initiative and doing a bit of testing on their own. :)
Posted ImagePosted Image
Posted ImagePosted Image
Posted ImagePosted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN