Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
Wesmosis

why my CD Writer always in PIO Mode!

14 posts in this topic

hey guyz

I donno , last couple of dayz i'm having a rough time with : HDD + CD Writer Driver + IDE Cables

I solved my (Samsung HDD Problem; Delayed Write Failed) which I posted it

but now I'm facing a problem with my LG CD-R/RW Driver 24x,

I bought a real good IDE Ultra DMA Cable (MSI) with the 80 wire - 80 pins

I'm connecting both the CD RW and the HDD into Secondary IDE Channel

the CD WR is Master , the HDD is Slave

the HDD is working fine now with the Ultra DMA Mode 3, but the CD RW always in PIO mode! which causing me a problem whenever I Burn or Reading from the CD, everthing become slow and Sluggish!............I read the Manual and the Officla Site of LG it Said:

Data Transfer Rate:
Burst ATAPI (Which I don't know what it means!);
16.67 MBs /s (PIO Mode4)
16.67 MBs /s (Multi DMA - Mode 2)

1234is.gif

& from little experince : PIO is Evil! , Ultra DMA is Good!

so how can I turn my LG Writer into DMA?!

I'm waiting for my heroS!

thanx guys in advanced

0

Share this post


Link to post
Share on other sites

Your best bet is to try to switch around the connections for your devices in as many different ways as possible.

Does your BIOS allow you to check the transfer mode of your devices?

You could also try uninstalling the device in Device Manager and letting the system find it again on boot.

0

Share this post


Link to post
Share on other sites

If the above advice doesn't work for you, check to see if there's an updated firmware revision for your burner. This cured a similar problem for me with my Plextor PX-708A DVD burner.

- ravashaak

0

Share this post


Link to post
Share on other sites

@Zxain

ok I'll give it a shot , & then see if it switchs to (DMA-MODE)

@Ravashak

excuse me, where can I find the update for the firmware revision for my burner?

LG CD-R/RW Drive 24x GCE-8240B

0

Share this post


Link to post
Share on other sites

I'd recommend the following (some of it was already suggested above, but you know...):

  • Put your hard drives on one cable on the primary IDE channel, and your optical drives on another cable on the secondary IDE channel.
  • Make sure that both of your cables are 80-wire cables.
  • Update your motherboard's BIOS to the latest version and update your optical drive's BIOS to the latest version.
  • Make sure that your BIOS is set to Auto and that UDMA is enabled.
  • Make sure that you have the latest chipset and IDE drivers for your motherboard installed.

0

Share this post


Link to post
Share on other sites

try to uninstall the problematic device in Device manager and then the Secondary channel. then restart. after restart should the devices automaticly be reinstalled.

XP put a device into PIO mode if a couple of errors by communitating appears and what I wrote is a workaround.

0

Share this post


Link to post
Share on other sites

ok guyz........ :wacko:

1- I can't put my HDD on the Primary IDE Channel since I got 2 HDDs connected there! so the only free space left is to connect the 160 GBs HDD with my CDRW!

2-I checked my BIOS settings.....ALL DMA is AUTO

3- My award BIOS is the latest version , I can't find this called (firmware)

4- I tried Uninstalling the CDRW........nothing new happen

5- I'll try Uninstalling the whole Secondary Channel IDE, maybe it works

6- I read somewhere on the net that whenever you connect your CDRW with other HDD, it will be PIO Defenitly! is that true? can anyone see his CDRW which connected with a HDD and tell us which Mode it is?! :}

Edited by Wesmosis
0

Share this post


Link to post
Share on other sites

Try starting your computer without your 160GB connected to see if that fixes your PIO issue, if so, then you have your answer.

0

Share this post


Link to post
Share on other sites

heyyyyyyyyyyyyyyyyyyyyyyyyy!

man! the Fifth Step was the One:

5- I'll try Uninstalling the whole Secondary Channel IDE, maybe it works

****! I knew MSFN can rock! LOL

Thanx Icarle and I'll try it later ,

Thanx Tester Pedro for this wonderful trick

check this Out:

12329ii.gif

Byeeeeeeeeeeee

0

Share this post


Link to post
Share on other sites
heyyyyyyyyyyyyyyyyyyyyyyyyy!

man! the Fifth Step was the One:

5- I'll try Uninstalling the whole Secondary Channel IDE, maybe it works

****! I knew MSFN can rock! LOL

Thanx Icarle and I'll try it later ,

Thanx Tester Pedro for this wonderful trick

check this Out:

12329ii.gif

Byeeeeeeeeeeee

You are welcome. ;)

0

Share this post


Link to post
Share on other sites

Maybe this will help next time...

When CD drive have trable to read some CD's, windows disable DMA, and if this hapen do this:

Re-enable DMA using the Registry Editor

Run REGEDIT. Go to the following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}

It has subkeys like 0000, 0001, 0002, etc. Normally 0001 is the primary IDE channel, 0002 the secondary, but other numbers can occur under certain circumstances. You have to go through these subkeys and check the DriverDesc value until you find the proper IDE channel.

Delete MasterIdDataChecksum or SlaveIdDataChecksum, depending on whether the device in question is attached as master or slave, but it can't actually hurt to delete both. Reboot. The drive DMA capabilities will be redetected.

Open Device Manager again and check whether the device is now actually using DMA mode. If so, congratulations, you've made it (at least until the next time Windows disables DMA).

0

Share this post


Link to post
Share on other sites

We should open up a 1-900-MSFN-SUPPORT line... :D

Edited by jcarle
0

Share this post


Link to post
Share on other sites

very good trick,

but what isa different between DMA MODE and MULTI-WORD MODE?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.