Gape

98 SE SP 2.0.2

118 posts in this topic

@randiroo76073

Thanks for your reply, and are you sure it's just for DirectX 8.1 installer ? Any other programs install fine after ? For the moment I have tested a bit and I havn't other problems but if a Microsoft program install doesn't detect correctly the version perhaps other program do the same ... if anyone has an opinion :unsure:

Goodbye.

0

Share this post


Link to post
Share on other sites

-good point, sonic... I've often wondered the same thing, altho I haven't had any problems with (many) installations yet...

...

-one prob I am having rite now, is trying to "fresh" reinstall w98se w/sp2.02 slipstreamed...

..

I took OPTIONS/CABS from a current (fully updated) OS (w/sp2.02 slipstreamed), and used it on otherwise blank partition to "fresh" reinstall, which has worked fine about a month ago, but now apparently something is broken, many errors during setup installation, and afterwards too...

..

(for example: during last phase of setup (Settings/Configuration), it starts as "Windows Update... An Error has occured loading c:\windows\system\wshext.dll... the file may not have been installed or is corrupted...", and it basically repeats that kind of error with many other system files: initpki.dll, cryptdlg.dll, Java Package Manager-xmlds04.cab, dajava.cab, iejava.cab, MSASN1.DLL, devmgr32.dll...)

...

-even after setup finishes, and the OS is booting/running ok, when I tried to install IE5.5sp2, hoping that maybe it would replace/update/register/fix the problem files, it just repeats the same errors/files...

..

I need to do further testing (in a few days; very busy rite now), perhaps that particular OPTIONS/CABS somehow got corrupted (altho when comparing files it *looks* ok, at first glance), I'll find an older ("clean") OPTIONS/CABS & O.S., and run all updates & slip sp2.02 into it, see how it goes... but in the meantime, I was just wondering if anybody out there has had similar experience, or any ideas... ?

>;]

Edited by PsycoUnc
0

Share this post


Link to post
Share on other sites
@randiroo76073

Thanks for your reply, and are you sure it's just for DirectX 8.1 installer ? Any other programs install fine after ? For the moment I have tested a bit and I havn't other problems but if a Microsoft program install doesn't detect correctly the version perhaps other program do the same ... if anyone has an opinion  :unsure:

Goodbye.

sonic, could you post the exact error message or could you put a screenshot?

0

Share this post


Link to post
Share on other sites

Hi,

Virtual PC

Microsoft Windows 98 SE French OEM (DirectX 6.1a inside)

Installed with an UnAttented "Layout.inf"

No drivers or softwares installed yet

Windows SP 2.0.2 (french release)

Reboot

DirectX 8.1 ... arghh ...

nodx8aftersp2.jpg

Translate ~

This version of DirectX isn't compatible with the version of your actual Windows

With DirectX 9.0c it's okay, but I use this for old machines ...

Goodbye.

Edited by sonic
0

Share this post


Link to post
Share on other sites

-sonic: ? why wouldn't directx 9.0c be good for old machines? -isn't it backward-compatible?...

...

-and: update on reinstall problems:

well, same problem with OPTIONS/CABS from a 6/9/05 backup (w/then-current sp2/updates slipped), but I found a 4/25/05 backup of OPTIONS/CABS (no sp2 slip), and it works fine... (I recall it also worked fine back around that time, w/sp2 slipped)... -so, whatever newer updates/changes, between 4/25 and 6/09, roughly, must have broken OPTIONS/CABS for reinstall... (or the possibility still exists that OPTIONS/CABS was somehow otherwise corrupted, but rechecking the files, it looks ok)

...

-I will next test the 4-25-05 (non-sp2-slip) with the most recent sp2 slipped, and then with other recent updates, too... [sigh... I've wiped & reinstalled about 12 times now, and more coming up... wee.]

>;]

0

Share this post


Link to post
Share on other sites

* uh oh, Gape: sp2.cab (from sp2.02) slipstreamed into OPTIONS/CABS thoroughly *breaks* a fresh w98se reinstall !

...

-I traced my reinstall problem down, using a 4/25/05 backup of OPTIONS/CABS... -without sp2.cab slipped, it installs perfectly, but with sp2 slipped it causes *many* errors & corruptions of the w98se fresh install (see my previous few posts for details)...

...

-I will try to find my oldest backup of OPTIONS/CABS and test it again, but sp2 should not break recent or current OPTIONS/CABS, since many OEM puters don't come with a w98se install CD, they just have the install files in \windows\options\cabs, which get updated occasionally by applied MS updates, etc... -of course, a workaround is simple: just don't slip it, install first, then run sp2.02... but it'd be nice to have it slipped, and to find out why it breaks the install...

?

(note: I think some previous version(s) of SP2 slipped just fine, during reinstalls...?)

Edited by PsycoUnc
0

Share this post


Link to post
Share on other sites
* uh oh, Gape:  sp2.cab (from sp2.02) slipstreamed into OPTIONS/CABS thoroughly *breaks* a fresh w98se reinstall !

:blink:

Slipstreamed into OPTIONS/CABS?

I don't understand that... Could you explain?

0

Share this post


Link to post
Share on other sites

EDIT: -it's not important, I don't have to have sp2.cab slipped before doing a reinstall, I'll just fire it up afterwards, same end result... (and probably safer, too)

Edited by PsycoUnc
0

Share this post


Link to post
Share on other sites

Gape:

I received this in email from erpdude8:

I did recently install Gape's W98se SP v2.02 on an old Win98se computer.  It had the HTML Help files from Win2003 SP1, not the files from the Win98 KB896358 HTML Help patch. Let's suggest that for his next release.

Also ask him if he can include your unofficial voltrack.vxd 4.10.1999, unofficial krnl386.exe 4.10.1999 and unofficial update.sys 4.10.2223 fixes.

I also believe that adding these files to your next SP 2.x release would be a good idea.

HTML Help Update [official from MS]:

http://www.mdgx.com/add.htm#HHU

voltrack.vxd fix [unofficial]:

http://www.mdgx.com/files/Q249824.EXE

krnl386.exe fix [unofficial]:

http://www.mdgx.com/files/98KRNLUP.EXE

update.sys fix [unofficial by Petr]:

http://www.mdgx.com/files/98UPDSYS.EXE

Hope this helps.

0

Share this post


Link to post
Share on other sites
I received this in email from erpdude8:
I did recently install Gape's W98se SP v2.02 on an old Win98se computer.  It had the HTML Help files from Win2003 SP1, not the files from the Win98 KB896358 HTML Help patch. Let's suggest that for his next release.

Also ask him if he can include your unofficial voltrack.vxd 4.10.1999, unofficial krnl386.exe 4.10.1999 and unofficial update.sys 4.10.2223 fixes.

I also believe that adding these files to your next SP 2.x release would be a good idea.

Thanks MDGx, [where is the erpdude8? :)]

This new HTML Help update looks like causes problem with old IE versions. Please, check this link.

About unofficial fixes, I'll add them in the next version, but they'll be optional.

0

Share this post


Link to post
Share on other sites
This new HTML Help update looks like causes problem with old IE versions. Please, check this link.

The quoted message is not related to W2003 based HH update in any way, I never tried it.

Petr

0

Share this post


Link to post
Share on other sites
I received this in email from erpdude8:
I did recently install Gape's W98se SP v2.02 on an old Win98se computer.  It had the HTML Help files from Win2003 SP1, not the files from the Win98 KB896358 HTML Help patch. Let's suggest that for his next release.

Also ask him if he can include your unofficial voltrack.vxd 4.10.1999, unofficial krnl386.exe 4.10.1999 and unofficial update.sys 4.10.2223 fixes.

I also believe that adding these files to your next SP 2.x release would be a good idea.

Thanks MDGx, [where is the erpdude8? :)]

This new HTML Help update looks like causes problem with old IE versions. Please, check this link.

About unofficial fixes, I'll add them in the next version, but they'll be optional.

I guess erpdude8 has taken a vacation. [?]

Petr:

I'm aware of official HTML Help (HH) errors with IE 5.5. :(

Could you [when/if you have the time] try the unofficial Win2003 SP1 HH files to see if they have the same bugs with older IE versions, and then post results here at your convenience?

Petr + Gape:

Because if unofficial 2003 SP1 HH files exhibit same bugs, then IMO Gape should replace them in next SP2 release with official MS HH files from KB896358.

Gape:

You're welcome, glad to help.

I've been testing the unofficial voltrack.vxd, krnl386.exe + update.sys fixes for a while, and never had problems [so far]. I've also installed them on a friend's PC with same results.

I believe erpdude8 also tested them [at least on his PC] successfully.

Gape:

IMO it would be a good idea to add the TSHOOT.OCX registry fix [as an option] to your next SP2 release:

http://www.mdgx.com/ietoy.htm#IEC

Hope this helps.

Edited by MDGx
0

Share this post


Link to post
Share on other sites

Long time no see, guys!

The TSHOOT.OCX registry fix is not necessary. It's only required if you apply IE update 824145 or higher AND you are using IE 5.01 SP2, IE 5.5 SP2 or IE 6.0 SP1 under Win98. And since Gape's SP doesn't include IE updates from none of the IE versions I mentioned, the tshoot.ocx registry fix is useless.

The HTML Help v1.4 applet requires IE 5.x or IE 6.x. Since the Win98 KB896358 HTML Help patch normally installs under IE 6 SP1, ask me how you can force the KB896358 patch to install under IE 5.5 SP2 or even under IE 5.01 SP2.

0

Share this post


Link to post
Share on other sites

Hello.

I have installed sesp202en patch on my Athlon AMD +2500 machine with

Pinnacle PCTV Tuner card. I have faced the following problem and could

find the reason at last. IE6 is installed on my system.

Whenever I start the Pinnacl PCTV, the following error is popping up

"Vision caused and Invalid page fault at module unknown" . I have reinstalled the software several times and also used the drivers update. I get the

"Vision caused and Invalid page fault in pfc.dll" when recording is started.

<snip>

I'm aware of an Athlon/AGP bug that wasn't mentioned by anyone, so I wanted to mention it in hopes someone could fix the code in Windows 98. There are two articles on this that I found in relation to Linux which discuss the issue, but it exists in any Windows versions prior to 2000. (Probably irrelevant before Windows 95 though!)

http://www.vnunet.com/vnunet/news/2117259/...tes-linux-users

Two year old bug bites Linux users

Open source OS can't handle older Athlon or Duron chips

James Middleton, vnunet.com 21 Jan 2002

An almost two-year old bug in AMD's Athlon and Duron processors has been found to trip up Linux users.

...

http://www.theregister.co.uk/2002/01/24/th...d_agp_bug_whos/

The Linux-AMD AGP bug – who's to blame?

By Andrew Orlowski in San Francisco

Published Thursday 24th January 2002 19:46 GMT

After arranging a tete a tete between two representatives of the Linux kernel team and AMD, Gentoo founder Daniel Robbins has drawn some initial conclusions on the bug affecting Linux users on AMD Athlon AGP systems.

Daniel concludes that neither side is guilty; that it isn't an AMD bug, more a feature; but he also recommends that kernel hackers find a new problem to this particular situation. It appears that the GART (Graphics Address Remapping Table) which feeds the AGP card with system memory isn't cache coherent. Although both Linux (and apparently Windows 2000) expect it to be.

...

I would like to know if anyone knows of a good fix for Windows 98SE. I'm unable to apply the following patch due to this abovementioned bug:

Microsoft Security Bulletin MS05-002

Vulnerability in Cursor and Icon Format Handling Could Allow Remote Code Execution (891711)

It causes some error that I've forgotten the exact word of, but I can barely make it into safe mode to fix the problem, and I've no wish to repeat the exercise. :}

Roving

0

Share this post


Link to post
Share on other sites

Hello Gape & Co.,

great work :hello: ,

unfortunately I'm also experiencing problems with KB891711, which I think is included after SP20RC1.EXE :(

My question is: Can I install somehow SP2.0.2 without installing any feature included in KB891711 ? Otherwise I should Use SP20RC1 4ever.

Problems with SP 2.0.2 generally ocure when running this application (shell replacement for Internet Cafes also for Home Use - kids U now :) ) KAIOWAS Client ( ENg version ) (it's a shell replacement for Internet Cafes also for Home Use - kids U now :) )

Thank You for your help in advance!

Best Wishes, Bye.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.