• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
tommyp

HFSLIP, The 2K/XP/2K3 slipstreamer

411 posts in this topic

Hi Kiki. I wish I could help out but I'm much too busy these days.

I already had a look at your TXTSETUP.SIF and HFSLIPWU.INF files and they look OK to me. The only advise I can give ATM is this:

1) Disable anti-virus

2) Copy a fresh source from the CD

3) Redownload additional programs including CMDOW.EXE

4) Run HFSLIP and burn new CD

5) Re-enable anti-virus

Edited by Tomcat76
0

Share this post


Link to post
Share on other sites

thanks TC! i'll try this ... :) was actually wondering why you haven't been quite active lately ;)

0

Share this post


Link to post
Share on other sites

hi TC! tried it without AVG ... re-downloaded cmdow ... as well as all recent hotfixes ... tried 2 different sources (XP Gold & XP SP1) ... still the same result ... all those add-ons that used to work as shown in the 1st pic above are no longer present (i.e., media player 11, lclock, some graphics & utilities add-ons) as compared to the 2nd pic where it used to show up after installation ... pls believe there was nothing new i did except for adding the new hotfixes + some add-ons which i took out too when i saw the initial result. i am certain there must be nothing that was changed in the cmd as i was able to create successful builds prior to my latest attempts ... i just wonder would there have been modifications made on how add-ons are treated this time ... or could there be new updates/hotfixes that could cause such? :wacko: thanks!

Edited by Kiki Burgh
0

Share this post


Link to post
Share on other sites

@Kiki...

Are you having the same problems with themes and everything if you try now with v60804 and v60712?

0

Share this post


Link to post
Share on other sites

hi all! sorry for bothering y'all with my recent posts ... today i am going to post that i have already resolved my concerns ... just to share so if somebody might encounter the same issues, then this could serve as a preventive measure :) ... i believe the cause was some conflicts in how add-ons were created ... i guess there is a conflict with rytukz_Vista_Icons_Pack_Ultimate_System_Patch_addon_1.1.cab & XPize45 as these both replace system files ... i also modified my HFANSWER.ini ... lesson learned for me regarding add-ons ;) ... finally i can rest easy for the weekend ... thanks!

yup TC ... i'm even having problems with themes ... even when using a patched UXTHEME.dl_

Edited by Kiki Burgh
0

Share this post


Link to post
Share on other sites

So if you remove either the Vista icon pack OR XPize 4.5, everything is OK?

0

Share this post


Link to post
Share on other sites

hi! reporting back to share results of several runs i did over the weekend ... i actually thought about the following possibilities for the issues i've encountered: (1) conflict in UXTHEME.dl_ contained in various themes addons & with that of XPize (well, XPize contains an executable for this) ... (2) probable changes made in XPize45.exe ... (3) file versions in new MS-updates released after 60810 ... as for the old versions i didn't encounter those i was able to burn cds with good ISOs using the very same files (except for those i added recently) ... i think there is a new update that breaks my install (specifically IE6.0sp1-KB918899-Windows-2000-XP-v2-x86-ENU.exe) ... attached are some logs & files ... i'll start a new thread for this HF so i could attach some pics too ...

EDIT: problems with shortcuts for other add-ons (for missing shirtcuts &/or install) are not related to the recent oversight that the_guy pointed out :P

files___logs.7z

Edited by Kiki Burgh
0

Share this post


Link to post
Share on other sites

To be honest, Kiki, I'm a bit confused here.

What exactly are your problems after using HFSLIP version 60810 when using the correct version of the KB918899 update (the one for XP SP2)?

Do you get the same problem(s) with an older version of HFSLIP if you run such older version again?

I couldn't see anything wrong with the setup files you provided in your post. Can I have a look at your SYSOC.INF too?

0

Share this post


Link to post
Share on other sites

it'a alright now TC ... i'm sorry for the bother ... have already figured that i used imcompatible HF meant for SP1 (as pointed out by the_guy) ... totally a bad oversight on my part :P ... as for the add-ons i believe conflict lies between XPize45 & Vista Icon pack as they more or less do the same thing ... thanks!

quick question: would there be any difference in treating files that we place in HF --- if in lower case or in upper case or a combo (i.e., XPize)?

Edited by Kiki Burgh
0

Share this post


Link to post
Share on other sites

None, the cmd interpreter will see XPIZE xpize XPize xPiZe xpIZE etc. as the same.

0

Share this post


Link to post
Share on other sites

thanks Yzöwl ... just as i thought so as this was never the case before ... it only crossed my mind to ask though as i remember some issue way back about using lower case & upper case (but not specifically for XPize) :P

0

Share this post


Link to post
Share on other sites

Is a version of HFSLIP later than 60810 required for later August Windows 2000 SP4 hotfixes?

This is critical, because there's more hotfixes reguarding the kernel!

Also, there's more hotfixes reguarding the shell! Thus even with the FDV fileset, I'm affected!

I appeared to have missed some hotfixes and there's no September final. :(

Edited by RJARRRPCGP
0

Share this post


Link to post
Share on other sites

Tomcat appears to be very busy lately. However, you can expect to get a September final very soon.

I am not sure whether the August final will support the latest 2000 hotfixes. I think your best bet is to confer with Tomcat or the_guy (very knowledgeable about the individual fixes).

0

Share this post


Link to post
Share on other sites

TC is indeed a busy dude lately. He is working hard and has some surprises in store for us ;)

0

Share this post


Link to post
Share on other sites

The only problem with September that I can think of is KB922528 on 2000. It requires the Rollup, and there's no special mode for it. I put a note on my list that it requires the Rollup, but I don't think that will be foolproof.

the_guy

0

Share this post


Link to post
Share on other sites
The only problem with September that I can think of is KB922528 on 2000. It requires the Rollup, and there's no special mode for it. I put a note on my list that it requires the Rollup, but I don't think that will be foolproof.

the_guy

I already have the rollup. I probably would be missing a major amount of hotfixes if I didn't!

0

Share this post


Link to post
Share on other sites

I haven't actually done a full Win2K install with the latest hotfixes yet, but there are no new files included and the installation INFs are OK so I don't see why there should be a problem.

RJARRRPCGP... If you're experiencing specific problems, can you explain which they are?

0

Share this post


Link to post
Share on other sites

I just thought that 922582 on 2000 would be a problem. Maybe adding a line that deletes it if the rollup is not included?

the_guy

0

Share this post


Link to post
Share on other sites
I haven't actually done a full Win2K install with the latest hotfixes yet, but there are no new files included and the installation INFs are OK so I don't see why there should be a problem.

RJARRRPCGP... If you're experiencing specific problems, can you explain which they are?

Just worried, because of more hotfixes after August 10. My CD from August 18 isn't good anymore, because I appeared to probably have missed at least one hotfix, then I saw another kernel hotfix!

0

Share this post


Link to post
Share on other sites

Is KB917008 required to be in another folder? The last time I had KB917008 in the HF folder, the KB917008 hotfix installer failed.

I suspect that KB917008 isn't a supported hotfix for the HF method.

Edited by RJARRRPCGP
0

Share this post


Link to post
Share on other sites

@RJARRRPCGP, you are right that KB917008 is treated differently from most of the other hotfixes. However, it should remain in HF. Tomcat76 currently has HFSLIP integrate it with SVCPACK. You don't have to do anything special to it ;).

Unfortunately, I'm not quite sure if Tomcat fixed the problems you were having with it. This SVCPACK integration was already implemented into HFSLIP_60810. I searched the Test releases forum as well as the HFSLP changelog, but didn't find any mention that Tomcat fixed any possible problems with it.

0

Share this post


Link to post
Share on other sites

The milestone HFSLIP release made it to the MSFN front page today :)

Great job everybody! :thumbup:thumbup

0

Share this post


Link to post
Share on other sites

Hello

I used 1.0.1 vesion to slipstream hotfixes and now i have problem with tv tuner drivers installation. When i slipstream hotfixes with version 60810 the drivers install ok. So this is a problem with the newest version. I think i know why i have this problem, when i use hfslip in "Slipstreaming new files" section there are added to i386 folder files: ks.sys, ksproxy.ax, ksuser.dll, stream.sys, msyuv.dll (in older version this files was not added), this files are used when i install drivers to my tv tuner and there are wrong. I took the original files from the system32 folder and the original files are bigger then this copying by hfslip. With the original files tv tuner works ok, so i back to version 60810.

Edited by grzesiek
0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.