Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

tommyp

HFSLIP, The 2K/XP/2K3 slipstreamer

Recommended Posts

S3pHiroTh    0
hi! attached screenshot + cmd screen (in .txt) for what i posted earlier:

Your HF directory is placed in Documents and Settings? I think that Tomcat has forgot to type " in the script... if you place the HF directory in another place it should work :)

Share this post


Link to post
Share on other sites
Kiki Burgh    0

thanks S3pHiroTh! i used to have separate drive dedicated to HFSLIP alone ... however i recently had storage probls which prompted me to put everything on the desktop ... perhaps this could considered in the next release ;)

Share this post


Link to post
Share on other sites
Kiki Burgh    0

hi! still the same: Could not find ... error :(

EDIT: it'd seem it couldn't work if working with sub-dirs ...

:no: previously, my structure was: C:\Documents and Settings\Woulfe\Desktop\Kiki temp\HFSLIP\HFAAO

:no: then moved it to: D:\KIKI\HFSLIP\HFAAO

:yes: finally moved it 1 level up: D:\HFSLIP\HFAAO ... this1 worked ... with no more Could not find ... errors for addons

could_not_find2.txt

Edited by Kiki Burgh

Share this post


Link to post
Share on other sites
S3pHiroTh    0
hi! still the same: Could not find ... error :(

You have done the same error :sneaky:

You have created a directory with a space in its name.

Rename "Kiki temp" in "Kiki" (without quotes) and all works fine :)

P.s. Sorry for my previous explanation :P

EDIT: it'd seem it couldn't work if working with sub-dirs ...

This is not true... The bug is when there is a directory with space in their name as Documents and Settings or Kiki temp. Tomcat has forgot to type quotes (") in file paths :)

So if you have a directory with a space in its name there was that bug. Maybe this bug there is for file name too.

Edited by S3pHiroTh

Share this post


Link to post
Share on other sites
Kiki Burgh    0

hi! i was finally able to finish a good installation ... everything seemed well (even my HFGUIRUNONCE have been addressed :) ) ... however, ie7 wasn't installed ... ie6 instead was there ... i already got it to work in earlier test releases prior to the Feb HF releases ... i'm thinking it might be 1 of the HFs i have added or overwritten ... while i'm seeking your advise, i am sorting it out too ... please advise ... thanks!

HFSLIP.rar

Edited by Kiki Burgh

Share this post


Link to post
Share on other sites

Hi, Kiki Burgh! :hello:

(1) msxml4-KB925672-enu.exe is obsolete - you already have the newer version.

(2) I bet one or more of your HFSVCPACK_SW MSIs should really belong in HFGUIRUNONCE, especially ones that affect Windows Explorer/Internet Explorer 7 behavior.

(3) Make sure all of your addons are up-to-date and don't conflict with IE7.

(4) MSICabExtract.exe is obsolete.

That's all I can suggest for now, but I can't really say that I know how to deal with your IE7 problem.

Share this post


Link to post
Share on other sites
Kiki Burgh    0

thanks S-M! i'm going to run hfslip.cmd again ... removed about a couple-3 HFs ... i'll see ... as for the addons, i'm basically using the same set when i had successful ie7 installation ...

Share this post


Link to post
Share on other sites
Tomcat76    1

@Kiki

In your case, I suggest you use the latest test release because it slipstreams IE7 (into Windows XP). It's working fine here.

Remove the StepByStep update because it's only useful if the main StepByStep program it applies to is installed first. HFSLIP only supports one "StepByStep" exe, by the way, so this update can't be included anyway.

I had a quick look at the code that does the HFAAO folder and every "full" path appears to be quoted. I'll have to test this for real in a working folder with spaces to see what could be wrong.

Edited by Tomcat76

Share this post


Link to post
Share on other sites
Kiki Burgh    0

thanks TC! see i haven't delved into the latest test rel yet because i wanted to build & burn an iso using the final 1st ;) ... i'll try the latest test rel later ... thanks too for looking into the HFAAO concern ... i'll just wait for any update you may come up with ... incidentally, are .zip addons supported?

Share this post


Link to post
Share on other sites
Gedrean    0

Okay so HFGuiRunOnce - I hate to ask, does this make an app fit into RunOnceEX? I have a switchless silent insty that needs a component put in ROEX, and I wanted to make it easy with HFSLIP and was hoping that's what it does but want to make sure.

Share this post


Link to post
Share on other sites
Sgt_Strider    0

Is HFSLIP going to eventually add SATA driver integration support? I would love if this feature is added and I will test it for you guys! Oleg II's method doesn't work, but I think he may be on the right track.

Share this post


Link to post
Share on other sites
Tomcat76    1

@Gedrean

HKLM/RunOnce.

@Sgt_Strider

It isn't on my agenda. Application addons are fairly easy because most people abide the rules, but there are millions of INF compositions out there used in driver packages. If I start it now, I may be able to complete it 5 years later. iTwins posted similar thoughts in the SATA integration thread.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×