tommyp

HFSLIP, The 2K/XP/2K3 slipstreamer

411 posts in this topic

Hello

no issues here with XP Pro SP2 Corp and HFSLIP_60310.

all fixes integrated.

the only fix that doesn't work is the legitXXXX.dll tha goes in the FIX folder.

MS update says it's not installed...

(i've got the latest legit cab given by Super-Magician, and the good fix).

the other thing i'm wondering, is the installation of Muweb.cab, the activeX is present, but, the windows update link on IE doesn't redirect to microsoft update, but still to windows update, and ther i've got to click on the link to use MSupdate, then click 3 button to validate, and then it's ok...

s***ty thing...

if someone can help :)

0

Share this post


Link to post
Share on other sites

If you're using the FIX folder, then rename the DLL to WGA1.DL_. (This is not a test as opposed to my question in another thread.)

MUWEB...

Yes I know. That was an issue that's been debated for several months now ever since MS started beta testing this service. Noone seems to know how to do it.

Edited by Tomcat76
0

Share this post


Link to post
Share on other sites

Thx for the advice for the legit ;) (i just rename, not recompress the dll to wga1.dl using mscompress ?)

gonna try it now :)

for muweb... :realmad: m$

Edited by EmRoD
0

Share this post


Link to post
Share on other sites
Thx for the advice for the legit ;) (i just rename, not recompress the dll to wga1.dl using mscompress ?)
I think... At least, that's how it used to be done for the two 2K rollup files in the past. Edited by Tomcat76
0

Share this post


Link to post
Share on other sites

renaming tio wga1.dl_ causes a copy error.

compressing it w/ ms compresse solves it, but, windows update still asks me to install the wga ...

0

Share this post


Link to post
Share on other sites

EmRoD - Are you sure you have the latest WGA cab file? There is more than one way to skin a cat with dll files. With this particular case, an option is to remove the legit cab and place the legitcheckcontrol.dll in the HFEXPERT\CODECS folder. Don't complain if you get missing files if *not* installing via CD.

0

Share this post


Link to post
Share on other sites

I install files all via cd :)

i've got (as i said before) the latest wga file 1.5.512.0.

Just found an exe for the KB892130 1.5.512.0 , gonna try putting it in the hf folder.

-> doesn't work...

Edited by EmRoD
0

Share this post


Link to post
Share on other sites
renaming tio wga1.dl_ causes a copy error.

compressing it w/ ms compresse solves it, but, windows update still asks me to install the wga ...

Use one of the test builds; I corrected an issue with LegitCheckControl.dll on WinXP SP2.
0

Share this post


Link to post
Share on other sites
Use one of the test builds; I corrected an issue with LegitCheckControl.dll on WinXP SP2.

testing right now :)

0

Share this post


Link to post
Share on other sites

i've done quite a number of unattended installs before and have integrated hotfixes through svcpack method. i'm newbie when it comes to HFSLIP.. i tried it yesterday and everything works fine except that i notice two new entries in my setuperr.log file, it says that drmclien.dll and drmstor.dll are not signed properly.. why is this? help please...

ERROR_REPORT.TXT

Edited by glentium
0

Share this post


Link to post
Share on other sites

Hi glentium

Remove WindowsXP-KB904706-x86-ENU.exe. It's an older version of the other DirectX 9 hotfix you're slipstreaming (WindowsXP-KB904706-v2-x86-ENU.exe).

Also, remove this file: WindowsServer2003.WindowsXP-KB904942-x64-ENU.exe. It is intended for 64-bit versions of Windows XP and Windows Server 2003. You're looking for WindowsXP-KB904942-v2-x86-ENU.exe.

Edit:

I recommend against including WindowsXP-KB912945-x86-ENU.exe for the moment. It appears that mshtml.dll (which is part of that package) can't be slipstreamed. You can use one of the test releases of HFSLIP where an attempt is made to work around the problem.

Edited by Tomcat76
0

Share this post


Link to post
Share on other sites

thanks for the quick response..

yup, i wasn't very careful in downloading that KB904942 update not noticing that i mistakenly downloaded the one for x64. oops! will be more careful next time. thanks for that info.

i'll try the test builds now.. will be back.

thanks again!

0

Share this post


Link to post
Share on other sites

Still having issues with the WGA "FIX"

legitcontrol.dll in FIX folder or renamed to WGA1.DLL doesn't work.

juste created a sfx for it and everything rules :)

0

Share this post


Link to post
Share on other sites

:thumbup First Thanks Tommy excellent tool (and all other contributers)

I have found a problem tho if you use advanced server it doesn't detect that it is the server version. A quick mod of the script file as below will fix this problem.

the additions are in bold

FINDSTR /I WINDOWS SOURCE\I386\PRODSPEC.INI>WORK\VERSION.TXT

FOR /F "TOKENS=2,3* DELIMS=, " %%I IN (WORK\VERSION.TXT) DO (

SET V1=%%I

SET V2=%%J

SET V3=%%K

)

IF "%V1%"=="2000" SET VERSION=2000

IF "%V2%"=="2000" SET VERSION=2000

IF "%V2%"=="Server" SET SERVER=SERVER

IF "%V3%"=="Server" SET SERVER=SERVER

IF "%V1%"=="XP" SET VERSION=XP

IF "%V2%"=="XP" SET VERSION=XP

IF "%V1%"=="2003" SET VERSION=2003

IF "%V2%"=="2003" SET VERSION=2003

this is just under the call folderprep statement

Regards

Nelly

Edited by noomsybaby
0

Share this post


Link to post
Share on other sites

Good catch, noomsybaby. I haven't tried Win2K ADV nor DCS yet so it hasn't occured to me either. Give me a minute or two to update the test builds in the other thread...

@EmRoD:

Can I have the HFSLIPWU.INF file from the SOURCESS\I386 folder?

0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.