Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

acpi.sys caused an unexpected error

- - - - -

This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1
danb

danb
  • Member
  • 1 posts
  • Joined 15-October 05
Hi, i'm hoping you lot can help me with some problems i'm having with a fresh install of win2k pro (sp4).

My PC: abit bd711-raid w/pentium 4 2.4g and 512mb ram - 2x40gig hdd (one removed for sake of install).

I have made the 4xfloppies required to boot win2k in dos. i have deleted all partitions, made a primary partition and formatted it.

i started to install win2k from the bootable floppy, and on disk two i get an error just as it starts to install "plug and play drivers/compatability or something" and then get a DISK I/O error 00010000 flash up before:

File acpi.sys caused an unexpected error (4096) at line 4241 in D:\nt\private\ntos\boot\setup\setup.c

The install can not continue. This is the third time i have reformatted and reinstalled win2k (same version) on this pc in the last two years and have never had any problems before. I googled my problem and hit upon a fix: to push f5 at the "push f6 to install scsi/raid drivers" bit and manually selected every single option - none of them made any difference. i then tried to push f7 at that bit to bypass that whole section of the install, and i still get the same error. I went through my bios settings, but cant find an en/disable ACPI selection.

.....along the same lines (perhaps) my pc, over the last 4 months, never shut down properly when i hit "shut down". Sometimes it would freeze at the "windows is saving your settings" bit and i'd just have to hold in the power button til it switched off. someone told me that it was related - i dunno.

Anywho, i'm looking for ideas and quick fixes. maybe i've not been doing things right up until now, but the previous google hits never seem to have any kind of real outcome. I don't have access to another pc (only this laptop) so i'm not too willing to throw money at it (new hdd / mboard etc) unless i really know what the problem is.

Thanks for your patience folks


How to remove advertisement from MSFN

#2
The-VOICE

The-VOICE

    Newbie

  • Member
  • 35 posts
  • Joined 31-March 05
It doesn't sound like you have a hardware problem. More than likely you have one or both of the following two issues.
1) A mismatched setting between the BIOS setting(s) for ACPI and/or APIC when used with a PlugAndPlay Operating System (Windows 2000).
2) An older version of the BIOS which may not properly support the P4.

The latest revision for the mainboard is 2003-07-22:
http://www.abit-usa....ries=1&model=35

Please consider re-flashing the BIOS and resetting to BIOS setup defaults.

#3
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,028 posts
  • Joined 09-September 01
If all else fails, disable power management in the BIOS, and press F5 during boot (when you are prompted to press F6) and select "Standard PC" from the HAL list.
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#4
RJARRRPCGP

RJARRRPCGP

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,193 posts
  • Joined 13-April 05
A bad HDD likely is the cause. Did you check your HDD?
Asus P5QL Pro, Core 2 Duo E4500, eVGA GeForce 9500 GT with XP Pro x64 Edition -> Works great with Asus P5QL Pro!