the_guy

Service Pack for Windows ME

550 posts in this topic

Sent! I've also obtained 838751, which includes msvcrt.dll 6.1.9847.0. It's also sent your way MDGx. Maybe include those 2 files in 98SE2ME? They only have dependencies in kernel32.dll (when used together).

New release sometime today!

the_guy

0

Share this post


Link to post
Share on other sites

Hey guys,

Thought I'd give you all a nice little gift,

A fully working version! Yes, this means beta 6 is now available for download. I installed it on a fresh install and it works perfect. Link is temporarily here until MDGx uploads it to his server. I hope it works perfectly fine for everyone. If not, let me know.

Changelog:

-rolled back msvcp60.dll to version 6.2.3104.0

-removed auupd.exe

-fixed npdsplay.dll copy issues

-Updated usp10.dll to 1.0422.3790.2706 (919136) Replaces 2003 SP1 version

-Updated msvcrt.dll to version 6.1.9847.0 (838751) Replaces 2000 SP4 version

-Updated scrrun.dll to version 5.6.0.8830 (906092) Replaces Script 5.6 version

-Updated vbscript.dll to version 5.6.0.8829 (903648) Replaces Script 5.6 version

-Updated triedit.dll to version 6.1.0.9240 (2003 sp1) Rplaces XP SP2 version

-Updated dhtmled.ocx to version 6.1.0.9242 (906216) Replaces XP SP2 version

-Updated hhctrlui.dll to version 5.2.3664.0 (ie6 sp1) Replaces 811630 version

-Added webvw.dll from 900725 (reshacked to version 5.50.4134.7061)

-Added asfsipc.dll and npwmsdrm.dll from wmfdist7

-Added dxmasf.dll, mplayer2.exe, msdxmlc.dll, and strmdll.dll from media player 6.4 (included in ie6 sp1)

-Added 832353 (msdxm.ocx)

-Updated jscript.dll to version 5.6.0.8832 (919237) Replaces 917344

-Added 920670 (hlink.dll) Replaces 888113

-Added 922616 (hhctrl.ocx + reg entries) Replaces 896358 version

-Added 830460 (msvcirt.dll)

-Added new unofficial 918547 (gdi.exe + gdi32.dll) replaces 912919. Still unsure about leaving the 918547 files from MS (updated by an anonymous person).

For those wondering about where 832414 is, I removed it as it would require msxml 3 installed for WU to work.

the_guy

0

Share this post


Link to post
Share on other sites
-Added new unofficial 918547 (gdi.exe + gdi32.dll) replaces 912919. Still unsure about leaving the 918547 files from MS (updated by an anonymous person).

dump the kb918547.exe and q918547.dll files. I've removed them from beta 4 of the 98fe SP2 which will be posted tomorrow morning.

also modify your mesp202en.SED file and edit the TargetWin9xVersion and the TargetNTVersion sections of the SED file to have the following:

TargetWin9xVersion=4.90.3000:%OSWarn%:0K

TargetNTVersion=0:%OSWarn%:0K

Then in the [strings] section put this line:

OSWarn=This Service Pack is for Windows Millennium Edition only.

Starting from beta 3 of the unofficial 98FE SP2, when running the 98FE SP2 under other versions of Windows than Win98fe, a warning message will say "This Service Pack is for Windows 98 Standard Edition only." instead of the default message "The 'Unofficial Windows98 SP2' package is not compatible with the version of Windows you are running."

Edited by erpdude8
0

Share this post


Link to post
Share on other sites

also can you include versions 5.6.0.8827 of the cscript.exe, scrobj.dll, wscript.exe, wshext.dll and wshom.ocx files? these files are from Win2003 SP1.

0

Share this post


Link to post
Share on other sites

@erpdude: Thanks for the suggestions. I was thinking about doing that. I might even update vbscript.dll and jscript.dll to version 5.6.0.8833, included with IE7 Beta 2.

Also, does anyone know why dispex.dll version 5.6.0.8825 does not work on any 9x OS's?

the_guy

0

Share this post


Link to post
Share on other sites
Also, does anyone know why dispex.dll version 5.6.0.8825 does not work on any 9x OS's?

Dispex.dll versions 5.6.0.8515, 5.6.0.8825 and higher BREAK IE 5.5/6.0's Print and Print Preview functions under Win9xME. If you run IE 5.5 SP2 or IE 6.0 SP1 under Win9xME, and have Dispex.dll 5.6.0.8825 and you try to use the Print or Print Preview function of Internet Explorer, IE will display a "script error" message and the Print/Print Preview features of IE no longer work correctly. That's why we should stick with version 5.6.0.6626 of the dispex.dll file.

Microsoft did the right thing on not updating the dispex.dll file to higher versions when they released WSH 5.6 build 8825 for Win98/ME/NT4. Just like not updating the oleaut32.dll file. Oleaut32.dll versions 2.40.4526 & higher dont work correctly under Win9x/ME/NT4.

Edited by erpdude8
0

Share this post


Link to post
Share on other sites

Ok. What do you think about jscript.dll and vbscript.dll from IE7 beta 3?

the_guy

0

Share this post


Link to post
Share on other sites

Microsoft also did that for Windows Server 2003 SP0 on the same day. They also did that for 2000/XP back in June.

I think jscript.dll and vbscript.dll will be upgraded to 5.6.0.8833 in the next version unless someone else has a reason not to.

the_guy

0

Share this post


Link to post
Share on other sites
I think jscript.dll and vbscript.dll will be upgraded to 5.6.0.8833 in the next version unless someone else has a reason not to.

are the other WSH 5.6 files like cscript.exe, wscript.exe and wshom.ocx included in IE7 beta 3?

0

Share this post


Link to post
Share on other sites

No they are not. They are included with Vista beta 2 though, but I don't think that I should use those files.

the_guy

0

Share this post


Link to post
Share on other sites

The_guy, a curiosity, is it necessary installation of ie6 sp1 such as 98 SP?

I've prepared service pack for win me beta 6 in italian! :thumbup

Now I'm testing with my italian friends.

After I show you a link of reference.

0

Share this post


Link to post
Share on other sites

IE6 SP1 is NOT NECESSARY in this SP. Gape just recommends IE6SP1 i believe.

Thanks Max_04. As soon as I see a link, I'll add it to the main post.

the_guy

0

Share this post


Link to post
Share on other sites

If you want, you can add link now (see below).

You'll find it in the section of forum about Unofficial service packs Eng2ita.net

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.