• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Gape

98 SE SP 3.32

2,361 posts in this topic

I thought MSXML 4.0 SP2 supersede older versions. If it doesn't then I can add'em all.

I'm pretty sure that, just like .NET Framework, it doesn't. Occasionally there might be some app or other that requires Msxml.dll rather than Msxml2.dll, for example.

My opinion: make all MSXML versions apart from 2.5 SP3 optional. As I said, 2.5 SP3 is an update for the version that shipped with 98 SE.

Edited by bristols
0

Share this post


Link to post
Share on other sites

I thought MSXML 4.0 SP2 supersede older versions. If it doesn't then I can add'em all.

I'm pretty sure that, just like .NET Framework, it doesn't. Occasionally there might be some app or other that requires Msxml.dll rather than Msxml2.dll, for example.

Thanks I will add 2 and 4.

0

Share this post


Link to post
Share on other sites

These are the MSXML files I will be adding MSXML 2.5 SP3 + MSXML 4.0 SP2 in the next release.

MSXML.DLL 8.0.7002.0

MSXML4.DLL 4.20.9876.0

MSXML4A.DLL 4.10.9404.0

MSXML4R.DLL 4.10.9404.0

MSXMLA.DLL 8.0.6730.0

MSXMLR.DLL 8.0.6730.0

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

Apparently IE6 installs MSXML 2.5 SP 3 + MSXML 3.0 SP 7. Less work for me to do :thumbup

But I will add the updated MSXML3.DLL 8.70.1113.0 and MSXML 4.0 SP 2.

New update later today.

0

Share this post


Link to post
Share on other sites

Are you sure? Please check again carefully. I've seen msxml3.* in two IE6-SP1 cabs: IEMIL_3.CAB and IEW2K_4.CAB, which would belong to Millenium and 2000, respectively. Since we're talking about a 98SE package, let's make sure that MSXML3 is actually installed under Win98SE.

0

Share this post


Link to post
Share on other sites

Well, I just did a clean install with 98lite pro

ripped out xml support ,updated IE6 with the web installer, and version 2 and 3 of MSXML was on my system.

It had to be IE6 that put it there because I check before I installed anything.

0

Share this post


Link to post
Share on other sites

Web installer? Hmmm... What would that be? I have a (presumably) full package of IE6-SP1 somewhere on my HDD, complete with language packs. Could you check whether my package misses something?

And somebody tell me why can't I upload a file to MSFN !?!

IE6 file list

Edited by Drugwash
0

Share this post


Link to post
Share on other sites

Just run the ie6setup.exe without the cab files and IE6 will update :thumbup of course you'll need a internet connection.

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

... an Internet connection capped at 5GB monthly, after which the download speed will become ridiculously low to be usable.

My current IE folder is 72,489,803 bytes, containing the files in the above-posted list. Last time I did a so-called web update, I remember having selected "download only" or something similar (after having selected all possible options,including language packs), so that all missing packages were downloaded and stored in the IE6 folder, so I assumed the folder would contain a full IE6 install kit. Don't forget there may be situations where a machine can't connect to the Internet right away (or ever), so the offline IE install kit should contain everything possible

[EDIT]

Forgot to say that certain IE6 libraries may actually be required by some applications to be able to run/display properly. MS released (deliberately or not - this is not the point right now) some system libraries only together with IE6 and in time, programmers took advantage of these updates, so whatever 9x-compatible applications out there, may well require these libraries. So it's not just a matter of "I hate IE so I remove it from my system", but a simple compatibility issue: if you want certain applications to run, you better update and keep all your IE libraries in your system. If you want, you may rename IEXPLORE.EXE to something else, as I did long ago, but removing all IE-related libraries from a system is a big mistake in my not-so-newbish opinion.

Edited by Drugwash
0

Share this post


Link to post
Share on other sites

I think it just a matter of time before M$ take it down. This is the only way I update IE6. Never done it with the full package.

I never had problems this way either.

0

Share this post


Link to post
Share on other sites

The more important that someone puts together a really fully package for offline installation, should anything happen to the online "pipe". Supposedly that would've been the case with soporific's UBCD, but I'm not sure it actually did contain the complete package.

Fortunately, yesterday I managed to revive my broken PM9MS mobo by replacing 5 gonflated capacitors (to a total of 19 replaced on that mobo since I got it), so I could now mount a spare HDD on the other machine and try to put together a full IE6 package through a web install. But that'll take some time and only after I get to cook something for the next week, coz working on an empty stomach is not pleasant. ;)

Edited by Drugwash
0

Share this post


Link to post
Share on other sites

Drugwash: I have the very same files in my IE6 package. Besides updates they are the latest afaik.

0

Share this post


Link to post
Share on other sites
:thumbup Updated :w00t: Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

Removed ASPI

Why are you removing ASPI. It is needed to directly access CD/DVD Drives.

0

Share this post


Link to post
Share on other sites

Why are you removing ASPI. It is needed to directly access CD/DVD Drives.

No 3rd party applications as of this point.

0

Share this post


Link to post
Share on other sites

I personally have no use for this pack so please feel free to ignore my opinion that it is not a good idea to 1) remove ASPI, and 2) include a stub for installing IE6 off Microsoft's servers.

Edited by loblo
0

Share this post


Link to post
Share on other sites

I personally have no use for this pack so please feel free to ignore my opinion that it is not a good idea to 1) remove ASPI, and 2) include a stub for installing IE6 off Microsoft's servers.

First of all who added a stub?

Second Adaptec is a 3rd party app. I removed this long time ago. You can always download it here http://www.adaptec.com/en-us/speed/software_pc/aspi/aspi_v471_exe.htm

3rd, if you don't use the pack why even comment. You are more than welcome to download a few hundred updates and install them 1x1. While your system is outdated mines will be updated.

I mean, do you accept ideas from BOTH Win9x AND Me users or you just want to meet the other 3 (three) persons in the worlds that run normally Windows Me? ;):angel:whistle:

:lol:

jaclaz

What's that actually supposed to mean?

Typical flame bait trolling IMO. :rolleyes:

Way to go Jaclaz! :thumbup

Looks like you doing the same thing :w00t:

Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites

Children, play nice, please. ;)

Let's not carve things in stone - Adaptec's ASPI is not an application, strictly speaking, but a driver and it is required on most systems that operate an optical CD/DVD unit. Sure, Ahead's Nero does install its own driver for this purpose, but that is a commercial application, while Adaptec released their driver freely, so I'd say let it in. After all, we don't need a 100% MS setup - we need a 100% functional system that can do the most possible, given the circumstances.

Personally I'd be more concerned about any possible issues such as dll version mismatching, BSOD, etc. reported by users through the topic (if any). I'd imagine Gape has gathered such information, in time and tweaked the pack accordingly; let's be careful and not throw all his work to the bin, shall we? ;)

0

Share this post


Link to post
Share on other sites

Why are you removing ASPI. It is needed to directly access CD/DVD Drives.

No 3rd party applications as of this point.

It is part of the standard set of drivers provided by Microsoft. I'm sure I am not the only one who distributes applications that use it.

0

Share this post


Link to post
Share on other sites

Why are you removing ASPI. It is needed to directly access CD/DVD Drives.

No 3rd party applications as of this point.

It is part of the standard set of drivers provided by Microsoft. I'm sure I am not the only one who distributes applications that use it.

I will add them back. I did not know they were drivers. Thanks Drugwash and rloew :thumbup

0

Share this post


Link to post
Share on other sites
:thumbup Updated :w00t: Edited by PROBLEMCHYLD
0

Share this post


Link to post
Share on other sites
Looks like you doing the same thing :w00t:

Sorry to see you taking it this way as I was just trying to be helpful.

0

Share this post


Link to post
Share on other sites
Looks like you doing the same thing :w00t:

Sorry to see you taking it this way as I was just trying to be helpful.

Well, I apologize if I misunderstood you. I'm sorry :blushing:

0

Share this post


Link to post
Share on other sites

No worries. :)

Thanks

The last and final update will include from MDGx site.

ATL70A.DLL

ATL71A.DLL

MFC70.DLL

MFC70U.DLL

MFC71.DLL

MFC71U.DLL

MSVCI70.DLL

MSVCP70.DLL

MSVCP71.DLL

MSVCR70.DLL

MSVCR71.DLL

I'm sorry that I wasn't able to add the 4 usb packages, let me explain why.

NUSB.EXE - it works with some of my usb devices but not all.

USB20DRV.EXE - needed to run side by side with NUSB.EXE.

WIA11.EXE - I don't have a scanner so I can't test this.

X360C.EXE - it works when I have both NUSB.EXE + USB20DRV.EXE + HKR,,NTMPDriver,,"wdmstub.sys,USBSTOR.SYS has to be loaded in order for it to work. Thats just too much trouble.

But if someone can combine the 2 NUSB.EXE + USB20DRV.EXE we might have something.

Other than that, the only things that's not added are

Internet Explorer

DirectX 9

Microsoft Data Access Components

.NET Framework

Soon you guys will be able to enjoy a fully updated 98SE SP. Thanks to Gape for starting the foundation :thumbup:w00t:

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.