Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  
Gurgelmeyer

CPU HALT bug in MSURP1

Recommended Posts

Gurgelmeyer    0

Hi :)

I recently digged into this, and this might be the answer: the only hotfix included in the MSURP1 which requires an updated HALMACPI.DLL is the KB835730 fix. The KB article also mentions P4 HT and "the C3 power-saving state", so I borrowed a P4 laptop with HT and tried all post-sp4 versions of HALMACPI.DLL. Version 5.0.2195.6988 mentioned in the KB artivle and all later versions seemed to have this problem. Second time I tested I modified the registry after installing the KB835730 fix as described in the KB. That certainly made a difference with all versions of this file - even with the MSURP1.

The registry change I'm referring to is this

• Edit the registry Add a DWORD value named 14140000FFFFFFFF that has a value of 00000010 to the following registry setting: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\HAL

Maybe MS forgot this setting in the URP1 (it's not there - I checked) ? Or maybe it only works with Dell hardware? Dono :no:

Best regards,

Gurgelmeyer B)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×