Sign in to follow this  
Followers 0
scibott

ehshell.exe

13 posts in this topic

I am currently receiving this error message while attempting to run Media Center:

-

ehshell.exe - Common Language Runtime Debugging Services

Application has generated an exception that could not be handled.

Process id=0xe98 (3736), Thread id=0xe9c (3740).

Click OK to terminate the application.

Click Cancel to debug the application.

-

Here is the debugger error, which I know what it's problem is.

-

ehshell.exe - No debugger found.

Registered JIT debugger is not available. An attempt to launch a JIT debugger with the following command resulted in an error code of 0x2 (2). Please check computer settings.

cordbg.exe !a 0xe98

Click on Retry to have the process wait while attaching a debugger manually.

Click on Cancel to abort the JIT debug request.

-

Now in the first dialog each time I run Media Center new Prcess and Thread ids are reported. I have my speculations as to why that is as it being run as a new process since the computer has been runing. However this does not answer why a new thread id is reported. My question is this, has anyone encountered this before, and how do I repair it.

Edited by scibott
0

Share this post


Link to post
Share on other sites

I also had this error. It was after I installed Update Rollup 2 for Media Center. Something went wrong I guess. Unintalled it, reinstalled, followed by the little update fix and everything worked fine.

0

Share this post


Link to post
Share on other sites

Which update fix would that have been, KB908250, KB873369, KB888316, or one of the standard Windows XP updates?

0

Share this post


Link to post
Share on other sites

It is an update for the Media Center Update Rollup 2. After you installed the big update, there is another small update fix available. I don't know the KB number. But I don't know if it has something to do with it. I geuss it was just me who did something wrong or messed to much in the ehome folder.

0

Share this post


Link to post
Share on other sites

the message migtht due 2 improper working of .NET framework

for MCE without rollup2 .net framwork 1.0.3705 is sufficient

for rollup2 1.1.4322 required

install proper ver.of .net and try

0

Share this post


Link to post
Share on other sites

@ scibott

Did you use nLite to create an unattended installation of Media Center?

0

Share this post


Link to post
Share on other sites

Just been seeing something similar to this myself on an unattended install.

Could be the Dot Net, or media player update issue, or something else!!

Anyway found This site to be quite useful. The Archives for Jan & Feb also contain some good stuff for media center.

Good Luck & please post back a solution if you sort it, would be useful info. My issue was the media player update as is now sorted.

0

Share this post


Link to post
Share on other sites

You musn't use any of the compacted versions of .netFramework like the Hotfix addon or the version in Autopatcher. They are not full complete versions. Download & install the full redist package & service pack etc. & it will all work.

0

Share this post


Link to post
Share on other sites

I've run into this error myself. The cause was ffdshow or something or other installed with KLite Mega. I've since did a minimal install of KLITE and no more errors. So it could be a codec. or not.

0

Share this post


Link to post
Share on other sites

Apert from the obvious the worst thing you can do to your PC is use Codec Packs. They conflict & cause untold damage to your installation. Keep it simple! Keep it sweet! Keep it smilng!

0

Share this post


Link to post
Share on other sites

Hello,

im a newbie and im not so great when it comes to pc's i have a similar problem to that of the person starting this topic except my codes are different. When i push the green button on my remote control mine says.

EHShell.exe - Strong name validation failed.

Strong name validation failed for assembly C:\windows\ehome\EHShell.exe

The file may have been tampered with or it was partially signed but not fully signed with the correct private key.

OK.

After pressing on OK another box comes up with

EHShell.exe Common Language Runtime Debugging Services.

Application has generated an exception that could not be handled

Process id=0x62c (1580), Thread id=0x58(3416)

Click OK to terminate application

Click Cancel to debug

So i click cancel to debug it when ANOTHER message appears saying

EHShell.exe - No debugger found

Registered JIT debugger is not available. An attempt to launch with the following command resulted in an error code of 0x2(2)

Please check computer settings.

Cordbg.exe !a0x62c

Click on Retry to have the process wait while attatching a debugger manually

Click on Cancel to abort the JIT debug request

Ive tried clicking on both but nothing seems to happen.

Im really confused the last time i used it and it was working properly i was setting it up to watch tv on and im not 100% sure if i exited the media centre properly. i tried to download Update Rollup1 for windows xp media centre but couldnt find rollup 2...... any ideas if this would help.

As i said im pretty crap with pcs so if any advice is given in the most simplest of terms i would be SOOOOOOO greatful.

Thanx

0

Share this post


Link to post
Share on other sites
Hello,

im a newbie and im not so great when it comes to pc's i have a similar problem to that of the person starting this topic except my codes are different. When i push the green button on my remote control mine says.

EHShell.exe - Strong name validation failed.

Strong name validation failed for assembly C:\windows\ehome\EHShell.exe

The file may have been tampered with or it was partially signed but not fully signed with the correct private key.

OK.

After pressing on OK another box comes up with

EHShell.exe Common Language Runtime Debugging Services.

Application has generated an exception that could not be handled

Process id=0x62c (1580), Thread id=0x58(3416)

Click OK to terminate application

Click Cancel to debug

So i click cancel to debug it when ANOTHER message appears saying

EHShell.exe - No debugger found

Registered JIT debugger is not available. An attempt to launch with the following command resulted in an error code of 0x2(2)

Please check computer settings.

Cordbg.exe !a0x62c

Click on Retry to have the process wait while attatching a debugger manually

Click on Cancel to abort the JIT debug request

Ive tried clicking on both but nothing seems to happen.

Im really confused the last time i used it and it was working properly i was setting it up to watch tv on and im not 100% sure if i exited the media centre properly. i tried to download Update Rollup1 for windows xp media centre but couldnt find rollup 2...... any ideas if this would help.

As i said im pretty crap with pcs so if any advice is given in the most simplest of terms i would be SOOOOOOO greatful.

Thanx

The same things happen to me 2 but i just have a different number :|

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.