Sign in to follow this  
Followers 0
dskyze

Am I SOL on HFSLIP? Winxp cd sp1a integrated

11 posts in this topic

The cd I have is Winxp cd with SP1a integrated. Is it impossible to run HFSLIP? Or more specifically when I try to integrate SP2, I get an error message that "This Service Pack cannot be integrated into a destination that also has integrated Software updates." Am I SOL? :no:

0

Share this post


Link to post
Share on other sites

Which command are you using to integrate SP2 and are you doing it before running HFSLIP?

0

Share this post


Link to post
Share on other sites

You're not SOL. I think you may have to either remove (or rename) your svcpack.in_ file and/or remove (or rename) your svcpack folder.

0

Share this post


Link to post
Share on other sites
Which command are you using to integrate SP2 and are you doing it before running HFSLIP?

I had copied i386 directory from the Windows CD to D:\

and now I'm on step #2

Here's what I've done

Saved the SP to D:\SP

Opened a command prompt and typed D:\SP\WindowsXP-KB835935-SP2-ENU.exe -x to extract the sp

Specified D:\sp for the directory to expand to

And here's the command I get stuck on.

When I type D:\sp\i386\update\update.exe -s:D:\ then it gives me the popup error.

Just FYI I successfully created a win2k with sp4, all update, dx9, mp9 using the win2k steps just fine.

My guess is my cd is already slipstreamed with sp1? :}

0

Share this post


Link to post
Share on other sites

Try this method:

Create a new directory on your D: partition i.e. WIN51IP.SP2

Move your Winxp with SP1a integrated D:\I386 directory to this new D:\WIN51IP.SP2

The path to the source is now D:\WIN51IP.SP2

Copy all files from the root of your original Winxp CD with SP1a integrated to D:\WIN51IP.SP2

The slipstream process may looks for ident files before slipstreaming latest SP.

now try to slipstream SP2 to your WinXP SP1a image with:

D:\sp\i386\update\update.exe -s:D:\WIN51IP.SP2

0

Share this post


Link to post
Share on other sites

There's another method too.

Copy the CD source into (for example) D:\WINXPSRC

Copy the SP2 installer into (for example) D:\

Then run this command:

D:\WindowsXP-KB835935-SP2-ENU.exe -s:D:\WINXPSRC\

0

Share this post


Link to post
Share on other sites
There's another method too.

Copy the CD source into (for example) D:\WINXPSRC

Copy the SP2 installer into (for example) D:\

Then run this command:

D:\WindowsXP-KB835935-SP2-ENU.exe -s:D:\WINXPSRC\

Try this method:

Create a new directory on your D: partition i.e. WIN51IP.SP2

Move your Winxp with SP1a integrated D:\I386 directory to this new D:\WIN51IP.SP2

The path to the source is now D:\WIN51IP.SP2

Copy all files from the root of your original Winxp CD with SP1a integrated to D:\WIN51IP.SP2

The slipstream process may looks for ident files before slipstreaming latest SP.

now try to slipstream SP2 to your WinXP SP1a image with:

D:\sp\i386\update\update.exe -s:D:\WIN51IP.SP2

Thanks guys but tried it both ways it didn't work. Gave me same error.

However, Using Tommy Ps idea I renamed SVCPACK.INF to SVCPACK.___ and that got it to work! I guess I shoulda just deleted it. Thanks Tommy.

I was able to burn the cd ok. I ran into a couple of things though. First thing I ran into is for one I got a warning and unfortunately I was pressed for time to read it all but it was about system restore and the install of Windows Media Player 9 install. Has anyone seen that problem b4? I was able to hit ok to bypass it but I was hoping to somehow avoid it popping up. I used the integrated method (mpsetupxp.exe in HFSVPK_SW).

Second the other problem I had was with KB898461. Windows update asked me to install it. I have the WindowsXP-KB898461-x86-ENU.exe in my HF folder.

Any ideas on the 2 things above?

0

Share this post


Link to post
Share on other sites

We can help if you post your error_report and hfnetchk logs. BTW, SP2 already has WMP9. There is no need to install it. As far as the 898461, there is a residual error when I went to town modifying HFSLIP this past weekend.

Line 1343 has an extra space. Edit as follows and you should be OK.

is

ECHO 1000 = system32\PreInstall\WinSE\%PKG% >>SOURCESS\I386\TXTSETUP.SIF

should be

ECHO 1000 = system32\PreInstall\WinSE\%PKG%>>SOURCESS\I386\TXTSETUP.SIF

Edited by tommyp
0

Share this post


Link to post
Share on other sites
BTW, SP2 already has WMP9. There is no need to install it. As far as the 898461, there is a residual error when I went to town modifying HFSLIP this past weekend.

Thanks Tommy good 2 know. :thumbup I've removed mpsetup that should take care of first probem.

Line 1343 has an extra space. Edit as follows and you should be OK.

is

ECHO 1000 = system32\PreInstall\WinSE\%PKG% >>SOURCESS\I386\TXTSETUP.SIF

should be

ECHO 1000 = system32\PreInstall\WinSE\%PKG%>>SOURCESS\I386\TXTSETUP.SIF

Ok made the edit..for my next run. That should take care of second problem.

We can help if you post your error_report and hfnetchk logs.

Ok let me first mention that when I ran windowsupdate from 62nds it says that I don't have kb885836 and kb905915. I do have both in my HF directory. As requested here's my error report:

COMPLETE THIS FILE AND ATTACH IT TO THE MESSAGEBOARD IF YOU RUN INTO PROBLEMS.

http://www.msfn.org/board/index.php?showforum=129

=======================YOU MUST COMPLETE THIS SECTION==========================

- Make a hfnetchk log - this is the COMMANDLINE HFNETCHK -V -F C:\WU.TXT

- Other errors, not reported by HFNETCHK

- Zip the information above and this file and post the info on the board listed on top.

=========================DO NOT ALTER THE SECTION BELOW========================

HFSLIP Version -

HFSLIP_60119.CMD

Your path - D:\HFSLIP\

OS you are slipstreaming - XP

Language you are working with - English

==============================================================================

The files in your FIX folder -

Names of the files in your HF folder:

gdidettool.exe

msxmlcab.exe

scripten.exe

windowsinstaller-kb893803-v2-x86.exe

Windows-KB890830-V1.12-ENU.exe

WindowsXP-KB873339-x86-ENU.exe

WindowsXP-KB885250-x86-ENU.exe

WindowsXP-KB885626-v2-x86-enu.exe

WindowsXP-KB885835-x86-ENU.exe

WindowsXP-KB885836-x86-ENU.exe

WindowsXP-KB886185-x86-enu.exe

WindowsXP-KB887472-x86-enu.exe

WindowsXP-KB887742-x86-ENU.exe

WindowsXP-KB887797-x86-enu.exe

WindowsXP-KB888113-x86-ENU.exe

WindowsXP-KB888302-x86-ENU.exe

WindowsXP-KB890046-x86-ENU.exe

WindowsXP-KB890859-x86-ENU.exe

WindowsXP-KB891781-x86-ENU.exe

WindowsXP-KB893066-v2-x86-ENU.exe

WindowsXP-KB893756-x86-ENU.exe

WindowsXP-KB894391-x86-ENU.exe

WindowsXP-KB896358-x86-ENU.exe

WindowsXP-KB896422-x86-ENU.exe

WindowsXP-KB896423-x86-ENU.exe

WindowsXP-KB896424-x86-ENU.exe

WindowsXP-KB896428-x86-ENU.exe

WindowsXP-KB898461-x86-ENU.exe

WindowsXP-KB899587-x86-ENU.exe

WindowsXP-KB899589-x86-ENU.exe

WindowsXP-KB899591-x86-ENU.exe

WindowsXP-KB900725-x86-ENU.exe

WindowsXP-KB901017-x86-ENU.exe

WindowsXP-KB901214-x86-ENU.exe

WindowsXP-KB902400-x86-ENU.exe

WindowsXP-KB904706-v2-x86-ENU.exe

WindowsXP-KB905414-x86-ENU.exe

WindowsXP-KB905749-x86-ENU.exe

WindowsXP-KB905915-x86-ENU.exe

WindowsXP-KB908519-x86-ENU.exe

WindowsXP-KB910437-x86-ENU.exe

WindowsXP-KB912919-x86-ENU.exe

WindowsXPMediaCenter2005-KB900325-usa.exe

wmcsetup.exe

Names of the files in your HFCABS folder:

Apr2005_d3dx9_25_x86.cab

Aug2005_d3dx9_27_x86.cab

Dec2005_d3dx9_28_x86.cab

Dec2005_MDX1_x86.cab

Dec2005_MDX1_x86_Archive.cab

dxdllreg_x86.cab

Feb2005_d3dx9_24_x86.cab

Jun2005_d3dx9_26_x86.cab

LegitCheckControl.cab

Oct2005_xinput_x86.cab

Names of the files in your HFSVPK folder:

adawarese106.EXE

firefox15.EXE

jre506.exe

MicrosoftAntiSpyware.exe

reader705.exe

spybot14.EXE

winrar351.EXE

winzip9.EXE

Names of the files in your HFSVPK_SW folder:

MPSetupXP.exe

Names of the files in your HFTOOLS folder:

boot.bin

==============================================================================

0

Share this post


Link to post
Share on other sites

You are using a buggy & old version of HFSLIP. Please download the latest version and all *should* be ok.

0

Share this post


Link to post
Share on other sites
You are using a buggy & old version of HFSLIP. Please download the latest version and all *should* be ok.

That fixed everything man..THanks so much! Now I'm just working on getting all my add-ons to work. It's almost perfected.

Thanks again!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.