• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
mraeryceos

What Not To Remove For Some Programs

193 posts in this topic

made several nLited iso, installed them in Virtual PC... but in many, VirtualMachine Additions don't want to install (MSI launches install but does a rollback before the end)...

I already figured that "file and printer sharing" network component is needed in order to execute setup up to the end.

However, in some cases, after install and a reboot, mouse integration doesn't work, shared folders aren't available, etc. and also cannot uninstall (same problem: try but rollback)!

some iso are working, but they are very very few nLited (ie. remove 2-3 components and no tweak at all)

I know, should do (many) bunch testing try-and-see; but to be honest I'm too tired, I'm busy of nLiting, breaks too many things, not enough infos of "this component is used by X and Y", no real dependencies management... and each test takes a LOT of time espacially on my turtle computer

so I drop, before I become crazy :P

0

Share this post


Link to post
Share on other sites

Windows XP Pro SP3 - Corporate - English

SP3 directly integrated on SP0 (vanilla) source, then latest RyanVM UpdatePack, then WMP11+hotfixes using WMP11 Slipstreamer, then IE7 addon by OnePiece, using RyanVM/Siginet Integrator

Even on a very little nLited source, Additions can install, but if try to uninstall them, uninstall process fails, however after reboot no mouse integration, shared folders etc. and need to do some heavy registry deletions in order to be able to reinstall Additions and make it working again.

As I said, I'm very very busy of that breaking events... on my working source, I will simply try to remove some components that annoy me, like firewall/ALG, QoS, etc. and see if they're needed for Additions. It can also simply be network tweaks... absolutely no idea as of now...

could try some process/file access monitor on an unmodified source, or step-after-step image comparison... but I'm tired of it and simply don't have time :rolleyes: (work+studies...)

0

Share this post


Link to post
Share on other sites

How do you expect that to help with nlite development that you fail to make a proper windows install cd? If you could come up with a detailed problem then that's good.

0

Share this post


Link to post
Share on other sites

I'm new to this forum, have just skimmed through the first 8 pages of this thread and done a few searches on the terms "HID" and "Human Interface Device" and not found an answer. Sorry if I have overlooked it.

In line with this thread's title, what shouldn't be removed during an nlite modification to maintain HID module functionality?

I am running XP with SP3 slipstreamed using nlite.

I apparently removed a component necessary for the HID service. I don't recall seeing it listed in the nlite "Remove components" window.

I just purchased a UPS with a third-party monitoring software that requires this service in order to work. I would like to run the monitoring service software because I live in an area with very unstable electrical transmission and have had an expensive power supply and monitor toasted previously.

Does anyone have information on which other components are necessary for the Human Interface Device service module to be installed and run properly?

If this has been addressed previously, a link would be nice.

0

Share this post


Link to post
Share on other sites

Briefly looking into hid service, it does point to winsta.dll. I remember having the same issue that you have here but i dont recall what was needed to not remove for it to work.

0

Share this post


Link to post
Share on other sites

TranceEnergy,

Thanks for your reply, if you can remember or come up anything on this service and what needs to be kept using nlite for it to be maintained that would be fantastic. I will keep monitoring this thread. :)

0

Share this post


Link to post
Share on other sites

A last session preset or such would help. Naturally you should stay clear of removing anything USB related to keep HID service working perfectly. Im not sure, but the first thing that popped into my head was terminal services, but that may be totally unrelated. As i said, i can't remember exactly, and my memory can't be forced =( As far as removal of components goes, if things will work or not, is always a question of what hardware the computer has. As a thumb rule, older devices needs things like those under "hardware support", newer devices most likely doesnt. And that again, is of course also dependent on the version of the driver of the hardware.

0

Share this post


Link to post
Share on other sites
I just purchased a UPS with a third-party monitoring software that requires this service in order to work. I would like to run the monitoring service software because I live in an area with very unstable electrical transmission and have had an expensive power supply and monitor toasted previously.

Does anyone have information on which other components are necessary for the Human Interface Device service module to be installed and run properly?

Maybe (i used translation.txt file to get this) Battery:

S323="Battery"

S324="Microsoft ACPI-Compliant Control Method Battery, HID UPS Battery Driver. Don't remove if you use this installation on a laptop/notebook."

Be carefull because UPS are not (all) power protection enabled, i own a stabilizer (kind of) where the V should stay 110V-120V but it always goes up to 134V.

Have fun! :thumbup

0

Share this post


Link to post
Share on other sites

Here is a wild guess :

Since i dont have a UPS myself, i dont know, but SURELY some UPS must come with some kind of software for monitoring its condition etc?

This would be very interesting to hear from if anyone has such software. Because the current UPS driver, at least for xp, even x64 in my case, is getting very old nowadays.

What i am getting is that how UPS works and such quite possibly works not according to windows services themselves.

0

Share this post


Link to post
Share on other sites
Bootvis

Required: Task Scheduler

Error: Bootvis won't start on next boot without Task Scheduler.

this is not true...

Can you please develop? Because I've tried 3 or 4 times to optimize my booting time with bootvis but it doesn't want to do it_ it needs the Windows defragmenter which apparently needs the task scheduler to work. i've tried defragging with a third party app then run the optimization again. But it still doesn't work. if you know a way of making bootvis without task scheduler, you are welcome to explain: I can't find the task scheduler in TinyXP09 and I suspect it's been removed.

0

Share this post


Link to post
Share on other sites
Since i dont have a UPS myself, i dont know, but SURELY some UPS must come with some kind of software for monitoring its condition etc?

This would be very interesting to hear from if anyone has such software. Because the current UPS driver, at least for xp, even x64 in my case, is getting very old nowadays.

Exactly.

The UPS I have comes with monitoring software bundled. The software is call "PowView".

I can post a screenshot of its display from the user manual if you want.

The UPS can be connected to the PC with either a USB or LAN cable to use PowView monitoring.

0

Share this post


Link to post
Share on other sites

Concerning UPS, i was wondering if the windows UPS service was actually needed. I'll try to see if i can get hold of that software. Any pictures or such wont help much unfortunately.

0

Share this post


Link to post
Share on other sites
Concerning UPS, i was wondering if the windows UPS service was actually needed.

I have previously installed PowView and connected the UPS to my PC using the provided USB cable. The software seemed to install properly and the PowView UI window opens but I didn't get any info from the UPS, so it seemed like it does need the HID service enabled and running in order to function properly and provide real-time monitoring of power.

0

Share this post


Link to post
Share on other sites

Ultravnc service needs Terminal Service to properly work per my experience.

Although ultravnc will install if terminal services is disabled upon reboot the server component won;t properly load. Upon activation of terminal services after a reboot the service load properly.

0

Share this post


Link to post
Share on other sites
Ultravnc service needs Terminal Service to properly work per my experience.

Although ultravnc will install if terminal services is disabled upon reboot the server component won;t properly load. Upon activation of terminal services after a reboot the service load properly.

Have you tried to see if u can just remove the dependency?

0

Share this post


Link to post
Share on other sites

:hello: Hello everybody and a Happy New Year! :thumbup

Does anybody know what not to remove for Deep Freeze?

Thank you in advance.

0

Share this post


Link to post
Share on other sites

The dutch tax program 2008 (belastingaangifte 2008) does need help&support installed. Without it will give an error and exit.

0

Share this post


Link to post
Share on other sites

Hi,

for my wireless connection, if I want to make Windows "repair" it, I need these services :

connection manager : works if set to "manual", however it is always started as soon as network is running so I personally set it to "automatic"

cryptographic services : I just discovered about this one today. If it is not running, Windows cannot even disable the adapter. If set to "manual" but is not running, Windows don't start it so it fails. I used to set it to "manual", however I remember I always seen this service running. Should be started by Windows at boot. Now will set this one to "automatic"

network location awareness (NLA) : the same as cryptographic service except it is not adapter disabling that fails, but the the IP acquisition step. repair process hangs.

DHCP client : again the same except it is final registration step that fails. displays a message box "failed at DNS register". and DNS client nearly the same, it fails just before, at releasing the previous DNS set.

as you can see, crypto, NLA, DNS and DHCP are called at different steps of the repair process. I think these services might be crucial for wired connections too. Also, I've already constated removing too many network-related components can lead to serious issues, like impossibility to accept incoming connection requests (server-oriented apps).

about my config : manually set adresses, no DHCP server on the network, do not use the Windows wireless assistant, no WEP or WPA

regards

Edited by OuTmAn
0

Share this post


Link to post
Share on other sites

what i need to leave so i will have conection to the internet with Router throw Ethernet cable ??

i tryed not to delete so much this but i allways delete something and i dont have connection :(

0

Share this post


Link to post
Share on other sites

to begin, try if working with non-nLited install

some advices:

cmd run "ipconfig /a", look at results

(is your interface up and assigned with correct addresses?)

ping 127.0.0.1 (localhost)

ping hosts of local network

ping known internet IP like 208.67.222.222 (this one is OpenDNS server)

Edited by OuTmAn
0

Share this post


Link to post
Share on other sites

Langage Bar; If you check to remove, apparently it disables the Quick Lanch. Anyone confirm this?

0

Share this post


Link to post
Share on other sites

in my installs I always remove the language bar, and the quicklaunch isn't show by default. but I don't know if this is related to the language bar removal.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.