Charlie.

Problem: Synchronizing Time on 2k3 PDC with External Source

27 posts in this topic

For those who run into this issue...

My problem was solved by reading the diagnostic steps in the article referenced by Charlow:

...

15. Check the Default Domain Controllers group policy and the Default Domain group policy and any others that could affect the PDCe or other DCs. Check the following areas:

Computer configuration/Administrative Templates /System/Windows Time service/Time Providers

Ensure that all three settings listed are set to “not configured”.

...

Lamphax

Thank you so much! I too have spent months trying to find the solution to this problem. I too have been through all of the registry settings dozens of times. I caught a lot of grief for the time becoming 'off'.

I was especially confused because I even tried using 'atomic clock' programs and they returned the same error as the Windows Time Service. I knew it couldn't be that UDP port 123 was blocked because other DC's and workstations were able to run the atomic.exe program with no problems. It was a real head scratcher.

Most of my policy setting were correct, but one was wrong. I changed it and rebooted my PDC. I went back through all of the registry and w32tm settings one more time just to make sure they were correct. Everything works now.

Thanks for sticking with this problem and finding a solution. I really appreciate your help! :thumbup

Conic

0

Share this post


Link to post
Share on other sites

All the above solutions still did not work for me. The policies were all set to "not configured". I tried to set them to "disabled", rebooted the machine, reset them to "not configured", rebooted, but to no avail.

Finally I found that policies get stored in the registry as well.

After renaming the following keys in :

\HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\W32TIME\

CONFIG to _CONFIG

PARAMETERS to _PARAMETERS

TIMEPROVIDERS to _TIMEPROVIDERS

and restarting w32time,

at last w32tm started reading the normal - documented - registry settings and this solved the problem for me as well.

( :angry: 8 hours wasted thanks to policy settings that do not appear in the policy editor or did I look in the wrong place?)

0

Share this post


Link to post
Share on other sites

I had to become a member of this forum - just to say a big THANKS to all that participated on this thread...

My problem was my PDCe continually bouncing back "The computer did not resync because no time data was available."

I spent literally hours scouring the web for solutions, finding great amounts of valuable information but this particular thread, I believe is the most helpful! My problem came down to the solution that annab2, so THANK YOU VERY MUCH - I sincerely appreciate everyone's time spent (no pun intended).

I have one question to add if I may... Our secondary DC is returning a NTP: error ERROR_TIMEOUT - no response from server in xxxxms. I have checked the registry settings to ensure that those pesky GPO inherited registry settings are removed, and checked that the DC is set in its default state, so it supposedly will sync automatically with the PDCe.

Running a w32tm /monitor command returns

C:\>w32tm /monitor
cde01.domainname.local *** PDC *** [xx.x.2.1]:
ICMP: 589ms delay.
NTP: +0.0000000s offset from cde01.domainname.local
RefID: reptile.digitalriver.com.au [121.54.129.52]
abc01.domainname.local [xx.x.1.4]:
ICMP: 0ms delay.
NTP: error ERROR_TIMEOUT - no response from server in 1000ms

Appreciate any help on this related subject... thanks.

Cheers

tropolite

0

Share this post


Link to post
Share on other sites

Fortunately with a bit of persistance I was able to resolve the NTP: error ERROR_TIMEOUT - no response from server in 1000ms problem.

My solution -

On the secondary DC that was returning the error I;

- made sure that W32time service was running

- reset HKLM\System\CurrentControlSet\Services\W32Time\Parameters\NTPServer to time.windows.com,0x1

- reset HKLM\System\CurrentControlSet\Services\W32Time\Parameters\Type to NT5DS

- reset HKLM\System\CurrentControlSet\Services\W32Time\TimeProviders\NtpServer\Enabled is set to 1

- closed Regedit and in the command prompt ran - net stop w32time && net start w32time

- and lastly ran - w32tm /monitor which will confirm the PDCe and DC/s running (hopefully) correctly.

C:\>w32tm /monitor
cde01.domainname.local *** PDC ***[xx.x.2.1:123]:
ICMP: 582ms delay
NTP: +0.0000000s offset from cde01.domainname.local
RefID: reptile.digitalriver.com.au [121.54.129.52]
Stratum: 3
abc01.domainname.local *** PDC ***[xx.x.1.19:123]:
ICMP: 0ms delay
NTP: -0.0044411s offset from cde01.domainname.local
RefID: cde01.domainname.local [xx.x.2.1]
Stratum: 4

I hope this is somewhat helpful to others having similar issues...

Cheers

tropolite

0

Share this post


Link to post
Share on other sites
All the above solutions still did not work for me. The policies were all set to "not configured". I tried to set them to "disabled", rebooted the machine, reset them to "not configured", rebooted, but to no avail.

Finally I found that policies get stored in the registry as well.

After renaming the following keys in :

\HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\W32TIME\

CONFIG to _CONFIG

PARAMETERS to _PARAMETERS

TIMEPROVIDERS to _TIMEPROVIDERS

and restarting w32time,

at last w32tm started reading the normal - documented - registry settings and this solved the problem for me as well.

( :angry: 8 hours wasted thanks to policy settings that do not appear in the policy editor or did I look in the wrong place?)

This was EXACTLY my problem. I have used a couple of days to solve this problem.

My PDC Emulator is running 2003 x64

I ran the "Group Policy Results Wizard" on our x86 DC and found out, that the settings came from the "Local Group Policy"

On the "Group Policy Challenged DC" I then ran MMC

Add/Remove Snapin

Select "Group Policy Object Editor"

Select "Local Computer" as the "Group Policy Object" (This is the default value)

Go to "Local Computer Policy", "Computer Configuration", "Administrative Templates", "System", "Windows Time Service"

Make sure that the settings are "not configured", also under "Time Providers"

My settings was configured under "Time Providers" and after setting to "Not Configured" the settings imidiately dissapeared from the Registry key in the Quote, and did NOT come back.

Edited by jrexa
0

Share this post


Link to post
Share on other sites

I know this is an older thread, but you guys are amazing. This problem has been driving me crazy for weeks.

Sure enough it was because of some group policy settings.

Thanks! You guys are lifesavers!

Edited by erobinson
0

Share this post


Link to post
Share on other sites

Thank you all for your time!

I just cant say thanks enough!

Edited by erobinson
0

Share this post


Link to post
Share on other sites

All the above solutions still did not work for me. The policies were all set to "not configured". I tried to set them to "disabled", rebooted the machine, reset them to "not configured", rebooted, but to no avail.

Finally I found that policies get stored in the registry as well.

After renaming the following keys in :

\HKEY_LOCAL_MACHINE\SOFTWARE\POLICIES\MICROSOFT\W32TIME\

CONFIG to _CONFIG

PARAMETERS to _PARAMETERS

TIMEPROVIDERS to _TIMEPROVIDERS

and restarting w32time,

at last w32tm started reading the normal - documented - registry settings and this solved the problem for me as well.

( :angry: 8 hours wasted thanks to policy settings that do not appear in the policy editor or did I look in the wrong place?)

GENIUS! PURE GENIUS!

I have had this problem for god knows how long! none of the replied to none of the other forums helped just like the fist post, but this one, this was the answer to all my problems!

I had to update group policy on all my machines and resync them to the DC after I was finally able to sync the DC with the external time source, but now all my machines are running on time!!!

Thank you so much, anneb2!!!

0

Share this post


Link to post
Share on other sites

It works!!

GP was the problem.. like many others i had tried for for too long to get this right.. rechecked all setting and configurations.. nothing worked until I tried to disable the time service in Group Policies that aparently affected even our DC..

Thanks a lot!!

0

Share this post


Link to post
Share on other sites

I've been having this same issue and hope it is related to the GPO settings like everyone else is saying. I am administering a Windows 2003 32bit SP2 machine. I only got hired a week ago and aparently the clocks here have always been about 12 minutes ahead of the real time.

Anyway, the network administrators before me set the default domain policy to configure the "Configure the Windows NTP Client" and the "Enable WIndows NTP client" to be enabled. Obviously since our domain controllers were in the domain that this policy was being issued to, they are getting these settings as well. I went ahead and made an OU and put the domain controllers in there and enforced the "Default domain controllers policy" GPO so that should override any settings the default domain policy issues. Of course, the default domain controllers policy has all three of the time settings discussed here set as "not configured". I went ahead and did a gpupdate /force on the domain controller with the PDC fsmo role and then logged off and logged back on. The problem was that I was getting the same error. Is this something that I will have to restart the domain controller for all the settings of the enforced "default domain controllers policy" to take effect? I really don't want to restart this domain controller seeing as it is running DHCP and DNS.

Thanks

0

Share this post


Link to post
Share on other sites

You have to be very sure you followed the instructions for using an external time source correctly. I've used these instructions on many a 2K3 server without issue, so to recap:

1. Change Windows to use the NTP protocol for time synchronization:

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Parameters

Value: Type

Data: NTP

2. Configure the AnnounceFlags value:

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Config

Value: AnnounceFlags

Data: 5

3. Enable the NTP server value:

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient

Value: Enabled

Data: 1

4. Specify the NTP server to use:

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Parameters

Value: NtpServer

Data: us.pool.ntp.org,0x1

5. Select the NTP polling interval:

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\TimeProviders\NtpClient

Value: SpecialPollInterval

Data: 900

6. Configure the time correction settings:

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Config

Value: MaxPosPhaseCorrection

Radix: Decimal

Data: 3600

Key: HKLM\SYSTEM\CurrentControlSet\Services\W32Time\Config

Value: MaxNegPhaseCorrection

Radix: Decimal

Data: 3600

After this, stopping and restarting the NTP service should get you working. If it does not, check the value configured in step 4 - this being misconfigured is the only time I've seen errors in the Windows Time service like the ones you've posted, so it's possible this is incorrect in your registry. I would also suggest using a time server OTHER than time.nist.gov, as it is a VERY busy time server and you are likely to miss one or two time syncs to it before you get a good one. I would suggest using another time server, preferrably a stratum-2 NTP server closer to you. You can find these listed here:

http://www.eecis.ude...tp/clock2a.html

Works great on my SBS 2003 server. Thanks!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.