Sign in to follow this  
Followers 0
mannyo

Strange problem with MCE hanging

10 posts in this topic

I have a rather frustrating problem with my MCE system,

All seems ok in windows, the pc will run for days if just left on the windows desktop. It quiet happily records scheduled programs, downloads the guide and is stable BUT.

As soon as I hit that green button, its just a matter of time till my system freezes completely. It doesnt matter if I leave it on the MCE start screen or watch LiveTV, it locks the whole pc after a random period of time. The longest its lasted before getting stuck is about 3 hours, but it has crashed within 5 mins before. I have to power the system off/on to get working again. Nothing is recorded in the event log.

System spec.

P4 3.0GHZ HT CPU

Intel D865GLC Motherboard

1GB Kingston DDR400 Ram (2x512MB in dual channel)

1x160GB HD (OS/Music/Pictures/Page file)

1x250GB HD (TV Recording/LiveTV Buffer)

2xHappauge Nova-T PCI DVB-T Tuners

Geforce 6600 Graphics card connected via DVI to LG RZ-42PX11 PlasmaTV @ 1080i 50hz.

Nvidia Purevideo decoder (185 version)

MCE has all the updates installed from windows update, including rollup2, the little patch and the recently released Rollup. I have also installed the latest driver versions for the TV tuners but its still the same (dont think its those anyway as recording works fine).

I have tried assorted graphics card drivers, motherboard chipset drivers with no success.

Any Ideas, short of a complete re-install.

Edit to add, I also have an xbox360 as an extender which seems to work fine. I watched several recorded shows without problem from it.

Edited by mannyo
0

Share this post


Link to post
Share on other sites

Is your video card or any other part of your system OC'ed? If it is, lower the clock frequency and try again. Your OC probably isn't stable.

Edited by RJARRRPCGP
0

Share this post


Link to post
Share on other sites

Hi,

this might sound more like a question:

how about turn off screen saver & not let the system turn off monitor/HDD & not allow system to go hibernate?

rgrds

HY

0

Share this post


Link to post
Share on other sites

Thanks for the replies,

System is not overclocked, and has screen saver disabled. I even tried some memory from another system and the problem still ocurrs

I'll check the power settings tonight but I think they are all set to "Always on".

Looks more and more likely that a rebuild is going to be the only course of action. I may try that onto another HD and see if its stable.

0

Share this post


Link to post
Share on other sites

Update

After much more fiddling, I finally gave in and reinstalled MCE from scratch. Several hours later I have a fully functioning system, all I need now is to sort out getting 1080i @50hz output again. At the moment 1080i @60hz is all I have.

0

Share this post


Link to post
Share on other sites

Doh, just as I thought it was sorted. After a complete reinstall from scratch and full config including running at 1080i@50hz the system hang is back once again. Symptoms same as before, as soon as directx comes into play the system hangs after a random period of time.

0

Share this post


Link to post
Share on other sites

Maybe it has something to do with a program you installed, or a specific setting you made. this may take long, but you should try to trigger the error after every change you make to your system. you could also try to monitor the cpu temperature, maybe it simply gets too hot and requires better cooling

Edited by what3v3r
0

Share this post


Link to post
Share on other sites

Can you ping your machine when it's hung like that from another machine? If so, the OS kernel is still running, and a dump can be gathered via a PS/2 keyboard to determine what's going on. If you cannot ping the box, that means the OS has hung completely, and it's likely a hardware or driver issue. If you can ping it, do the following to get a dump the next time it hangs:

1. Create or set the following registry value:

Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

Value: CrashOnCtrlScroll

Type: REG_DWORD

Data: 1

Refer to the following Knowledge Base article for more information on this registry key:

244139 Windows Feature Allows a Memory.dmp File to Be Generated with Keyboard

http://support.microsoft.com/?id=244139

2. Right-Click on the "My Computer" icon on the desktop and select "Properties"; this will open the "System Properties" window. Go to the "Advanced" tab and click "Performance Options". Click "Change" under "Virtual Memory". Set the pagefile to be located on the partition where the OS is installed, and set it to be equal to Physical RAM + 50 MB.

3. Also in the "System Properties" window, click on the "Advanced" tab, then click "Startup and Recovery". Make sure "Complete Memory Dump" is selected. You can change the location of the memory dump file to a different local partition if you do not have enough room on the partition where the OS is installed.

4. You will need to reboot for these changes to take effect.

5. The next time that the machine is hung, hold down the RIGHT CTRL key and press the SCROLL LOCK key twice to cause the machine to bugcheck (STOP 0xE2) and create the memory.dmp file. After the machine comes back up, wait for the disk activity to stop before logging in. Once the disk activity has stopped, please log in and find the resulting memory dump file (again, located by default at %systemroot%\memory.dmp).

Unless it's really bizarre, I can tell you what hung your box from the memory.dmp file.

0

Share this post


Link to post
Share on other sites

Maybe some more info about your uwxpcd would be helpfull

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.