Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Tomcat76

HFSLIP - Test releases

Recommended Posts

tommyp    3

A new beta is up. Please test if you are a home user. If you are a working at a company or business, get lost and don't use this software. If there's one more business user that comes on this board and asks for help, I'm outta here.

simbionte - you discovered a lingering prob. There was an issue with your language of the script. There was a "fix" I posted in the installer thread a few months back that required a manual edit to fix things for your language. Hopefully I have automated that process with the new beta.

wela - thanks for posting. Hopefully others will follow suit and say they are successful too so I can make this a final and get on with my life. :)

If your language isn't Chinese or Portuguese, then this beta won't change things for you.

Share this post


Link to post
Share on other sites
Martin H    0

Sorry Tom, I thought that we should only post if having a problem with the betas...

Anyway, me to is succesfull, allthough I installed yesterday with rev.F and not the newest rev.G, but i'm using ENU so that shouldn't matter i believe...

All is OK with XP-SP3-ENU, HFCLEANUP and all security updates and high-priority non-security updates for the standard XP-SP3 components(except MRT, WGA, Package Installer and Windows Update Engine).

Thanks again for all your efforts, mate! :)

Share this post


Link to post
Share on other sites
fdv    0

The new betas have worked for me 100% fine FWIW. 2000 and XP. Haven't tried 2003 with any betas beyond C, but C worked fine.

Share this post


Link to post
Share on other sites
Inki    0

Sorry to be a party spoiler, but there may be a possible issue with Windows 2000 + DirectX 9 and KB975560/MS10-013 (quartz.dll, msyuv.dll)

(Unless, of course it is a glitch by MS or I fouled something up):

Installing Windows2000-DirectX9-KB975560-x86-ENU.exe manually presents no problem. However, when installing from a HFSLIP-based installation CD, the text-mode file copying phase is interrupted by the following error message:

The file msyuv.dll was not copied correctly

The file Setup placed on your hard drive is not a valid

Windows 2000 system image. If you are installing from a CD,

there may be a problem with the Windows 2000 CD.

- To retry, press ENTER.

- To skip this file, press ESC.

- To quit Setup, press F3.

Choosing the option to skip allows the installation to proceed, and once it is done, the file msyuv.dll on the hard drive is exactly the same as after a manual installation or what can be extracted from the hotfix installer. (Tried this with two CD burns, using betas F and G)

HFSLIPLOG.ZIP

Share this post


Link to post
Share on other sites
tommyp    3

I had a feeling that the quartz hotfix wasn't going to be handled correctly. Put it into the sw1 folder and call it a day. or better yet, have you considered using the 2k update list instead of the old school unoffical sp5? Whatever the case is, I have no plans for fixing 2k. I've moved on.

I suppose though, you can manually edit the layout.inf file, locate the msyuv.dll entry and make it say msyuv.dll = 1,,,,,,,,3,3 instead. I don't recall is layout.inf is a protected file or not so do this on a test case. Other than that, I don't plan to investigate further.

Edited by tommyp

Share this post


Link to post
Share on other sites
Inki    0

Sorry to hear that, but OK and no sweat, if you say so. You're the Boss.

And thanks for the tip, I will be sure to try it out.... No joy, though, but that's cool.

Edited by Inki

Share this post


Link to post
Share on other sites
tommyp    3
BETA G Error message:

can not copy portabledeviceclassextension.dll

Please extract your WMP11 installer into HF\WMP11 with winzip or winrar. Report back.

Share this post


Link to post
Share on other sites
Lilla    0

Tommyp,

Successful report. I used 1.7.10 beta G to slipstream SP3, IE8, WMP11, RDC7, and most other updates

into Windows XP Pro, Gold (aka, Service Pack 0) source.

I used HFSLIPFC v2010/02/12 to prepare. This tool was VERY, VERY helpful.

FYI, I didn't use the HFCleanup utility or nLite.

After running HFSLIP I created a CD from the resulting .iso and used it to do a fresh install.

All worked great, no problems at all. Later I used the CD to do a repair install, all worked great there too! (See followup note below.)

You can help by checking if the binary removal files (2000SP4.EXT, XPSP1.EXT and XPSP2.EXT) cover everything. Download dumpdupes.cmd and place it in the main HFSLIP folder (alongside the normal HFSLIP executable). Run this tool AFTER you ran HFSLIP (it namely requires a SOURCE and a SOURCESS folder to compare). If there are any duplicate binaries that can be removed, a file called EXCLUDE.TXT will be created. Let me know if it contains additional files to those that already exist in the current removal files.

I'm confused, can someone please tell me which .EXT file I should be comparing to? My XP source is SP0 (Gold), I'm intregrating SP3.

Thank you so very much for all of your hard work, and for sharing it with us home users.

Lilla

2010-03-02 Followup. While the repair install I did above "appeared" to work, it was a simple case where I did a fresh install with network cable unplugged, then immediately did a repair install. Since I could open WMP11, notepad, etc. I concluded the repair install worked. But, today I tried to repeat this, and after doing the repair install I find IE8 doesn't work and CCleaner (installed after repair install) gives error messages. See my new post for details.

EXCLUDE.TXT

Edited by Lilla

Share this post


Link to post
Share on other sites
Acheron    18

I personally do also use a exclude list simply by modifying HFSLIP.CMD. I only use it to exclude svn directories from being copied. Normally I should export my project first but using this hack I can run hfslip directly.

hfslip-1.7.10_beta_G (line 561)

TITLE %T1% - Copying Source
XCOPY/DE /EXCLUDE:HFTOOLS\EXCLUDE.TXT SOURCE SOURCESS

In HFTOOLS directory I now put a textfile:

EXCLUDE.TXT


\.

Edited by Acheron

Share this post


Link to post
Share on other sites
theruan    0

Hi, sorry to be the that will say that something got wrong but this updates aren't getting slipped in the source:

WindowsXP-KB969084-x86-ptb.exe

WindowsXP-KB968389-x86-PTB.exe

WindowsXP-KB967715-x86-PTB.exe

after using hfslip i can see them in SVCPACK\ folder and also they are opened in the install process to the user press next,... not hidden.

I supposed they should be slipstreamed 'cause in HFSLIPFC and Mimo's list is said to put them on HF folder.

Is this normal? Should i make an addon with them? I add both log file and the .cmd after integrating everything from Mimo's list.

Also 905474 isn't getting to work, or better it's is installed but still asking to install it in the updates.

EDIT:OBS... I realized that the version i did download from hfslip site is old, so far that might be the problem, tonight i will try it again.

Sorry my bad english.

HFSLIP.CMD.txt

HFSLIP.LOG.txt

Edited by theruan

Share this post


Link to post
Share on other sites
tommyp    3

theruan - Sorry I can't help you if you didn't post the results from your last post. I don't know what I don't know.

A new beta is up. Please test if you are a home user. If you are using hfslip at a company or business, get lost and don't use this software. If there's one more business user that comes on this board and asks for help, I'm done with this.

Share this post


Link to post
Share on other sites
dziubek    0

3ebbd6d0257f49ccm.gif

When I use addons in HFAAO folder often shows me a request to replace the existing file.

What I need to change to the default script to overwrote all files?

thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×