Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

HFSLIP - Test releases

* * * * * 1 votes

  • Please log in to reply
2379 replies to this topic

#2001
Dawid

Dawid
  • Member
  • 6 posts
Has anyone experienced problem with Windows Installer after hfslip-1.7.9_beta_d.cmd on Windows Server 2003 SP2?
Installation process ran smoothly, but then I was forced to install WindowsServer2003-KB942288-v4-x86.exe, 'cause none of msi was able to install:
"The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or the Windows Installer is not correctly installed. Contact your support personnel for assistance."
Am I missing something?

Thanx

Attached Files




How to remove advertisement from MSFN

#2002
krose

krose

    Junior

  • Member
  • Pip
  • 78 posts
  • OS:Windows 7 x64
  • Country: Country Flag
KB942288 is not supported. You can however place it in HFSVCPACK_SW1 folder to be installed at T-13. Should end your problem.

Edited by krose, 30 March 2009 - 08:41 PM.


#2003
Dawid

Dawid
  • Member
  • 6 posts
Thanx for the working tip. The thing is, I never had a problem with Windows Installer in HFSLIP build, but I don't mind to have the latest version installed at T-13.
I was playing with hfslip-1.7.9_beta_f (see attached log) and everything works fine. Great and many thanx to all of you.
I'm unable to integrate 960715 without WU prompting this update, though. Only installing with RunOnceEx helps.
Guys, how do you deal with update 960715?

Attached Files


Edited by Dawid, 04 April 2009 - 08:47 AM.


#2004
krose

krose

    Junior

  • Member
  • Pip
  • 78 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I apologize that I did not notice that you were working with Server 2003. Don't know how but I did. Well it was late and I was getting sleepy. Anyway, I am using hfslip-1.7.9_beta_d and XP SP3. With WindowsXP-KB960715-x86-ENU.exe in the HF folder, and WindowsXP-KB942288-v3-x86.exe in the HFSVCPACK_SW1 folder, I get a perfect install. Maybe what you are seeing is related specifically to Server 2003? Hope you can get it sorted out.

Edited by krose, 04 April 2009 - 07:12 PM.


#2005
tain

tain

    Cyber Ops

  • Super Moderator
  • 3,680 posts
  • OS:none specified
  • Country: Country Flag

Donator

Current version has the following line that appears to be a bug:

ECHO>>HFSLIP.LOG Use of HFSLIP for anything other than personal non-commercial purposes
echo>> is strictly not allowed.
ECHO>>HFSLIP.LOG Copyright© TommyP 2005-2009



#2006
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
Thanks Tain. Updated new beta.
Posted Image

#2007
tain

tain

    Cyber Ops

  • Super Moderator
  • 3,680 posts
  • OS:none specified
  • Country: Country Flag

Donator

Line 3,932 has almost the same bug.

ECHO>>HFSLIP.LOG	Use of HFSLIP for anything other than personal non-commercial purposes 
echo										  is strictly not allowed.
ECHO>>HFSLIP.LOG						  Copyright(C) TommyP 2005-2009


#2008
Acheron

Acheron

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 988 posts
  • OS:XP Pro x86
  • Country: Country Flag
I noticed after enabling AHCI my CD-ROM drive letter is moved to after my Removable Flash Drive causing error messages during setup at T13 when HFSLIP.cmd is detecting the drive letter.

I have written a patch for it as you can easily find the drive letter by reading the path.

Replace in the :UPDATEINIT section the following lines:

:UPDATEINIT
ECHO>>SOURCESS\I386\SVCPACK\HFSLIP.CMD FOR %%%%i IN (C D E F G H I J K L M N O P Q R S T U V W X Y Z) DO IF EXIST %%%%i:\%MBOOTPATH%I386\SVCPACK (
ECHO>>SOURCESS\I386\SVCPACK\HFSLIP.CMD 	SET HFSLIP=%%%%i:\%MBOOTPATH%I386\
ECHO>>SOURCESS\I386\SVCPACK\HFSLIP.CMD 	SET HFSLIPSVC=%%%%i:\%MBOOTPATH%I386\SVCPACK\
ECHO>>SOURCESS\I386\SVCPACK\HFSLIP.CMD )

with these:

ECHO>>SOURCESS\I386\SVCPACK\HFSLIP.CMD 	SET HFSLIP=%%~dp0..\
ECHO>>SOURCESS\I386\SVCPACK\HFSLIP.CMD 	SET HFSLIPSVC=%%~dp0

Another feature request while I'm now experimenting with integrating all driverpacks is to be able to manually specify HFSLIP export directory so I can redirect file copying to another drive. My experiments show a speed increase of about 50% when building a HFSLIP iso.

For example I have my XPSOURCE in C:\HFSLIP\SOURCE. Instead of copying everything to C:\HFSLIP\SOURCESS I have manually changed it to D:\SOURCESS which gives a major performance improvement. On ISO creation the same trick is done as now are files are read from the D: drive and copied back to the C:\HFSLIP directory.

Edited by Acheron, 14 April 2009 - 09:33 AM.

Say no to bloatware. Download Nero Lite!

#2009
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
Acheron - Good stuff. Can someone who does network installations test out those lines to see if it works for their environment? I have no problem changing the script, as long as a network installer can verify this.
Posted Image

#2010
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
New beta up to address the dx9 hotfix & software license. Thanks for submitting the dx9 prob Brimborium & thanks to jimmsta for the creative commons agreement.

Edited by tommyp, 18 April 2009 - 07:57 AM.

Posted Image

#2011
wsmith

wsmith
  • Member
  • 2 posts
I integrated IE8 into WindowsXP PRO VL SP3 by using 1.7.9-beta_j.
In that case, dxtrans.dll was not installed. Moreover, some errors were recorded in syserr.log.

It is in the line 2416 of 1.7.9-beta_j.
REN WORK\I386E\I386\dxtrans.dll dxtrans2.dll
is wrong.

REN WORK\I386E\dxtrans.dll dxtrans2.dll
is correct?

#2012
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
That line of code looks odd. Nice find! Can you rename the line as you mentioned, retest and report back? BTW, that line came from here.
Posted Image

#2013
wsmith

wsmith
  • Member
  • 2 posts

That line of code looks odd. Nice find! Can you rename the line as you mentioned, retest and report back? BTW, that line came from here.

I renamed the line, and tested actually.

Content of setuplog.txt before line is corrected.
04/19/2009 14:23:12.456,d:\xpsp\base\ntsetup\syssetup\ctls.c,521,,SETUP: C:\WINDOWS\system32\proctexe.ocx did not register successfully
04/19/2009 14:23:42.509,d:\xpsp\base\ntsetup\syssetup\ctls.c,521,,SETUP: C:\WINDOWS\system32\dxtrans.dll did not register successfully
04/19/2009 14:23:42.569,d:\xpsp\base\ntsetup\syssetup\ctls.c,521,,SETUP: C:\WINDOWS\system32\dxtmsft.dll did not register successfully
After correcting the line.
04/19/2009 18:03:53.203,d:\xpsp\base\ntsetup\syssetup\ctls.c,467,,SETUP: C:\WINDOWS\system32\proctexe.ocx registered successfully
04/19/2009 18:04:22.185,d:\xpsp\base\ntsetup\syssetup\ctls.c,467,,SETUP: C:\WINDOWS\system32\dxtrans.dll registered successfully
04/19/2009 18:04:22.615,d:\xpsp\base\ntsetup\syssetup\ctls.c,467,,SETUP: C:\WINDOWS\system32\dxtmsft.dll registered successfully

Additionally, dxtrans.dll had not existed in the file list of system information on IE8 before correcting the line. It came to exist after the line had been corrected.

#2014
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
Thanks for finding and fixing the bug wsmith. New beta released to fix this issue.
Posted Image

#2015
Zamiel

Zamiel

    Newbie

  • Member
  • 12 posts
Devs:

For your reference, here is my exclude.txt:

ntkrnlpa.ex_
ntkrpamp.ex_

Here is my hfslip.log

This file is automatically generated by HFSLIP
   Use of HFSLIP for anything other than personal non-commercial purposes 
							is strictly prohibited.
						 Copyright(C) TommyP 2005-2009

============================HOW TO REPORT A PROBLEM============================

	   If running into problems, refer to http://hfslip.org/support.html

	  HFSLIP support forum: http://msfn.org/board/index.php?showforum=129

===============================================================================

Host OS		 - Windows XP

HFSLIP Version  - 1.7.9_beta_k, build 90419

HFSLIP Path	 - C:\Documents and Settings\Nesta\Desktop\hfslip_beta_Apr19\

OS in SOURCESS  - Windows XP Professional SP3 English

MSIE Version	- MSIE7

Drivers		 - DRIVER.CAB Updated

CD Install Path - Default

CDTAG		   - WIN51

===============================================================================
Files in your HF folder:
IE7-WindowsXP-KB938127-v2-x86-ENU.exe
IE7-WindowsXP-KB958215-x86-ENU.exe
IE7-WindowsXP-KB960714-x86-ENU.exe
IE7-WindowsXP-KB963027-x86-ENU.exe
IE7-WindowsXP-x86-enu.exe
WindowsXP-KB923561-x86-ENU.exe
WindowsXP-KB923789-x86-ENU.exe
WindowsXP-KB938464-x86-ENU.exe
WindowsXP-KB946648-x86-ENU.exe
WindowsXP-KB950762-x86-ENU.exe
WindowsXP-KB950974-x86-ENU.exe
WindowsXP-KB951066-x86-ENU.exe
WindowsXP-KB951376-v2-x86-ENU.exe
WindowsXP-KB951698-x86-ENU.exe
WindowsXP-KB951748-x86-ENU.exe
WindowsXP-KB951978-x86-ENU.exe
WindowsXP-KB952004-x86-ENU.exe
WindowsXP-KB952287-x86-ENU.exe
WindowsXP-KB952954-x86-ENU.exe
WindowsXP-KB954211-x86-ENU.exe
WindowsXP-KB954459-x86-ENU.exe
WindowsXP-KB954600-x86-ENU.exe
WindowsXP-KB955069-x86-ENU.exe
WindowsXP-KB955839-x86-ENU.exe
WindowsXP-KB956391-x86-ENU.exe
WindowsXP-KB956572-x86-ENU.exe
WindowsXP-KB956802-x86-ENU.exe
WindowsXP-KB956803-x86-ENU.exe
WindowsXP-KB956841-x86-ENU.exe
WindowsXP-KB957097-x86-ENU.exe
WindowsXP-KB958644-x86-ENU.exe
WindowsXP-KB958687-x86-ENU.exe
WindowsXP-KB958690-x86-ENU.exe
WindowsXP-KB959426-x86-ENU.exe
WindowsXP-KB960225-x86-ENU.exe
WindowsXP-KB960715-x86-ENU.exe
WindowsXP-KB960803-x86-ENU.exe
WindowsXP-KB961373-x86-ENU.exe
WindowsXP-KB967715-x86-ENU.exe
WindowsXP-WindowsMedia-KB952069-v2-x86-ENU.exe

Files in your HFCABS folder:
wbemoc.cab

Files in your HFGUIRUNONCE folder:

Files in your HFSVCPACK folder:
KB956391.reg

Files in your HFSVCPACK_SW1 folder:

Files in your HFSVCPACK_SW2 folder:

Files in your HFTOOLS folder:
boot.bin
CDIMAGE.EXE

Files in your REPLACE folder:

===============================================================================
HFSLIP run time: 11m58s

Hopefully this helps bring the beta one step closer to release. Thanks for all your hard work into HFSLIP!

Edited by Zamiel, 23 April 2009 - 02:55 PM.


#2016
Fudeba

Fudeba

    Newbie

  • Member
  • 41 posts
Hello.

Two strange error occours in my windows 2000 sp4 splitstream with hfslip-1.7.9_beta_k.cmd

First:

On fase T-13 in install Kazaa Lite Mega Codec Pack, RegServ32 failed to register Ivfsrv.ax. Error code is 0x5

This file is placed on C:\Windows\System32

I try to click on retry and not sucessful. Click on Ignore and install continue.

Second error:

On finish install, explorer.exe crashed and desktop not loaded. I send Control Alt Del and reset. On new boot attempt, explorer.exe crash again in a desktop init.

Not show any desktop icon, no taskbar, none. Only a black screen and mouse cursor.

In attach my hfslip.log

Attached File  HFSLIP.zip   2.24KB   9 downloads

Edited by Fudeba, 06 May 2009 - 12:26 AM.

Posted Image
My System: W2KSP5 by HFSLIP/ ASUS A8N-E/ AMD Opteron 170 (Dual-Core 2x2GHz)/ SevenTeam ST-500BKV/ 3Gb DDR400 Corsair in DualChannel/ HDD: 1*250GB Samsung SP2504C , 1*500Gb Samsung HD502IJ/ NVidia GeForce NX8400GS (256Mb)/ Creative SB-Live 5.1/ Encore ENL-TV-FM Pro/ ZyXEL Parks Prestige 642R/ LG GH22NS30 DVD-RW/ LG CED8120B CD-RW

#2017
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
I'd recommend to make your hotfix list agree with the stickied post on this forum. You have a variety of flavors of mdac and wmp hotfixes you're trying to slipstream. You'll need to make a decision what flavor you'd like and use that flavor only (i.e. mdac 2.5 vs mdac 2.8 and wmp7 vs wmp9).
Posted Image

#2018
SunLion

SunLion

    Junior

  • Member
  • Pip
  • 56 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
help...

Is correct kb960715 not to copy no archive during the process?

Extract of hfslip.log sees one below

WindowsXP-KB960715-x86-PTB.exe
0 arquivo(s) copiado(s)


I thank any aid

#2019
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
The activex bits hotfix is just an registry change. No files are inside the hotfix installer other than the necessary registry fixes.
Posted Image

#2020
SunLion

SunLion

    Junior

  • Member
  • Pip
  • 56 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag

The activex bits hotfix is just an registry change. No files are inside the hotfix installer other than the necessary registry fixes.


I am thankful for answering, tommyp.

Congratulations for the magnificent work!
:thumbup

#2021
user3k

user3k
  • Member
  • 4 posts
Hi
I'm having a error after the install. Without IE8, i don't have this error. XP sp3 ptbr clean.

hfslip log
http://rapidshare.co...HFSLIP.LOG.html

And the error in setuperr.log

Erro:
O Programa de Instalação não pôde registrar o controle OLE C:\WINDOWS\system32\occache.dll devido ao seguinte erro: GetProcAddress retornou o erro 127 (procedimento especificado não encontrado).


***

Translated:

Error:
Setup could not register the OLE Control C:\WINDOWS\system32\occache.dll because of the following error: GetProcAddress returned error 127 (the specified procedure could not be found).

#2022
tommyp

tommyp

    MSFN Addict

  • Developer
  • 1,680 posts
  • OS:none specified
  • Country: Country Flag
For starters, please rename your working directory so it's just a string of characters... instead of D:\T‚cnica\aba\xp\hfslip_sp3_maio_2009\ you should use D:\Tcnica\aba\xp\hfslip_sp3_maio_2009\. Also, you'll need to check to be sure that you aren't including any IE6/OE6 updates. Don't worry, I won't take the fun away from you by comparing hotfix lists. :)
Posted Image

#2023
user3k

user3k
  • Member
  • 4 posts
I changed the path to D:\hfslip_sp3_maio_2009. I'm using the update page maintained by you (tommyp) as source to updates (http://www.vorck.com...otfixes_xp.html). And i have checked for IE6/7 updates and i found none (i don't have downloaded them). I've downloaded a second time IE8 using other pc, and the result its the same. :(

edit: same thing using just ie8 as update.

Edited by user3k, 09 May 2009 - 08:41 AM.


#2024
AxEx

AxEx
  • Member
  • 1 posts
I have same occache.dll error, in setuperr.log. ( Setup could not register the OLE Control )

#2025
SunLion

SunLion

    Junior

  • Member
  • Pip
  • 56 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag

I changed the path to D:\hfslip_sp3_maio_2009. I'm using the update page maintained by you (tommyp) as source to updates (http://www.vorck.com...otfixes_xp.html). And i have checked for IE6/7 updates and i found none (i don't have downloaded them). I've downloaded a second time IE8 using other pc, and the result its the same. :(

edit: same thing using just ie8 as update.


Its hfslip.log consists that you are bringing up to date the Windows 2003 and not XP. The problem would not be occurring for conflict of hotfix of XP SP3 with this its system?

Edited by SunLion, 10 May 2009 - 06:35 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN