Sign in to follow this  
Followers 0

F6 fails to copy SCSI driver

5 posts in this topic

I have created a DVD-rom with Shell menu and two operating systems (winxp sp2 / win2k sp4)

This works fine without loading additional SCSI drivers.

When I try to load SCSI drivers (from floppy disk) during text based setup part (F6) it loads the driver correctly. But when Windows starts copying installation files it cannot find the SCSI drivers on the floppy disk.

This is working fine when I use the original Windows XP SP2 CD-ROM.


Share this post

Link to post
Share on other sites

The problem is caused by WINNT.SIF, I am still investigating..


Share this post

Link to post
Share on other sites


This option is default to No but if you are using the $OEM$ Distribution Folders then it needs to be set to Yes, so that Setup regards this installation as a distribution and copies these files over to the system drive. This occurs at the end of Text-mode Setup.

Having OemPreinstall set to Yes will also prevent you from loading RAID/SATA drivers from a floppy disc during textmode setup.

IN winnt.sif


OemPreinstall = "No"



Arguments = "/C START C:\WINDOWS\system32\OemPreinstall.CMD"

In txtsetup.sif


OemPreinstall.cmd = 1,,,,,,,2,0,0

CMDOW.EXE = 1,,,,,,,2,0,0

In OemPreinstall.cmd

cmdow @ /HID

@echo off

REM +===============================+

REM | Finding CDROM driveletter. |

REM |---------------------------------------------------------|


FOR %%i in (c d e f g h i j k l m n o p q r s t u v w x y z) DO IF EXIST "%%i:%TAGFILE%" set CDDRIVE=%%i:

REM +================================+

REM | Enable OemPreinstall installation of $OEM$ folders.|

REM |-----------------------------------------------------------|



XCOPY /E /I /Q /Y %CDDRIVE%\ROOT\UXPP\$OEM$\$Docs "%SYSTEMDRIVE%\Documents and Settings"



put OemPreinstall.cmd and CMDOW.EXE in \I386 folder

Edited by gummy2

Share this post

Link to post
Share on other sites

Thanks alot gummy2 for your help!

It seems that I used the wrong search criterea's :o in google..

I am testing it at the moment.

It is working now, thanks!

Edited by dizje

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.