Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Notepad to Word "copy/paste" problem

- - - - -

This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1
D-Cam

D-Cam
  • Member
  • 2 posts
  • Joined 21-March 06
I have a big document saved in notepad (.txt) where I've lined up all 5 collumns of information so it's easy to read. I've been using the document as a database of information but I need to move it all over to Word now so that I can password protect the information.

My problem is that when I copy the document and paste it into word, the tidy column alignment dissapears. What I don't understand is that the column character reading is still accurate... that is, each letter of the every collumn is in the exact same "col", but to the eye, it looks mis-aligned. For example, col 95 starts off the 3rd collumn of information, but in my second row, even though it still reads col 95, it looks more like it would be col 75.

What is going on and how can I fix it? I Presentation of this material is extremely important. I'm in a jam, it just looks very unprofessional as it is. :wacko:


How to remove advertisement from MSFN

#2
KatM

KatM
  • Member
  • 2 posts
  • Joined 22-March 06
Are you using spaces to "line up" the columns in your text file? If you can, try to separate your columns with tabs. (I don't know what your data looks like, but you may be able to do a search and replace to do this.) Once the data is brought over to Word, the tabs will be very easy to line up - or can easily be converted into a table.

#3
jaclaz

jaclaz

    The Finder

  • Developer
  • 15,654 posts
  • Joined 23-July 04
How to convert a (multiple) space separated text into Tab delimited (with WORD).
1) paste the columnar text in an empty Word Document
2) Start the search/replace function
2) In the search field input 2 (two) spaces
3) in the replace field input ^t (the character t preceded by ^ means a TAB)
4) run the replace until no more occurrences of the two spaces is found
5) now input in the search field ^t^t (it means two conscutive TABs)
6) leave the replace field as is
7) run the replace until no more occurrences of double TABs are found
8) if the number of spaces between the columns was ODD, there can still be occurrences of either TAB followed by a single space or of a single space followed by a TAB, to "clean them re-run the replace function once with [space]^t and once with ^t[space] in the search field
9) copy the now tab-delimited text
10) paste it to the "final" word document

At this point you can (as you wish) set the TABs or select the data and convert it to a table using the TXT->Table function, specifying that the separator is a TAB

If you enable seeing "hidden characters" in the WORD document (where a space is shown as a dot and a tab is shown as a right handed arrow) will help you visually analize the proceedings.

Just for the record, the apparent "misalignment" you experienced is due to the fact that NOTEPAD uses a FIXED font, whilst WORD usally defaults to Times New Roman which is a PROPORTIONAL font, i.e. a font where a letter like W takes as much as THREE times the space for a letter I.

jaclaz

Edited by jaclaz, 22 March 2006 - 01:30 PM.


#4
D-Cam

D-Cam
  • Member
  • 2 posts
  • Joined 21-March 06
Wow. That's some really solid advice. I didn't even think about the proportioal/fixed font thing.

As far as creating tabs, I'm not sure that'll work for my purposes. The company to whom I deliver this information needs each collumn to start on a specific COL number... the same for each customer of theirs. Thus, if I mess around with Tabs... they won't be happy. (for example, every customer's second collumn must start at Col 95)

I'll try changing the Font when I get back to work. Thanks. :yes: