Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Tweak UI has been disabled by your administrator.

- - - - -

  • Please log in to reply
10 replies to this topic

#1
ashleypower

ashleypower
  • Member
  • 2 posts
  • Joined 23-March 06
I have installed the 'Unofficial Windows 98SE Service Pack' and included the Tweak UI utility...the only thing is, when I try to run this utility, 'Tweak UI has been disabled by your administrator.'.

I don't understand this...since there are no accounts on my PC.

Any remedy?


How to remove advertisement from MSFN

#2
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts
  • Joined 28-March 05
That's the setting in the registry you want to modify or delete :

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\System
"DisableRegistryTools"=dword:00000001

Obviously you can't do it with Regedit as it's use is also blocked by this policy setting.

You can use either a third party registry editor, MS Poledit or easier, the freeware Regtick :

http://woundedmoon.o.../regtickpro.zip

Go in the "System" page and untick the "Disable MS Registry Tools" checkbox on the top left of the page

This should get you sorted.

Edited by eidenk, 23 March 2006 - 10:52 PM.

Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#3
erpdude8

erpdude8

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,141 posts
  • Joined 24-November 04
and if this does not work, re-install Win98 SE from scratch as you might have bad or corrupted registry entries that prevent using TweakUI.

#4
ashleypower

ashleypower
  • Member
  • 2 posts
  • Joined 23-March 06
Actually, I can still use Regedit, but I'll try that anyways!

A format and reload...it isn't THAT important to me! Haha.

I'll let ya know if it works!

Thanks alot man, works perfectly! I just went in and deleted that value...works fine now!

Again, thanks alot for your time and help.

#5
eidenk

eidenk

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,527 posts
  • Joined 28-March 05

Actually, I can still use Regedit, but I'll try that anyways!


That's interesting. Normally Regedit should also be blocked by this setting. At least it is on my ME system. Did you modify something of Regedit such as it's location and/or name ?
Asus A8V Deluxe - Athlon 64 FX-55 2.6Ghz - 1GB DDRAM 400 - Windows ME (IE 5.5 SP2 Shell) + KernelEx 4.0 and Revolutions Pack 10

#6
erpdude8

erpdude8

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,141 posts
  • Joined 24-November 04
by the way, ashleypower, what version of TweakUI are you using? Latest version of TweakUI for Windows 9x/ME is version 1.33 which I am using.

#7
devisdavis

devisdavis
  • Member
  • 1 posts
  • Joined 09-December 10
  • OS:none specified
  • Country: Country Flag

I have installed the 'Unofficial Windows 98SE Service Pack' and included the Tweak UI utility...the only thing is, when I try to run this utility, 'Tweak UI has been disabled by your administrator.'.

I don't understand this...since there are no accounts on my PC.

Any remedy?




I am also facing the same problem??

Edited by devisdavis, 09 December 2010 - 09:00 AM.


#8
egrabrych

egrabrych

    Junior

  • Member
  • Pip
  • 84 posts
  • Joined 27-May 10
  • OS:98SE
  • Country: Country Flag

Donator


I have installed the 'Unofficial Windows 98SE Service Pack' and included the Tweak UI utility...the only thing is, when I try to run this utility, 'Tweak UI has been disabled by your administrator.'.

I don't understand this...since there are no accounts on my PC.

Any remedy?



I am also facing the same problem??


The answer you are over ... although not directly.
Well, the problem stems from the variable in the Windows Registry:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000001

You delete the variable "DisableRegistryTools" - the problem disappears... but how to do it?
Fortunately, just change the value of this variable on the dword:00000000

Create a text file named: ANY_NAME.REG and content :

REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"DisableRegistryTools"=dword:00000000
;

Warning! This content may not contain spaces. Remove, if you find them.

After saving, double click the file to merge with the Windows Registry. Now Tweak UI and Regedit.exe become available.

Edited by egrabrych, 09 December 2010 - 03:40 PM.


#9
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag
"Tweak UI has been disabled by your administrator"
This error message can be fixed...

The "DisableRegistryTools" registry value must be deleted from your registry:
http://www.mdgx.com/...p9.htm#RESTRICT
How to use RegEdit (REGEDIT.EXE) to add/change/delete/rename registry values:
http://support.micro....com/?id=310516
More info [refers to XP TweakUI 2.x, but solution is the same]:
http://windowsxp.mvp...tweakuirest.htm
If you'd like to use the REG.EXE DOS box/console tool in Windows 98/98SE/ME, you need to download it from MS Win98 Resource Kit (RK) ftp server:
ftp://ftp.microsoft.com/services/technet/samples/ps/win98/reskit/REGISTRY/REG.EXE
because unlike NTx based Windows, it is not installed by the OS. ;-(
Then run REG from a DOS box to view its command line parameters.
This command displays the REG DELETE help screen:

REG DELETE /?

To delete the registry value above, you need to run this command line:

REG DELETE HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools

Press Enter, and you'll see this screen:

Permanently delete registry value DisableRegistryTools Y/N ?

Type Y (Yes) and press Enter.

Repeat these steps (if necessary) for the HKLM hive key:

REG DELETE HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools

To bypass the Y/N screen, you can use the /FORCE switch:

REG DELETE HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools /FORCE
REG DELETE HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools /FORCE

REG.EXE switches are case insensitive, except the "\\Machine" parameter, because UNC names are sometimes case sensitive.

FYI:
Everything about TweakUI:
http://www.mdgx.com/98-3.htm#TWK98

HTH

#10
egrabrych

egrabrych

    Junior

  • Member
  • Pip
  • 84 posts
  • Joined 27-May 10
  • OS:98SE
  • Country: Country Flag

Donator

@MDGx:
Placing the variable "DisableRegistryTools"=dword:00000001 in the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\ System] does not, at least for me, the blockade.

#11
MDGx

MDGx

    98SE2ME + 98MP10

  • Super Moderator
  • 2,678 posts
  • Joined 22-November 04
  • OS:none specified
  • Country: Country Flag

@MDGx:
Placing the variable "DisableRegistryTools"=dword:00000001 in the key [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\ System] does not, at least for me, the blockade.

The solution to this error message is to delete that registry value.
But if that did not fix your problem, you may want to try something else...

1. Make sure you use Windows logged in as Administrator or sole owner [with administrative rights], or as part of the Administrators/Sysadmin group.

2. See this system restrictions guide:
http://www.mdgx.com/...p9.htm#RESTRICT
and make sure your executables (.EXE files) and/or REG/VBS/HTA/INF scripts are not blocked from running on your computer.

3. Make sure you don't have any antivirus/trojan/malware/spyware "infestation". Clean it up if you do:
http://www.mdgx.com/vir.htm#RMV

HTH




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users