Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows Update Notification Icon Missing

- - - - -

  • Please log in to reply
5 replies to this topic

#1
kilowatt

kilowatt
  • Member
  • 4 posts
I've got a problem I've started to see over the last couple of weeks and I can't seem to find an answer to it on my own so i figured i'd ask.

I've got a 2003 server that is a domain controller on a network with all Windows XP clients. I've enable the policy to force Windows Updates to happen on their own and ask the user to install them at their convenience.

What is happening now is the updates are downloading on their own as expected but the tray icon is missing and doesn't notify the user. However when they go to shut down the computer it says install updates and shut down the computer.

Is there an exe i can run to inititiate the installations or a registry tweak to re-enable the tray icon?


How to remove advertisement from MSFN

#2
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
In the GPO that's affecting the client machines (not users, but machine accounts), go to computer configuration > administrative templates > windows components > windows update

You'll notice a policy setting for non-administrators to receive update notifications. Enabling that policy should re-enable what you want.
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#3
kilowatt

kilowatt
  • Member
  • 4 posts
The GPO hasn't changed at all, this machine used to show the update icon. The domain group Domain Users is a member of the Local Administrators group on every machine.

However i tried it and it did work. Seems a little odd to me, but thank you very much for your help.

Edited by kilowatt, 27 April 2006 - 11:00 PM.


#4
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
It's odd, but when you force windows update to use the public server (and not your own SUS/WSUS server), this kind of thing can happen. Not sure why, but...
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!

#5
ulogic

ulogic
  • Member
  • 2 posts
I maintain about 40 different computers and about half a dozen of them now exhibit this system where the update shield icon does not display in the notification area. Some are running Windows XP and some are running Windows Server 2003. These machines run mission critical operations 24/7 and are at remote locations so having them install and reboot automatically is not acceptable. The machines are all set up to automatically download but not install the updates. I remotely log into them, shut down the running applications in an orderly fashion, then apply the updates and reboot at prescribed times.

The machines actually do download the updates, because there are notices in the event log from the Windows Update Agent with Event ID 17 showing "Installation Ready". Also, if I go the the shutdown dialog, one of the options is to install updates and shut down. Since these are remote machines, I have no way of turning them back on. Too bad there isn't an option to install updates and restart.

In the past, I was able to correct the problem by stopping the automatic update service and deleting two folders, but that no longer seems to work. By the way those folders are
%windir%\SoftwareDistribution
%windir%\system32\CatRoot2


This is what finally worked for me.

Stop the Windows update service from the command prompt with
NET STOP WUAUSERV


Run REGEDIT and navigate to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update

Delete the BalloonTime and BalloonType values, or if you want to keep
a record of them, rename them to BalloonTimeX and BalloonTypeX.
The BalloonTime seems to be stored in GMT.

Note that the dates below are in international format
YYYY-MM-DD HH:mm:ss with a 24 hour clock.

Set DownloadExpirationTime (if present) to a date in the past.
Set NextDetectionTime to a minute or two in the future.
As far as I can tell, this value is in local time and not GMT.


Restart the Windows update service from the command prompt with
NET START WUAUSERV

After a minute or two, the update shield appears on the taskbar, then I was able to proceed with the update installation.

Edited by ulogic, 17 October 2008 - 05:27 AM.


#6
mvietori

mvietori
  • Member
  • 1 posts

I maintain about 40 different computers and about half a dozen of them now exhibit this system where the update shield icon does not display in the notification area. Some are running Windows XP and some are running Windows Server 2003. These machines run mission critical operations 24/7 and are at remote locations so having them install and reboot automatically is not acceptable. The machines are all set up to automatically download but not install the updates. I remotely log into them, shut down the running applications in an orderly fashion, then apply the updates and reboot at prescribed times.

The machines actually do download the updates, because there are notices in the event log from the Windows Update Agent with Event ID 17 showing "Installation Ready". Also, if I go the the shutdown dialog, one of the options is to install updates and shut down. Since these are remote machines, I have no way of turning them back on. Too bad there isn't an option to install updates and restart.

In the past, I was able to correct the problem by stopping the automatic update service and deleting two folders, but that no longer seems to work. By the way those folders are
%windir%\SoftwareDistribution
%windir%\system32\CatRoot2


This is what finally worked for me.

Stop the Windows update service from the command prompt with
NET STOP WUAUSERV


Run REGEDIT and navigate to

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update

Delete the BalloonTime and BalloonType values, or if you want to keep
a record of them, rename them to BalloonTimeX and BalloonTypeX.
The BalloonTime seems to be stored in GMT.

Note that the dates below are in international format
YYYY-MM-DD HH:mm:ss with a 24 hour clock.

Set DownloadExpirationTime (if present) to a date in the past.
Set NextDetectionTime to a minute or two in the future.
As far as I can tell, this value is in local time and not GMT.


Restart the Windows update service from the command prompt with
NET START WUAUSERV

After a minute or two, the update shield appears on the taskbar, then I was able to proceed with the update installation.


Just registered here to say... THANK YOU!

This stupid little Windows bug has been driving me crazy and to finally find a solution is a huge relief! I had this problem on quite a few machines (with increasing frequency) and was getting quite frustrated that I could never manually select which updates to install via the little notification icon.

Just FYI, on my machine I never found any BalloonTime or BalloonType values. Nonetheless, I did as you stated and changed the other two values and it worked like a charm.

Thanks again!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN