Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
comomolo

DriverSigningPolicy=Ignore... ignored!

3 posts in this topic

Hi there,

For some reason this key under [unattended]

DriverSigningPolicy=Ignore

is actually ignored. When I try to install the NVIDIA drivers it goes silent all the way (it's an Installshield install) until the Windows dialog box about an unsigned driver being installed shows up

Here's my full [unattended] chapter:

[unattended]

UnattendMode=FullUnattended

OemSkipEula=Yes

OemPreinstall=Yes

UnattendSwitch=Yes

DriverSigningPolicy=Ignore

Repartition=No

TargetPath=*

WaitForReboot=No

CrashDumpSetting=0

(By the way, Aaron, I don't quite get why you suggest to use "no" for UnattendSwitch. The manual clearly explains you should use Yes and it works for me, while "no" doesn't...)

Regards

Como Molo

0

Share this post


Link to post
Share on other sites

I couldn't find much in the Knowledge base for issues regarding DriverSigningPolicy=Ignore

These is all I could find:

http://support.microsoft.com/default.aspx?...kb;en-us;293765

http://support.microsoft.com/default.aspx?...kb;en-us;314479

--

UnattendSwitch

Specifies whether Setup skips Windows Welcome or Mini-Setup when preinstalling Windows XP Home Edition or Windows XP Professional using the CD Boot method.

Syntax UnattendSwitch = Yes | No

Yes

Instructs Setup to skip Windows Welcome.

No

Instructs Setup not to skip Windows Welcome

I used no so I could create a user account to log into for the batch to install my specific reg entries into.

0

Share this post


Link to post
Share on other sites

Thanks Aaron, I misunderstood you about the UnattendSwitch thing, sorry.

Regarding the main point here, I don't quite get it (I have everything the way it's supposed to be). Maybe the problem has to do with the fact that the NVIDIA drivers are installed with their own install program and the flag only applies to .inf drivers installation, what do you think?

If that were the case, I believe a registry tweak made *before* installing the drivers should work. What do you think? Do you know where the registry holds any value regarding this?

Best regards. Great work by the way.

CM

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.