• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
andregcasal

[How To] Multi-boot DVD Guide

178 posts in this topic

OKay, Here A The Long Code To The .cmd File

Well, i would appreciate if you could post this to us :) And i would post it in the guide too :)

Glad to help Black Wolf :)

xpsp2.cmd

0

Share this post


Link to post
Share on other sites

Actually amazing, with "for" cycles and everything :P It could be very useful :D Although RyanVM has that covered ;)

Edited by andregcasal
0

Share this post


Link to post
Share on other sites

It's possible to add RyanVM Update Pack with your method ?

0

Share this post


Link to post
Share on other sites

Absolutely :) In fact i was thinking of adding that method to the guide. It doesn't have directly to do with multi boot, but it sure should help.

Edited by andregcasal
0

Share this post


Link to post
Share on other sites

I added the ryan updatepack and after Windows copied files I have this error:

post-120751-1168905054_thumb.jpg

I added too: IE7 with nlite + Directx 9 + Codec Pack + Java 6 And WMP 11.

Edited by OzOne
0

Share this post


Link to post
Share on other sites

Keep in mind that the the RyanVM update pack is the first thing you should do to your source. Use before anything else.

If that's not the case, then it seems you have some bad reference to a drive that isn't there. Don't know exactly what it is, but I'd say some of you CMD files (if you have some) has a reference to something other than C:\ (or the drive you'r installing to).

Not exactly sure, but take a look at your CMD files and check for errors. Hope it helps

0

Share this post


Link to post
Share on other sites

I have just added ryan update pack and modify my svcpack.inf: now it's work :) Thx

0

Share this post


Link to post
Share on other sites

Hi guys. I'm using this guide to streamline our SOE Build process and hopefully save our Field Service agents some time when rebuilding machines from scratch. I've been able to use these instructions to make a dual boot CD, which creates 2 different versions of our Windows XP CD by duplicating the source files for different installations. My unattend answer file uses the runonceex method to install our applications, and as such I'm unsure if it's really compatible with the instructions. I'd rather use the same DVD to build all four versions of our SOE, as they are all windows XP service pack 2 based. I've attempted to make setup call the correct batch file to make the registry entries in runonceex by using the .TAG file method, in order to differentiate between each SOE version.

The issue I'm having, is I've followed the instructions for creating the TAG file, however setup isn't creating the file at all.

My winnt.sif file is as follows:

;SetupMgrTag
[Data]
AutoPartition=0
MsDosInitiated="0"
UnattendedInstall="Yes"

[Unattended]
DetachedProgram="cmd.exe /c @ECHO something>%SystemDrive%\DTPR.TAG"
UnattendMode=FullUnattended
OemSkipEula=Yes
OemPreinstall=Yes
UnattendSwitch="Yes"
ResetSourcePath=e:\i386
TargetPath=\WINDOWS
Repartition=No
WaitForReboot="No"
OemPnPDriversPath="Drivers"
DriverSigningPolicy=Ignore
FileSystem=*



[GuiUnattended]
AdminPassword=adminpassword
EncryptedAdminPassword=no
OEMSkipRegional=1
TimeZone=255
OemSkipWelcome=1
AutoLogonCount=2

[UserData]
ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX
FullName="company"
OrgName="company"
ComputerName=*

[RegionalSettings]
LanguageGroup=1
SystemLocale=00000c09
UserLocale=00000c09
InputLocale=0c09:00000409

[Identification]

[Networking]
InstallDefaultComponents=Yes

[Shell]
DefaultStartPanelOff = Yes

[Components]
AccessOpt = on ; accessibility wizard
Calc = on ; calculator
CertSrv = on ; certificate services compontents of the certificate server
CertSrv_Client = on ; web client components of the certificate server
CertSrv_Server = on ; server components of the certificate server
CharMap = on ; enables insertion of symbols and characters into documents
Chat = off ; chat client
Clipbook = on ; clipboard viewer
Complusnetwork = on ; COM+ network access
DeskPaper = off ; desktop wallpaper
Dialer = on ; phone dialer
Dtcnetwork = on ; DTC network access
Fax = on ; Fax components
fp_extensions = on ; Front Pager Extensions
fp_vdir_deploy = on ; Visual Interdev RAD remote deployment
freecell = off ; freecell game
hearts = off ; hearts game
hypertrm = on ; hyperterm
IEAccess = on ; installs visible entry points (shortcuts) for IE
IEHardenAdmin = off ; harden IE for administrators, power users
IEHardenUser = off ; harden IE for users
Iis_Common = off ; common set of files needed by internet information services
Iis_Ftp = off ; ftp service
Iis_Htmla = off ; html based administration tools for iis
Iis_Inetmgr = off ; microsoft management console based administration tools for iis
iis_nntp = off ; NNTP server.
iis_nntp_docs = off ; NNTP server docs.
iis_pwmgr = off ; personal web manager, valid only for w2k professional
iis_smtp = off ; SMTP server.
iis_smtp_docs = off ; SMTP server docs.
iis_www = off ; www service
iis_www_vdir_printers = off ; Web printing components
iis_www_vdir_terminalService = off; Installs terminal Services Active X control into the virtual directory
IisDbg = on ; script debugger
indexsrv_system = off ; indexing services, requires iis_common, iis_inetmgr, iis_www and com = on
inetprint = on ; internet printing, requires iis_common, iis_inetmgr, and iis_www
LicenseServer = off ; Disable Terminal Services licensing.
media_clips = off ; Sample Sounds
Media_Utopia = off ; utopia sound scheme
minesweeper = off ; game
mousepoint = off ; mouse pointers
Mplay = on ; Windows media player
msmq_ADIntegrated = off ; Integrates MSMQ into AD
msmq_Core = off ; MSMQ core components
msmq_HTTPSupport = off ; Enables MSMQ to use HTTP
msmq_LocalStorage = off ; Allows messages to be stored locally
msmq_MQDSService = off ; Provides AD and site recognition
msmq_RoutingSupport = off ; Provides MSMQ routing
msmq_TriggerService = off ; associates message arrival with com objects
msnexplr = off ; Installs MSN Explorer
msmsgs = off ; Disables Windows Messenger
MsWordPad = on ; Word Pad
NetCis = on ; microsoft com internet services, requires iis_common, iis_inetmgr, iis_www and com = on
NetOc = on ; additional optional networking components, requires [NetOptionalComponents] section
ObjectPkg = on ; object packager
OEAccess = off ; hide Outlook Express icons
Paint = on ; MS Paint
pinball = off ; game
rec = on ; sound recorder
reminst = off ; remote installation services
rootautoupdate = on ; OCM update root certificates
RStorage = off ; remote storage services enable the use of tape libraries as extensions of ntfs volumes
solitaire = off ; Solitaire game
spider = off ; spider game
Templates = on ; document templates
TerminalServer = off ; Installs Terminal Services on SERVERs only
TsClients = off ; if TsEnable = On then tsClient files for creating client disks, appx 10MB
TsWebClient = on ; Installs the ActiveX component for terminal services. requires IIS
vol = on ; volume control
wmaccess = off ; show Windows Messenger shortcuts
wmPOCM = off ; show Windows Media Player shortcuts
Wms = off ; windows media technologies components
Wms_Admin_asp = off ; windows media technologies server administration tools web components
wms_admin_mmc=off ; Windows Media MMC snap in
Wms_Server = off ; windows media technologies server, requires Wms_Admin
zonegames = off ; Installs MS Game Zone internet games


[NetOptionalComponents]
LPDSVC = 1

[IEPopupBlocker]
BlockPopups=No

I know setup is calling the winnt.sif file to do the Windows installation, as setup does not ask me any questions - and all the options are configured correctly in the operating system after installation, however setup is still not creating the .TAG file as required. The winnt.sif file is being placed in the PRO1 folder as suggested... Any suggestions?

Edited by dunkie12
0

Share this post


Link to post
Share on other sites

Hello dunkie12 :hello:

The problem is very simple... You have DetachedProgram="cmd.exe /c @ECHO something>%SystemDrive%\DTPR.TAG" instead of DetachedProgram="%SystemRoot%\System32\cmd.exe /c @ECHO something>%SystemDrive%\XPPRO.TAG". Hope it helps ;)

Edited by andregcasal
0

Share this post


Link to post
Share on other sites

Hi all :)

I want to let you guys know that I'm working on 2 projects right now, a XP CD and this Multi Boot DVD Guide. The XP CD will help me test some features I want to add to this guide, but I'm not sure if they work, so... testing is needed.

The main goal is to make this an ultimate guide, covering the best methods, tools, and automations.

I'm a fan of simplicity so I'll try to make the guide so making DVDs is as simple and fast as possible.

My future updates will be: nLite, PowerPacker, XPize, WPI (and maybe others), Drivers (BTS's or not), and a FAQ. Hope you guys like it ;)

Anything, just ask :hello:

0

Share this post


Link to post
Share on other sites
Hello dunkie12

The problem is very simple... You have DetachedProgram="cmd.exe /c @ECHO something>%SystemDrive%\DTPR.TAG" instead of DetachedProgram="%SystemRoot%\System32\cmd.exe /c @ECHO something>%SystemDrive%\XPPRO.TAG". Hope it helps

Yup, I realise that - I should have mentioned in my original post, that I had the full path in that you described (IE %SystemRoot%\System32\cmd.exe) however it didn't work that way either - so I changed it to what I have there.

Does it make any difference what the .TAG file is called? I need four of these files in Total, which is why I went for the naming convention that I had...

It's kinda got me stumped, as I pretty much followed your instructions step by step.

Edited by dunkie12
0

Share this post


Link to post
Share on other sites

Update:

I've managed to get around some of the missing software by installing the common applications with the RunonceEx method. I still can't get the method described in this thread to work however. I can see the batch scripts executing at the correct stages of setup, but it's still not creating the .tag file as required. I'm now sure that the rest of the setup will work as intended if the .tag file appears.

Edited by dunkie12
0

Share this post


Link to post
Share on other sites

Hi :hello:

Hum... It didn't worked? Maybe you deleted cmd.exe with nLite...

Try again, but in the "remove components" option, go to "Advanced" and in the "[Keep Box]" of nLite add "cmd.exe" so it doesn't get deleted.

This is assuming you have used nLite, if you didn't, after installing that source, try looking for the cmd.exe file, maybe it's missing anyway.

0

Share this post


Link to post
Share on other sites
Hi :hello:

Hum... It didn't worked? Maybe you deleted cmd.exe with nLite...

Try again, but in the "remove components" option, go to "Advanced" and in the "[Keep Box]" of nLite add "cmd.exe" so it doesn't get deleted.

This is assuming you have used nLite, if you didn't, after installing that source, try looking for the cmd.exe file, maybe it's missing anyway.

Nope, CMD.exe is there... I don't use N-Lite at all - I'm using a completely un-modded windows XP SP2 source, aside from me adding my $OEM$ distribution folders for unattend...

Could there be something in the formatting of the winnt.sif document that I've inadvertantly gotten wrong?

Edited by dunkie12
0

Share this post


Link to post
Share on other sites

Bwahahahaha if you were to call me a fool right now you'd be correct...

I've just figured out what's causing my problem -

I put the command into the [unattended] section of winnt.sif instead of [GUIUnattended]... bwahahaha what an id*** I am! hehe

Thanks for your help anyway andregcasal, I appreciate it man!

0

Share this post


Link to post
Share on other sites

wow it's beatiful.

I have followed the instructions but i have a problem.

then i try to load the command: memdisk xxx.IMA appear the error: command not available in script debugger

Why?

Thank you very much

Bye

Max

0

Share this post


Link to post
Share on other sites

Hum... Not sure, but it seems CDShell has a new version and the scripting language may have changed. Try to search for that error at the CHShell site and fórum. If you find anything, please report back :)

The tests i've been conducting on XP are almost over, i'll have a complete guide in 2 or 3 months :P

0

Share this post


Link to post
Share on other sites

After I got my DVD working, I managed to perfect the runonceex method using the .TAG files. If you prefer to use runonceex, you can use the same method of searching for the .TAG file to call the correct runonceex script - just have your cmdlines.txt call a batch script that searches for the .TAG file as instructed, and then use the same script to call the desired runonceex batch script. I've got this working perfectly! :thumbup

0

Share this post


Link to post
Share on other sites

Yep, that's another simple way to do it ;) I'll had it to the guide, thanks :)

EDIT: The only problem is RunOnceEx runs at first logon, so it requires a reboot after first logon. If the applications installed don't need reboot, then it's actually a nice method :) Without RunOnceEx, all aplications, are installed at the T-13, so the first logon already has everything installed "rebootless" ;) lol

Edited by andregcasal
0

Share this post


Link to post
Share on other sites

How would you incorporate WPI in this process? I like the menu option to install apps after the OS is installed. I would like to have a base WPI folder for all OS's that I install. That way I only have to update one menu. I have not started to create a multiboot yet even though I am going to soon. My other question is can this include Bart PE? That way I can have 1 DVD that has utils from Bart PE and then an option to install Windows XP Pro or Home. Any ideas? thanks

0

Share this post


Link to post
Share on other sites

Hi, about the WPI, go to the WPI webpage and take a look at the tutorial provided. I believe it's explained there ;)

0

Share this post


Link to post
Share on other sites

I've tried to create my own cdshell.ini based on the example, and tried to make it as simple as possible. But i've get stuck, and now I'm a little bit confused...

boot:
cls
print "\n"
print "Press Enter to boot from DVD... \n"
getkey 5 boot 0x80
if $lastKey == key[enter]; then goto time
# When no key found...
goto boot


# Printing the Interface
menu:
set textColor= color[grey on black]
set boldColor= color[cyan on black]
cls
print c "\n\cXXÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ<\c0B$time $date\cXX>ÄÄ \n\n"
print c "\cXXMicrosoft Windows XP Professional Installation Pack \n\n""
print l "\cXXPress \c0BF1 \cXXfor Help"\n"
print c "\cXXÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ \n\n"
print c " Choose language version: \n"
print "1) Polish\n"
print "2) English\n\n"

print "R) Reboot \n"
print "Q) Quit to Command Prompt \n"
print "ESC) Boot from 1st Harddisk \n"
print c "\n"

MainKey:
getkey 20 boot 0x80
if $lastKey == key[1]; then ???
if $lastKey == key[2]; then ???
if $lastKey == key[q]; then end
if $lastKey == key[r]; then reboot

if $lastKey == key[F1]; then goto Help
if $lastKey == key[esc]; then boot 0x80

Now, what should I put to these two lines, to start installation of the choosed system immedietely?

if $lastKey == key[1]; then ???
if $lastKey == key[2]; then ???

Directory structure:

\DVD\

\DVD\Setup\

\DVD\Setup\XP

\DVD\Setup\XP\PL

\DVD\Setup\XP\EL

\DVD\PRO1

\DVD\PRO2

\DVD\BOOT

(BTW what files should i keep in the 'boot' folder?)

0

Share this post


Link to post
Share on other sites

Hum, i didn't realized the example file has "???" on it, sorry about that :)

You should change those ??? with PRO1.DAT according to my tutorial. Of course you can name the boot file, what ever you what :)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.