Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


chee

how to disable the annoying "http://runonce.msn.com/runonce2.aspx

62 posts in this topic

is it set as your homepage?

Edited by WolfX2
0

Share this post


Link to post
Share on other sites

no, not at all

the default homepage is set to be "Blank"

hehe.

this whole process manifests itself as:

open ie -- then it goes to :http://go.microsoft.com/fwlink/?linkid=54834 --

then redirect to: http://runonce.msn.com/runonce2.aspx

the latter reqires to me check some ie setting options and requires me to check "join ms experience..."

every time after the ie temperory contents are cleared ie goes to this page

annoying

thanks

0

Share this post


Link to post
Share on other sites

;Put the following in a reg file and run:

Windows Registry Editor Version 5.00

;Changes Main Web Page to blank

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"Start Page"="http://about:blank"

0

Share this post


Link to post
Share on other sites
;Put the following in a reg file and run:

Windows Registry Editor Version 5.00

;Changes Main Web Page to blank

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"Start Page"="http://about:blank"

I would like to thank the person mentioned above for setting me on the right track to fixing my issue, but would like to add that this did not fix my problem.... BUT INSTEAD IT CAUSED ME TO FIND AN ANSWER TO THE PROBLEM.

If you open the registry editor by going to the start menu and then choosing run, then type in regedit, then you may be able to fix the problem as I did.

Fist, locate the key [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main] .

Second, on the right side of the screen locate the subkey [RunOnceHasShown] .

Third, click on the subkey mentioned in step 2 and change the value from 0 to 1 .

Fourth, close regedit and restart IE.

:thumbup I HOPE THIS FIXES YOUR PROBLEM AS IT DID MINE!!! :thumbup

0

Share this post


Link to post
Share on other sites

Using the IE7 final, the last message posted does not fix the problem listed.

After a little playing, I did find the solution to the problem. It does require that you make the change recommended in the last post (Or in my case, it did not exist, so I had to create the DWORD).

IN ADDITION to what the last post recommends, you should also create the following DWORD in HKCU>Software>Microsoft>Internet Explorer>Main:

RunOnceComplete

Set it to 1

This FIXED it for me! Hopefully this will fix it for everyone else having the same problem.

Good luck!

0

Share this post


Link to post
Share on other sites

I installed last nights release today. Had a problem loading the RUNONCE page. After hanging for 5 minutes or more, the page finally loaded. I recorded two registry keys that was created. I closed IE7 and reopened and the RUNONCE page did not attempt to load. I removed the registry keys and the RUNONCE page attempted to load.

I did a Google search and could not find this resolution anywhere, hope this helps somebody.

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]
"RunOnceComplete"=dword:00000001
"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks - Who would have thought that after two years that Microsoft has not corrected this problem. I have updated scripts using several appliations and created a couple of executables for those who do not want to manually edit their registry.

Updated Link (January 30, 2008)

Source: http://it.megocollector.com/?p=56

Source: http://it.megocollector.com/detail.asp?iFaq=230&iType=25 is no longer valid.

Edited by canon
0

Share this post


Link to post
Share on other sites

i have the same problem, but im not at all computer savy. could someone please explain how to do this? thanks.

oh, and sometimes when i open a new IE7 window, it crashes instantly. This also happens whe I open a new "tab"

Edited by allison
0

Share this post


Link to post
Share on other sites

Thanks changing the registry from 0 to 1 worked for me to. It was driving me crazy.....

0

Share this post


Link to post
Share on other sites

I'm having the same problems and have never gone into my registry and changed things. I think I followed the instructions correctly and could not find the subkey [RunOnceHasShown] . I have registrysmart and ran it and there were over 500 problems; I clicked fix and it did not fix a thing?

Heeeeeeeeelllllllllp me

Thanks,

Dyann

0

Share this post


Link to post
Share on other sites

I copy and pasted the far below from your site:

Let me know if this is what I'm suppose to do.

Go into my registry

Click on: HKEY_CURRENT_USER

Click on : Software (folder)

Click on: Microsoft (folder)

Click on: Internet Explorer (folder) then last but not least

Click on: Main (folder) and manually type in the Main (folder)

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Not knowing much about computers from your instructions below that's what I would do. Is that right??

I really want this problem fixed sooooooo bad it's driving me to well I'd rather not say.......

Question: Internet Explorer 7 Gold RunOnce Removal Added: 10/19/2006

Category: Tips & Tricks Views: 306

Rating: (4.7) By: 3 users

Answer:

Microsoft Windows Internet Explorer 7

Version: 7.0.5730.11CO

Update Versions: 0

The annoying Runonce linking to runonce.msn.com/runonce2.aspx either fails to start or you do not want it to start.

There is no reasonable explaination as to the purpose of this link. All settings may be changed within the installation of itself without linking to Microsoft.

I have found solutions for IE 7 Beta 2 and other versions which included registry keys that are not required for the Gold release and I discovered a key that is required, not mentioned anywhere else.

To bypass IE7 Runonce

Create this registry file

----RunOnceDone.reg---------

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

0

Share this post


Link to post
Share on other sites
To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

I just become a member here....I just wanted to say thank you thank you!

the above instructions "fixed" my problem

~yorky~

0

Share this post


Link to post
Share on other sites

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

I just become a member here....I just wanted to say thank you thank you!

the above instructions "fixed" my problem

~yorky~

I would like to confirm this, RunOnce* is NOT a value under HKLM - it only exisits under HKCU. My system doesn't have a problem, but for those who do:

Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Internet Explorer\Main]
"RunOnceComplete"=dword:00000001
"RunOnceHasShown"=dword:0000000

Save as IE7FIX.REG and run it.

For those who manually open Regedit and are not familiar with it - KEYS are FOLDERS, and the things inside the Keys are the VALUES (whereas normally files are inside values). Each value contains DATA. For instance:

"HKCU\Software\Microsoft\Internet Explorer\Main" is a KEY.

"RunOnceComplete" is a VALUE.

"dword:00000001" is DATA.

You could also do this with a batch (.CMD or .BAT) file:

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceComplete" /T REG_DWORD /D 1 /F

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceHasShown" /T REG_DWORD /D 1 /F

0

Share this post


Link to post
Share on other sites
Using the IE7 final, the last message posted does not fix the problem listed.

After a little playing, I did find the solution to the problem. It does require that you make the change recommended in the last post (Or in my case, it did not exist, so I had to create the DWORD).

IN ADDITION to what the last post recommends, you should also create the following DWORD in HKCU>Software>Microsoft>Internet Explorer>Main:

RunOnceComplete

Set it to 1

This FIXED it for me! Hopefully this will fix it for everyone else having the same problem.

Good luck!

0

Share this post


Link to post
Share on other sites

Also more info on that here =

http://search.microsoft.com/results.aspx?m...2frunonce2.aspx

Note: If your problem continues to the point that you feel that you need help from HJT, it is strongly suggested that you do not use a "Do it yourself" type online logreader such as http://www.hijackthis.de/en

but that you ask that your HJT log be read by an expert at one of these sites:

http://tomcoyote.com/hjt/

http://www.tomcoyote.com

http://www.spywareinfo.com

http://www.virusvault.co.uk/fusionbb/index.php?

http://www.castlecops.com/f67-Hijackthis_S...jans_Oh_My.html

http://forums.majorgeeks.com/

Edited by sultan_emerr
0

Share this post


Link to post
Share on other sites

I found a really easy quick fix. Just right click on http://runonce.msn.com/runonce2.aspx since this is the target. The page should open correctly. When there, make all corrections then click save changes. Close your internet explorer windows and click your IE icon to reopen. It should work just fine. At least on my two computers it did. Do tinkering with the registry!

Mike

I found a really easy quick fix. Just right click on http://runonce.msn.com/runonce2.aspx since this is the target. The page should open correctly. When there, make all corrections then click save changes. Close your internet explorer windows and click your IE icon to reopen. It should work just fine. At least on my two computers it did. Do tinkering with the registry!

Mike

Opps! I mean NO tinkering with the registry!

0

Share this post


Link to post
Share on other sites

Open IE7, then Click the tool button on the upper right side of browser. From the Manage Add-ons menu select “Enable or Disable Add-ons”. You should be looking at the add-ons currently loaded window. Now look for any add-ons with names that might appear to support your ant-virus, spy ware, or popup blocker software.

Example: I use Freedom all in one anti-virus software, which is produced by zero-knowledge and had to add-ons containing the name zero-knowledge.

I disabled them, restarted browser, completed the runonce screen and then enabled them again and everything works perfect.

This trick may also help those who are having trouble with Musicmatch and Roxio – Cd Creator (by disabling any add-ons associated with the software).

0

Share this post


Link to post
Share on other sites

The only way I found to get rid of http://runonce.msn.com/runonce2.aspx is to start Internet explorer from Start/All Programs/Accessories/System Tools/Internet Explorer (no add ons). Once you launch IE you put the following address in the address window. http://runonce.msn.com/runonce2.aspx. Select your choices and go to the bottom of the page to submit. Once finished you will be back to your normal start page.

Edited by allen1y
0

Share this post


Link to post
Share on other sites

Hello

I've joined the forum for the express purpose of thanking you all for giving us the fix to this situation. This problem has been p***ing us off ever since a 'not specifically denied' automatic update to IE (7.0.5346.5 Beta 2) presented itself for approval. (Denied). But 1 restore point and 2 new DWORDS later and we're BAU. Thanks to all.

rapato wollongong Australia

0

Share this post


Link to post
Share on other sites

I was having this same problem on IE6, it was going to "about:blank".

I deleted the entry that causes this and it still did it. It was because

I was only editing the HKEY_LOCAL_MACHINE part of the registry and

it is in HKEY_CURRENT_USER!

All I had to do was change the "Start Page" entry to Google's address.

Make sure you change it in the HKCU though not just HKLM. :blushing:

0

Share this post


Link to post
Share on other sites

After having this problem with our second computer and reading all the suggested solutions, I found a very simple solution. When first opening explorer, it will go to a site something like http://go.microsoft.com/fwlink/?LinkID=XXXXX, where X is a string of numbers. Close explorer. Then go to start-all programs-accessories-system tools-internet explorer(no add-ons). This opens explorer in a new window. Enter the address that explorer first tries to access, and enter. Voile! The set up site should appear where you can set the defaults, and problem solved! No need to add, delete, adjust any registry values or change any program settings. The problem apparently is caused by an add-on, such as an active-X control or something, which I haven't found, but IE now goes right to the home page.

0

Share this post


Link to post
Share on other sites

Being semi-computer literate I tried this after my runonce.msn.com/runonce2.aspx simply remained that certain shade of blue... It took a second or two of "connecting" and although it appeared to load nothing appeared on the screen. If you have this problem, try clicking anywhere on the blue screen and then click CTRL+A (ie or edit / select all) and then open Word or similar word processor. Paste into it and you'll see the page come up... no idea why this is so, but now you can see what should have loaded, albeit not layed out the same way. The first link is for editing the settings. If you cannot double click it to go to a browser window, right click instead and select edit hyper link or edit url link depending on your software. The link (java..etc) appears and cut & paste this into the browser window. In my case this brought the correct page up. I selected my options and saved them. After the closing & opening of IE7 I was back to my good ol' goggle.co.uk home page ;-).

Hope it works for some.

0

Share this post


Link to post
Share on other sites

To prevent RunOnce from loading.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main]

"RunOnceComplete"=dword:00000001

"RunOnceHasShown"=dword:00000001

Also posted in my Tips and Tricks

I just become a member here....I just wanted to say thank you thank you!

the above instructions "fixed" my problem

~yorky~

I would like to confirm this, RunOnce* is NOT a value under HKLM - it only exisits under HKCU. My system doesn't have a problem, but for those who do:

Windows Registry Editor Version 5.00

[HKCU\Software\Microsoft\Internet Explorer\Main]
"RunOnceComplete"=dword:00000001
"RunOnceHasShown"=dword:0000000

Save as IE7FIX.REG and run it.

For those who manually open Regedit and are not familiar with it - KEYS are FOLDERS, and the things inside the Keys are the VALUES (whereas normally files are inside values). Each value contains DATA. For instance:

"HKCU\Software\Microsoft\Internet Explorer\Main" is a KEY.

"RunOnceComplete" is a VALUE.

"dword:00000001" is DATA.

You could also do this with a batch (.CMD or .BAT) file:

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceComplete" /T REG_DWORD /D 1 /F

REG ADD "HKCU\Software\Microsoft\Internet Explorer\Main" /V "RunOnceHasShown" /T REG_DWORD /D 1 /F

Thank YOu Very much This was the easiest solution for us that do not know a lot about registry thank you!!!!!!!

Edited by rabanito172
0

Share this post


Link to post
Share on other sites
Using the IE7 final, the last message posted does not fix the problem listed.

After a little playing, I did find the solution to the problem. It does require that you make the change recommended in the last post (Or in my case, it did not exist, so I had to create the DWORD).

IN ADDITION to what the last post recommends, you should also create the following DWORD in HKCU>Software>Microsoft>Internet Explorer>Main:

RunOnceComplete

Set it to 1

This FIXED it for me! Hopefully this will fix it for everyone else having the same problem.

Good luck!

Hey Friends!! I Just navigated to this forum in search for the answer to this problem, and FOUND IT!! Thanks for your knowledge..

Artaban... form Venezuela.. :thumbup

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.