red2k

48-bit LBA on Win2k setup

56 posts in this topic

only on win2k with sp4

replaced the SETUREG.HIV (from attachment) on your cd

but test it on virtual pc bevore install

no guarentee

cu red2k

SETUPREG.zip

1

Share this post


Link to post
Share on other sites

and what is this suposed to do (in plain english)?

0

Share this post


Link to post
Share on other sites

@ -I-

i think he is saying

add this to the cd and enable hard drivers over 200 gb to fully work and able to format without a problem

but i could be wrong coz i dont have w2k

but if its like XP big hard drivers where space cap to 128 gb to you install SP1 to fix that problem :)

thats what i think he is geting at :)

love to know what it does and is waiting to see what dirtwarrior say about it :)

0

Share this post


Link to post
Share on other sites

Hello all, new here. This is the exact problem I think I am having with my Win2k install. It is seeing my HD as 131,070MB. My HD is a 250gig WD.

I am thinking of slipstreaming the 5.1 release from this site to my Windows cd and do a fresh install. Is this 48-bit LBA thing not included in the 5.1 package? (i.e. I need to replace the file the OP of this thread attached?)

I am having problems with installing Win2k with the HD issue above. When using the XP cd, the HD is reported as the correct size. When using a 2003 server CD, the HD is reported the correct size. The problem must lie in the Win2k installation, or maybe in my bios.

I am stuck. Please help. I am doing a dual boot config. I already know about the ntdlr and ntdetect swapping, but I cannot get that far. Win2k setup reports the HD size incorrectly and says both partitions are "Unformatted or Damaged". When I choose install to D:\ drive, it says it must also format C:\ since it is "Unformatted or Damaged".

I have slipstreamed SP4 and tried with that, no go. I read somewhere that this 5.1 SP from this site would fix the problem. I am downloading it now.

TIA

Dell 8400

Win XP on drive C:\ 225gb

Want 2k on drive D:\ 25gb

Western Digital 250gig HD.

Thanks again.

0

Share this post


Link to post
Share on other sites

USP 5.1 does remove the 127GB barrier if it's slipstreamed.

It doesn't do so if it is installed normally. This is the safest way, but I better fix it to avoid any confusion :)

/Gurgelmeyer B)

0

Share this post


Link to post
Share on other sites

:hello: Hello to all!..I am new here

I use W2K+SP4 and recently I bought a Seagate Barracuda ST3160021A (160 GB).

I ignored the barrier of 137GB, so I placed HDD how slave in a PC with

WinXPpro+SP2, I partitioned (1 primary of 5GB, and in the extended 7 logical

units) it and formatee everything in FAT32.

At once I transferred HDD to my PC (W2K+SP4), also as slave, and I began to

copy all my data in the logical units. Finally, I established it as master, I

installed W2K+SP4 (slipstreamed Cd), software, etc. and I turned off the PC.

The following day, I pull up the PC and a black screen announces me that it is

impossible the access my new HDD... and to my data!

Summarizing... I lost many data, recovery working hours, and I discovered that

SP4 has support 48 bit LBA, but it is not activated during the installation of

W2K... but later and through Regedit.

Now, I need to be prepared for when I have to re-install W2K... and lose not

data again.

I believe that the best solution is to get that the support for 48-bit LBA, incorporated in SP4, comes activated in the setup program of Windows.

My questions:

1.- for it serves it the file attached here by red2k?

2.- would it be enough that I edit an ISO of my Cd of W2K+SP4, and do replace this

file?

3.- did some of you check their effectiveness?

I appreciate your comments, experiences and/or suggestions ahead of time in

this respect.

Greetings! :)

0

Share this post


Link to post
Share on other sites

Activating is just a small reg-tweak. Why not to include it into Unattended installation or run a REG file after installation?

M$ article ID 305098.

EnableBigLba.reg

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\atapi\Parameters]
"EnableBigLba"=dword:00000001

There is also a tool for enabling here

Edited by Oleg_II
0

Share this post


Link to post
Share on other sites

I think this is mainly for having support at the beginning of setup, where you select the partition.

the_guy

0

Share this post


Link to post
Share on other sites

hi..

i have it tested on windows sp4 pro

1. you must copy your win2k cd on hdd

2. replace the setupreg.hiv from the archiv on your cd

3. burn it

4. install it new and you have 48bit LBA on windows 2000 setup

red2k

0

Share this post


Link to post
Share on other sites

Hello! I appreciate your prompt answers. :thumbup

Oleg: The utility of www.48bitlba.com is also applied already with W2K+SP4 installed :whistle:

the guy: What you say, is in fact what we all would want :yes:

:oI forgot something important: I use the version in Spanish of W2K+SP4 :no:

red2k: what do you say? do you know about somebody that has applied it to Spanish W2K version?... will they have problems?

Hey Gurgelmeyer !: Is it possible to apply your USP 5.1, without problems, to the version in Spanish of W2K?

Greetings!

Edited by marlei
0

Share this post


Link to post
Share on other sites

As far as I know you can install Windows 2000 on a big drive anyway (at least if you make a separate partition for W2k).

You will need LBA support in future when you start using the drive (save your documents and stuff).

So running REG file or utility after installation won't hurt ;)

And by the way: first check if G had already enabled big LBA in his SP5 ;) Install with this SP and search registry for EnableBigLba key. If this key is in your regestry you won't need for any REG or utility at all!

Edited by Oleg_II
0

Share this post


Link to post
Share on other sites
USP 5.1 does remove the 127GB barrier if it's slipstreamed.

Hello Gurgelmeyer! :)

Is it possible to apply your USP 5.1, without problems, to the version in Spanish of W2K?

I need to obtain it supports 48-bit LBA, to the beginning of the setup program of W2K, and this way to avoid to corrupt data in existent partitions (beyond 137GB), when having that re-install W2K for any reason.

Greetings!

marlei

0

Share this post


Link to post
Share on other sites

Just add it to a reghive.

Copy your CD to the HDD.

Open HIVESFT.INF

Add the line below

Save

Burn a new CD.

I am not sure but I think USP5.x is English only. Of course I defer to Gurglemeyer's official answer on that.


[Version]
Signature = "$Windows NT$"
DriverVer=06/19/2003,5.00.2195.6717

[AddReg]
; enable large block addressing
HKLM,"SYSTEM\CurrentControlSet\Services\Atapi\Parameters","EnableBigLba",0x10001,01,00,00,00

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.