Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
Fin2000

Why does the 5.1.2195 access wabmig.exe in the outlook express folder

7 posts in this topic

Why does the w2ksp51.exe access the \outlook express\wabmig.exe ??? This happens already at the time when the Welcome screen is displayed: Use any security tool that allow you to supervise installations, start w2ksp51.exe, it will do the file extracting, then the Welcome screen is shown, now wait about 5 seconds.

0

Share this post


Link to post
Share on other sites

Another way to inspect this is to simply rename the wabmig.exe in the \outlook express -folder, then run w2ksp51.exe, wait until the Welcome screen appears, then wait about 5 seconds more. A dialog is shown that says that the installer can not access the wabmig.exe. The installation is not allowed to continue.

wabmig.exe is the address book import tool of Outlook Express, it looks for other email clients and when found imports the mail address list from them to be used by Outlook Express.

0

Share this post


Link to post
Share on other sites

seams to me that this is just yet another of Microsofts mallicious ways of installing hotfixes

it has probably to do with the SP installer itself or maybe one of the Outlook Express updates.

probably is quite normal (yikes) from MS' point of view.

but i realy find this strange as well,

Edited by -I-
0

Share this post


Link to post
Share on other sites

During the time the Welcome dialog is displayed the SP installer does not do any updating, it is basically sitting quiet just waiting for the user to press the OK button, except in this case it does try to launch the wabmig.exe.

The Microsoft updates and fixes that I have installed have never accessed the wabmig.exe

0

Share this post


Link to post
Share on other sites

:lol:

Did you checked the "description" field in the properties of wabmig.exe ?

Mine shows "Microsoft ® Address Book Import Tool".

It seems OK to see this one running after a SP/hotfix install... Just imagine this SP/Hotfix updates the WAB (Windows Adress Book) binaries... WabMig.exe is then ran to MIGrate the old address books (files with .wab extension) to a somewhat updated form... or to check if there's no error/flaw in them...

That's like the GRPConv.exe utility ran during windows setup, where there is no GRP file...

++

PS: w2ksp51 is not made by MS ; it's an *unofficial* service pack made by Gurgulmeyer

0

Share this post


Link to post
Share on other sites
Did you checked the "description" field in the properties of wabmig.exe ? Mine shows "Microsoft ® Address Book Import Tool"
Yes I did, as you can see from one of my earlier posts.
It seems OK to see this one running after a SP/hotfix install...

This one is run _before_ anything has been installed, it runs during the Welcome dialog is up. Normally wabmig.exe is run when the OE is taken into use the first time and the user responds yes to the question if he wants to import addresses.

Just imagine this SP/Hotfix updates the WAB (Windows Adress Book) binaries... WabMig.exe is then ran to MIGrate the old address books (files with .wab extension) to a somewhat updated form... or to check if there's no error/flaw in them...
A far reach, but perhaps. I'd very much like to hear the official unoffcial comment on this.
PS: w2ksp51 is not made by MS ; it's an *unofficial* service pack made by Gurgulmeyer

Of course. What I tried to say was that those updates and hot fixes that I have downloaded from Microsoft and then installed have never tried to run the wabmig.exe. I have installed all or nearly all Microsoft fixes and patches that there are available on Microsoft site for the win2000sp4.

0

Share this post


Link to post
Share on other sites
Yes I did, as you can see from one of my earlier posts.
Whoops... :blushing:
This one is run _before_ anything has been installed, it runs during the Welcome dialog is up. Normally wabmig.exe is run when the OE is taken into use the first time and the user responds yes to the question if he wants to import addresses.

Before or after don't changes anything. I never saw this question (i don't have non-MS AB).

What you label "far reach" is based on my expericence. I had a backup of my WAB file, and after restoration i saw it not working (my file was renamed to .bak, and a new was created). I don't remember if it was a OE4 or OE5 file, but i needed hotfixes to read the WAB file...

(and you ignored my comparison with GRPConv... again, there's no .GRP file on a fresh new install of windows, but GRPConv is ran by windows setup... guess this tool, like WabMig i suppose, does more than what it claims)

++

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.