Camarade_Tux

[Help] Do not enable PAE

24 posts in this topic

Hi,

I have a new computer with 2GB RAM and an A643000+ and windows enabled PAE.

But I don't need or want PAE : 2GB is not 4GB.

According to sysinternal's boot.ini reference I should be able to use a /NOPAE switch in boot.ini but this has no effect. At least on XP SP2.

Does anyone have an idea ?

Thanks. :)

0

Share this post


Link to post
Share on other sites

How do you check PAE status ? Why disable PAE ?

Perhaps you want to disable DEP instead ?

/noexecute=alwaysoff

0

Share this post


Link to post
Share on other sites

No it's PAE I want to be disabled.

It's listed in System (right-click "my computer", under the amount of RAM you may have "physical adress extension")

PAE just needs more memory. It uses 64-bit adresses (2^32=4GB and 2^64=much more). But theses adresses have to be stored somewhere and programs end up using more memory.

I have enough memory but this is pure waste.

ATM I'm running XP SP1a and have no problem with that. "Processus Inactif" takes 16KB of memory. Under SP2 with PAE, it uses 28KB. Only 12KB more but that +75%!

(that's another method to know wheteher PAE is enabled or not)

If PAE adds 33% to BF2's memory requirement, I'm going to have problems (just an example, I don't like BF2, it's annoying and unfriendly) :rolleyes:

0

Share this post


Link to post
Share on other sites

Yes, but your processor supports and implements hardware DEP - and on Windows XP and 2003 x86 versions, this automatically enables the PAE kernel, as this is the only way for x86 versions of Windows XP and 2003 to be able to utilize the hardware DEP capabilities of the processor. Disabling PAE also disables the capabilities of the OS to use the hardware DEP functionality, and to truly disable PAE on the OS with a processor that implements hardware DEP, you should use the /noexecute=AlwaysOff and /nopae boot.ini options. This should disable PAE (but also disable DEP).

0

Share this post


Link to post
Share on other sites

Ok. Thanks. I'll try that and reboot asap.

And I usually disable DEP : I had some problems with that. :/

0

Share this post


Link to post
Share on other sites

My boot.ini has this:

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professionnel" /noexecute=AlwaysOff /nopae /fastdetect

And PAE is still enabled. :?

0

Share this post


Link to post
Share on other sites

Case sensitive maybe?

KB900524 describes the switches, backing up what cluberti said.

0

Share this post


Link to post
Share on other sites

I don't think PAE is enabled, because my System Idle Process is at 28KB as well. Might just be a peculiarity of SP2, or that I have DEP enabled as well :). One (risky) way to check is to remove the PAE kernel files (ntkrnlpa.exe and ntkrnlpamp.exe) and if your system still boots, then you don't have it enabled. If it doesn't...well you can't hold me liable for any damages :P.

0

Share this post


Link to post
Share on other sites

...

Forgot to report:

11121.png

And DEP is disabled, for sure.

/NOPAE instead of /nopae has no effect.

:?

Edited by Camarade_Tux
0

Share this post


Link to post
Share on other sites

firstly remove u r PID

then simple googling

PAE memory and windows

u r problem may be due to the pagefile

windows allocates initial pagefilesize as abt 1.5 x RAM

so u have 2 + 3 = 5 GB

which definitely require PAE

0

Share this post


Link to post
Share on other sites

That can't be it, because it says I have PAE enabled as well, but I've turned off my PF, so the total amount of virtual memory in my system is still 2GB, which shouldn't require PAE.

0

Share this post


Link to post
Share on other sites

That might just tell you it supports PAE, not that it's enabled.

0

Share this post


Link to post
Share on other sites

no thats not it enables PAE

the PAE indication in system properties is controlled my

[HKLM\SYSTEM\CurrentControlSet\SessionManagemnt\MemoryManagemnet\PhysicalAdressExtension] Value

it is set by the kernel

i have my System idle process memory 28KB with DEP enabled

when i disabled DEP (and so PAE by microsoft webpage) System idle process memory is 16KB

so there is some memory effect as Camarade_Tux said

i heard somewhere that

ntoskrnl.exe and ntkrnlmp.exe are for Uni ,Multi processors < 1GB respectevely

ntkrnlpa.exe and ntkrpamp.exe for > 1GB respectevely

these kernels may have PAE support

so if the processor supports it may benabled

another point is that if DEP enabled it may forces PAE to be on if the processor supports it

The PAE kernel can be enabled automatically without the /PAE switch present in the boot entry if the system has DEP enabled (/NOEXECUTE switch is present) or the system processor supports hardware-enforced DEP. Presence of the /NOEXECUTE switch on a system with a processor that supports hardware-enforced DEP implies the /PAE switch. If the system processor is capable of hardware-enforced DEP and the /NOEXECUTE switch is not present in the boot entry, Windows assumes /NOEXECUTE=optin by default and enables PAE mode.
Edited by Innocent Devil
0

Share this post


Link to post
Share on other sites
firstly remove u r PID

Thanks. :ph34r:

And, I've set my pagefile to 512MB so I shouldn't need PAE either.

I'll make a C app soon to check wether PAE is enabled or not : you just need to have a pointer and check if it's 32-bit or 64-bit.

And I already tried with /NOEXECUTE=alwaysoff : it has no effect on PAE, only on DEP.

I'll check my bios btw.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.