Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Francesco

Microsoft update causes 100% cpu usage

36 posts in this topic

Am I the only one that sees SVCHOST.exe cpu usage going to 100% when checking for updates on Microsoft Update website? I'm completely sure that the 100% cpu usage is caused by the automatic updates service because if I terminate that service the cpu usage stops.

I had this problem on all of my computers (5) and I'm pretty sure a lot of people in this forum had this problem too. Does somebody here managed to fix it?

Edited by Francesco
0

Share this post


Link to post
Share on other sites

Automatic Updates should only kick in when you visit the Windows Update site manually or at the daily scheduled check time if it's enabled, like 3am.

Why should it be a problem if a single-CPU system hits 100% utilisation during the check?

Or are you saying that it remains constantly at 100% even once the check is complete?

The number of checks the system is doing is quite extensive, so it doesn't surprise me that it's an exhaustive process - I just did a check for updates on a Windows 2003 SP1 dual-CPU system and it (svchost.exe -k netsvcs) hit 50% utilisation, so it's definitely a single thread under the AU service which is "busy" during the check.

0

Share this post


Link to post
Share on other sites
Automatic Updates should only kick in when you visit the Windows Update site manually or at the daily scheduled check time if it's enabled, like 3am.

Why should it be a problem if a single-CPU system hits 100% utilisation during the check?

Or are you saying that it remains constantly at 100% even once the check is complete?

The number of checks the system is doing is quite extensive, so it doesn't surprise me that it's an exhaustive process - I just did a check for updates on a Windows 2003 SP1 dual-CPU system and it (svchost.exe -k netsvcs) hit 50% utilisation, so it's definitely a single thread under the AU service which is "busy" during the check.

After the check the cpu usage goes back to normal but the problem is that the check even on fast systems last for at least 3-4 minutes, on a celeron 1000 I have it lasts for 30 minutes!! While it's checking new applications can't be launched and the system is very slow.

Everytime new updates are released automatic updates hangs slow computers for hours because the checks are so long that wu connection goes time out so it has to start from scratch every time. It's really awful.

0

Share this post


Link to post
Share on other sites

Tried using Windows Update instead of Microsoft Update?

Go to the regular Windows Update link from within IE, then click "Change Settings" on the left, then tick the box at the bottom on the right to check only for Windows updates, then click the apply button.

Now try an Express check and watch svchost.exe CPU usage - is it reasonable?

0

Share this post


Link to post
Share on other sites
Tried using Windows Update instead of Microsoft Update?

Go to the regular Windows Update link from within IE, then click "Change Settings" on the left, then tick the box at the bottom on the right to check only for Windows updates, then click the apply button.

Now try an Express check and watch svchost.exe CPU usage - is it reasonable?

I can't leave automatic updates turned off and I also need microsoft update because it updates automatically office (and there are worms spreading through .ppt and .doc files).

0

Share this post


Link to post
Share on other sites
Go to the regular Windows Update link from within IE, then click "Change Settings" on the left, then tick the box at the bottom on the right to check only for Windows updates, then click the apply button.

it worked for me :thumbup no more high cpu/mem usage at startup

0

Share this post


Link to post
Share on other sites

Go to the regular Windows Update link from within IE, then click "Change Settings" on the left, then tick the box at the bottom on the right to check only for Windows updates, then click the apply button.

it worked for me :thumbup no more high cpu/mem usage at startup

Yes but you lose office updates and as you may know there are a lot of critical exploits coming out for office files. If you use outlook 2003 as a email client you can't keep automatic updates turned off.

0

Share this post


Link to post
Share on other sites

I also have this problem, when using MicrosoftUpdate. I figured out, that this happens if you have a lot of msi-files in the folder %Windir%\Installer. MSUpdate opens several files in this folder to check something, but I don't have any idea what the updater checks in this folder.

0

Share this post


Link to post
Share on other sites
I also have this problem, when using MicrosoftUpdate. I figured out, that this happens if you have a lot of msi-files in the folder %Windir%\Installer. MSUpdate opens several files in this folder to check something, but I don't have any idea what the updater checks in this folder.

It checks for external applications, for example office and windows desktop search. **** I wish there was a way to fix this mess I don't want to update office by hand every time.

0

Share this post


Link to post
Share on other sites

very interesting I was about to post about this problem.

I have auto updates disabled but when updating I get the same problem, it pauses for a while on 100% cpu usage and process explorer (sysinternals) shows its the svchost.exe for auto updates using the cpu. When it downloads the files its normal but then their is another 100%/delay before each update is installed. My pc is a amd64. On a amd 900 and p3 500 its much worse taking about 10-20 minutes.

0

Share this post


Link to post
Share on other sites
I have auto updates disabled but when updating I get the same problem...
Whether you visit Microsoft Update/Windows Update manually or the system does its automatic check, the code being executed is common (otherwise it would be a duplication and 2 sets of code to maintain & patch).

The current workarounds are to switch from Microsoft Update (back) to Windows Update, or to move the .MSI files out of the %systemroot%\Installer folder.*

Edit:

* If uninstalling an application requires the MSI file you can either return it to this folder or point to the new location.

Edited by Mr Snrub
0

Share this post


Link to post
Share on other sites
I have auto updates disabled but when updating I get the same problem...
Whether you visit Microsoft Update/Windows Update manually or the system does its automatic check, the code being executed is common (otherwise it would be a duplication and 2 sets of code to maintain & patch).

The current workarounds are to switch from Microsoft Update (back) to Windows Update, or to clear the .MSI files in the %systemroot%\Installer folder.

If you clear the MSI files you can't uninstall anything without the installer. **** somebody should report this to MS to have this mess fixed.

0

Share this post


Link to post
Share on other sites

I switched back to WindowsUpdate und searched for Office-Hotfixes seperately. This is a **** stupid bug.

0

Share this post


Link to post
Share on other sites
I switched back to WindowsUpdate und searched for Office-Hotfixes seperately. This is a **** stupid bug.

With the latest office 0day exploits you can get infected by worms just by opening a word file this is why downloading all the office hotfixes by hand is not a good idea.

Edited by Francesco
0

Share this post


Link to post
Share on other sites

I install every Hotfix for Office and Windows on every patchday ;)

0

Share this post


Link to post
Share on other sites
I install every Hotfix for Office and Windows on every patchday ;)

I can't I have too much PCs at home to install updates on all of them every time. Also I can't leave the PCs i've repaired without MU.

0

Share this post


Link to post
Share on other sites

why don't you use a WUS-Server?

0

Share this post


Link to post
Share on other sites

I've found a better idea. You know the MS baseline analyzer? If I run it with a schedule now it automatically makes automatic updates get the updates even for office! This should finally fix the problem.

0

Share this post


Link to post
Share on other sites

cool, I'll check this out.

0

Share this post


Link to post
Share on other sites

I solve this issue.

The update Hotfix KB916089 Version 5 ( http://support.microsoft.com/kb/916089/en-us ) (Msi.dll 3.1.4000.2805) solve the issue. I don't have 100% cpuusage and I still have a GUI when installing programs through a msi-file. The GUI wasn't shown while installing, so that programs which have 2 or more cds fails to install, when I installed other patches who had a never msi.dll than MSI 3.1V2.

I'm so happy :thumbup:wub:

0

Share this post


Link to post
Share on other sites

Scan for viruses and malware. Then go to Start > Run > cmd

Enter this:

sfc /purgecache

When complete, enter:

sfc /scannow

This may ask for your Windows install cd.

0

Share this post


Link to post
Share on other sites
I solve this issue.

The update Hotfix KB916089 Version 5 ( http://support.microsoft.com/kb/916089/en-us ) (Msi.dll 3.1.4000.2805) solve the issue. I don't have 100% cpuusage and I still have a GUI when installing programs through a msi-file. The GUI wasn't shown while installing, so that programs which have 2 or more cds fails to install, when I installed other patches who had a never msi.dll than MSI 3.1V2.

I'm so happy :thumbup:wub:

Yeah, ran in to that last week trying to install Street and Trips 2006.. Took me a few minutes to track down the the probelm and then the hotfix that updated msi.dll.. Going to try this new one out so I can have the fix and still run MSI installers correctly.. :lol:

Tarun, not spyware in this case.. Seen it on 2 machines that are completely clean.. (1 doesnt even get connected to the net actively).. Before 916089 v5 there was another hotfix (I dont remember the number now, the one I removed earlier) that also updated msi.dll but didnt cut it for this bug..

Update: Found it..

Actually there were a couple updates that replaced msi.dll

http://support.microsoft.com/kb/906219

Never installed that one.. (Oldest update I can find that is newer then the MSI 3.1 base install)

And

http://support.microsoft.com/kb/914810

Which happens to deal with a problem with Automatic Updates too.. It is the one that caused my installer for Streets and Trips to fail..

Msi.dll version 3.1.4000.2648

It didnt do anything to resolve the slow or dead stop updating I ran in to occasionally. It would still take forever to scan..

Edited by bilemke
0

Share this post


Link to post
Share on other sites
Tarun, not spyware in this case.. Seen it on 2 machines that are completely clean.. (1 doesnt even get connected to the net actively)..

yes, thats right. Tarun you are wrong, this is a strange Bug in the Microsoft Installer, but now, every thing is ok :):wub:

0

Share this post


Link to post
Share on other sites

Ooh, harsh! ;)

I just cover the most common possibilities, including that of which I just recently had to resolve at the shop. Those just turned out to be virus/malware related. Glad yours isn't though. :P

0

Share this post


Link to post
Share on other sites

:huh:

:rolleyes:

You are both wrong.. Wrong wrong wrong!!!! :realmad:

:lol:

Just a very annoying problem to encounter.. ;)

(And, end smiley face mod)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.