Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



soporific

Auto-Patcher For Windows 98se (English)

Recommended Posts

:hello: thydreamwalker, please don't confuse the issue :)

Techoidy, you only need the latest full version, you don't need preceding versions.

If re-installing the OS is an option, definitely take it. Do NOT install any updates until you have used Auto-Patcher, but by then you shouldn't need to. Auto-Patcher does what it was intended to do, provide an easy way to get your WIn98 OS updated without you having to do them all yourself.

The new version is coming very soon, the upgrade pack is about 25 megs (will upgrade your AP from dec 07 to june 08). here's the change log so far:

++++++++++++++++++++++++++++++++

June 2008

++++++++++++++++++++++++++++++++

update: "Twain Compatible Scanner Core Files Update" is now "Unofficial Windows Image Acquisition v1.1"

update: Sun Java 2 Runtime Environment 6 update 6

update: Unofficial DirectX Media Update for IE 6 sp1 (Apr '08)

update: kb947864 - Unofficial Cumulative Update for Internet Explorer 6 sp1

update: Unofficial Microsoft Scripting Engines v5.7 (JSCRIPT.DLL 5.7.0.20550) (removed v5.6)

update: RootsUpd - Root Certificate Update (Dec '07)

update: kb942763 - Unofficial Daylight Saving Time Zone Updates (Mar '08)

Share this post


Link to post
Share on other sites

:hello: thydreamwalker, please don't confuse the issue :)

Techoidy, you only need the latest full version, you don't need preceding versions.

If re-installing the OS is an option, definitely take it. Do NOT install any updates until you have used Auto-Patcher, but by then you shouldn't need to. Auto-Patcher does what it was intended to do, provide an easy way to get your WIn98 OS updated without you having to do them all yourself.

The new version is coming very soon, the upgrade pack is about 25 megs (will upgrade your AP from dec 07 to june 08). here's the change log so far:

++++++++++++++++++++++++++++++++

June 2008

++++++++++++++++++++++++++++++++

update: "Twain Compatible Scanner Core Files Update" is now "Unofficial Windows Image Acquisition v1.1"

update: Sun Java 2 Runtime Environment 6 update 6

update: Unofficial DirectX Media Update for IE 6 sp1 (Apr '08)

update: kb947864 - Unofficial Cumulative Update for Internet Explorer 6 sp1

update: Unofficial Microsoft Scripting Engines v5.7 (JSCRIPT.DLL 5.7.0.20550) (removed v5.6)

update: RootsUpd - Root Certificate Update (Dec '07)

update: kb942763 - Unofficial Daylight Saving Time Zone Updates (Mar '08)

Now that I recall, I think I used your Autopatcher incorrectly. I installed "December 2007 Final (FULL)" first and then installed "December 2007 RC1 to December 2007 Final (UPGRADE)" over it, thinking it was an upgrade to Dec 2007 Final Full, but now I see it is an upgrade path from Dec 2007 RC1. Am I correct? I don't know if that was partly to blame for my PC getting corrupt. I will await the June2008Upgrade. How is "very soon"? So when I reinstall my OS, I run Dec2007FinalFull first and then June2008Upgrade, yes?

Also, what do you mean by "Do NOT install any updates until you have used Auto-Patcher"? Are you talking about the 98SE Windows Update at the Microsoft site? So then what is the best order of installation should I use then? Does it look something like this? >>

0. 98SE CD install

1. Hardware drivers

2. Autopatch

3. Windows Update

4. DirectX 9C

5. IE 6 and SP's (or is this all on the AP?)

6. TweakUI for 98SE (v1.33 I think)

7. MS Office (I will use MSO 2k)

8. Any other software

In a prior thread, someone also told me about Service Pack 3.2 beta by Gape. Do I really need this too?

Finally, is there any other beta patches I should install after Autopatcher? There are so many projects, I don't know what else I'd want/need to use. This includes any unofficial service packs for 98SE, if there's any you recommend. I also intend on reading this entire thread. Thanks for the help thus far.

Share this post


Link to post
Share on other sites
:whistle: Just stating Auto-patcher works better when use older Sept2007 Application First ...then apply newer ones...At least this is how it works on 4 different computers i use with 98SE on a weekly rotation......All have Full 98SE updares and applications from MSFN sources=90% with microsoft=10% orless installs if really necessary!*Just not being confusing just trying to help order of events which installs can be installed in proper order *if we wish to do this on our own?This could and should be listed in a MSFN Topic "Possibly???"Just for everyone's interest at least?oh,well :blink:

Share this post


Link to post
Share on other sites
...

So when I reinstall my OS, I run Dec2007FinalFull first and then June2008Upgrade, yes?

...

Correct.

...

Also, what do you mean by "Do NOT install any updates until you have used Auto-Patcher"? Are you talking about the 98SE Windows Update at the Microsoft site?...

Here is what I wrote some posts back to answer your question:

...

Auto-Patcher 98 has everything on Windows Update and more including many newer updates.

Even though Windows Update for 9x is no longer updated, Microsoft are still updating components like IE6 SP1 and WMP 9.

...

...

So then what is the best order of installation should I use then? Does it look something like this? >>...

Here is your list amended:

0. 98SE CD install

1. Hardware drivers

2. Autopatch

3. Windows Update - as explained above

4. DirectX 9C - in Auto-Patcher

5. IE 6 and SP's (or is this all on the AP?) - in Auto-Patcher, and SPs are not really needed with AP

6. TweakUI for 98SE (v1.33 I think) - an optional install in AP, from memory

7. MS Office (I will use MSO 2k) - update Office at http://office.microsoft.com/en-au/downloads/maincatalog.aspx

8. Any other software

...

In a prior thread, someone also told me about Service Pack 3.2 beta by Gape. Do I really need this too?...

As above, no not really since Auto-Patcher will install all the individual updates anyway.

...

Finally, is there any other beta patches I should install after Autopatcher?...

You can look at MDGx's updates topic (just been updated):

http://www.msfn.org/board/98-FE-98-SE-ME-u...hes-t46581.html

Edited by RetroOS

Share this post


Link to post
Share on other sites
Now that I recall, I think I used your Autopatcher incorrectly. I installed "December 2007 Final (FULL)" first and then installed "December 2007 RC1 to December 2007 Final (UPGRADE)" over it, thinking it was an upgrade to Dec 2007 Final Full, but now I see it is an upgrade path from Dec 2007 RC1. Am I correct? I don't know if that was partly to blame for my PC getting corrupt. I will await the June2008Upgrade. How is "very soon"? So when I reinstall my OS, I run Dec2007FinalFull first and then June2008Upgrade, yes?

Also, what do you mean by "Do NOT install any updates until you have used Auto-Patcher"? Are you talking about the 98SE Windows Update at the Microsoft site? So then what is the best order of installation should I use then? Does it look something like this? >>

0. 98SE CD install

1. Hardware drivers

2. Autopatch

3. Windows Update

4. DirectX 9C

5. IE 6 and SP's (or is this all on the AP?)

6. TweakUI for 98SE (v1.33 I think)

7. MS Office (I will use MSO 2k)

8. Any other software

In a prior thread, someone also told me about Service Pack 3.2 beta by Gape. Do I really need this too?

Finally, is there any other beta patches I should install after Autopatcher? There are so many projects, I don't know what else I'd want/need to use. This includes any unofficial service packs for 98SE, if there's any you recommend. I also intend on reading this entire thread. Thanks for the help thus far.

First, installing RC1 over the final December 2007 version is not the end of the world as long as you then installed the upgrade to Dec Final over the top. The only thing wrong with this is that there will be extra obsolete files in the AP program directory that you don't need that takes up space. The patching process should be exactly the same.

Second, auto-patcher contains: DirectX 9C, IE6 and service packs, and TweakUI for 98SE, so you can remove these from your list. Also, simply FORGET about using Windows Update -- not only has Microsoft stopped updating WU, it will report that you are missing some updates when in fact you already have them installed. This happens due to the unofficial updates overwriting files that WU expects to find. There is no harm visiting WU, just treat their results with a grain of salt.

You don't need Gape's Service Pack 3.2 beta, but it does install a few extra goodies that AP doesn't. I'm sorry, i can't provide a list of what is different, but you can compare the two contents lists and see for yourself. I recommend installing gape's SP after you have finished using AP.

With regard to other packs, if they contained anything crucial, i would have already included them in AP. That's not to say there is no point installing them, just that its certainly not necessary. AP is designed to make your PC fully up-to-date, so to be on the safe side, its NOT a good idea to install ALL the update packs -- pick your preferred update pack and stick with it.

Hope this helps.

Share this post


Link to post
Share on other sites

Soporific, does AP June 2008 contain the June 2008 Update to DirectX 9.0c Runtime?

The reason I ask is because I've been having trouble installing it (see here)

This hasn't been resolved as yet, and I was hoping that AP might succeed where the normal install routine is failing!

Thanks, Dave.

:)

Share this post


Link to post
Share on other sites
:hello: Thanks for IE CU info as my system went "Really" crazy after MDIECU 2.2 and it was normal after Complete Re-install without 2.2 and stuck to older MDIECU2.1a......COOL! :thumbup So we should re-add 950759 ,after using mdiecu2.2...then it would re-update backdated files...Correct??? :wacko: thanks

Share this post


Link to post
Share on other sites

Hi again. Just to update, I went ahead and reformatted and reinstalled 98SE and then tried Autopatcher again (latest version, Dec2007Full). I patched everything except that Jet database thingy (about 149 things I think) and stuff seem to be working successfully and stable now (no blank desktop this time). However, during the patching, DirectX 9.0C installation just kinda stalled/froze. I rebooted and then did a forced install, but that didn't work either. When I go into dxdiag, it shows DX at version 6. I have read Dave-H's thread. Is that the same problem? Or should I just go ahead and install DX9.0C using Microsoft's redistributable package? I shall await a reply(s), thanks.

Btw, what exactly is that Jet database stuff? I might useful for me, who knows. I'm guessing it has something to do with databases, but I could be wrong. ;)

Edited by technoid

Share this post


Link to post
Share on other sites
...

Btw, what exactly is that Jet database stuff? I might useful for me, who knows. I'm guessing it has something to do with databases, but I could be wrong. ;)

The Jet Database Engine is used by Windows and many applications to store and access data.

Because of this, it is a targeted part of Windows by malicious software.

Therefore, I would recommend that you install the Jet Database updates just for security reasons alone.

Share this post


Link to post
Share on other sites
The Jet Database Engine is used by Windows and many applications to store and access data.

Because of this, it is a targeted part of Windows by malicious software.

Therefore, I would recommend that you install the Jet Database updates just for security reasons alone.

Are you saying that stock 98SE (fresh CD install) already has Jet as part of the stock OS? If not, I know I don't have Jet installed at all, not even from AP, let alone any Jet updates.

Share this post


Link to post
Share on other sites
...

Are you saying that stock 98SE (fresh CD install) already has Jet as part of the stock OS?...

Yep.

The Windows 98SE CD CABs contain MS Jet 3.5 and MS Jet 4.0 files.

Share this post


Link to post
Share on other sites

Just checking in to say :hello: so ya know I ain't MIA. Been busy building a few old 'puters and learning newer-type stuff (XP, Server, Networks, Firewalls, etc). :wacko:

Share this post


Link to post
Share on other sites

:hello: I tested the Version of jscript.dll

-- 5.6.0.8831 / 5.6.0.8835 (SCR569x)944338 :thumbdown

also in mdi6cu22e (be aware of that)i do not recommend this update because of the 944338

-- 5.7.0.16535--5.7.0.20550 (SCR579x) :thumbdown

and i found that all newer Versions from 5.6.0.8831 up are buggy

5.6.0.8835 see older posts is totaly buggy

5.7.0.16535 /5.7.0.20550 i found these Bugs --

go to this Site

http://tel.search.ch/ type a name / search / hit the underlined name / hit maps / and i see no map !?????!

only with 5.6.0.8831 it works fine ?????

in Firefox 2.0.0.16 it works fine

and the best is

when i login to my sunrise mail account , i dont see my messages,Site loads not all, must go to Firefox to work properly !!!!!!!?????

no problem with older Version

when i go to yahoo.de games applets wont load !!!??!??

and with newer jscript.dlls i have sometimes no historymenu anymore ??????

uuuuuuuaaahhhhhahhaaaaa :realmad:

I installed new AP DEZ Full (IE 6 Sp1 and 950759)

Flash 9.0.124 shockwave 10.2.0.23 (nothing newer will wait for final releases ) to test

i will use only 5.6.0.8831 :thumbup

this will calm my nervs :thumbup

,the rest of that crap Updates are realy s***y :rolleyes:

Edited by barbarien

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×