Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


jungle_warrior

net use failed under winpe 2.0

16 posts in this topic

I type the following command under winpe 2.0

X:\windows\system32> net use k: \\192.168.0.135\share

user name:guest

password:

The user context supplied is invalid

and if use net /add to add a user, then
X:\windows\system32> net use k: \\192.168.0.135\share username

It shows net helpmsg 1312.

The network seems working, IP address is 192.168.0.74, and ping 192.168.0.135 is ok.

:angel

how to make net use work? thanks in advance.

0

Share this post


Link to post
Share on other sites

What operating system are you connecting to?

Guest accounts are usually locked out.

2003 server will generally disallow accounts without passwords to connect.

Create an account with a password and check share perminnsions as well as ntfs permissions to the shared folder and use the context:

net use t: \\%server%\%share% password /user:usename (may need to be /user:%server or domain%\username

oh, test the connection using the administrator account and test the share permissions set to everyone - full controll then work back on the security settings.

0

Share this post


Link to post
Share on other sites

Many thanks for your warm hearted help... :angel

however the problem is still there. have anyone successfully use network in winpe2.0?

The operating system I connect to is XP SP2 and Win2K advanced server.

and I give full control to the Everyone group, but still not work.

I tried net.exe many times with many arguments, and the most often receive helpmsg 1312.

and to my surprise, in WinPE, ping another machine is ok(such as 192.168.0.135), but on another machine,ping the WinPE machine is not ok!

0

Share this post


Link to post
Share on other sites

I know it's not down to domain or workgroups as my pe2 connects to anything I want. Your share may have everyone full control but what are the ntfs permissions set at on the folder that is shared.

Are you using dhcp as the default subnet mask for that ip address is 255.0.0.0 which might put the systems on different subnets.

0

Share this post


Link to post
Share on other sites

Yes it is DHCP, I boot pe2 from local hard disk, and, there is a wpeinit.log file in the x:\windows\system32 directory, the content of the file includes:

no unattend file was found... wpeinit use default settings...

ipv6 initialized ok, parameters is ...

ipv4 initialized ok, found DHCP server at 192.168.0.2

default gate is 192.168.0.1

default DNS is 192.168.0.1

ipv4 address is 192.168.0.87(Perferred)

NETBIOS over TCP/IP is ok...

node type: hybrid

...

...

but what and where is the "unattend" file? in previous versions of winpe, there is winbom.ini, but what it is for the pe2.0's wpeinit.exe? like some friends have said, the pe2.0's help documents is "not helpful" :w00t:

0

Share this post


Link to post
Share on other sites

To connect to XP + SP2 from PE you need to disable some of the security features added by SP2. Run the following reg file on the XP + SP2 machine to which you are trying to connect:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters]

"NullSessionPipes"=hex(7):43,00,4f,00,4d,00,4e,00,41,00,50,00,00,00,43,00,4f,\

00,4d,00,4e,00,4f,00,44,00,45,00,00,00,53,00,51,00,4c,00,5c,00,51,00,55,00,\

45,00,52,00,59,00,00,00,53,00,50,00,4f,00,4f,00,4c,00,53,00,53,00,00,00,4c,\

00,4c,00,53,00,52,00,50,00,43,00,00,00,62,00,72,00,6f,00,77,00,73,00,65,00,\

72,00,00,00,73,00,72,00,76,00,73,00,76,00,63,00,00,00,00,00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]

"RestrictAnonymous"=dword:00000000

You will need to use the target computer name as part of the /user parameter for a workgroup connection.

Edited by Paraglider
0

Share this post


Link to post
Share on other sites

nice! thanks all.

success, connect to Win2K server, with user name \\%server_name%\%user_name%

0

Share this post


Link to post
Share on other sites

jungle,

is ping from other machine to winpe now successful?

i still cannot ping winpe from other machine

how to make it succesful?

0

Share this post


Link to post
Share on other sites
is ping from other machine to winpe now successful?

i still cannot ping winpe from other machine

how to make it succesful?

probably you can't to winpe because of the WinPE 2.0 integrated Firewall. It is enabled by default, if I remember well.

0

Share this post


Link to post
Share on other sites
nice! thanks all.

success, connect to Win2K server, with user name \\%server_name%\%user_name%

I had the same problem. After reading this thread, I can connect to the share resource without disable any security, but using corect format for user

i still cannot ping winpe from other machine.

MS007 suggested that probably is because of the WinPE 2.0 integrated firewall.

Can somebody help me to disable the firewall?

0

Share this post


Link to post
Share on other sites
wpeutil.exe DisableFirewall

I am not able to ping other machine from winPE 2.0.

It says "ping transmit failed error code 1231"

I also tried diabling firewall with above settings.

(I have n/w booted vmware bare metal instance using PXE method)

0

Share this post


Link to post
Share on other sites

Have installed the vmware drivers into WinPE2?

I have WinPE2 networking working in VMWare Workstation using the default nic devices.

here is the list of vmware drivers I preload into winpe2:

vmware-nic.inf

vmxnet.inf

vmx_svga.inf

vmmouse.inf

vmmemctl.inf

0

Share this post


Link to post
Share on other sites
Have installed the vmware drivers into WinPE2?

I have WinPE2 networking working in VMWare Workstation using the default nic devices.

here is the list of vmware drivers I preload into winpe2:

vmware-nic.inf

vmxnet.inf

vmx_svga.inf

vmmouse.inf

vmmemctl.inf

Thanx Guru it works :)

0

Share this post


Link to post
Share on other sites

Have installed the vmware drivers into WinPE2?

I have WinPE2 networking working in VMWare Workstation using the default nic devices.

here is the list of vmware drivers I preload into winpe2:

vmware-nic.inf

vmxnet.inf

vmx_svga.inf

vmmouse.inf

vmmemctl.inf

Thanx Guru it works :)

I am facing networking issues while n/w booting DOS image.

i can net use and map network drive.

but "dir" doesnt show any files in n/w drive

it shows "File Not Found".

After googling, I found this link:

http://www.computing.net/dos/wwwboard/forum/10680.html

But i could not locate pcnet.cab.

P.S. I know this forum might not be a right place to post this question, but context is pretty similar so I posted

0

Share this post


Link to post
Share on other sites

My Solution:

Map the network drive from Startnet.cmd but place the command after call to wpeinit.

Steps:

1. MountRW the boot.win.

2. Goto SYSTEM32

3. Open Startnet.cmd

4. Type:

wpeinit

Net use * \\Server Location user:UserName Password

Hope I helped!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.