Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Editing WINNTBBU.DLL For Dummies

- - - - -

  • Please log in to reply
151 replies to this topic

#26
Yazoo

Yazoo

    Junior

  • Member
  • Pip
  • 60 posts
I think when you do a setup straight from the CD you will use the winntbu.dll file. But when you boot from the CD it will uncompress the winntbu.dl_ and use that. Thats why you did not see the tweaked screen at first.


How to remove advertisement from MSFN

#27
Enclave

Enclave

    Newbie

  • Member
  • 15 posts
How do I change the resolution of the setup screen? I edited my setup screen and it worked but it is only displayed at 640x400 or 800x600 not sure which one but def not 1024x768.....


I set bitmap 103 with a 256 colors 1024x768.....

#28
celzius

celzius

    Newbie

  • Member
  • 45 posts
Ogre, can you please post a link to your matrix winntbbu.dll file. It's very cool, thanks. :)

#29
b0r3d

b0r3d

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 821 posts

How do I change the resolution of the setup screen? I edited my setup screen and it worked but it is only displayed at 640x400 or 800x600 not sure which one but def not 1024x768.....


I set bitmap 103 with a 256 colors 1024x768.....

you need to have a relatively good match for your graphics drivers on your CD. If you dont, windows will use its standard driver which may not work well with your card, forcing it into a lower resolution.

Try getting the latests ones for your card, unpack them, throw them on your CD, and add the location to your winnt.sif file.
Remember, you can wear your underpants four times without washing.
Forwards. Backwards. Inside out forwards, and inside out backwards.

#30
Enclave

Enclave

    Newbie

  • Member
  • 15 posts
That would make sense but I always thought that the driver was installed during the "Installing Devices" phase so for 5 mins I would see a screen that was low resolution. Anyway I have a Geforce 3 ti200 and when it installed the driver 45.33 it still uses low resolution.

#31
b0r3d

b0r3d

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 821 posts
To tell you the truth, im not completly sure what would cause that to happen.
Remember, you can wear your underpants four times without washing.
Forwards. Backwards. Inside out forwards, and inside out backwards.

#32
Enclave

Enclave

    Newbie

  • Member
  • 15 posts
Can anyone confirm that the nvidia cards can get high resolution at setup????
specifically a geforce 3
If so tell me the drivers used.... or any method that worked before actually getting it to run at high resolution.

#33
b0r3d

b0r3d

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 821 posts
Well im using a Geforce 4 MX 440 and it works perfectly.
I dont see why it would be a problem...is your XP CD legit ?
Remember, you can wear your underpants four times without washing.
Forwards. Backwards. Inside out forwards, and inside out backwards.

#34
Enclave

Enclave

    Newbie

  • Member
  • 15 posts
Using cd that came with my dell computer. Would that make a difference? Hmm just installed on that computer and it seems that it didnt install the new 43.33 drivers.. THat might be a problem :)

#35
Ogre

Ogre

    They call me Ogre cause i'm hairy.

  • Member
  • 44 posts

Ogre, can you please post a link to your matrix winntbbu.dll file. It's very cool, thanks. :)

i'm still working on it, but as soon as its done, i'll post link.

#36
Enclave

Enclave

    Newbie

  • Member
  • 15 posts
Hmm i'm wondering with 1024x768 if that is the resolution you start with right after the reboot of txtsetup...... OK finally got it to install the 40.31 drivers because the new 45.25 or whatever was giving me problems. It definitely installed the drivers because I booted up with them. But it is still a 800x600 setup screen..

I dont understand how this could be causing me to only run 800x600 because the setup only installs the drivers after it is in the setup. Let me try installing a pre made one maybe mine just sucks??

check my winnt.sif:


[Data]    AutoPartition=0
    MsDosInitiated="0"
    UnattendedInstall="Yes"

[Unattended]
    UnattendMode=DefaultHide
    OemPreinstall=Yes
    OemSkipEula=Yes
    NoWaitAfterTextMode=1
    NoWaitAfterGUIMode=1
    TargetPath=\WINDOWS
    DriverSigningPolicy=Ignore
    OemPnPDriversPath="Drivers\nForce\GART;Drivers\nForce\MemCtl;Drivers\nForce
\IDE;Drivers\SATAr;Drivers\nForce\SMBus;Drivers\nForce\Ethernet;Drivers\ATI\Driver\2KXP_INF;Drivers\Nvidia;Drivers\nForce\AudioDrv"


[GuiUnattended]
    OEMSkipWelcome = 1
    EncryptedAdminPassword=NO
    TimeZone=4
    OEMSkipRegional=1

[UserData]
    ProductKey=""
    FullName=""
    OrgName=""

[Display]
    BitsPerPel=32
    Xresolution=1024
    YResolution=768
    Vrefresh=85

[Identification]
    JoinWorkgroup=MSHOME

[Networking]
    InstallDefaultComponents=Yes

[Components]
    msmsgs=off
    msnexplr=off
    zonegames=off

[Shell]
    DefaultStartPanelOff = Yes
    DefaultThemesOff = Yes

[GuiRunOnce]



#37
C0rpse Phxer420

C0rpse Phxer420

    Newbie

  • Member
  • 39 posts
:) DAMNIT :rolleyes:

Ok, first things first, this is a damned amazing thing. This was definitely the type of customization that I was looking for. I followed your guide and everything is fine....EXCEPT that when I save my file as a 256 color bitmap, the colors get all "pasty." Now, I understand that I'm going from a higher to lower color count and that's why. So my question is to you guys...how the hell are you guys making those nice high-res install pics? I'm using Photoshop 7.0 and just take my files and save it as a 256 color bmp. I've also used the built in windows paint and same thing...What photo editing programs are you guys using and most importantly....I have not downloaded any of your winntbbu files, so I haven't seen if they are really nice looking, but in the screenshots they look very nice, high res, and clean cut. Am I doing something wrong???
2 out 3 people contract anthrax anally...ENJOY!
[-= C0rpse Phuxer 420 =-]

#38
b0r3d

b0r3d

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 821 posts
I use photoshop 7 to make mine aswell.
The way i drop the colour resolution on my pictures, is to open/make your picture then select image --> mode --> index colour.
Just have a fiddle with the options there, and make sure its 256 colours.

Hope it helps! :)
Remember, you can wear your underpants four times without washing.
Forwards. Backwards. Inside out forwards, and inside out backwards.

#39
C0rpse Phxer420

C0rpse Phxer420

    Newbie

  • Member
  • 39 posts
Alright, I'm currently having probs with my photoshop right now. Every time I go and try to open it, I get a "system error" from photoshop, not windows and it will not let me get into it...time for a...do I dare say it? *FORMAT* After I format and set everything back up, I will try that. Thank you bored, and thank you everyone for all the time you've spent on this!
2 out 3 people contract anthrax anally...ENJOY!
[-= C0rpse Phuxer 420 =-]

#40
valkyre

valkyre

    Member

  • Member
  • PipPip
  • 112 posts
Does anyone know if it's possible to use a higher color amount, other then 256?

#41
valkyre

valkyre

    Member

  • Member
  • PipPip
  • 112 posts
Scratch that, I got my setup screen looking quite decent at 256 colors.

#42
astrolabos

astrolabos

    Newbie

  • Member
  • 16 posts
Marvelous, simply beautiful. Way to go b0r3d!!! :)
Posted Image

#43
Mann

Mann

    Junior

  • Member
  • Pip
  • 95 posts
how to capture the screenie during setup :)

#44
The Saint

The Saint

    Junior

  • Member
  • Pip
  • 52 posts
hmmm is there any way to see how the Setup screen will look during the installation or everytime you have to reformat everything???

:rolleyes:

an exe file somewhere....??

yes....? :)

#45
The Saint

The Saint

    Junior

  • Member
  • Pip
  • 52 posts
I `ve the same problem Enclave is having.

I did a Setup Screen and its only displayed at 800*600 and on my LCD looks really bad!

Anybody has a site were to upload the screenie of my setup......?

#46
DaveXP

DaveXP

    The One

  • Member
  • PipPipPipPipPipPip
  • 1,295 posts
email me the screen shot dave.neilson@ntlworld.com i will put it up for you.

#47
The Saint

The Saint

    Junior

  • Member
  • Pip
  • 52 posts
done! :)

#48
DaveXP

DaveXP

    The One

  • Member
  • PipPipPipPipPipPip
  • 1,295 posts
Here we go:

Image

looks nice. :)

#49
The Saint

The Saint

    Junior

  • Member
  • Pip
  • 52 posts
Thanks Dave!

The only problem is changing the TEXT color to black or something like it!

Otherwise you can`t see anything! :)

#50
DarkBringer

DarkBringer

    Member

  • Member
  • PipPip
  • 219 posts
  • OS:none specified
  • Country: Country Flag
If The Saint or anyone else hasn't figured out something yet, the way I found to see
how my setup screen will look is to save the XP CD as an iso and then mount the image on a virtual drive (created by CloneCD or Alcohol 120%).

From there you should just choose to install XP. (But don't go any further!..........
......Unless you want to)
If a man speaks in a forest, and no woman is there to hear him, is he still wrong?




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Baidu (1)


How to remove advertisement from MSFN