Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



IcemanND

[Utility] Driver Backup

Recommended Posts

Double driver misses a lot of files.

Driver genius isn't free for the full version, and I've had the free version miss files.

Mine is free for anyone to use, and though it may still have a few bugs, it will pull all of the files for a driver that it finds.

I'm currently working on an updated version which is faster. The file search is the slowest part of the application and I've managed to narrow the searches and speed them up but there are still a few issues before I release it for general consumption.

Share this post


Link to post
Share on other sites

Using driverbackup79

Running Win2k sp4

Hit scan machine and got;

d-link dfe-530tx+ pci adapter

dell p991

nvidia geforce2 gts/geforce2 pro

via bus master ide controller

via cpu to agp controller

via standard cpu to pci bridge

win2000 promise ultra 100 ide controller(pdc20265)

Hit backup drivers and got;

backup path: c:\driverbackup

working folder: c:\docume~1\admini~1\locals~1\temp

listbox line: d-link dfe-530tx+ pci adapter

driver caption: d-link dfe-530tx+ pci adapter

locating drivers for d-link dfe-530tx+ pci adapter

creating folder: c:\driverbackup\d-link dfe-530tx+ pci adapter

oem10.inf

Then it stops with an internet explorer script error.

!An error has occured in the script on this page.

line: 2029

char: 2

error: could not complete the operation due to error 80041017

code: 0

url: file://c:\documents and settings\administrator\local

settings\application data\compiledScriptHTA

Happens every time backing up 1 driver, several, or all.

I'm hoping the next version will fix it. :)

elbrute

Share this post


Link to post
Share on other sites

Never been tested with W2k, at least to my knowledge.

v2 should work with 2k, hope to release it by the end of the week.

Share this post


Link to post
Share on other sites

I too am looking forward to this working in Windows 2000. Looks like a great tool. And maybe this thread should be made "sticky"?

Share this post


Link to post
Share on other sites

Version 2 which is almost complete has been completely rewritten from beginning to end. I hope to have it finalized and ready for alpha testing by the end of the first week of January.

Share this post


Link to post
Share on other sites

I'm getting an error every time I press backup.

Line: 1897

Char: 5

Error: No value given for one or more required parameters

Code: 0

Do you want to continue running scripts on this page?

YES/NO

And when I press yes nothing happens.

When I press backup again there comes other error message.

Line 1882

Char 3

Error: Operation is not allowed when the object is open

Code 0

YES / NO

And I can not do anything with this prog.

Share this post


Link to post
Share on other sites

Yeah, what's the IE scipt errors? :blink: Nice that you are making something I've wanted for ages but Driver Genius 2005 Pro works for me each time.

Share this post


Link to post
Share on other sites

Awesome utility. Have you thought about making this tool available under knoppix? Its nice to be able to boot into windows and run driverbackup but what if its so far gone you cant?

John

Share this post


Link to post
Share on other sites

I really like your program. Nice and simple and to the point with no bull.

I do have an error though when trying to backup Cam driver. Can you help please?

thanks

post-123402-1169749087_thumb.jpg

Share this post


Link to post
Share on other sites

Trying to run driverbackup79.exe I'm getting an application error: Cannot install the apllication properly (0xc0000135).

post-124433-1174830276_thumb.jpg

What's wrong / how can this be fixed?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×