Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

New Utility: Windows Media Player 11 Integrator

- - - - -

  • Please log in to reply
82 replies to this topic

#51
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts

does integrate cabs files, or is doing the same as command /integrate


What is the difference between 2 methods?

/integrate relies on Microsoft's method of integration while doing cab integration is more of a hand picked method.


How to remove advertisement from MSFN

#52
R33K3R

R33K3R

    it's just me

  • Members
  • 45 posts
excellent tool jcarle thank you :thumbup I'll use it soon.

but there's a little something I need help with,I want to add some WMP Skins to be installed with the player during the unattended setup,please tell me how-to?

thanks again :D

#53
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts
Simplest way is to add them to your $OEM$ folder so that they're automatically copied to the right directory.

#54
chiners_68

chiners_68

    Advanced Member

  • Members
  • PipPipPip
  • 310 posts
Hi Guys,
Need a little help here..

im using BArtPE wit the XPE shell via RIS. when it boots up I get the error message reported on previous pages.

Dialogue title: unregmp2.exe - Unable To Locate Component
Dialogue box: This application has failed to start because WMDRMSDK.DLL was not found. Re-installing the application may fix this problem.


how can I get round this with my setup.?

#55
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts

Hi Guys,
Need a little help here..

im using BArtPE wit the XPE shell via RIS. when it boots up I get the error message reported on previous pages.

Dialogue title: unregmp2.exe - Unable To Locate Component
Dialogue box: This application has failed to start because WMDRMSDK.DLL was not found. Re-installing the application may fix this problem.


how can I get round this with my setup.?

Make sure that those two files found in I386 on your XP source get copied over to WINDOWS\SYSTEM32.

#56
ralphclark

ralphclark
  • Members
  • 1 posts
I had a problem installing the "start menu" version (1.0b60). After right clicking on the .inf file there was a popup saying "The file 'uninstall.exe' on WMP11 Integrator Files is needed. Type the path where the file is located, and then click OK."

I know that uninstall.exe is in the .cab file but the Windows installer can't seem to find it and I had to extract it manually.

Is this a problem with the version of Windows Installer my system has? Its on Windows Update and should be completely up to date. I just wonder what else won't work if this is a problem.

#57
booster

booster

    Junior

  • Members
  • Pip
  • 63 posts
I use the 1.1.60 version, but still get the message that wmdrmsdk.dll is missing.

If I copy wmdrmsdk.dll and mfplat.dll to the windows folder manually it works fine.

In DOSNET.INF I have

[Directories]
d5=\

[Files]
d5,I386\wmdrmsdk.dll
d5,I386\MFPLAT.dll

In TXTSETUP.SIF I have

[SourceDisksFiles]
wmdrmsdk.dll = 100,,,,,,,2,0,0
mfplat.dll   = 100,,,,,,,2,0,0


Seems right, but still dosnt work unless I manually copy the 2 files to the systemroot folder.

#58
tap52384

tap52384

    nLite Lover

  • Members
  • PipPipPip
  • 331 posts
Is your WMP11 integration the first modification to your XP source? I find that if it is not that problems arise.

#59
booster

booster

    Junior

  • Members
  • Pip
  • 63 posts
No I have integrated some hotfixes with nlite.
Should I integrate WMP11 first and then the hotfixes ?

#60
NeoZeruel

NeoZeruel

    Newbie

  • Members
  • 25 posts
Hi jcarle, your wmp integrator is great... but the theme service doesn't start... Are you working on that?

thanks and congratulations for your work... and sorry about my english :D

#61
boooggy

boooggy

    MSFN Master

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,329 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
i made a fix for that theme issue but on current time is not online....it will be hopefully soon

#62
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts

Hi jcarle, your wmp integrator is great... but the theme service doesn't start... Are you working on that?

thanks and congratulations for your work... and sorry about my english :D

I can't quite put my finger on what causes that. Does anyone have any idea?

#63
Lemonzest

Lemonzest

    Junior

  • Members
  • Pip
  • 84 posts
Hi

I just used the latest version of this to integrate into Windows Server 2003 Enterprise and on txt setup it could not copy mfplat.dll and asked me to retry or skip.

#64
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts
I don't believe that Microsoft officially supports WMP11 on Windows Server 2003.

#65
_philosopher

_philosopher
  • Members
  • 9 posts
Does it work witch spanish WMP11 and XP?

#66
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts

Does it work witch spanish WMP11 and XP?

If it's a final release, and not the beta one, it should work fine. :)

#67
R33K3R

R33K3R

    it's just me

  • Members
  • 45 posts
I don't know what happened,I just tried to use the integrator with new nLite 1.3 RC and it fails,i started with a fresh source as you instructed but nlite 1.3 RC gave me this Posted Image

then I tried to ignore the prompet and select No.

the slipstreaming begins then it suddenly fails and give me this:

Posted Image

any help is much appreciated :blushing:

#68
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts

I don't know what happened,I just tried to use the integrator with new nLite 1.3 RC and it fails,i started with a fresh source as you instructed but nlite 1.3 RC gave me this Posted Image

then I tried to ignore the prompet and select No.

the slipstreaming begins then it suddenly fails and give me this:

Posted Image

any help is much appreciated :blushing:

slipstream sp2 first, then wmp11, then hotfixes

#69
R33K3R

R33K3R

    it's just me

  • Members
  • 45 posts
my bad,sorry I misinterpreted "fresh source",thanks I'll try again :thumbup

#70
toto51

toto51

    Newbie

  • Members
  • 11 posts
Hello

Great work :thumbup

But i have a problem.
I'm trying to integrate wmp11 (french final) to a fresh XP Home SP2 (french) using your soft (v1.1 b 60 ).
it seems to work flawlessly.

But...
the resulting txtsetup.inf is actually corrupted

["Keyboard Layout"]...
0000040C = "Franais"
0000080C = "Franais - Belgique"
00000C0C = "Franais - Canada"
00010C0C = "Franais - Canada, Multilingue"
0000100C = "Franais - Suisse"
...
0000041D = "Sudois"
00000405 = "Tchque"
00010405 = "Tchque - latin"
...

you can notice that "é", "è", "ç" are missing.
Of course, XP installation process breaks at the very beginning ("français" [keyboard layout] not found in .sif).

Is it a bug ?
Is your integrator compatible with xp home sp2 french and with wmp 11 french ?

I've tested Boooggy's slipstreamer.
The same weird thing happened.

Could you help me ?
Thanks

#71
jcarle

jcarle

    MSFN Master

  • Developers
  • 2,579 posts
I'll take a look and see if there's some sort of character set limitation in effect...

#72
dread

dread

    Newbie

  • Members
  • 41 posts
Good program. Only problem I have ran into is that if I run it before I install everything with nlite I get a error. Wish you would make one for IE7 and it would allow you to install windows in dos. Here is what I am talking about. I am about to download and try out Windows Updates Downloader. Just not sure what all updates I should get to get the same as the ryanvm xp sp2 update pack lol.

#73
boooggy

boooggy

    MSFN Master

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,329 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
it still adds almost 70 mb on a fresh source. jcarle please dont extract the parts on wmp installer casue they dont have to do anything with oobe and theme issues reported after integrating wmp11. to fix this issues u need to update the uxtheme.dll and msobmain.dll.
i hope this helps to reduce xp source on a right size ...meaning around 20MB..... :hello:

#74
sam9879

sam9879
  • Members
  • 2 posts
You're a JAM!

#75
WeBeRiO

WeBeRiO

    Newbie

  • Members
  • 18 posts
[English]

Hello, your program is very good.

I found a possible failure, once the integration button should put exit, terminate or something like that and not again 'Integrate'.

Thank you.



[Spanish]

Hola, tu programa es muy bueno.

He encontrado un posible fallo, una vez finalizada la integración el botón deberia poner salir, terminar o algo por el estilo y no nuevamente 'Integrate'.

Un saludo.




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users



How to remove advertisement from MSFN