Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Disable roaming profiles.

- - - - -

  • Please log in to reply
4 replies to this topic

#1
tarrant64

tarrant64
  • Member
  • 3 posts
I am looking for a way to disable roaming profiles for my unattended installations. I know going through gpedit.msc I can disable it, but I don't want to have to do that for every new installation.

Is there a registry edit that can be applied that does this? I only want to use local profiles in my setups.


Thanks!


How to remove advertisement from MSFN

#2
Vadikan

Vadikan

    MSFT MVP Windows Expert: Consumers

  • Member
  • PipPipPip
  • 349 posts
  • OS:Windows 8 x64
  • Country: Country Flag
Pretty much all group policies have their registry equivalents. In your case it is

Administrative Templates\System\User Profiles
Only allow local user profiles
At least Microsoft Windows XP Professional or Windows Server 2003 family
This setting determines if roaming user profiles are available on a particular computer. By default, when roaming profile users log on to a computer, their roaming profile is copied down to the local computer. If they have already logged on to this computer in the past, the roaming profile is merged with the local profile. Similarly, when the user logs off this computer, the local copy of their profile, including any changes they have made, is merged with the server copy of their profile. Using the setting, you can prevent users configured to use roaming profiles from receiving their profile on a specific computer. If you enable this setting, the following occurs on the affected computer: At first logon, the user receives a new local profile, rather than the roaming profile. At logoff, changes are saved to the local profile. All subsequent logons use the local profile. If you disable this setting or do not configure it, the default behavior occurs, as indicated above. If you enable both the Prevent Roaming Profile changes from propagating to the server setting and the Only allow local user profiles setting, roaming profiles are disabled. Note: This setting only affects roaming profile users.

HKLM\Software\Policies\Microsoft\Windows\System!LocalProfile
!parameter means: parameter=dword:00000001 (enabled) or dword:00000000 (disabled)
Source: Group Policy Reference

Alternatively, you can distribute .adm files.

Edited by Vadikan, 13 November 2006 - 12:33 AM.

What we know is not much. What we do not know is immense. Pierre-Simon Laplace
--
Unattended Installation in Russian

#3
tarrant64

tarrant64
  • Member
  • 3 posts
Thanks a lot! Exactly what I was looking for.

#4
Vadikan

Vadikan

    MSFT MVP Windows Expert: Consumers

  • Member
  • PipPipPip
  • 349 posts
  • OS:Windows 8 x64
  • Country: Country Flag
Oh, now I see what the PM was about :) You're welcome!
What we know is not much. What we do not know is immense. Pierre-Simon Laplace
--
Unattended Installation in Russian

#5
cluberti

cluberti

    Gustatus similis pullus

  • Supervisor
  • 11,252 posts
  • OS:Windows 8.1 x64
  • Country: Country Flag
It's worth noting that almost all group policy settings are enforced via the registry, and you can easily see (most times) what you're looking for by editing the .adm and finding the entry you are configuring. This will tell you what registry key and value are being modified, and what the appropriate values are.
MCTS Windows Internals, MCITP Server 2008 EA, MCTS MDT/BDD, MCSE/MCSA Server 2003, Server 2012, Windows 8
--------------------
Please read the rules before posting!
Please consider donating to MSFN to keep it up and running!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN