Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Cheap new VIA/AMD PC and Windows 98 SE

- - - - -

  • Please log in to reply
15 replies to this topic

#1
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • Joined 15-April 05
  • OS:98SE
  • Country: Country Flag
I never had any PC VIA/AMD motherboard so I decided to test one very cheap but new one to see how it works with Windows 98 SE.

The configuration is as follows:
Motherboard: GA-K8VM800M-RH with K8M800 chipset (includes UniChrome Pro IGP) and Rhine II Fast Ethernet Adapter
CPU: Sempron 2800+ (Palermo core, 256 KB cache)
RAM: 512 MB DDR400
HDD: WD1600JS-08NCB1 160 GB SATA disk
DVD: TEAC DV-W516GDM
Standard case with power suply, FDD, accessories.
The cost is about $250.


I installed Windows XP - everything OK, Windows Vista RC2 - everything OK but it was not possible to set refresh rate since there is no specific driver for integrated graphics, and then Windows 98 SE.

It was necessary to change the setting of the SATA controller from IDE mode to RAID mode because there is no Win9x driver for SATA IDE but there is driver for SATA RAID. This is recommended by VIA. All other drivers work as expected with one exception - the audio driver supplied by Gigabyte (Realtek WDM driver) caused GPF during driver detection after the reboot. For example:
Date 11/12/2006 Time 21:50
MSGSRV32 caused a general protection fault
in module COMMCTRL.DLL at 0001:00000afc.
Registers:
EAX=36eeec40 CS=1caf EIP=00000afc EFLGS=00000282
EBX=0000fffe SS=1f57 ESP=000070d6 EBP=000070dc
ECX=00000000 DS=1d47 ESI=00020058 FS=0000
EDX=80d736ee ES=0eb6 EDI=0002b242 GS=0000
Bytes at CS:EIP:
66 26 89 07 8e 46 0e 26 ff 04 8b c7 1f 5e 5f c9 
Stack dump:
ec400e27 70ee000f 29a79e40 36eeec40 0058422e 0e270eb6 9a487268 ec4029a7 422e36ee 0eb60058 00010058 36ee0000 575c3a43 4f444e49 495c5357 445c464e
Very often the GPF was in module KRNL386:EXE and in other 16-bit modules. But alwas it was caused by MSGSRV32. It means dead end - Explorer will not start and the only possible thing to do is to shut down Windows.

Then I disabled sound card in BIOS but problems remained - it was not possible to install DirectX9, nUSB caused same MSGSRV32 errors during disk detection.

So I have reinstalled Windows 98 SE with SESP2.1A, IE6.0SP1, all updates, DX9.0c, and then tried to install various sound drivers. At first Windows Update offered a driver (This was for the first time I have seen Win9x driver in Windows Update). It worked. Then I tried Vinyl Audio driver from VIA website. It worked. Then I tried the latest Realtek driver (setup.exe) and again the same problem with MSGSRV32. This time I had the sate before saved by Ghost so it was easy to go back and I tried to install the Realtek driver maanually using the device manager - and voila, everything was correct.

I remember that I had exactly the same problems with Realtek WDM AC97 driver on board with Intel 915P chipset so there is - probably - some conflict between the drive, Windows 98 SE and some hardware configuration.

Has anybody found out what is the reason of those MSGSRV32 errors and how to avoid them?

Other two problem are not so easy to describe.

The first is significant random slowdown of Windows - everything is extremely slow. Even the disk transfer rate drop for short time to < 10 MB/s while standard is 60 MB/s (measured by HDTach 2.70)

The second appeared repeatedly when I pressed backspace in Total Commader several times. Then blue screen with Exception 0E appeared, repeated 5 times, then almost black screen appeared, no mouse, when I pressed Ctrl-Alt-Del the task mananager appeared but behind it appeared small window with GPF in VTTimer.exe (part of the video driver) and everything got frozen.


I supposed that there sould be no problems - but there are some.

Has anybody encountered any of these problems and/or does anybody know how to solve them?


This PC is just for testing, I will have it another two days and then it will go away with Windows XP, but I would like to know if this PC is not compatible with Windows 98 SE or I made just some error.

If I will have some time I will also try to use Windows ME, Windows 98 (Gold) and maybe also Windows 95 and OSR2 - to see what VXDs and PDRs will cause faults because of high speed AMD processor.

Petr


How to remove advertisement from MSFN

#2
bristols

bristols

    Advanced Member

  • Member
  • PipPipPip
  • 451 posts
  • Joined 24-September 05
  • OS:none specified
  • Country: Country Flag
I've had exactly the same MSGSRV32 problem with the WDM Realtek audio driver for onboard sound on a VIA-based Gigabyte board. Windows (or Explorer) fails to start on bootup.

I wasn't able to solve them, after having tried many different versions of the AC97 audio driver (the version linked to from the Gigabyte site didn't work for me. In fact, I think it was incorrect for my particular Realtek codec). Eventually, I used the Vinyl Audio VIA driver too. And it worked for me too (although it seemed that any audio device that needed even slightly intensive CPU usage would cough and splutter, and sometimes even stop dead. There were other peculiarities that I can't remember exactly).

Regarding slowness, I have experienced that too. But I found that George Breese's PCI Latency Patch (and the registry tweaks he supplies) and his Memory Interleaver had a significant effect in speeding things up. Apparently, many VIA BIOSes do not offer the ability to turn on the memory interleaving feature.

In spite of these problems, the board was/is generally stable.

Hope this can help a bit.

#3
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • Joined 15-April 05
  • OS:98SE
  • Country: Country Flag

Regarding slowness, I have experienced that too. But I found that George Breese's PCI Latency Patch (and the registry tweaks he supplies) and his Memory Interleaver had a significant effect in speeding things up. Apparently, many VIA BIOSes do not offer the ability to turn on the memory interleaving feature.


Thank you for your comments.

The PCI Latency Patch is for older chipsets only:

This version may be unstable on new VIA chipsets if the southbridge chip is not VT8233 or VT8233A or VT8235. Specifically, this version does not identify VIA's newer VT8237 correctly, and might patch the chipset incorrectly as a result.

- my chipset contains VT8237R.

Petr

#4
bristols

bristols

    Advanced Member

  • Member
  • PipPipPip
  • 451 posts
  • Joined 24-September 05
  • OS:none specified
  • Country: Country Flag
Hi Petr.

The southbridge in my Gigabyte board is VT8237, and the patch worked for me.

Until I applied one of the registry tweaks included with the patch, the system would freeze quite often when closing or opening apps. After applying the reg tweak, everything was fine.

So, it may be worth a try.

#5
RJARRRPCGP

RJARRRPCGP

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,190 posts
  • Joined 13-April 05
  • OS:XP Pro x64
  • Country: Country Flag

I never had any PC VIA/AMD motherboard so I decided to test one very cheap but new one to see how it works with Windows 98 SE.

The configuration is as follows:
Motherboard: GA-K8VM800M-RH with K8M800 chipset (includes UniChrome Pro IGP) and Rhine II Fast Ethernet Adapter
CPU: Sempron 2800+ (Palermo core, 256 KB cache)
RAM: 512 MB DDR400
HDD: WD1600JS-08NCB1 160 GB SATA disk
DVD: TEAC DV-W516GDM
Standard case with power suply, FDD, accessories.
The cost is about $250.


I installed Windows XP - everything OK, Windows Vista RC2 - everything OK but it was not possible to set refresh rate since there is no specific driver for integrated graphics, and then Windows 98 SE.

It was necessary to change the setting of the SATA controller from IDE mode to RAID mode because there is no Win9x driver for SATA IDE but there is driver for SATA RAID. This is recommended by VIA. All other drivers work as expected with one exception - the audio driver supplied by Gigabyte (Realtek WDM driver) caused GPF during driver detection after the reboot. For example:

Date 11/12/2006 Time 21:50
MSGSRV32 caused a general protection fault
in module COMMCTRL.DLL at 0001:00000afc.
Registers:
EAX=36eeec40 CS=1caf EIP=00000afc EFLGS=00000282
EBX=0000fffe SS=1f57 ESP=000070d6 EBP=000070dc
ECX=00000000 DS=1d47 ESI=00020058 FS=0000
EDX=80d736ee ES=0eb6 EDI=0002b242 GS=0000
Bytes at CS:EIP:
66 26 89 07 8e 46 0e 26 ff 04 8b c7 1f 5e 5f c9 
Stack dump:
ec400e27 70ee000f 29a79e40 36eeec40 0058422e 0e270eb6 9a487268 ec4029a7 422e36ee 0eb60058 00010058 36ee0000 575c3a43 4f444e49 495c5357 445c464e
Very often the GPF was in module KRNL386:EXE and in other 16-bit modules. But alwas it was caused by MSGSRV32. It means dead end - Explorer will not start and the only possible thing to do is to shut down Windows.

Then I disabled sound card in BIOS but problems remained - it was not possible to install DirectX9, nUSB caused same MSGSRV32 errors during disk detection.

So I have reinstalled Windows 98 SE with SESP2.1A, IE6.0SP1, all updates, DX9.0c, and then tried to install various sound drivers. At first Windows Update offered a driver (This was for the first time I have seen Win9x driver in Windows Update). It worked. Then I tried Vinyl Audio driver from VIA website. It worked. Then I tried the latest Realtek driver (setup.exe) and again the same problem with MSGSRV32. This time I had the sate before saved by Ghost so it was easy to go back and I tried to install the Realtek driver maanually using the device manager - and voila, everything was correct.

I remember that I had exactly the same problems with Realtek WDM AC97 driver on board with Intel 915P chipset so there is - probably - some conflict between the drive, Windows 98 SE and some hardware configuration.

Has anybody found out what is the reason of those MSGSRV32 errors and how to avoid them?

Other two problem are not so easy to describe.

The first is significant random slowdown of Windows - everything is extremely slow. Even the disk transfer rate drop for short time to < 10 MB/s while standard is 60 MB/s (measured by HDTach 2.70)

The second appeared repeatedly when I pressed backspace in Total Commader several times. Then blue screen with Exception 0E appeared, repeated 5 times, then almost black screen appeared, no mouse, when I pressed Ctrl-Alt-Del the task mananager appeared but behind it appeared small window with GPF in VTTimer.exe (part of the video driver) and everything got frozen.


I supposed that there sould be no problems - but there are some.

Has anybody encountered any of these problems and/or does anybody know how to solve them?


This PC is just for testing, I will have it another two days and then it will go away with Windows XP, but I would like to know if this PC is not compatible with Windows 98 SE or I made just some error.

If I will have some time I will also try to use Windows ME, Windows 98 (Gold) and maybe also Windows 95 and OSR2 - to see what VXDs and PDRs will cause faults because of high speed AMD processor.

Petr


Many of the crash symptoms you got sounds like when the CPU isn't stable. Did you check the Vcore?
If those symptoms continue, the processor may be bad or overheating.

I suggest that you run Prime95. When you do, look for the following symptoms:

You get a GPF in KRNL386.EXE when running Prime95.

You get a bunch of GPFs or invalid instruction errors in other system binaries.

Then when running Prime95, you may get other crash error messages in Windows 3.1-style pop-ups!

Then you may get a screen with just a simple background and mouse pointer, which
makes it appear to be a software-related crash, when it wasn't, which is rare, AFAIK.

or

Windows gives a BSOD, usually A fatal exception 0E occured or A fatal exception 06 occured when running Prime95.

If the above symptoms occur, your Athlon 64 is malfunctioning. Please check the Vcore and temp.

Edited by RJARRRPCGP, 12 November 2006 - 07:29 PM.

Asus P5QL Pro, Core 2 Duo E4500, eVGA GeForce 9500 GT with XP Pro x64 Edition -> Works great with Asus P5QL Pro!

#6
modicr

modicr

    Member

  • Member
  • PipPip
  • 134 posts
  • Joined 08-January 05
Hello!

Here are some hints (from my experience when installing
Windows 98SE on Intel 875 motherboard)

1. 512 MB RAM - is this single module or
two 256 MB sticks configured as dual-channel memory.
In this case try with just with 256 MB

2. Have you tried to disable LAN. For example,
in the Intel case I had to use additional PCI NIC
until I found the solution:
http://support.intel...b/cs-009346.htm

Symptom(s):
When installing the Windows* 98 driver for the Intel Gigabit Desktop adapters, the installation runs smoothly.
Upon reboot, the customer receives a "VFAT Device initialization Failed" error and can only boot into Safe Mode.

Solution:
Install PROSet if the utility hasn't already been installed. Go to "Advanced Settings" and locate the Transmit Descriptors and Receive Descriptors. Reduce the number to 80.

Reboot.


3. In fact, try to disable as many devices as possible in BIOS.
Maybe there are some subtle IRQ problems ...

4. Force Windows 98 to be installed as Standard PC (instead of
ACPI machine)

5. Try to change AGP BIOS settings if possible

6. Try to install Windows ME ;)

Good luck, Roman
© I'm not patented!

#7
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • Joined 15-April 05
  • OS:98SE
  • Country: Country Flag
Today I tried Windows Me on the above mentioned VIA system.

Everythng worked prefectly, no blue screens, no lockups, even the Realtek driver was possible to install using the Realtek's setup.exe.

And as described in other threads, Mitsumi USB Floppy workd fine (98SE+nusb not), and the system booted with 1.5 GB RAM both in normal and safe mode (98SE not).

Surprising. I always thought that 98SE is more stable that Me - but I see that it is not so.

Petr

#8
RJARRRPCGP

RJARRRPCGP

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,190 posts
  • Joined 13-April 05
  • OS:XP Pro x64
  • Country: Country Flag

Today I tried Windows Me on the above mentioned VIA system.

Everythng worked prefectly, no blue screens, no lockups, even the Realtek driver was possible to install using the Realtek's setup.exe.

And as described in other threads, Mitsumi USB Floppy workd fine (98SE+nusb not), and the system booted with 1.5 GB RAM both in normal and safe mode (98SE not).

Surprising. I always thought that 98SE is more stable that Me - but I see that it is not so.

Petr


I never had that problem with a Via chipset.
That's more likely to occur with a nForce chipset.

On an Asus A7N266-VM/AA, with Windows 98 SE, if I installed the video card drivers for my Radeon 9000 Pro, then during the next boot, ends up crashing with a black screen.

Windows ME didn't have that problem with the Asus A7N266-VM/AA.

But I didn't have this problem with the onboard video, which is an integrated GeForce 2 GPU.

But, the PC has randomly rebooted with Windows 98 SE on an Asus A7N266-VM/AA.

Edited by RJARRRPCGP, 14 November 2006 - 06:07 PM.

Asus P5QL Pro, Core 2 Duo E4500, eVGA GeForce 9500 GT with XP Pro x64 Edition -> Works great with Asus P5QL Pro!

#9
modicr

modicr

    Member

  • Member
  • PipPip
  • 134 posts
  • Joined 08-January 05
Hello!

Today I tried Windows Me on the above mentioned VIA system.

Everythng worked prefectly, no blue screens, no lockups,
even the Realtek driver was possible to install using the
Realtek's setup.exe.

And as described in other threads, Mitsumi USB Floppy
workd fine (98SE+nusb not), and the system booted
with 1.5 GB RAM both in normal and safe mode (98SE
not).

Surprising. I always thought that 98SE is more stable that
Me - but I see that it is not so.


Great! BTW, there are many threads about max memory and Windows 98SE.
What is the maximum memory for Windows ME?

Roman
© I'm not patented!

#10
Petr

Petr

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 981 posts
  • Joined 15-April 05
  • OS:98SE
  • Country: Country Flag

Great! BTW, there are many threads about max memory and Windows 98SE.
What is the maximum memory for Windows ME?

Roman



According to my experience on this specific board, 512 MB is safe for both 98SE and Me, and anything above is risky, no system.ini settings help in certain situations.

Petr

#11
tee charoen

tee charoen

    tee

  • Member
  • 20 posts
  • Joined 10-September 06
Hello Petr,
Your experience on installing 98se on a Via motherboard is perhaps quite a hit/miss affair for todays m/b's. May I add my experience of installing Win98se on an Asustek M2V:

Mainboard:Asus M2V Via K8T890 m/b (Bios 0702): (nb:Asus states No Support for 98se on this mb)
CPU: AMD 3800+ X2 Dual Core
Ram: 2 X 512 Kingston DDR2 (533)
Video: Powercolor PCI-E ATI X800GTO 16 (Catalyst 5.9 Win Me/98se Drivers)
HDD: 2 x 160g Seagate IDE
Sound: Creative SB live 5.1
Lan: Linksys LNE 100
CD/DVD: Benq DW1670
Monitor: Sony E220
PSU: HEC Tru-Power 480W
98se Driver: VIA Hyperion 1.5.10a (Works well for this M2V board)
USB2 : Via USB2.0 driver for 98se (searchable on Via website)
Other: Triple Boot to Ubuntu Linux and WinXp Sp2.

W98se Experiences:
* Installed and running extremely stable for 3 months now. Speed response in 98se: -Fearsome!
* Choose IDE Drives to avoid 98se incompatibilities with Sata even though the M2V has 3 Sata connectors;
(and 2 std Ide connectors.)
* If you choose to get same board disable the E-Sata (External Sata) controller in Bios or 98se keeps
saying "found std dual pci ide device"
Disable one "unknow device" in 98se System Hardware Config as that probably refers to the
E-Sata controller that has no drivers for 98se .
Disable the Gigabit Lan and the Onboard Sound in Bios. Buy your own Lan and Sound Card that
still has 98se drivers.
* Use the "unofficial lba 48bit driver esdi_506.pdr" from Mdgx's website
* Use a ATI Radeon X300 - X800 PCIE Vga card as these still have 98se drivers.
* Dont use Bios 1003 for M2V as this Bios is enhanced for Vista and somehow messes up
System Hardware Configuration in 98se by having an extra PCI Bus device.
* Apply all 98se sec and system updates.
* Avoid nvidia boards for 98se, they simply wont support it anymore - period.
* your 98se wont use the 2nd core if you're using an AMDX2 but who cares - 98se is so fast
on an Amd X2.

That's about as much as I can think of. I installed Win98se 3 times before I was satisfied it was getting
stable. Make many images for subsequent test changes if you want ot rollback.

Conclusion: I never expected all this to work for W98se. But it did. I have, now, a new generation board
running 98se with the most satisfying speed response I've ever experienced.
The A64 3800+ x2 chip really rocks!
Got my Panasonic Camera driver, Imation Go flash drive driver all working
flawlessly. What's more now can play those games that wont run on XP.

HTH.

T.Charoen 3 months old member.
98se onwards regardless!

#12
tee charoen

tee charoen

    tee

  • Member
  • 20 posts
  • Joined 10-September 06
Hello Folks,
Just to add to my earlier post couple of things I overlooked:
If you have more than 512mb of ram in 98se - do add to theMaxFileCache setting System.ini file
thusly:
[VCache]
MaxFileCache=524288

Next if using a ATI X800 series card - DirextX9 must be installed.
The vga card drivers comes with Dx9.0c. Therafter running in 32bit mode on 98se desktop is
a cinch.

Sorry for the ommission.

T.Charoen

#13
nicke85

nicke85

    Chetnik

  • Member
  • PipPip
  • 110 posts
  • Joined 13-May 06

Hello Folks,
Just to add to my earlier post couple of things I overlooked:
If you have more than 512mb of ram in 98se - do add to theMaxFileCache setting System.ini file
thusly:
[VCache]
MaxFileCache=524288

Next if using a ATI X800 series card - DirextX9 must be installed.
The vga card drivers comes with Dx9.0c. Therafter running in 32bit mode on 98se desktop is
a cinch.

Sorry for the ommission.

T.Charoen


I want to buy
ATI] 100-714502 / VGA PCI-E 256MB GDDR3 Radeon X800XL, All-In-Wonder, ViVO, PAL/SECAM+DVB-T, Remote Wonder, 256bit
very soon...
So,can I install Win98se with these card and get 32 bit support...only with DX9c?

#14
RJARRRPCGP

RJARRRPCGP

    MSFN Expert

  • Member
  • PipPipPipPipPipPip
  • 1,190 posts
  • Joined 13-April 05
  • OS:XP Pro x64
  • Country: Country Flag

* Avoid nvidia boards for 98se, they simply wont support it anymore - period.


I'm with you on this one, because even if Nvidia still supports Windows 98, can still be show stopping crashes.
Even with the first nForce chipset, Windows 98 has had stability issues.

If the motherboard is nForce-based, you're likely gonna get random reboots.

But, Nvidia video cards may still be fine with Windows 98 SE. At the least, avoid nForce-based motherboards!

Edited by RJARRRPCGP, 16 November 2006 - 02:42 PM.

Asus P5QL Pro, Core 2 Duo E4500, eVGA GeForce 9500 GT with XP Pro x64 Edition -> Works great with Asus P5QL Pro!

#15
tee charoen

tee charoen

    tee

  • Member
  • 20 posts
  • Joined 10-September 06
Hi Chetnik,

"I want to buy
ATI] 100-714502 / VGA PCI-E 256MB GDDR3 Radeon X800XL, All-In-Wonder, ViVO, PAL/SECAM+DVB-T, Remote Wonder, 256bit
very soon...
So,can I install Win98se with these card and get 32 bit support...only with DX9c?"


From what I understand - AMD/Ati has this to say about Win98se support:\

Quote:"Windows 98/98SE is supported through the Windows Millennium Edition driver.
Desktop product family support
The CATALYST™ software suite is designed to support the following ATI desktop product family:
RADEON™ X850 series
RADEON™ X800 series
RADEON™ X700 series
RADEON™ X600 series
RADEON™ X300 series " Unquote

Clearly this would appear to cover the X800XL card you intend to get.
One other thing that comes to my mind now is that while installing your Catlyst Driver set for the X800series
Pl *remember* to install Hydravision first as this seems to let Win98se pick up the dual vga output
from the start, and the following install of the other driver then proceeds smoothly.

You dont need DX9c to get 32bit color depth support, DX9a or b, or for that matter even DX8 would
allow you 38bit color depth support unless I'm wrong.
Just that with DX9x you can play DX9 compatible games.

HTH

T.Charoen
3month old member

#16
nicke85

nicke85

    Chetnik

  • Member
  • PipPip
  • 110 posts
  • Joined 13-May 06
Ok thank you tee charoen for this info! :rolleyes:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users