Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
bagheera

fix my zen micro!

5 posts in this topic

so i recently tried to upgrade the firmware on my zen micro to "plays for sure". i couldn't get it to work on my computer so i tried to take it off of the zen. i selected the "reload firmware" in the recovery mode and soon found out that was a very bad idea...

so anyway the problem is my player has no firmware installed on it...i can't install any new firmware on it because my computer won't recognize the device and therfore does not see it connected.

...so now my mp3 player's just an expensive peice of junk. does anyone know how to fix it?

0

Share this post


Link to post
Share on other sites

copy the firmware that should on the micro onto your hard drive, then uninstall the micro. as long as that works, you can then connect it, and the micro should show up as a removeable device or something like that, then you can put the firmware back on.

if that doesn't work then i don't know what to tell you. its tricky business getting firmware back on.

0

Share this post


Link to post
Share on other sites

From what I've heard, once a firmware update/downgrade has failed, the device is gone. I don't even think you can get the PC to recognize it since the firmware is what will tell the PC what to use for drivers.

0

Share this post


Link to post
Share on other sites

i had a problem once with my creative zen micro photo when i tried to connect my player to my computer. some things was happing to the driver so i removed and installed it serval times but this didnt work so i just left it. any after a wee while i thought i would try it again and it now works?. Creative's web site gives u steps to do if u have any problems.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.